Subject: [OAUTH-WG] I-D Action:draft-ietf-oauth-v2-10.txt

From: [email-masked]
Date: Sun, 11 Jul 2010 14:30:02 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Open Authentication Protocol Working Group of the IETF.

	Title           : The OAuth 2.0 Protocol
	Author(s)       : E. Hammer-Lahav, et al.
	Filename        : draft-ietf-oauth-v2-10.txt
	Pages           : 44
	Date            : 2010-07-11

This specification describes the OAuth 2.0 protocol.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-oauth-v2-10.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Sun, 11 Jul 2010 14:35:26 -0700

Draft -10 submitted. It includes the following changes:

   o  Fixed typos.  Many editorial changes.  Rewrote introduction. removed terminology grouping.
   o  Allowed POST for end-user authorization endpoint.
   o  Fixed token endpoint to not require client authentication.
   o  Made URI query and POST body 'oauth_token' parameter optional.
   o  Moved all parameter names and values to use underscores.
   o  Changed 'basic_credentials' to 'password', 'invalid_client_credentials' and 'invalid_client_id' to 'invalid_client'.
   o  Added note that access token requests without an access grant should not include a refresh token.
   o  Changed scheme name from 'Token' to 'OAuth', simplified request format to simple string for token instead of key=value pair (still supported for extensions).
   o  Defined permitted access token string characters (suitable for inclusion in an HTTP header).
   o  Added a note about conflicts with previous versions.
   o  Moved 'client_id' definition from client authentication to access token endpoint.

There will not be another official draft until at least August 1st, 2010.

Please review and provide detailed feedback on the list. I will post the SharedCopy link for editorial feedback as soon as the draft is up and active on the tools site.

Brian has raised some important issues over the weekend, most of which were not addressed in the draft due to time or lack of consensus. Please review and participate in the discussion.

EHL

On 7/11/10 2:30 PM, "[email-masked]" <[email-masked]> wrote:

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Sun, 11 Jul 2010 17:52:19 -0700

Please use this link to post purely editorial feedback:

http://r9.sharedcopy.com/6djt2n9v

EHL

On 7/11/10 2:35 PM, "Eran Hammer-Lahav" <[email-masked]> wrote:

EHL