Subject: [OAUTH-WG] Instead of desktop apps, refer to mobile apps

From: Luke Shepard <[email-masked]>
Date: Tue, 13 Jul 2010 07:54:24 +0000

Minor language change request. We have seen much more demand for use of the user-agent flow in mobile apps than in desktop apps in the past month. I think that the spec should address that. 

Instead of this:

1.4.3.  Native Application

   Native application are clients running as native code on the end-
   user's computer or device (i.e. executing outside a user-agent or as
   a desktop program).  These clients are often capable of interacting
   with (or embedding) the end-user's user-agent but are limited in how
   such interaction affects their end-user experience.  In many cases,
   native applications are incapable of receiving direct callback
   requests from the server (e.g. firewall, operating system
   restrictions).

The spec should mention that mobile applications typically qualify as operating entirely in the user-agent. Going forward I think those are going to be way more popular and widespread than desktop apps (well, the whole concept of the two is blurring).

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Tue, 13 Jul 2010 08:18:27 -0700

I think the profiles section is mostly useless in helping developers pick the right profile unless they are clearly a JS browser client or a client running on a well-protected web server. We have blurred the lines so much in when each profile should/could be used, that a new reader will be lost.

The only way I can come up with to fix this is to move the user-agent and web-server profiles into new normative sections (with new names that don't imply client type), and to use the introduction to discuss how different use cases can be addressed by profiling the generic framework.

I'll try that before -11 in my public sandbox.

EHL

On 7/13/10 12:54 AM, "Luke Shepard" <[email-masked]> wrote:

Instead of this:

_______________________________________________
OAuth mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/oauth