Subject: Re: [OAUTH-WG] Underscore, dash, green, blue

From: Pelle Braendgaard <[email-masked]>
Date: Thu, 1 Jul 2010 09:39:52 -0400

I already implemented 09 but it was a (very tiny) bit of a hassle to
have to convert underscores.

So I also agree with 3 except headers

On Thu, Jul 1, 2010 at 2:41 AM, Lukas Rosenstock <[email-masked]> wrote:
> 3 except headers.
>
> 2010/7/1 Eran Hammer-Lahav <[email-masked]>:
>> First, sorry about this. J
>>
>>
>>
>> I do my best not to ask the group this kind of questions and just pick
>> something on my own, but I can’t decide so I’ll run a quick vote (yes, a
>> VOTE – I can’t imagine seeking a consensus call on this).
>>
>>
>>
>> -09 uses underscores for parameter names (except for in the headers) and
>> dashes for parameter values. This seems like an odd selection. Before, it
>> used dashes for header parameter names, and underscore everywhere else. Not
>> great either.
>>
>>
>>
>> So…
>>
>>
>>
>> The changes my OCD can live with:
>>
>>
>>
>> 1. Use dashes throughout
>>
>> 2. Use underscores for all parameter names (headers included), dashes for
>> all values
>>
>> 3. Use underscores throughout
>>
>>
>>
>> I want to get this done with in a day because people are writing code for
>> -09 and I’d like to stop making changes beyond editorial.  I just think that
>> having different styles between the endpoint parameters and header
>> parameters is broken.
>>
>>
>>
>> EHL
>>
>> _______________________________________________
>> OAuth mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/oauth
>>
>>
>
>
>
> --
> http://lukasrosenstock.net/
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>

-- 
http://agree2.com - Reach Agreement!
http://stakeventures.com - My blog about startups and agile banking

---

From: Justin Hart <[email-masked]>
Date: Thu, 1 Jul 2010 07:09:48 -0700

+1 for underscores except header keys.
----
-- Justin Hart
-- [email-masked]

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Thu, 1 Jul 2010 09:23:30 -0700

That's wasn't an option for a reason. Beside offending my esthetic sensibility :-) having the same parameter use a different name between the header and endpoint makes registration of extension parameters much harder. For example, if we used this scheme, the 'error-uri' parameter would require two registration requests, one for 'error-uri' and another for 'error_uri'.

EHL

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Justin Hart
> Sent: Thursday, July 01, 2010 7:10 AM
> To: Pelle Braendgaard
> Cc: OAuth WG ([email-masked])
> Subject: Re: [OAUTH-WG] Underscore, dash, green, blue
> 
> >>> I do my best not to ask the group this kind of questions and just
> >>> pick something on my own, but I can't decide so I'll run a quick
> >>> vote (yes, a VOTE - I can't imagine seeking a consensus call on this).
> >>>
> >>>
> >>>
> >>> -09 uses underscores for parameter names (except for in the headers)
> >>> and dashes for parameter values. This seems like an odd selection.
> >>> Before, it used dashes for header parameter names, and underscore
> >>> everywhere else. Not great either.
> >>>
> >>>
> >>>
> >>> So...
> >>>
> >>>
> >>>
> >>> 2. Use underscores for all parameter names (headers included),
> >>> dashes for all values
> >>>
> >>> -09 and I'd like to stop making changes beyond editorial.  I just
> >>> think that having different styles between the endpoint parameters
> >>> and header parameters is broken.
> >>>
> >>>
> >>>
> >>> EHL
> >>>

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Thu, 1 Jul 2010 11:01:35 -0700

> From: Luke Shepard [mailto:[email-masked]]
> Sent: Thursday, July 01, 2010 10:58 AM
> To: Eran Hammer-Lahav
> Cc: Justin Hart; Pelle Braendgaard; OAuth WG ([email-masked])
> Don't really care, but to pick one - underscores throughout.
> 
> Why not headers?

Historically, HTTP headers use dashes and not underscores, but there is nothing to prevent us from using underscores throughout.

EHL

> On Jul 1, 2010, at 9:23 AM, Eran Hammer-Lahav wrote:
> 
> > That's wasn't an option for a reason. Beside offending my esthetic
> sensibility :-) having the same parameter use a different name between the
> header and endpoint makes registration of extension parameters much
> harder. For example, if we used this scheme, the 'error-uri' parameter would
> require two registration requests, one for 'error-uri' and another for
> 'error_uri'.
> >
> > EHL
> >
> >> From: [email-masked] [mailto:[email-masked]] On
> >> Behalf Of Justin Hart
> >>> On Thu, Jul 1, 2010 at 2:41 AM, Lukas Rosenstock
> >>> <[email-masked]>
> >> wrote:
> >>>> 3 except headers.
> >>>>
> >>>>> -09 uses underscores for parameter names (except for in the
> >>>>> headers) and dashes for parameter values. This seems like an odd
> selection.

---

From: Luke Shepard <[email-masked]>
Date: Thu, 1 Jul 2010 10:57:36 -0700

Why not headers?

---

From: Marius Scurtescu <[email-masked]>
Date: Thu, 1 Jul 2010 11:19:28 -0700

3 - all underscores.

If underscores are a big issue with headers then we should consider 1
- all dashes. The problem with all dashes is that it is
counterintuitive for people that know OAuth 1.

Marius

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Thu, 1 Jul 2010 11:25:20 -0700

The 1.0 install base is small enough to ignore. Looking at the interest and community around 2.0 makes such considerations marginal.

There is no problem with underscores in headers, it is just unusual.

EHL

> From: Marius Scurtescu [mailto:[email-masked]]
> Sent: Thursday, July 01, 2010 11:19 AM
> To: Eran Hammer-Lahav
> Cc: Luke Shepard; OAuth WG ([email-masked])
> - all dashes. The problem with all dashes is that it is counterintuitive for
> people that know OAuth 1.
> 
> Marius
> 
> 
> 
> > Historically, HTTP headers use dashes and not underscores, but there is
> nothing to prevent us from using underscores throughout.
> >
> > EHL
> >
> >> sensibility :-) having the same parameter use a different name
> >> between the header and endpoint makes registration of extension
> >> parameters much harder. For example, if we used this scheme, the
> >> 'error-uri' parameter would require two registration requests, one
> >> for 'error-uri' and another for 'error_uri'.
> >> >
> >> > EHL
> >> >
> >> >>> I already implemented 09 but it was a (very tiny) bit of a hassle
> >> >>> to have to convert underscores.
> >> >>>
> >> >>>>> I do my best not to ask the group this kind of questions and
> >> >>>>> just pick something on my own, but I can't decide so I'll run a
> >> >>>>> quick vote (yes, a VOTE - I can't imagine seeking a consensus call on
> this).
> >> >>>>>
> >> >>>>>
> >> >>>>>
> >> >>>>> Before, it used dashes for header parameter names, and
> >> >>>>> underscore everywhere else. Not great either.
> >> >>>>>
> >> >>>>>
> >> >>>>>
> >> >>>>> So...
> >> >>>>>
> >> >>>>>
> >> >>>>>
> >> >>>>> -09 and I'd like to stop making changes beyond editorial.  I
> >> >>>>> just think that having different styles between the endpoint
> >> >>>>> parameters and header parameters is broken.
> >> >>>>>
> >> >>>>>
> >> >>>>>
> >> >>>>> EHL
> >> >>>>>

---

From: Joseph Smarr <[email-masked]>
Date: Fri, 2 Jul 2010 15:15:33 -0700

Just remember that dashes are problematic for JavaScript, since oauth_token
is a valid variable name, but oauth-token is not. So unless you're sure this
will never be a problem, +1 to underscores everywhere. I know HTTP headers
normally use dash, but if you want to use dashes for headers and underscores
everywhere, you have the burden of proof that this won't cause too much
confusion...

Thanks, js

On Thu, Jul 1, 2010 at 11:25 AM, Eran Hammer-Lahav <[email-masked]>wrote:

> The 1.0 install base is small enough to ignore. Looking at the interest and
> community around 2.0 makes such considerations marginal.
>

---

From: "William Mills" <[email-masked]>
Date: Fri, 2 Jul 2010 17:46:46 -0700

+1 for _
 
I don't find HTTP header names having dashes confusing, because they all
do.

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Joseph Smarr
	Sent: Friday, July 02, 2010 3:16 PM
	To: Eran Hammer-Lahav
	Cc: OAuth WG ([email-masked])
	Subject: Re: [OAUTH-WG] Underscore, dash, green, blue

	Just remember that dashes are problematic for JavaScript, since
oauth_token is a valid variable name, but oauth-token is not. So unless
you're sure this will never be a problem, +1 to underscores everywhere.
I know HTTP headers normally use dash, but if you want to use dashes for
headers and underscores everywhere, you have the burden of proof that
this won't cause too much confusion... 

	Thanks, js

	On Thu, Jul 1, 2010 at 11:25 AM, Eran Hammer-Lahav
<[email-masked]> wrote:

		The 1.0 install base is small enough to ignore. Looking
at the interest and community around 2.0 makes such considerations
marginal.
		
		There is no problem with underscores in headers, it is
just unusual.
		
		EHL

		> >> >>>>> headers) and dashes for parameter values.
This seems like an
		> >> >>>>> odd
		> >> >>>>> I want to get this done with in a day because
people are
		> >> >>>>> writing code for
		> >> >>> http://stakeventures.com - My blog about
startups and agile
		> >> >>> banking