Subject: [OAUTH-WG] Possible "typos" in -09, section 2.1 examples

From: Diogo Almeida <[email-masked]>
Date: Sat, 3 Jul 2010 23:57:54 +0100

Hello,

Both examples in section 2.1 mention a "type" parameter, which, if I'm interpreting the changes correctly, has been removed in -07.

Assuming it's indeed a typo. Where it reads:

   For example (line breaks are for display purposes only):

     POST /token HTTP/1.1
     Host: server.example.com
     Authorization: Basic czZCaGRSa3F0MzpnWDFmQmF0M2JW
     Content-Type: application/x-www-form-urlencoded

     type=web-server&code=i1WsRn1uB1&
     redirect_uri=https%3A%2F%2Fclient%2Eexample%2Ecom%2Fcb

it should read:

   For example (line breaks are for display purposes only):

     POST /token HTTP/1.1
     Host: server.example.com
     Authorization: Basic czZCaGRSa3F0MzpnWDFmQmF0M2JW
     Content-Type: application/x-www-form-urlencoded

     code=i1WsRn1uB1&
     redirect_uri=https%3A%2F%2Fclient%2Eexample%2Ecom%2Fcb

And where it reads:

For example (line breaks are for display purposes only):

     POST /token HTTP/1.1
     Host: server.example.com
     Content-Type: application/x-www-form-urlencoded

     type=web-server&client_id=s6BhdRkqt3&
     client_secret=gX1fBat3bV&code=i1WsRn1uB1&
     redirect_uri=https%3A%2F%2Fclient%2Eexample%2Ecom%2Fcb

It should read:

For example (line breaks are for display purposes only):

     POST /token HTTP/1.1
     Host: server.example.com
     Content-Type: application/x-www-form-urlencoded

     client_id=s6BhdRkqt3&
     client_secret=gX1fBat3bV&code=i1WsRn1uB1&
     redirect_uri=https%3A%2F%2Fclient%2Eexample%2Ecom%2Fcb

Best regards,
Diogo Almeida

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Sat, 3 Jul 2010 21:48:45 -0700

Thanks. This was previously reported and already fixed for -10. Should include the grant_type parameter.

EHL

On 7/3/10 3:57 PM, "Diogo Almeida" <[email-masked]> wrote:

Hello,

     POST /token HTTP/1.1
     Host: server.example.com <http://server.example.com>
     Authorization: Basic czZCaGRSa3F0MzpnWDFmQmF0M2JW
     Content-Type: application/x-www-form-urlencoded

it should read:

     POST /token HTTP/1.1
     Host: server.example.com <http://server.example.com>
     Authorization: Basic czZCaGRSa3F0MzpnWDFmQmF0M2JW
     Content-Type: application/x-www-form-urlencoded

     code=i1WsRn1uB1&

And where it reads:

     POST /token HTTP/1.1
     Host: server.example.com <http://server.example.com>
     Content-Type: application/x-www-form-urlencoded

It should read:

     POST /token HTTP/1.1
     Host: server.example.com <http://server.example.com>
     Content-Type: application/x-www-form-urlencoded

     client_id=s6BhdRkqt3&

Best regards,
Diogo Almeida