Subject: MDCs and PGP 6.5.1b15

From: Werner Koch <[email-masked]>
Date: Mon, 17 May 1999 15:12:16 +0200

Hi,

I think I found a reason why NAI argues against MDCs in signature
packets.  There is a key which caused some key servers to crash and
it seems that this one has been created by a new PGP version.  The
key looks like this:

:public key packet:
        version 3, algo 1, created 838857600, expires 0
        pkey[0]: [1024 bits]
        pkey[1]: [17 bits]
:user id packet: "Thawte Server CA <[email-masked]>"
:signature packet: algo 0, keyid 0000000000000000
        version 4, created 0, md5len 0, sigclass 10
        digest algo 1, begin of digest 00 00
        hashed subpkt 2 len 5 (sig created 1996-08-01)
        hashed subpkt 3 len 5 (sig expires after 24y158d23h59m)
        hashed subpkt 5 len 3 (trust signature)
        hashed subpkt 100 len 795 (?)
        unknown algorithm 0
  
So we have all the stuff Tom proposed for MDCs in signature packets:
keyid of zero and a public key algorithm identifier of zero.  The
private subpacket with id 100 maybe a X509 certificate - I have not
analyzed it.

If this has really been created by PGP, why didn't tell NAI us about
it?  

Tom, what about changing your MDC to use a unhashed subpacket for the
MDC instead of an MPI?  I think this will be a much nicer solution and
I wonder why we didn't came up with this earlier.

-- 
Werner Koch at guug.de           www.gnupg.org           keyid 621CC013

---

From: Tom Zerucha <[email-masked]>
Date: Mon, 17 May 1999 19:41:53 -0400

On Mon, 17 May 1999, Werner Koch wrote:

[key stuff deleted]

It may be a rogue version - and although I never sent any such keys to any
PGP server, I did experiment with using the X509 output capabilities of
openssl (so you could use a PGP key in an X509 routine, and vice versa).

> I wonder why we didn't came up with this earlier.

That would also work - I would have to put in the logic earlier, but then
the signature test logic wouldn't have the zero algorithm there.

We just need an unhashed packet ID