Subject: [openpgp] OCB statement from Rogaway

From: Werner Koch <[email-masked]>
Date: Sun, 28 Feb 2021 20:23:16 +0100

Hi!

I think this is important for us.

The statement from Phil Rogaway may allow us to have OCB as a MUST
implement mode and degrade EAX to a MAY implement mode.

Salam-Shalom,

   Werner

Subject: [Cryptography] Direct public confirmation from Dr. Rogaway
From: "Salz\, Rich via cryptography" <[email-masked]>
To: "cryptography\@metzdowd.com" <[email-masked]>
Date: Sat, 27 Feb 2021 19:37:30 +0000
List-Id: The Cryptography and Cryptography Policy Mailing List <cryptography.metzdowd.com>

https://mailarchive.ietf.org/arch/msg/cfrg/qLTveWOdTJcLn4HP3ev-vrj05Vg/ :

I can confirm that I have abandoned all OCB patents
and placed into the public domain all OCB-related IP of mine.
While I have been telling people this for quite some time, I don't
think I ever made a proper announcement to the CFRG or on the
OCB webpage. Consider that done.

I hope people will use the scheme to do positive things.

phil
_______________________________________________
The cryptography mailing list
[email-masked]
https://www.metzdowd.com/mailman/listinfo/cryptography

-- 
Die Gedanken sind frei.  Ausnahmen regelt ein Bundesgesetz.

---

From: "brian m. carlson" <[email-masked]>
Date: Sun, 28 Feb 2021 19:31:34 +0000

> implement mode and degrade EAX to a MAY implement mode.

Yes, I saw that as well.  I'm happy to even drop EAX in favor of OCB now
that we don't have the patent concerns.
-- 
brian m. carlson (he/him or they/them)
Houston, Texas, US