Subject: Re: [openpgp] openpgp WG design team plan

From: Stephen Farrell <[email-masked]>
Date: Fri, 16 Jul 2021 17:16:39 +0100

Hi all,

Just an update on that. We formed the DT as planned and
there's a DT mailing list (closed subscription but with
an open archive).

We'd like to thank Justus Winter and Daniel Huigens for
volunteering to help the editors (Paul and Werner) and
the chairs on the design team.

We had our first call today and the meeting notes are
at [1] in the DT list archive.

Cheers,
S.

[1] 
https://mailarchive.ietf.org/arch/msg/openpgp-dt/yFnDnsDCtqxj_p3OVTRiRZJx16A/

On 18/06/2021 14:29, Stephen Farrell wrote:
> 
> Hi all,
> 
> As you may have noticed we've not asked for a session for the
> openpgp WG at IETF-111. The main reason is that we didn't see
> that being so productive for us at this point as we probably
> need to get more of the "catch-up" work out of the way before
> it'd be a good way of using so many people's time.
> 
> So, in order to try speed things up a bit, we (as chairs) are
> going to try form a design team. Our idea is that that team
> will consist of the chairs and editors (Paul and Werner) and
> a few others, will meet roughly monthly with the goal of
> reviewing all the changes needed to bring the WG draft up to
> the same level as the earlier draft-10. We hope that the DT
> will emit an I-D also roughly monthly, as changes are handled
> and committed to the repo.
> 
> For those less familiar with the IETF's design team (DT)
> concept, a DT is a group selected by chairs who do some work
> that is then an input to the WG - whether or not the WG have
> rough consensus on the DT output is up to the WG and not the
> DT. For this DT, we'll have a closed mailing list with an
> open archive, and, as stated, roughly monthly calls.
> 
> So, if you're interested in helping out, *and* can commit to
> making those calls, *and* to reviewing changes in between
> calls, then please drop a note to the chairs. We plan to try
> get this started in the next couple of weeks, with a goal of
> resolving all the draft-10->WG draft issues ideally by the
> end of August (ok, that's optimistic, but hey, why not? :-).
> 
> Thanks,
> Stephen & Daniel.
> 
> 
> _______________________________________________
> openpgp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/openpgp
>

---

From: Ángel <[email-masked]>
Date: Mon, 19 Jul 2021 02:00:29 +0200

> there's a DT mailing list (closed subscription but with

It's nice to see this start rolling on. Or about to.
I guess the open archive is so that non-members can keep track of the
DT activity.

Would it be possible to do directly from the inbox (i.e. as a mailing
list) instead of using the archives?

Cheers

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Tue, 20 Jul 2021 16:38:21 -0400

> I guess the open archive is so that non-members can keep track of the

Yep, that's right, though we don't expect or need everyone in the WG to
follow it closely.  The DT will post back regular progress reports to
the main [email-masked] mailing list.

> list) instead of using the archives?

Good idea!  I don't know that this has been done before for a DT list on
IETF infrastructure, but I took a look at the settings for mailman, and
i think i've adjusted the permissions appropriately to make that work.

Anyone should now be able to subscribe to the [email-masked]
mailing list [0] via standard e-mail confirmation, and they'll receive
openpgp-dt messages in their inbox, but only members of the DT can post
to that list.

This is an experiment, and hopefully it will work out as planned.  If we
find it doesn't, i'll revert to the earlier settings and let folks know
how it failed.

Regards,

        --dkg

[0] https://www.ietf.org/mailman/listinfo/openpgp-dt