Subject: [OPS-AREA] OPS Area WG Charter proposal

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Wed, 18 Apr 2007 09:26:35 +0300

Following the discussions in the OPS Area meetings in Prague, please
find below an initial proposal for chartering a OPS Area Working Group.
Please provide feedback, comments and proposals for charter items to
[email-masked]. 

Ron and Dan

Operations and Management Area Working Group (opsawg)

Chair(s): 

TBD
TBD

Area Directors: 

Dan Romascanu <[email-masked]>
Ronald Bonica <[email-masked]>

The Operations and Management Area receives occasional proposals for 
the development and publication of RFCs dealing with operational and 
management topics that are not in scope of an existing working group 
or do not justify the formation of a new working group. The OPSAWG will 
serve as the forum for developing such work items in the IETF.

The OPSAWG mailing list is an open discussion forum for such work 
items, when they arise. The working group meets if there
are active proposals that require discussion. The working group 
milestones are updated as needed to reflect the current work items and 
their associated milestones. All new work items and rechartering 
proposals will be brought for approval with the IESG.
  
The focus of the work will be on topics that govern the behavior or 
WGs in the O&M area  (e.g., manageability
requirements) and on small, highly focused projects that don't merit a 
WG of their own or belong to WGs that have already concluded (e.g. 
advancement of documents on the standards track,  application 
statements, extensions of MIB modules).
  
The OPSAWG will undertake only work items that are proved to have at 
least a reasonable level of interest from the operators and users 
community and have a committed number of editors and reviewers.  It is 
not within the scope of the OPSAWG to pick up failed WG work or parts 
of a WG charter items that could not come to convergence on what they 
were chartered to do.
  
The currently active OPSAWG work items mostly fall under the following
topics:
  
(A) Development of a BCP document that will provide guidelines for 
operational and manageability requirements that need to be covered in 
IETF documents, especially those documents that include requirements 
and specification of new protocols or protocol extensions.
  
(B) Templates and tools for Operations and Management Area Documents
  
(C) Maintenance and extensions of documents that define MIB modules 
which were developped in working groups that have concluded.
  
Goals and Milestones:
  
June 2007 - Initial submission for the Guidelines for Considering 
Operations and Management of New Protocols Internet-Draft 

December  2007 - WGLC for the Guidelines for Considering Operations and 
Management of New Protocols Internet-Draft 

February 2008 - Submit the Guidelines for Considering Operations and 
Management of New Protocols Internet-Draft to the IESG for consideration
as BCP

_______________________________________________
OPS-AREA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ops-area

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 18 Apr 2007 08:43:20 +0200

> Please provide feedback, comments and proposals for charter items to

A quick question - do small (SNMP) protocol extensions also fall into
this WG?  I am talking about things like the SNMP over IEEE 802 spec
we did last year to support work in the IEEE or the SNMP LocalEngineID
document I am currently editing (draft-schoenw-snmp-discover-02.txt).
The charter specifically talks about MIB modules.

I am not specifically asking for inclusion; the individual submission
approach we used for the SNMP over IEEE 802 spec was fast and pretty
much painless. Perhaps I am just asking for guideance how
draft-schoenw-snmp-discover-02.txt document should be handled... ;-)

/js

-- 
Juergen Schoenwaelder		 Jacobs University Bremen
<http://www.eecs.iu-bremen.de/>	 P.O. Box 750 561, 28725 Bremen, Germany

---

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Wed, 18 Apr 2007 10:11:55 +0300

Long-term we want to reduce the load on the ADs and ensure that such
documents undergo wider community review. For these reasons I believe
that such documents would fall under the scope and we should find some
charter words to make this clear, e.g.:

D) minor extensions to management protocols and definition of new
transport mappings of management protocols

For the specific case, we will not delay ongoing work, and we may still
use individual submission via AD unless the OPSAWG is approved quickly. 

Dan

> -----Original Message-----
> From: Juergen Schoenwaelder [mailto:[email-masked]] 
> Sent: Wednesday, April 18, 2007 9:43 AM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]
> Subject: Re: [OPS-AREA] OPS Area WG Charter proposal
> 
> A quick question - do small (SNMP) protocol extensions also 
> fall into this WG?  I am talking about things like the SNMP 
> over IEEE 802 spec we did last year to support work in the 
> IEEE or the SNMP LocalEngineID document I am currently 
> editing (draft-schoenw-snmp-discover-02.txt).
> I am not specifically asking for inclusion; the individual 
> submission approach we used for the SNMP over IEEE 802 spec 
> was fast and pretty much painless. Perhaps I am just asking 
> for guideance how draft-schoenw-snmp-discover-02.txt document 
> should be handled... ;-)
> 
> /js
> 
> --

---

From: "David Harrington" <[email-masked]>
Date: Wed, 18 Apr 2007 20:26:27 -0400

Hi,

We are moving from an SNMP-focused to a multi-protocol 
focused approach.

The MIB module templates I have been working on will help 
people develop the surrounding text for MIB modules (and then 
they #include the actual MIB module definitions into the document).

Do you think we should develop a generic template that has 
similar sections, to provide the surrounding descripions for 
things like netconf data models, syslog structured data 
elements, and so on? 

Such a document template could include sections for
1) management framework boilerplate (probably with a pointer 
to the guidelines for operability and manageability)
2) conventions and terminology
3) an overview of the technology being managed via the data model
4) the structure of the data model
5) how the data model relates to other data models
6) definitions <the actual data model>
7) security considerations (with specific NM-related guidelines)
8) IANA considerations (with NM-specific considerations)
9) normal sections for acknowledgements, references, etc.
 
If you think this would be worth doing, should it be an item 
in the charter of the OPSWG? 

David Harrington
[email-masked] 
[email-masked]
[email-masked]

> From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
> Sent: Wednesday, April 18, 2007 2:27 AM
> To: [email-masked]
> Subject: [OPS-AREA] OPS Area WG Charter proposal
>

---

From: Jon Saperia <[email-masked]>
Date: Wed, 18 Apr 2007 20:31:54 -0400

To the extent you do this work, the different data models should be
related. That is, if you create configuration data models, then the
monitoring objects in existing MIB modules, or new MIB objects should
be cross referenced.

/jon

David Harrington wrote:

Hi,

David Harrington
[email-masked]
[email-masked]
[email-masked]

-----Original Message-----
From: Romascanu, Dan (Dan) [mailto:[email-masked]]
Sent: Wednesday, April 18, 2007 2:27 AM
To: [email-masked]
Subject: [OPS-AREA] OPS Area WG Charter proposal

Following the discussions in the OPS Area meetings in Prague, please
find below an initial proposal for chartering a OPS Area
Working Group.
Please provide feedback, comments and proposals for charter items to
[email-masked].

Ron and Dan

Chair(s):

TBD
TBD

Area Directors:

or do not justify the formation of a new working group. The
OPSAWG will
serve as the forum for developing such work items in the IETF.

milestones are updated as needed to reflect the current work
items and

requirements) and on small, highly focused projects that
don't merit a

least a reasonable level of interest from the operators and users
community and have a committed number of editors and
reviewers. It is
not within the scope of the OPSAWG to pick up failed WG work or

parts

of a WG charter items that could not come to convergence on what

they

were chartered to do.

The currently active OPSAWG work items mostly fall under the

following

topics:

(A) Development of a BCP document that will provide guidelines for
operational and manageability requirements that need to be covered

in

Goals and Milestones:

December 2007 - WGLC for the Guidelines for Considering
Operations and
Management of New Protocols Internet-Draft

Management of New Protocols Internet-Draft to the IESG for
consideration
as BCP

--
Jon Saperia
(cell) 617-201-2655
(Eve.) 978-461-0264