Subject: [OPS-AREA] Q: Why no open [email-masked] mailing list ?

From: Toerless Eckert <[email-masked]>
Date: Fri, 25 Jun 2021 20:05:57 +0200

I was just wondering about subject matter, triggered by an issue with Yang we have
in an ANIMA draft.

I understand the process of asking for yang doctor review, and thats fine and dandy for
official resolution, but it does not seem to particularily seem to help proliferate
knowledge about yang in the community given how yang-doctors is a closed mailing list.
Which means that 

a) It is more difficult to read/observe the list unless you like the archive
   web interface and/or have an email system where you can subscribe to the archive via imap.

b) It is not mean for casual discussions about yang given how (AFAIK) its specifically
   created to only reuqest help from yang doctors. This of course also includes
   beginners questions, where you do know the question is so silly that it would
   likely be a waste of precious yang-doctor cycles.

Aka: not criticising yang-doctors setup, i think for what its intended its sete up
correctly, i am just wondering if it would not be helpful
to amend it with an open yang discussion list for the overall IETF community.

Some more specialized yang non-WG mailing lists exist, but afaik especially not in
OPS, where IMHO arguably the largest demand for yang models should exist.

Cheers
    Toerless

---

From: Andy Bierman <[email-masked]>
Date: Fri, 25 Jun 2021 11:25:04 -0700

Hi,

> OPS, where IMHO arguably the largest demand for yang models should exist.
IMO email is not the greatest way to help people figure out YANG.
I remember discussing the idea with the ADs in the past about moving
RFC 8407 online,
and updating it often as needed. (As opposed to recording another yang-next
issue
and forgetting about it).  Maybe an online IETF YANG FAQ would help.

FYI...
I posted this email to yang-doctors on May 5 and got no response...

 Hi,

I know Benoit tried very hard to make the IETF proactive and
engage the user and tools community.  He actually used to do
the stuff below in f2f meetings on Sunday sessions at the IETF

I notice that the YANG doctor review process is very heavyweight,
scarce resources, and very official.

What if we proactively headed off bad YANG usage before it got to the YD
review?

What if we had a FAQ on good YANG usage, and a WEB site so people
could submit questions to the YANG doctors about their modules.
Each question becomes another entry in the FAQ.

It should be open to any YANG developer, even vendors, not just all SDOs.
Sponsors should get a small logo on the Sponsors tab.
If it cannot be hosted by the IETF than maybe a new WEB site can be created
for it.

Is there any interest in such a project?

I have found that if you steer people into good design and
don't make them start over then they will just do it.
Now if we could only get people to design the data model before they start
writing it....

Cheers
>     Toerless

Andy

>
> _______________________________________________
> OPS-AREA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ops-area
>

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 25 Jun 2021 21:02:08 +0200

Thanks, Andy, inline
> IMO email is not the greatest way to help people figure out YANG.

Thats probably true for many if not most IETF technologies. I was only
claiming it would be extremely helpful to have instead of not having it.
In-person discussions or online meeting calls for example are often btter too ;-)

> RFC 8407 online, and updating it often as needed. (As opposed to recording 
> another yang-next issue and forgetting about it).

No reason not to start such an effort yourself. Alas, our tooling is not
ideal to make it easy. I wouldn' recommend codimd as it does not allow
to asily undo changes, which leaves our trac wiki, which is ok, but just
a good amount of work to convert the rfc first into the format and
be somewhat diligent on having a good changelog.

>  Maybe an online IETF YANG FAQ would help.

This one ? https://trac.ietf.org/trac/netmod/wiki/YANG_FAQ

Neith of these type of wiki pages are IMHO a good reason to NOT have a mailing list though.

> scarce resources, and very official.

Sure. WHich is exactly why i suggested to add the simple options which _may_
help mor with self-help.

> Each question becomes another entry in the FAQ.

Sure. For both of this we need easy options for more participants to
contribute and help each other. Did i say mailing list ?

> If it cannot be hosted by the IETF than maybe a new WEB site can be created

There is nothing in our IETF processes that would prohibit anyone to participate.

> Now if we could only get people to design the data model before they start

;-)

Cheers
    Toerless

-- 
---
[email-masked]