Subject: [OPSAWG] DRAFT Notes From Vancouver Meeting

From: "Seely, Ted A [CTO]" <[email-masked]>
Date: Tue, 11 Dec 2007 16:16:45 -0600

Hi All,

Here are the draft notes from the meeting.  Please add, correct, clarify as needed please.

Thanks

Agenda Bashing

Sharon Chisholm asked for time to discuss syslog alarming document (draft-gerhards-chisholm-syslog-alarm-01.txt)

KIKUCHI Yutaka asked for time to discuss/address tunnel work document during open mic after presentations?

        Dan Romanascu as AD - this presentation has been made before (Chicago - IETF 69), and is more suited to IPPM
        No prob to re-present if there is time, but doesn't think it belongs here in OPSAWG.

        Yutaka - IPPM chair is not sure it belongs there either, as it is an active measurement.

        Scott Bradner as WG co-chair - if there is time we will discuss

Dan Romanascu as AD - can we discuss initial charter draft (draft-ietf-opsawg-snmp-engineid-discovery-00.txt)

        Ted Seely as co-chair - as we had previously discussed, there is agreement to take to last call on mailing list -
        no objections in audience.

---------------------------------

Agenda Presentations

Dave Harrington - SMI to XSD Translations

Take aways - make draft-li-natale-smi-datatypes-in-xsd-00 a OPSAWG doc (slide 10)

Andy Bierman - question - is the output of the WG a doc that contains the algorithms for translations, or the module of types - because they are incompatible.

        Harrington - trying to limit it to only the translation of RFC 2578 & 9

        Andy Bierman - that won't include addresses

Sharon Chisholm - scope question.  methods for defining netconf data types - seems like SMI translations want SNMP consistency, doesn't understand why you want to align?

Dave Harrington - not sure that what Yang and he (Dave) wants are the same thing.

Sharon Chisholm - we are disagreeing on XML type, not sure what the value is.

Dave Harrington - if using an XML data structure to access MIB data, we want standardized XSD to acquire that.  it is not to support NETCONF, or web based services, it is just if you are going to from XML, here is a way to do it. If you are going to access MIB data, need a way to make sure you understand the baggage that comes with

Sharon Chisholm - does comparing these things make sense?

Dave Harrington - BOF said yes.  mail list said we don't want multiple versions of XSD flying around.  wants to ask chairs to mod charter to admit/address
goal is to get past issue of multiple versions of XSD - must i.d. diff version to do so

Dan Romanascu - questioning the blocking effect?  what prevents progress / conclusions that it does more harm than good, vis a vis,

Dave Harrington - lots of time spent debating - not sure its technical or personal

Bob Natale - problem is we haven't taken use cases seriously.  Need to push to ADs and use case for translating MIBS to XML via XSD.  Distinct point Netconf, rendering the XML for a given context.  Leadership decision?  can we address these diff use cases and is there one decision that addresses all?  be more forceful about use cases, and define them and when the baggage is appropriate?

Andy Bierman  - agrees with Bob.  Use case for straight translation for using mgr tool for accessing snmp data w/o using snmp agent/tool?  Security implications? Netconf issues are unique, and this issue isn't solving a general problem that is useful to everyone.

Bob Natale - Asks is there a use case that is applicable to everyone?

Dave Harrington - says if netconf wants to use a diff counter than SMI uses, then name it differently.

Andy Bierman - says they do,

Sharon - agrees with Bob and Andy and use cases, not 2 diff translations depending on how you look at it, doesn't think they're 2 diff translations for the same things because the use cases are very diff.

Scott Bradner (as chair) - asks does the Yang team have anything to say in response,
        Responders Name Unintelligible - agree that common data types would be nice - need to sit at table and see what can be arrived at.

Dave Partan - acknowledges and states to Dave Harrington & Bob Natale, want to work with you all and have same view

Dave Harrington back on preso - diff use cases may drive diff XSDs, like to see otherwise, but...
protocol independent would be best.

Dave Harrington (?) - SHOULD HARMONIZING BE DONE IN OPSAWG?

Scott Bradner (as chair) - asks do you have anything specific to be done?

Dave Harrington - start with doc, and move forward

Bob Natale - about proposed approach - putting forth reqs that we expect to satisfy w/o considering why?

Scott Bradner - IETF has been really good at max'ing defining req's, lets move forward.

Bob Natale - Agree - this isn't a hard task

Scott Bradner (as co-chair) - asks group - is this worth doing?

Dave Harrington makes suggestion - lets compare some translations that have been done.

Dave Harrington's point is we are going for human readability
        Scott Bradner asks do we want to discuss that.  (technology vs. human readability)
        Bob Natale- answers - in some cases comments or more info in definition of OID can impede and is meaningless to real reader.
        Scott Bradner - what's the balance?
        Bob Natale - important content vs. bloat comments.  (summarized)

Andy Bierman - does the doc deal with XML encoding issues?  characters, etc...?
        Dave Harrington - not that he is aware of.
        Andy Bierman - at this level can it be ignored?
        Dave Harrington - not aware

Phil Shaffer - making rules on how XML will be encoded?  LIB SMI gives 2 ways to gen data , which path are you talking?  SNMP as flat tables, or hierarchy?
        Dave Harrington - doesn't know
        Bob Natale - plan in XMSDI to take another doc (what doc?  ref please) , use what it does and incorporate that.
        Phil Shaffer - suggests hierarchical view

Bob N - addressing file being displayed - and cosmetics of raw pattern vs, objects
        (left side is data types draft (romanscanu), right side is LIB SMI)

Andy - not xsd friendly - xsd needs to be told how to process pattern (app info?)

Jabber question - relayed by Dan R. for Dave Perkins - how do you figure out how to get hierarchical data from SNMP flatness
        Phil Shaffer - not my magic, but Juergen does it off the index code.

Scott Bradner's observation is at the high order bit they are very similar
        Dave Harrington - agrees, need tool generators to provide some guidance
        readability
        readability by readers of the doc
        readability by readers/developers
        readability by tool users
                Andy Bierman has a question regarding current file being displayed - can you go over the bits data type (its diff)?
                Dave Harrington - netconf issues on how it is used with a union and an index. yang is more human friendly and would be, and friendliness to XSD                         LisT.
                Andy Bierman - lets come to an agreement and stick with it.

Scott Bradner (as co-chair) - show of hand - consistent way of doing this is a worthwhile endeavor - yes (many) outweighs no's (zero)

Open question - do it in this WG? Discuss with ADs to add to charter?

Dan Romanascu as AD - draft applicability statement, etc... ?

---------------------------------

OPEN MIC

Sharon on SYSLOG
        - no slides - open discuss
                status of indiv. submission
                        description of mapping
                        defined SD output params

                reasonable interest in CHI
                update & posted to mailing list
                wondering next steps?

        Scott Bradner as co-chair - what status

        Sharon Chisholm - standards track

        Dave Harrington - as chair of syslog WG - thinks its useful and not doing it there as syslog is in security area - he supports the work in OPSAWG

        Ron Bonica as AD - please address informational versus proposed standard

        Sharon Chisholm - defines some interoperability issues between vendors / alarm types , fields, tags , severity mapping diffs...

        Gene Govlinksy(SP?) - move forward with it

        Dan Romanascu as contrib. - believes its a useful doc as well

        Sharon Chisholm - doc aligns with ITU & Alarm MIBs.

        Scott Bradner as co-chair - can you do a sanity check with ITU since Alarm'ing types are near and dear to them

        Scott Bradner as co-chair - asks for show of hands for standards track - hands up - many yes's, zero no's

Dan Romanascu as AD - draft naming led to confusion - will be taken as a WG work.

------------------------

KIKUCHI Yutaka discussing tunnel measurement performance draft (draft-kikuchi-tunnel-measure-req-01.txt)

        discussing two IDs
        focus on OAM point of view
        split from one ID into 2
        Prague ietf - IPPM not the right place (no OPSAWG then)
        (Basically looking for a home)
        draft has been rev'd

        should it be discussed here?
                Kikuchi thinks the 1st one belongs here but not metrics piece
        metrics alternatives
                not IPPM
                not within PMOLs charter (charter?)

Scott Bradner as co-chair asks - can you address comments on mailing list in summary here?

                Yutaka thinks he already did

                Scott Bradner - terminology not clear enough - too ambiguous?

Scott Bradner as co-chair - is working on a doc that defines perf. of measurement of tunnels to interest in the room.  yes's 2 , no's 1.

        not comfortable expanding charter to accept the work.

last call

Dan (AD) - ops & mgmt'abilty draft - Dave h can you speak too?

        dave h - big issue from last mtg
                need input from others,
                Dave Kessens will deliver his review to Dave Harrington tomorrow
                presentation tomorrow in WG Chairs Lunch
                these are guidelines for Ops & Mgmt for other WGs and protocol developers.

                Scott Bradner as co-chair asks - timeframes?

                Dave Harrington - still looking for feedback from operators
                        still looking for more reviewers in operator land

                Scott Bradner as co-chair - if you are comfortable after review, we can ask for last call

                Dave Harrington - we'll try to see if we can complete it within 30 days.

------------------------

mic closed

session adjourned

_______________________________________________
OPSAWG mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/opsawg

---

From: KIKUCHI Yutaka <[email-masked]>
Date: Wed, 12 Dec 2007 07:35:18 +0900 (JST)

Ted-san, and the loggers,

Thanks for the log. I am sending a correction.

> Here are the draft notes from the meeting.  Please add, correct, clarify as needed please.

snip...

"-01.txt" -> "-02.txt"

> Scott Bradner as co-chair - is working on a doc that defines perf. of measurement of tunnels to interest in the room.  yes's 2 , no's 1.

"yes's 2 , no's 1." -> "yes's 5, no's 1, many neutral"

>         not comfortable expanding charter to accept the work.

snip...

-- Regards, Yu.