Subject: Re: [OPSAWG] new IETF draft - large flow load-balancing

From: "Fred Baker (fred)" <[email-masked]>
Date: Sun, 14 Oct 2012 04:36:45 +0000

A general remark: it would be good to spell out an acronym before using it extensively in a paper. LAG is, I presume, Link Aggregation, and ECMP is Equal-cost Multipath Routing.

Should there be a reference to RFC 2991, 2992, or 4814?

My general comment is that while this is an interesting algorithm that a vendor might choose to implement and sell, it is far from the only algorithm that could be used, and opportunistic load balancing could be automated rather than requiring continuous operator intervention. My personal recommendation for the draft is that it should seek experimental status.

---

From: ramki Krishnan <[email-masked]>
Date: Sun, 14 Oct 2012 10:40:36 -0700

Hi Fred,

Thanks for the comments. Please find answers inline.

I will be uploading a new version shortly.

Thanks, ramki

-----Original Message-----
From: Fred Baker (fred) [mailto:[email-masked]] 
Sent: Saturday, October 13, 2012 9:37 PM
To: ramki Krishnan
Cc: Scott O. Bradner; Chris Liljenstolpe; Melinda Shore; [email-masked]; Sanjay Khanna
Subject: Re: [OPSAWG] new IETF draft - large flow load-balancing

[ramki Krishnan] will do.

 [ramki Krishnan] Probably not - these RFCs treat all flows alike and do not distinguish between large and small flows.

 [ramki Krishnan] The draft suggests various techniques and their tradeoffs for a locally optimized solution addressing the following scenarios 1) Different links in the network experience different levels of utilization and, thus, a more "targeted" solution is needed for those few hot-spots in the network 2) Some networks may lack end-to-end visibility. This is based on feedback from Network Operators (especially Shane Amante from Level-3).

The feedback from Network Operators was the preference for a manual intervention for load-balancing, given the fact that moving large flows may have some side effects. I will add automation of load balancing as a possible option.

I would agree on the experimental status.

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Sun, 14 Oct 2012 20:15:33 +0000

> [ramki Krishnan] Probably not - these RFCs treat all flows alike and do not distinguish between large and small flows.

True. But they describe the hashing algorithms you refer to.