Subject: [OPSAWG] Fwd: Feedback Requested: Proposed IEEE RAC OUI Tier Restructuring

From: Melinda Shore <[email-masked]>
Date: Wed, 12 Dec 2012 18:46:16 -0900

Likely of interest to the OPS community.

-------- Original Message --------
Subject: 	Feedback Requested: Proposed IEEE RAC OUI Tier Restructuring
Date: 	Wed, 12 Dec 2012 19:37:23 -0800
From: 	IAB Chair <[email-masked]>
To: 	[email-masked] <[email-masked]>

The IEEE Registration Authority Committee (RAC) has requested IETF
feedback on a proposal for restructuring of the Organizational Unique
Identifier (OUI) within the IEEE 802 Medium Access Control (MAC)
Address.  Information on the proposal is available here:

http://www.ietf.org/iesg/ieee/20120725/RAC_Virtualization_July2012.pdf

http://ieee802.org/secmail/msg15524.html

Comments should be sent to Glenn Parsons <[email-masked]
<mailto:[email-masked]>> and cc’d to [email-masked] <mailto:[email-masked]>.

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Thu, 13 Dec 2012 08:26:04 +0000

On Dec 13, 2012, at 7:46 AM, Melinda Shore wrote:

> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

My first thought on scanning the deck is that the problem is fundamentally one of scaling. The reason that we structure addressing and routing as we do in IP is to make addressing and routing scale. The Ethernet MAC was designed to identify a NIC on a physical wire, and by extension in a VLAN. It seems to me that the VM problem they are having derives primarily from the confusion of a network attachment point on a broadcast LAN with a large scale routing architecture.

As noted, one approach is a DHCP-like assignment of MAC addresses. This doesn't do away with physical addresses; the DHCP-like request would come from the physical address, and the response to it, assigning a virtual address to a VM. 

But it frankly seems a lot simpler to use RFC 4941 addresses layered onto the physical addresses and as a result a scalable routing infrastructure, rather than trying to do large scale host routing.

My $0.02.