Subject: [OPSAWG] FW: [ieee-ietf-coord] Liaison from IEEE 802.1 - Deterministic Networking

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 22 Jul 2014 18:51:55 +0000

Forwarding to folks in NETCONF and the OPS area.

Regards,

Dan

From: ieee-ietf-coord [mailto:[email-masked]] On Behalf Of Norman Finn (nfinn)
Sent: Tuesday, July 22, 2014 6:17 PM
To: Glenn Parsons; [email-masked]; Richard Barnes; Alissa Cooper; Alia Atlas; Adrian Farrel; Julien Meuric; JP Vasseur; Alvaro Retana (aretana); Jeff Tantsura; Brian Haberman; [email-masked]; Pascal Thubert (pthubert); [email-masked]; Karen O'Donoghue; Yaakov Stein; Spencer Dawkins; [email-masked]; David Black; Gorry Fairhurst; James Polk (jmpolk); Benoit Claise (bclaise); Joel Jaeggli; Mehmet Ersue; Bert Wijnen
Cc: [email-masked]
Subject: Re: [ieee-ietf-coord] Liaison from IEEE 802.1 - Deterministic Networking

I organized this meeting (requested the room, etc.)  There will be a < 20-slide introduction, then a free-for-all discussion.  I appreciate that this is a request for a time commitment from some very busy people.  In that vein, the invitees should feel free to delegate their attendance to parties who may have a particular interest.

I’m attending meetings all week.  Feel free to txt me at 1-925-980-6430 with questions or complaints.  Email may work, also.

— Norm Finn

From: Glenn Parsons <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 22, 2014 at 04:04 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Richard Barnes <[email-masked]<mailto:[email-masked]>>, Alissa Cooper <[email-masked]<mailto:[email-masked]>>, Alia Atlas <[email-masked]<mailto:[email-masked]>>, Adrian Farrel <[email-masked]<mailto:[email-masked]>>, Julien Meuric <[email-masked]<mailto:[email-masked]>>, JP Vasseur <[email-masked]<mailto:[email-masked]>>, "Alvaro Retana (aretana)" <[email-masked]<mailto:[email-masked]>>, Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, Brian Haberman <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Pascal Thubert <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Karen O'Donoghue <[email-masked]<mailto:[email-masked]>>, Yaakov Stein <[email-masked]<mailto:[email-masked]>>, Spencer Dawkins <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, David Black <[email-masked]<mailto:[email-masked]>>, Gorry Fairhurst <[email-masked]<mailto:[email-masked]>>, "James Polk (jmpolk)" <[email-masked]<mailto:[email-masked]>>, "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>, Joel Jaeggli <[email-masked]<mailto:[email-masked]>>, Mehmet Ersue <[email-masked]<mailto:[email-masked]>>, Bert Wijnen <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [ieee-ietf-coord] Liaison from IEEE 802.1 - Deterministic Networking

To:

Richard Barnes <[email-masked]<mailto:[email-masked]>>; Alissa Cooper <[email-masked]<mailto:[email-masked]>>;
Real-time Applications and Infrastructure Area Directors

Alia Atlas <[email-masked]<mailto:[email-masked]>>; Adrian Farrel <[email-masked]<mailto:[email-masked]>>;
Routing Area Directors

Julien Meuric <[email-masked]<mailto:[email-masked]>>; JP Vasseur <[email-masked]<mailto:[email-masked]>>;
Path Control Element WG chairs

Alvaro Retana (aretana) <[email-masked]<mailto:[email-masked]>>; Jeff Tantsura
<[email-masked]<mailto:[email-masked]>>; Routing Area WG chairs

Brian Haberman <[email-masked]<mailto:[email-masked]>>; Ted Lemon
<[email-masked]<mailto:[email-masked]>>; Internet Area Directors

Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>; Thomas Watteyne
<[email-masked]<mailto:[email-masked]>>; IPv6 over TSCH WG chairs

Ray Bellis <[email-masked]<mailto:[email-masked]>>; Mark Townsley <[email-masked]<mailto:[email-masked]>>;
Home Networking WG chairs

Karen O'Donoghue <[email-masked]<mailto:[email-masked]>>; Yaakov Stein <[email-masked]<mailto:[email-masked]>>;
Tictoc WG chairs

Spencer Dawkins <[email-masked]<mailto:[email-masked]>>; Martin Stiemerling
<[email-masked]<mailto:[email-masked]>>; Transport Area Directors

David Black <[email-masked]<mailto:[email-masked]>>; Gorry Fairhurst <[email-masked]<mailto:[email-masked]>>;
James Polk (jmpolk) <[email-masked]<mailto:[email-masked]>>; Transport Area WG chairs

Benoit Claise <[email-masked]<mailto:[email-masked]>>; Joel Jaeggli <[email-masked]<mailto:[email-masked]>>;
Operation and Management Area Directors

Mehmet Ersue <[email-masked]<mailto:[email-masked]>>; Bert Wijnen <[email-masked]<mailto:[email-masked]>>
Network Configuration WG chairs

At 8:00 PM on Wednesday, July 23, at IETF90 in Toronto, there will be a
side meeting (aka Bar BOF — see RFC6771) on the subject of Deterministic
Networking in the Quebec room.  IEEE 802.1 wishes to encourage your
cooperation and/or participation.

Over the past few years, the IEEE 802 Audio Video Bridging Task Group and
it successor, the Time-Sensitive Networking TG, have released standards
that define:

1. Protocols for the reservation, by end stations, of Layer 2 network
resources for critical flows;
2. Specific data plane mechanisms for a Layer 2 network to guarantee 0
congestion loss, and consequently, a known finite end-to-end latency, for
those reserved flows; and
3. Plug-and-play distribution of the Precision Time Protocol (IEEE 1588
PTP) over bridged, routed, or mixed networks.

These standards were originally targeted for the transport of raw audio
and video streams.  The successful deployment of multi-vendor networks
employing these standards has triggered interest from new market segments,
including industrial, vehicular, and other real-time systems.  As a
consequence, the IEEE 802.1 Time-Sensitive Networking Task Group has
number of projects in progress to expand the first-round capabilities.

This success has also made clear that the users of these capabilities have
networking needs that transcend the limitations imposed by networks that
operate at only Layer 2.  The following elements are essential to expand
the current Time-Sensitive Networking TG’s standards into “Deterministic
Networking”:

A. Deterministic Networking has to be a QoS feature of standard networks,
not a set of point features around which one could write an Application.
B. The networks of interest contain a mixture of bridges and routers.  The
QoS features have to be supported regardless of Layer 2 / Layer 3
boundaries.  The control protocols must be visible to both routers and
bridges; every box along the path must reserve resources.
C. The host making the reservations must not care whether the first box to
which it is connected is a bridge or a router, or what suite of protocols
is used by the network to support its reservations.

A number of members of IEEE 802.1 believe that the models for information
propagation used by the Path Computation Element, RSVP, RSVP-TE, PCEP,
and/or segment routing are a superset of that used by the existing and
planned work by the 802.1 TSN WG, and offer a model for a combined Layer 2
/ Layer 3, IEEE / IETF, effort.

We hope that the Deterministic Networking side meeting can be used by the
participants to test the waters, and see whether there is interest in
working on the above problems.

--
Glenn Parsons - Chair, IEEE 802.1
[email-masked]<mailto:[email-masked]>
+1-613-963-8141

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 23 Jul 2014 19:39:45 -0400

On 22 Jul 2014, at 14:51, Romascanu, Dan (Dan) <[email-masked]> wrote:

> < 20-slide introduction,

… which apparently can be found here:

http://www.ieee802.org/1/files/public/docs2014/tsn-nfinn-Deterministic-Networking-L2-L3-0714-v1.pdf

Grüße, Carsten