Subject: [OPSAWG] Fw: I-D Action: draft-hartman-snmp-sha2-02.txt

From: t.petch <[email-masked]>
Date: Thu, 7 Aug 2014 10:51:24 +0100

I am not sure where this should be discussed but I note that it creates
a new SnmpAuthProtocols but it contains no request to IANA to register a
name and is Experimental whereas the update procedure for the registry
is Standards Track.

And if this seems familiar, it may be because I made similar comments
about
http://tools.ietf.org/html/draft-hmac-sha-2-usm-snmp-00
back in March this year

Tom Petch

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Thursday, July 31, 2014 7:41 AM

>
> A New Internet-Draft is available from the on-line Internet-Drafts
directories.
>
>
>         Title           : Authenticating version 3 of the Simple
Network Management Protocol (SNMPv3) using HMAC-SHA-2 procedures
>         Authors         : Sam Hartman
>                           Margaret Wasserman
>                           Dacheng Zhang
>                           Manav Bhatia
>                           Danping He
> Filename        : draft-hartman-snmp-sha2-02.txt
> Pages           : 10
> Date            : 2014-07-30
>
> Abstract:
>    This document describes the mechanism to authenticate SNMPv3
protocol
>    packets using Hashed Message Authentication Mode (HMAC) with the
SHA-
>    256, SHA-384, and SHA-512 algorithms.
>
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-hartman-snmp-sha2/
>
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-hartman-snmp-sha2-02
>
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-hartman-snmp-sha2-02
>
>
> Please note that it may take a couple of minutes from the time of
submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Wes Hardaker <[email-masked]>
Date: Mon, 11 Aug 2014 08:31:44 -0700

> name and is Experimental whereas the update procedure for the registry

It's certainly not implementable as-is.  It'd need to use a private
registration, both for in-packet identifiers and for oid identifiers.

-- 
Wes Hardaker
Parsons