Subject: [OPSAWG] OPEN-O draft

From: Hui Deng <[email-masked]>
Date: Mon, 4 Apr 2016 08:52:58 -0300

Hello all

We have posted a submission this morning, apologize for late submission.

https://www.ietf.org/id/draft-deng-opsawg-nfvrg-sdnrg-openo-00.txt

OPEN-O would intent to propose an open source project under Linux foundation. It
   includes cross domain orchestrator, SDN-O and NFV-O. SDN-O is
   sitting on top of SDN Controller like ODL or ONOS and somewhere
   below the SDN APP. NFVO is aligned with ETSI NFV ISG. This document
   is seeking for the relationship between open standard IETF and open
   source project OPEN-O.

thanks a lot for your kind review

Best regards,

DENG Hui

---

From: Warren Kumari <[email-masked]>
Date: Mon, 04 Apr 2016 23:34:17 +0000

There is very little content in the draft (although it does have a very
pretty ASCII art drawing), but I'm not sure why OpsAWG and not NFVRG (
https://datatracker.ietf.org/group/nfvrg/charter/) or SDNRG (
https://datatracker.ietf.org/group/sdnrg/charter/) or Netconf (
https://datatracker.ietf.org/group/netconf/charter/)

Those groups seem much more likely...

W

On Mon, Apr 4, 2016 at 8:53 AM Hui Deng <[email-masked]> wrote:

> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>

---

From: Hui Deng <[email-masked]>
Date: Tue, 5 Apr 2016 20:18:04 -0300

Hi Warren

As you said, we do also contact with NFVRG and SDNRG about the draft.
The reason coming to OPSAWG is to discuss about Yang related in OPS Area,
because there are multiple WGs related to this like (NETCONF, NETMOD),
so we approach OPSAWG for the simple way to proceed,

thanks a lot for your consideration
Best regards,

DENG Hui

---

From: Hui Deng <[email-masked]>
Date: Wed, 6 Apr 2016 14:45:13 -0300

Can I treat no reply means "No", thanks a lot for chair's reply,
that could save me time to work on useless preparation.

Best regards,

DENG Hui

---

From: Warren Kumari <[email-masked]>
Date: Wed, 06 Apr 2016 18:21:33 +0000

> that could save me time to work on useless preparation.

It is currently a No.

The current document has almost no detail. I think the right thing to do is:
1: flesh out the document so that there is content / protein.
2: discuss it in NFVRG / SDNRG, once there is support OpsAWG might be the
place for a yang discussion / how this integrates with other things, etc.

W

---

From: Andy Bierman <[email-masked]>
Date: Wed, 6 Apr 2016 11:52:20 -0700

Hi,

I have a stronger opinion...
IMO the IETF is not in the open-source business and has no
official role to play in open-source.  You should come to the
IETF with very specific requests that you want addressed
in the standards.

Andy

---

From: Hui Deng <[email-masked]>
Date: Wed, 6 Apr 2016 15:55:17 -0300

Thank you for letting us know after we asked, we must be not clear before.

We thought the architecture diagram shows some detail and content, maybe
different people has different opinion.
Anyhow we will try to work in other place first.

thanks a lot for your advice

DENG Hui

---

From: Hui Deng <[email-masked]>
Date: Wed, 6 Apr 2016 15:59:33 -0300

I see that open standard is working together with open source today, just
like OPSArea presentation today.
People are seeking for the cooperation, it doesn't mean open source is
superior than open standard, or vice versa

2016-04-06 15:52 GMT-03:00 Andy Bierman <[email-masked]>:

>>>>> There is very little content in the draft (although it does have a
>>>>> very pretty ASCII art drawing), but I'm not sure why OpsAWG and not NFVRG (

---

From: Melinda Shore <[email-masked]>
Date: Wed, 6 Apr 2016 11:19:55 -0800

On 4/6/16 10:59 AM, Hui Deng wrote:
> I see that open standard is working together with open source today,
> just like OPSArea presentation today.

I guess I don't understand why it requires "cooperation."
I think that the IETF has by and large benefited from an
increased focus on implementation, both in terms of the
quality of the documents (in those cases where there's an
implementation underway in partnership with the document
development) and in terms of the timeliness of the documents
(it's a lot easier to move things along when there's
running code available to support your argument).  So this
one's easy: code it up, check the code into a publicly-
available repository, and release it under a liberal license.

But, in this case, you appear to want more than that.
Again, the document doesn't really have much in the
way of detail, but what I'm inferring from it is that you'd
like the IETF to support ETSI's request for funding from
the Linux Foundation for implementation of this vaguely-
specified thing?

Melinda

---

From: Andy Bierman <[email-masked]>
Date: Wed, 6 Apr 2016 12:27:26 -0700

> superior than open standard, or vice versa

Nobody is saying one is better than the other.
I am saying the IETF does standards.
Is there a protocol you have that you want the IETF to standardize?
Is there an existing protocol that needs improvement so you
can accomplish your open-source project goals?

Your draft needs to identify the specific work you want done in the IETF.

Andy

>>> 2: discuss it in NFVRG / SDNRG, once there is support OpsAWG might be
>>> the place for a yang discussion / how this integrates with other things,
>>> etc.
>>>
>>> W
>>>
>>>
>>>>
>>>> Best regards,
>>>>
>>>> DENG Hui
>>>>

---

From: Randy Bush <[email-masked]>
Date: Thu, 07 Apr 2016 14:21:53 -0300

> I am saying the IETF does standards.

and running code

---

From: Andy Bierman <[email-masked]>
Date: Thu, 7 Apr 2016 10:50:52 -0700

> > I am saying the IETF does standards.

that's what the t-shirt says, but I have never seen "running code"
in a WG charter.

Andy

---

From: Randy Bush <[email-masked]>
Date: Thu, 07 Apr 2016 14:53:05 -0300

> that's what the t-shirt says, but I have never seen "running code" in
> a WG charter.

an ops wg might be a good place to start.  but we've kinda been beaten
to the punch.

the idr wg, as in most routing wgs, requires two or more interoperating
implementations to progress a document.

randy

---

From: Andy Bierman <[email-masked]>
Date: Thu, 7 Apr 2016 11:03:19 -0700

> implementations to progress a document.

sounds wonderful.  All WGs should avoid sandbox flailing, and
requiring 2 implementations is a nice high bar to accomplish that.

My point was that (for YANG anyway) the IETF is working closely with
opensource projects like OpenDaylight because people involved in these
projects bring their requests to the WGs.  I don't think ODL wants to
be "owned" by the IETF and the IETF should not attempt to control
such projects.

Andy