Subject: [OPSAWG] Adoption poll for draft-lear-ietf-netmod-mud-04

From: Zhoutianran <[email-masked]>
Date: Wed, 3 Aug 2016 07:14:35 +0000

Dear OPSAWG,

The chairs would like to know if the WG participants agree that the following document should be adopted as a WG document in OPSAWG. 
Manufacturer Usage Description Specification:
https://datatracker.ietf.org/doc/draft-lear-ietf-netmod-mud

The adoption poll will take two weeks. Please let us know your opinion by August 16. It would also be good to hear who is willing to review and/or implement or deploy the technology described in the document.

Since we already found that the majority of the f2f participants at our IETF96 session like this idea, please do speak up now if you do not agree or have serious objections (with explanation of course).

Regards,
Warren and Tianran

---

From: Thorsten Dahm <[email-masked]>
Date: Wed, 3 Aug 2016 10:29:38 +0100

I support the adoption of MUD.

cheers,
Thorsten

On 3 August 2016 at 08:14, Zhoutianran <[email-masked]> wrote:

> Dear OPSAWG,
>
> The chairs would like to know if the WG participants agree that the
> following document should be adopted as a WG document in OPSAWG.
> The adoption poll will take two weeks. Please let us know your opinion by
> August 16. It would also be good to hear who is willing to review and/or
> implement or deploy the technology described in the document.
>
> Since we already found that the majority of the f2f participants at our
> IETF96 session like this idea, please do speak up now if you do not agree
> or have serious objections (with explanation of course).
>
> Regards,
> Warren and Tianran
>
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>

-- 
Thorsten Dahm

Network Engineer
Google Ireland Ltd.
The Gasworks, Barrow Street
Dublin 4,  Ireland

Registered in Dublin, Ireland
Registration Number: 368047

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 3 Aug 2016 11:27:05 +0100

I've been following this work and believe it is something the IETF should work on and that this is better than a good starting point for working group work.
 
I can't promise that I will devote much attention to the work as it progresses, but I will participate in occasional reviews. I've talked to Eliot about some of the privacy trade-offs involved and I believe he understands my concerns.
 
Adrian
 
Dear OPSAWG,

Regards,
Warren and Tianran

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Wed, 3 Aug 2016 12:54:02 +0200

Mmmmm

- first I wonder why this document has "netmod" in the draftname".
   it is targeted at opsawg, and besides, it not only has a YANG
   datamodel, but also talks bout DHCP, x509 and LLDP.
   So people should be aware that this is more than just YANG data model.
- the document also refers to draft-lear-mud-framework-00 (now expired)
   in the introduction section. So should we also adopt that document
   or is its content now included (or will it be included) in this
   document that we want to adopt as opsawg work item?

I do support this work in opsawg, but would like to see above 2 points
clarified. I am willing to review future versions

Bert

---

From: Joe Clarke <[email-masked]>
Date: Wed, 3 Aug 2016 08:38:41 -0400

> Since we already found that the majority of the f2f participants at our IETF96 session like this idea, please do speak up now if you do not agree or have serious objections (with explanation of cou…

I feel this work should be adopted, and opsawg is a good place for it.

Joe

---

From: Eliot Lear <[email-masked]>
Date: Wed, 3 Aug 2016 14:44:14 +0200

Hi Bert,

>   So people should be aware that this is more than just YANG data model.

Long history.  Short answer is that if approved it would be renamed
accordingly, and if you see content that seemingly focuses just too much
on the model, then we should balance it off.  To that end...

>   document that we want to adopt as opsawg work item?

We haven't updated the framework doc because we've been consolidating
all the other ones into one work.  I would be perfectly happy to
continue that consolidation (it would be non-normative text as the
framework is).

> clarified. I am willing to review future versions

Thanks,

Eliot

---

From: Paul Duffy <[email-masked]>
Date: Wed, 3 Aug 2016 10:13:00 -0400

I support adoption of this work.

On 8/3/2016 3:14 AM, Zhoutianran wrote:
> .

---

From: Warren Kumari <[email-masked]>
Date: Wed, 10 Aug 2016 08:20:35 -0700

Hi all,

Just a reminder that this call for adoption is still ongoing, and
closes on August 16th.

So far we see strong support for adoption, but would welcome more[0].

W
[0]: Partly so we have a pool of victims^w volunteers to ask for review.

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: "Brian Weis (bew)" <[email-masked]>
Date: Wed, 10 Aug 2016 16:02:27 +0000

I support the adoption of this draft, and consider myself properly warned regarding future requests for reviews. :-)

Thanks,
Brian

> On Aug 10, 2016, at 8:20 AM, Warren Kumari <[email-masked]> wrote:
> 
> Hi all,
> 

-- 
Brian Weis
Security, CSG, Cisco Systems
Telephone: +1 408 526 4796
Email: [email-masked]

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 10 Aug 2016 19:01:00 +0000

I would agree.

> On Aug 3, 2016, at 5:38 AM, Joe Clarke (jclarke) <[email-masked]> wrote:
>

---

From: Warren Kumari <[email-masked]>
Date: Tue, 16 Aug 2016 15:33:34 -0400

Dear OpsAWG,

We see sufficient interest to go play in the MUD.

Authors, please resubmit the document named draft-ietf-opsawg-mud (or
something similar, this ain't yer first rodeo).

While I have folks attention -- please remember to also review the
TACACS+ document - we wish to WGLC it soon.

W

---

From: Eliot Lear <[email-masked]>
Date: Wed, 17 Aug 2016 06:47:58 +0200

Thanks, Warren.  Before we do that, I would like to make two proposals,
to keep things moving (and I'm not quite sure of order here);

First, and hopefully most trivially, I propose just to capture a point
or two more from the expired informational document.  This would be
non-normative text.  I think much of it is there, but would like to
remove the outdated reference.   Should take a few days.

Second, and hopefully not that more of a controversy, I would like to
request early IANA assignments to assist with interoperable
development.  These would be listed in the IANA considerations section
of the current draft.  If we need a WG draft to make this happen, that's
fine with me, but we should do a quick rev after the assignments.

Eliot

---

From: Warren Kumari <[email-masked]>
Date: Wed, 17 Aug 2016 10:17:07 -0400

> remove the outdated reference.   Should take a few days.

Sure.

> fine with me, but we should do a quick rev after the assignments.
I believe that this *can* be accomplished without it being a WG doc, but it
is better / cleaner / easier if we make it a WG doc and then ask for early
assistant. We are fine with lots of revisions / it being submitted and then
quickly revised.

Oh, please also confirm (all authors) that any needed IPR disclosures have
been made...

W

> > On Wed, Aug 3, 2016 at 3:14 AM, Zhoutianran <[email-masked]
> <javascript:;>> wrote:
> >> Dear OPSAWG,
> >>
> >> The adoption poll will take two weeks. Please let us know your opinion
> by August 16. It would also be good to hear who is willing to review and/or

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Eliot Lear <[email-masked]>
Date: Wed, 17 Aug 2016 16:51:55 +0200

On 8/17/16 4:17 PM, Warren Kumari wrote:
>
>
> On Wednesday, August 17, 2016, Eliot Lear <[email-masked]
> <mailto:[email-masked]>> wrote:
>
> I believe that this *can* be accomplished without it being a WG doc,
> but it is better / cleaner / easier if we make it a WG doc and then
> ask for early assistant. We are fine with lots of revisions / it being
> submitted and then quickly revised.

Ok.  Will publish shortly what we have.

>
> Oh, please also confirm (all authors) that any needed IPR disclosures
> have been made...

From my perspective, this is the case.

Eliot

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 18 Aug 2016 09:11:58 +0000

I am not aware about any IPR relevant to this work.

Regards,

Dan

From: OPSAWG [mailto:[email-masked]] On Behalf Of Warren Kumari
Sent: Wednesday, August 17, 2016 5:17 PM
To: Eliot Lear
Cc: [email-masked]; [email-masked]
Subject: Re: [OPSAWG] Adoption poll for draft-lear-ietf-netmod-mud-04

On Wednesday, August 17, 2016, Eliot Lear <[email-masked]<mailto:[email-masked]>> wrote:
Thanks, Warren.  Before we do that, I would like to make two proposals,
to keep things moving (and I'm not quite sure of order here);

Sure.

I believe that this *can* be accomplished without it being a WG doc, but it is better / cleaner / easier if we make it a WG doc and then ask for early assistant. We are fine with lots of revisions / it being submitted and then quickly revised.

Oh, please also confirm (all authors) that any needed IPR disclosures have been made...

W

Eliot

On 8/16/16 9:33 PM, Warren Kumari wrote:
> On Wed, Aug 3, 2016 at 3:14 AM, Zhoutianran <[email-masked]<javascript:;>> wrote:
>> Dear OPSAWG,
>>
>> https://datatracker.ietf.org/doc/draft-lear-ietf-netmod-mud<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dlear-2Dietf-2Dnetmod-2Dmud&d=CwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=4RwrFFCvs5Tn3zxL8hDxEBa2k4sAhbFcPf-uAK63pXs&s=NdccP3IAiWQX8gZei2qAMyc7V0WcRGqPm4kGnitTP6c&e=>
>>
>>

--
I don't think the execution is relevant when it was obviously a bad idea in the first place.
This is like putting rabid weasels in your pants, and later expressing regret at having chosen those particular rabid weasels and that pair of pants.
   ---maf

---

From: Eliot Lear <[email-masked]>
Date: Mon, 22 Aug 2016 13:04:03 +0200

Hi Warren, Tianran, and all,

> submitted and then quickly revised.

Just following up on this point: we'd like to request early assignment
from IANA for the various registries.  Does that go through the chairs
or the authors at this point?

Thanks,

Eliot

---

From: Zhoutianran <[email-masked]>
Date: Tue, 23 Aug 2016 09:46:50 +0000

Hi All,

Since the authors of the draft-ietf-opsawg-mud-00 asked for the early assignment for various registries from IANA, I would like to ask the WG consensus.

There will be 1 week since today. You can express your support or objection.

If there is no objection, I would like to request from the WG.

The following is a list of IANA considerations copied from the draft.

Best,
Tianran

-------------------------------------

15.  IANA Considerations

15.1.  DHCPv4 and DHCPv6 Options

   IANA is requested to allocated the DHCPv4 and v6 options as specified
   in Section 9.

15.2.  PKIX Extensions

   The IANA is requested to assign a value for id-pe-mud-uri in the "SMI
   Security for PKIX Certificate Extension" Registry.  Its use is
   specified in Section 10.

15.3.  Well Known URI Suffix

   The IANA is requested to register the URL suffix of "mud" as follows:

   o URI Suffix: "mud" o Specification documents: this document o
   Related information: n/a

15.4.  MIME Media-type Registration for MUD files

   The following media-type is defined for transfer of MUD file:

   o Type name: application
   o Subtype name: mud+json
   o Required parameters: n/a
   o Optional parameters: n/a
   o Encoding considerations: 8bit; application/mud+json values
     are represented as a JSON object; UTF-8 encoding SHOULD be
     employed.
   o Security considerations: See {{secon}} of this document.
   o Interoperability considerations: n/a
   o Published specification: this document
   o Applications that use this media type: MUD controllers as
     specified by this document.
   o Fragment identifier considerations: n/a
   o Additional information:

       Magic number(s): n/a
       File extension(s): n/a
       Macintosh file type code(s): n/a

   o Person & email address to contact for further information:
     Eliot Lear <[email-masked]>, Ralph Droms <[email-masked]>
   o Intended usage: COMMON
   o Restrictions on usage: none

   o Author: Eliot Lear <[email-masked]>, Ralph Droms <[email-masked]>
   o Change controller: IESG
   o Provisional registration? (standards tree only): No.

15.5.  LLDP IANA TLV Subtype Registry

   IANA is requested to create a new registry for IANA Link Layer
   Discovery Protocol (LLDP) TLV subtype values.  The recommended policy
   for this registry is Expert Review.  The maximum number of entries in
   the registry is 256.

   IANA is required to populate the initial registry with the value:

   LLDP subtype value = 1

   Description = the Manufacturer Usage Description (MUD) Uniform
   Resource Locator (URL)

   Reference = < this document >

From: Eliot Lear [mailto:[email-masked]]
Sent: Monday, August 22, 2016 7:04 PM
To: Warren Kumari
Cc: Zhoutianran; [email-masked]; [email-masked]
Subject: Re: Adoption poll for draft-lear-ietf-netmod-mud-04

Just following up on this point: we'd like to request early assignment from IANA for the various registries.  Does that go through the chairs or the authors at this point?

Thanks,

Eliot