Subject: Re: [OPSAWG] Soliciting thoughts on draft-wu-opsawg-service-model-explained

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 31 Oct 2016 12:07:08 -0000

Hi,

We previously discussed draft-wu-opsawg-service-model-explained a bit on this
list and also at a face-to-face meeting.

Since then the I-D has moved on to a -03 revision picking up and addressing
comments from the list, private emails, and the authors' gradual understanding
of the field.
 
We do not think that this I-D is conflicted by, with, or from draft-ietf-netmod-
yang-model-classification (which we understand may be approaching WG last call
in NETMOD).

We believe there are some issues that would benefit from focused discussion in
the OPSAWG.

Is there agreement on our separation of models into customer service models,
service delivery models, and network/device configuration models? We think
that we have the right split of function, but not necessarily the right names
for
the terms.

Can we refine the definition of "service"? There was some discussion of this at
the last meeting, and it led us to refine the language a bit, but it would be
helpful
to have more feedback.

Is this stuff "obvious" or is there value in publishing an RFC? Our experience
working in L3SM has been that there is a tension with the protocol working
groups (particularly BESS) that arises from the equipment vendors being closer
to
how services are delivered within a network (i.e., by configuring a set of
devices
in the network) than they are to an understanding of how an operator presents a
service for consumption by their customer. Our intention is to make that
distinction clearer.

Have we got the correlation with the MEF's LSO right? We have heard a
conflicting view to what we have written, but we have also heard supporting
views. Should we drop all discussion of the MEF's model as it is out of scope
for
the IETF?

Thanks for any opinions.

Adrian
--
Support an author and your imagination.
Tales from the Wood - Eighteen new fairy tales.
More Tales from the Wood - Eighteen MORE new fairy tales.
https://www.feedaread.com/profiles/8604/
http://www.amazon.co.uk/Tales-Wood-Adrian-Farrel/dp/1786100924
Or buy from me direct.

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 31 Oct 2016 22:09:51 +0000

Adrian, 

Does your draft intend to cover model for all possible services? Such as Private Line service? 
Simple vanilla IP Internet access services, SD-WAN services, or others? 

As of now, the draft is primarily on L3VPN services. Is it intended? Or to be expanded to more?

Linda
-----Original Message-----
From: OPSAWG [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: 2016年10月31日 7:07
To: [email-masked]' <[email-masked]>
Cc: [email-masked]
Subject: Re: [OPSAWG] Soliciting thoughts on draft-wu-opsawg-service-model-explained

Hi,

We previously discussed draft-wu-opsawg-service-model-explained a bit on this list and also at a face-to-face meeting.

Since then the I-D has moved on to a -03 revision picking up and addressing comments from the list, private emails, and the authors' gradual understanding of the field.
 
We do not think that this I-D is conflicted by, with, or from draft-ietf-netmod- yang-model-classification (which we understand may be approaching WG last call in NETMOD).

We believe there are some issues that would benefit from focused discussion in the OPSAWG.

Is there agreement on our separation of models into customer service models, service delivery models, and network/device configuration models? We think that we have the right split of function, but not necessarily the right names for the terms.

Can we refine the definition of "service"? There was some discussion of this at the last meeting, and it led us to refine the language a bit, but it would be helpful to have more feedback.

Is this stuff "obvious" or is there value in publishing an RFC? Our experience working in L3SM has been that there is a tension with the protocol working groups (particularly BESS) that arises from the equipment vendors being closer to how services are delivered within a network (i.e., by configuring a set of devices in the network) than they are to an understanding of how an operator presents a service for consumption by their customer. Our intention is to make that distinction clearer.

Have we got the correlation with the MEF's LSO right? We have heard a conflicting view to what we have written, but we have also heard supporting views. Should we drop all discussion of the MEF's model as it is out of scope for the IETF?

Thanks for any opinions.

Adrian

_______________________________________________
OPSAWG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/opsawg

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 31 Oct 2016 22:50:11 -0000

Hi Linda,

> Does your draft intend to cover model for all possible services? Such as
Private
> Line service?

Are we reading the same draft? :-)

I think we do give L3VPN customer service model as an example in section 6.3
where we also discuss the L2VPN customer service model work. We used these two
examples because the L3SM draft is completing IESG review, and the L2SM working
group is just being formed. 

But of course other examples exist. it is not our intention to try to catalogue
all possible examples. Rather, we intend to stablish the terminology and then
other work has a reference point on which to stand. So, if you are doing work
on, say, IP-as-a-service, you might be able to look at this document and select
appropriate terms to use in your work. 

So the question back to you is "Do the terms and figures set out in this
document fit with the work you are doing?"

Thanks,
Adrian