Subject: [OPSAWG] I-D Action: draft-ietf-opsawg-mud-12.txt

From: [email-masked]
Date: Sat, 07 Oct 2017 04:56:30 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Operations and Management Area Working Group WG of the IETF.

        Title           : Manufacturer Usage Description Specification
        Authors         : Eliot Lear
                          Ralph Droms
                          Dan Romascanu
	Filename        : draft-ietf-opsawg-mud-12.txt
	Pages           : 55
	Date            : 2017-10-07

Abstract:
   This memo specifies a component-based architecture for manufacturer
   usage descriptions (MUD).  The goal of MUD is to provide a means for
   Things to signal to the network what sort of access and network
   functionality they require to properly function.  The initial focus
   is on access control.  Later work can delve into other aspects.

   This memo specifies two YANG modules, IPv4 and IPv6 DHCP options, an
   LLDP TLV, a URL suffix specification, an X.509 certificate extension
   and a means to sign and verify the descriptions.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-opsawg-mud/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-opsawg-mud-12
https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-mud-12

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-mud-12

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Eliot Lear <[email-masked]>
Date: Sat, 7 Oct 2017 13:58:59 +0200

This version is intended to address all outstanding issues based on last
call.  That includes the following:

   o  Correct examples based on ACL model changes.
   o  Change ordering nodes.
   o  Additional explanatory text around systeminfo.
   o  Change ordering in examples.
   o  Make it VERY VERY VERY VERY clear that these are recommendations,
      not mandates.
   o  DHCP -> NTP in some of the intro text.
   o  Remove masa-server
   o  "Things" to "network elements" in a few key places.
   o  Reference to JSON YANG RFC added.

Eliot

On 10/7/17 1:56 PM, [email-masked] wrote:
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>

---

From: Joe Clarke <[email-masked]>
Date: Mon, 9 Oct 2017 10:29:55 -0400

On 10/7/17 07:58, Eliot Lear wrote:
> This version is intended to address all outstanding issues based on
> last call.  That includes the following:
> 
> o  Correct examples based on ACL model changes. o  Change ordering
> nodes. o  Additional explanatory text around systeminfo. o  Change
> ordering in examples. o  Make it VERY VERY VERY VERY clear that
> these are recommendations, not mandates. o  DHCP -> NTP in some of
> the intro text. o  Remove masa-server o  "Things" to "network
> elements" in a few key places. o  Reference to JSON YANG RFC
> added.

Hey, Eliot.  Thanks for addressing the majority of comments.  I've
read through this latest draft, and I have a couple more:

You have a typo in section 2:

"Furthermore, only or "accept" or "drop" actions SHOULD be included."

You have an unnecessary "or" in there.

===

In the example in Section 8, the cl0-todev rule still lists the
directory as "from-device".  I think it should be "to-device" unless I
misunderstand the purpose of the direction.

Joe

>> A New Internet-Draft is available from the on-line
>> Internet-Drafts directories. This draft is a work item of the
>> Operations and Management Area Working Group WG of the IETF.
>> 
>> Authors         : Eliot Lear Ralph Droms Dan Romascanu Filename
>> : draft-ietf-opsawg-mud-12.txt Pages           : 55 Date
>> : 2017-10-07
>> 
>> Abstract: This memo specifies a component-based architecture for
>> manufacturer usage descriptions (MUD).  The goal of MUD is to
>> provide a means for Things to signal to the network what sort of
>> access and network functionality they require to properly
>> function.  The initial focus is on access control.  Later work
>> can delve into other aspects.
>> 
>> This memo specifies two YANG modules, IPv4 and IPv6 DHCP options,
>> an LLDP TLV, a URL suffix specification, an X.509 certificate
>> extension and a means to sign and verify the descriptions.
>> 
>> 
>> Please note that it may take a couple of minutes from the time of
>> submission until the htmlized version and diff are available at
>> tools.ietf.org.
>> 
>> _______________________________________________ OPSAWG mailing
>> list [email-masked] 
> _______________________________________________ OPSAWG mailing
> list [email-masked] https://www.ietf.org/mailman/listinfo/opsawg
>

---

From: Eliot Lear <[email-masked]>
Date: Mon, 9 Oct 2017 19:46:23 +0200

Hi Joe,

> You have an unnecessary "or" in there.

Nuked the extra "or" in my copy.

> misunderstand the purpose of the direction.

I think you misunderstand something.  "direction-initiated" is the TCP
connection direction, not packet flow.

Eliot

---

From: Joe Clarke <[email-masked]>
Date: Mon, 9 Oct 2017 14:08:39 -0400

On 10/9/17 13:46, Eliot Lear wrote:
>> directory as "from-device".  I think it should be "to-device"
>> unless I misunderstand the purpose of the direction.
> 
> I think you misunderstand something.  "direction-initiated" is the
> TCP connection direction, not packet flow.

Yes, I did misread.  That makes sense.  The device initiates the
tcp/443 in this case.

Thanks, Eliot.

Joe