Subject: Re: [OPSAWG] New Version Notification for draft-ietf-opsawg-nat-yang-06.txt

From: <[email-masked]>
Date: Thu, 12 Oct 2017 14:13:19 +0000

Dear all, 

The new version fixes some cosmetic issues (mainly, indentation of the YANG module) and points to YANG1.1 RFC as per a comment received from Mahesh Jethanandani. 

We are waiting for the yang doctors review. 

Cheers,
Med

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]]
> Envoyé : jeudi 12 octobre 2017 16:02
> À : Qin Wu; Senthil Sivakumar; BOUCADAIR Mohamed IMT/OLN; Suresh
> Vinapamula; JACQUENET Christian IMT/OLN
> Objet : New Version Notification for draft-ietf-opsawg-nat-yang-06.txt
> 
> 
> A new version of I-D, draft-ietf-opsawg-nat-yang-06.txt
> has been successfully submitted by Mohamed Boucadair and posted to the
> IETF repository.
> 
> Name:		draft-ietf-opsawg-nat-yang
> Revision:	06
> Title:		A YANG Data Model for Network Address Translation (NAT)
> and Network Prefix Translation (NPT)
> Document date:	2017-10-11
> Group:		opsawg
> Pages:		78
> URL:            https://www.ietf.org/internet-drafts/draft-ietf-opsawg-
> nat-yang-06.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-opsawg-nat-
> yang/
> Htmlized:       https://tools.ietf.org/html/draft-ietf-opsawg-nat-yang-06
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-
> nat-yang-06
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-nat-
> yang-06
> 
> Abstract:
>    For the sake of network automation and the need for programming
>    Network Address Translation (NAT) function in particular, a data
>    model for configuring and managing the NAT is essential.  This
>    document defines a YANG module for the NAT function.
> 
>    NAT44, Network Address and Protocol Translation from IPv6 Clients to
>    IPv4 Servers (NAT64), Customer-side transLATor (CLAT), Explicit
>    Address Mappings for Stateless IP/ICMP Translation (SIIT EAM), and
>    IPv6 Network Prefix Translation (NPTv6) are covered in this document.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: Benoit Claise <[email-masked]>
Date: Mon, 16 Oct 2017 12:23:57 +0200

Dear all,

Historically, the MIB doctor reviews would happen during IETF LC.
Because YANG was new, we started early YANG doctor reviews. Those 
reviews don't have to occur in sequence, i.e. before the IETF LC starts. 
In fact, at some point in time in the future (when the YANG knowledge 
will be widely spread), the YANG doctor reviews will be triggered by the 
IETF LC.
Bottom line: if the OPSAWG chairs believe this document is ready, it can 
progress to IETF LC now.

Regards, Benoit.
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: <[email-masked]>
Date: Tue, 17 Oct 2017 14:50:05 +0000

Hi Benoit, 

Thank you for this clarification. 

If Juergen is OK to provide his review before the WGLC, I would prefer to go that path. That is, wait for his early review, fix any comments from Juergen, and then go for a last call.

Obviously, this is only my preference as an editor. I will defer to the chairs to decide.

Cheers,
Med

> De : Benoit Claise [mailto:[email-masked]]
> Envoyé : lundi 16 octobre 2017 12:24
> À : BOUCADAIR Mohamed IMT/OLN; [email-masked]
> Cc : JACQUENET Christian IMT/OLN; Juergen Schoenwaelder
> Objet : Re: [OPSAWG] New Version Notification for draft-ietf-opsawg-nat-
> yang-06.txt
> 
> Dear all,
> 
> > The new version fixes some cosmetic issues (mainly, indentation of the
> YANG module) and points to YANG1.1 RFC as per a comment received from
> Mahesh Jethanandani.
> >

---

From: Tianran Zhou <[email-masked]>
Date: Thu, 19 Oct 2017 01:08:29 +0000

We have applied the YANG doctor early review. And it's better to present current status of the draft on the coming meeting.
So that we can get another round revision before the last call.

Regards,
Tianran

> -----Original Message-----
> From: OPSAWG [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Tuesday, October 17, 2017 10:50 PM
> To: Benoit Claise; [email-masked]
> Cc: JACQUENET Christian IMT/OLN
> Subject: Re: [OPSAWG] New Version Notification for
> draft-ietf-opsawg-nat-yang-06.txt
> 
> Hi Benoit,
> 
> If Juergen is OK to provide his review before the WGLC, I would prefer to
> go that path. That is, wait for his early review, fix any comments from
> Juergen, and then go for a last call.
> 
> > De : Benoit Claise [mailto:[email-masked]] Envoyé : lundi 16
> > octobre 2017 12:24 À : BOUCADAIR Mohamed IMT/OLN; [email-masked] Cc :
> > JACQUENET Christian IMT/OLN; Juergen Schoenwaelder Objet : Re:
> > [OPSAWG] New Version Notification for draft-ietf-opsawg-nat-
> > yang-06.txt
> >
> > Dear all,
> >
> > will be widely spread), the YANG doctor reviews will be triggered by
> > the IETF LC.
> > Bottom line: if the OPSAWG chairs believe this document is ready, it
> > can progress to IETF LC now.
> >
> > Regards, Benoit.
> > > Dear all,
> > >
> > >> Envoyé : jeudi 12 octobre 2017 16:02 À : Qin Wu; Senthil Sivakumar;
> > >> BOUCADAIR Mohamed IMT/OLN; Suresh Vinapamula; JACQUENET Christian
> > >> IMT/OLN Objet : New Version Notification for
> > >> draft-ietf-opsawg-nat-yang-06.txt
> > >>
> > >>
> > >> A new version of I-D, draft-ietf-opsawg-nat-yang-06.txt has been
> > >> successfully submitted by Mohamed Boucadair and posted to the IETF
> > >> repository.
> > >>
> > >> URL:
> https://www.ietf.org/internet-drafts/draft-ietf-opsawg-
> > >> nat-yang-06.txt
> > >> Status:
> https://datatracker.ietf.org/doc/draft-ietf-opsawg-nat-
> > >> yang/
> > >> Htmlized:
> https://tools.ietf.org/html/draft-ietf-opsawg-nat-yang-
> > 06
> > >>     NAT44, Network Address and Protocol Translation from IPv6
> > >> Clients
> > to
> > >> submission until the htmlized version and diff are available at
> > >> tools.ietf.org.
> > >>
> > >> The IETF Secretariat