Subject: [OPSAWG] WGLC request for draft-ietf-opsawg-ipfix-bgp-community-03.txt

From: li zhenqiang <[email-masked]>
Date: Fri, 20 Oct 2017 07:56:49 +0000

Dear WG Chairs and all,

I updated the following draft according to the comments received from the list and the Praha meeting. The purpose to introduce new IEs in IPFIX is explained more clearly in the introducation part and emphesized in the abstract part. We changed one section title from  Message Length Considerations to  Operational Considerations, and explained, at present for the field network, one IPFIX message has enough space to fit all the community information related to a specific traffic flow .

Since no more technical issues remain to be solved, as requested in the Praha meeting, we think this doc is ready to do WGLC. Thank you very much.

Name: draft-ietf-opsawg-ipfix-bgp-community
Revision: 03
Title: Export BGP community information in IP Flow Information Export (IPFIX)
Document date: 2017-10-17
Group: opsawg
Pages: 17
URL: https://www.ietf.org/internet-drafts/draft-ietf-opsawg-ipfix-bgp-community-03.txt
Status: https://datatracker.ietf.org/doc/draft-ietf-opsawg-ipfix-bgp-community/
Htmlized: https://tools.ietf.org/html/draft-ietf-opsawg-ipfix-bgp-community-03
Htmlized: https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-ipfix-bgp-community-03
Diff: https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-ipfix-bgp-community-03

Abstract:
   This draft updates RFC7012 IPFIX information model by introducing
   several information elements to enable IPFIX to export the BGP
   community information, including BGP standard community defined in
   RFC1997, BGP extended community defined in RFC4360, and BGP large
   community defined in RFC8092.  Network traffic flow information can
   then be accumulated and analysed at the granularity specified by the
   BGP communities, which is suitable for and needed by some traffic
   optimization applications located in IPFIX collector, SDN controller
   or PCE (Path Computation Element).

________________________________
[email-masked]

---

From: Tianran Zhou <[email-masked]>
Date: Mon, 30 Oct 2017 08:19:09 +0000

Hi Zhenqiang and the coauthors,

Based on your latest post, the co-chairs would like to suggest the following improvements before issuing the LC.

1. It's still not clear why the proposed IEs are necessary and useful, although you have some simple words in the introduction. It's better to add a separate use case section to expand the two references [Community-TE] and [RFC4384], and to address your operation experience on using them.
This will also help to motivate the audience to understand and use this IE extension.

2. Given that both standard and large communities will stay in deployment and they both accomplish equivalent function, and large can carry all the value spaces of standard ones, one option is to define a container for large with a predefined field for mapping in a standard community value. This is a technique issue that need to be discussed. If you insist your way, please add some texts in the draft to clarify why two were chosen.  Perhaps you have operational experience that explains why the multiple containers help.

3. You have added an operational considerations section as was requested in Prague.  Perhaps a bit more text on the "why" concerning the approach is also required to help inform those who might deploy this.

Thanks,
Ignas, Joe, Tianran

From: li zhenqiang [mailto:[email-masked]]
Sent: Friday, October 20, 2017 3:57 PM
To: [email-masked]; opsawg-chairs
Subject: WGLC request for draft-ietf-opsawg-ipfix-bgp-community-03.txt

Dear WG Chairs and all,

Abstract:

________________________________
[email-masked]<mailto:[email-masked]>

---

From: li zhenqiang <[email-masked]>
Date: Mon, 30 Oct 2017 09:03:36 +0000

Hello Tianran and the co-chairs,

Thank you very much for your review and suggestions. I will address all your comments in the next vesion. But I am afraid I can not catch the submittion deadline for the coming meeting. So, the updated version will be uploaded after the Singapore meeting.

Best Regards,
Zhenqiang Li

From: Tianran Zhou<mailto:[email-masked]>
Date: 2017-10-30 16:19
To: li zhenqiang<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; opsawg-chairs<mailto:[email-masked]>
Subject: RE: WGLC request for draft-ietf-opsawg-ipfix-bgp-community-03.txt
Hi Zhenqiang and the coauthors,

1. It’s still not clear why the proposed IEs are necessary and useful, although you have some simple words in the introduction. It’s better to add a separate use case section to expand the two references [Community-TE] and [RFC4384], and to address your operation experience on using them.
This will also help to motivate the audience to understand and use this IE extension.

Thanks,
Ignas, Joe, Tianran

Dear WG Chairs and all,

Abstract: