Subject: Re: [OPSAWG] I-D Action: draft-ietf-opsawg-yang-vpn-service-pm-02.txt

From: "Wubo (lana)" <[email-masked]>
Date: Thu, 20 Jan 2022 03:24:03 +0000

Hi WG,

Many thanks to the WG for the discussion and valuable comments.

This update mainly reflects the discussion decision of the 112 meeting and also the comments of Adrian and Greg on the mailing list. 

The detailed changes are the following:
1. Adds modeling considerations to the introduction
2. Adds a reference to draft-ietf-netmod-node-tags
3. YANG: Replaces the type of "pm-source”: string' -> 'identity'
4. YANG: Adds "vpn-one-way-pm-statistics* [class-id]" to collect class-based VPN underlay tunnel statistics
5. YANG: Adds “vpn-network-access” specific counters under " termination-point"
6. YANG: Highlights the unidirectional link metrics with " one-way-pm-statistics"
7. Fixed a lot of editorial issues

Here is the diff: https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-yang-vpn-service-pm-02.

Thanks,
Bo

> -----邮件原件-----
> 发件人: OPSAWG [mailto:[email-masked]] 代表
> [email-masked]
> 发送时间: 2022年1月20日 10:50
> 收件人: [email-masked]
> 抄送: [email-masked]
> 主题: [OPSAWG] I-D Action: draft-ietf-opsawg-yang-vpn-service-pm-02.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Operations and Management Area Working
> Group WG of the IETF.
> 
>         Title           : A YANG Model for Network and VPN Service
> Performance Monitoring
>         Authors         : Bo Wu
>                           Qin Wu
>                           Mohamed Boucadair
>                           Oscar Gonzalez de Dios
>                           Bin Wen
> 	Filename        : draft-ietf-opsawg-yang-vpn-service-pm-02.txt
> 	Pages           : 35
> 	Date            : 2022-01-19
> 
> Abstract:
>    The data model for network topologies defined in RFC 8345 introduces
>    vertical layering relationships between networks that can be
>    augmented to cover network and service topologies.  This document
>    defines a YANG module for performance monitoring (PM) of both
>    networks and VPN services that can be used to monitor and manage
>    network performance on the topology at higher layer or the service
>    topology between VPN sites.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-opsawg-yang-vpn-service-pm/
> 
> There is also an htmlized version available at:
> https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-yang-vpn-service-pm-0
> 2
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-yang-vpn-service-pm-02
> 
> 
> Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts
> 
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: tom petch <[email-masked]>
Date: Fri, 21 Jan 2022 12:30:08 +0000

From: OPSAWG <[email-masked]> on behalf of Wubo (lana) <lana.wubo=[email-masked]>
Sent: 20 January 2022 03:24

Hi WG,

<tp>
Some possible glitches for you.

Some of the lines in the YANG module are too long (they were ok in -01)

You use XXXX to refer to two different I-D (this was ok in -01)

Abbreviations need expanding, perhaps in Terminology e.g. VPLS OWAMP L3VPN

I want references in the YANG module for OWAMP IPDV P

ITU-T Y.1731 would benefit from a title and needs adding to the I-D References

five fraction digits for a percentile?  I note that the defaults have only two digits

/http:/https:/
TLP is out of date

percentile definition seems not quite right.  You are using a percentage here but there is no requirement to do so - it can be an integer count or any other measurement of a proportion

'middle-delay' I think confusing; sounds too much like it is the median or mode; perhaps medium?

time when statistics are collected; start time, end time, duration of interval?

subnetwork (broadcast, multicast) I find unclear - sub which layer of our current network many-layered stacks.

Tom Petch

Thanks,
Bo

> Ab