Subject: [OPSAWG] I-D Action: draft-ietf-opsawg-yang-vpn-service-pm-02.txt

From: [email-masked]
Date: Wed, 19 Jan 2022 18:50:22 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Operations and Management Area Working Group WG of the IETF.

        Title           : A YANG Model for Network and VPN Service Performance Monitoring
        Authors         : Bo Wu
                          Qin Wu
                          Mohamed Boucadair
                          Oscar Gonzalez de Dios
                          Bin Wen
	Filename        : draft-ietf-opsawg-yang-vpn-service-pm-02.txt
	Pages           : 35
	Date            : 2022-01-19

Abstract:
   The data model for network topologies defined in RFC 8345 introduces
   vertical layering relationships between networks that can be
   augmented to cover network and service topologies.  This document
   defines a YANG module for performance monitoring (PM) of both
   networks and VPN services that can be used to monitor and manage
   network performance on the topology at higher layer or the service
   topology between VPN sites.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-opsawg-yang-vpn-service-pm/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-yang-vpn-service-pm-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-yang-vpn-service-pm-02

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: "Wubo (lana)" <[email-masked]>
Date: Thu, 27 Jan 2022 12:26:47 +0000

Hi Tom,

Many thanks for your kindly help. Please see inline.

Best regards,
Bo

> -----邮件原件-----
> 发件人: tom petch [mailto:[email-masked]]
> 发送时间: 2022年1月26日 1:09
> 收件人: Wubo (lana) <[email-masked]>; Wubo (lana)
> <lana.wubo=[email-masked]>; [email-masked];
> [email-masked]
> 主题: Re: [OPSAWG] I-D Action: draft-ietf-opsawg-yang-vpn-service-pm-02.txt
> 
> From: Wubo (lana) <[email-masked]>
> Sent: 25 January 2022 13:16
> 
> Hi Tom,
> 
> Thanks for the review and we will correct these issues in the next version.
> Please see inline.
> 
> <<tp> inline twice>
> 
> Best regards,
> Bo
> 
> > -----邮件原件-----
> > 发件人: tom petch [mailto:[email-masked]]
> > 发送时间: 2022年1月21日 20:30
> >
> > From: OPSAWG <[email-masked]> on behalf of Wubo (lana)
> > <lana.wubo=[email-masked]>
> > Sent: 20 January 2022 03:24
> >
> >
> > percentile definition seems not quite right.  You are using a
> > percentage here but there is no requirement to do so - it can be an
> > integer count or any other measurement of a proportion
> [Bo Wu] We provide two options here, and some providers think percentile is
> also useful. I'm not sure the issue. Could you elaborate a little bit?
> 
> <tp>
> Percentile is fine as a way of characterising  a distribution with a single value.
> My comment is that for any percentile, be it 50-percentile, 95-percentile or
> whatever, then there is a value to go with that and that value can be anything
> that is a value - integer, percentage etc.  I think that the description here
> wants it to be a percentage which I think too limiting.
> 
[Bo Wu] Thanks for the explanation. How about the following change?
OLD:
     typedef percentile {
       type decimal64 {
         fraction-digits 5;
         range "1..100";
       }
       description
         "The percentile is a statistical value that indicates that a
          certain percentage of a set of data falls below it.";
     }
     
NEW:
     typedef percentile {
       type decimal64 {
         fraction-digits 2;
           range "0..100";
       }
       description
         "The percentile is a value between 0 and 100, e.g. 10, 99.9 ,99.99 etc. . 
         For example, if the percentile is set to 95. For a given one-way delay measurement, 
         if the 95th percentile one-way delay is 2 milliseconds, then the 95 percent of the sample value is less than or 
         equal to 2 milliseconds.";
     }

> > 'middle-delay' I think confusing; sounds too much like it is the
> > median or mode; perhaps medium?
> [Bo Wu] Agree. rfc3393 uses median to indicate 50th percentile. so we change
> it to "median-delay"?
> 
> <tp>
> Well no, it is median only when it is a 50-percentile which is only the default
> here and if the user chose 90 instead, wanting the three percentiles to be 60,
> 90, 95, then I think median is misleading.
> 
> And RFC3393 says (along with defining ipdv:-) that the 50-percentile is the
> median which is correct.  Here you are defining low, something else, high and
> when something else is not 50, then it is not the median.  I am struggling for a
> word that sits between low and high that does not have connotations of being
> the middle!  intermediate?

[Bo Wu]Got it. Thanks. We will change it to "intermediate" to avoid the confusion.