Subject: Re: [OPSAWG] I-D Action: draft-ietf-opsawg-yang-vpn-service-pm-02.txt

From: "Wubo (lana)" <[email-masked]>
Date: Tue, 25 Jan 2022 13:16:35 +0000

Hi Tom,

Thanks for the review and we will correct these issues in the next version. Please see inline.

Best regards,
Bo

> -----邮件原件-----
> 发件人: tom petch [mailto:[email-masked]]
> 发送时间: 2022年1月21日 20:30
> 收件人: Wubo (lana) <lana.wubo=[email-masked]>;
> [email-masked]; [email-masked]
> 主题: Re: [OPSAWG] I-D Action: draft-ietf-opsawg-yang-vpn-service-pm-02.txt
> 
> From: OPSAWG <[email-masked]> on behalf of Wubo (lana)
> <lana.wubo=[email-masked]>
> Sent: 20 January 2022 03:24
> 
> 
> Hi WG,
> 
> Many thanks to the WG for the discussion and valuable comments.
> 
> This update mainly reflects the discussion decision of the 112 meeting and also
> the comments of Adrian and Greg on the mailing list.
> 
> <tp>
> Some possible glitches for you.
> 
> Some of the lines in the YANG module are too long (they were ok in -01)
[Bo Wu] Thanks for catching this, will fix in the next revision.
> 
> You use XXXX to refer to two different I-D (this was ok in -01)
[Bo Wu] Thanks. Fixed.
> 
> Abbreviations need expanding, perhaps in Terminology e.g. VPLS OWAMP
> L3VPN
[Bo Wu] OK. Thanks.
> 
> I want references in the YANG module for OWAMP IPDV P
[Bo Wu] OK.
> 
> ITU-T Y.1731 would benefit from a title and needs adding to the I-D References
[Bo Wu] OK.
> 
> five fraction digits for a percentile?  I note that the defaults have only two
> digits
[Bo Wu] Fixed.
> /http:/https:/
> TLP is out of date
[Bo Wu] Fixed.
> 
> percentile definition seems not quite right.  You are using a percentage here
> but there is no requirement to do so - it can be an integer count or any other
> measurement of a proportion
[Bo Wu] We provide two options here, and some providers think percentile is also useful. I'm not sure the issue. Could you elaborate a little bit?
[Bo Wu] Fixed.
> 'middle-delay' I think confusing; sounds too much like it is the median or mode;
> perhaps medium?
[Bo Wu] Agree. rfc3393 uses median to indicate 50th percentile. so we change it to "median-delay"?
> 
> time when statistics are collected; start time, end time, duration of interval?
[Bo Wu] OK, we will change "reference-time" to "start time" and "end time", but we like to keep " measurement-interval".
> 
> subnetwork (broadcast, multicast) I find unclear - sub which layer of our current
> network many-layered stacks.
[Bo Wu] OK, we directly use IETF interface YANG description in this version. We will make this clearer. 
> 
> Tom Petch
> 
> The detailed changes are the following:
> 1. Adds modeling considerations to the introduction 2. Adds a reference to
> draft-ietf-netmod-node-tags 3. YANG: Replaces the type of "pm-source”:
> string' -> 'identity'
> 4. YANG: Adds "vpn-one-way-pm-statistics* [class-id]" to collect class-based
> VPN underlay tunnel statistics 5. YANG: Adds “vpn-network-access” specific
> counters under " termination-point"
> 6. YANG: Highlights the unidirectional link metrics with "
> one-way-pm-statistics"
> 7. Fixed a lot of editorial issues
> 
> Here is the diff:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-yang-vpn-service-pm-02.
> 
> Thanks,
> Bo
> 
> > -----邮件原件-----
> > 发件人: OPSAWG [mailto:[email-masked]] 代表
> > [email-masked]
> > 发送时间: 2022年1月20日 10:50
> > 收件人: [email-masked]
> > 抄送: [email-masked]
> > 主题: [OPSAWG] I-D Action: draft-ietf-opsawg-yang-vpn-service-pm-02.txt
> >
> >
> > A New Internet-Draft is available from the on-line Internet-Drafts directories.
> > This draft is a work item of the Operations and Management Area
> > Working Group WG of the IETF.
> >
> >         Title           : A YANG Model for Network and VPN Service
> > Performance Monitoring
> >         Authors         : Bo Wu
> >                           Qin Wu
> >                           Mohamed Boucadair
> >                           Oscar Gonzalez de Dios
> >                           Bin Wen
> >       Filename        : draft-ietf-opsawg-yang-vpn-service-pm-02.txt
> >       Pages           : 35
> >       Date            : 2022-01-19
> >
> > Ab

---

From: tom petch <[email-masked]>
Date: Tue, 25 Jan 2022 17:08:39 +0000

From: Wubo (lana) <[email-masked]>
Sent: 25 January 2022 13:16

Hi Tom,

<<tp> inline twice>

Best regards,
Bo

[Bo Wu] Thanks. Fixed.
[Bo Wu] OK. Thanks.
[Bo Wu] OK.
[Bo Wu] OK.
[Bo Wu] Fixed.
[Bo Wu] Fixed.

<tp>
Percentile is fine as a way of characterising  a distribution with a single value.  My comment is that for any percentile, be it 50-percentile, 95-percentile or whatever, then there is a value to go with that and that value can be anything that is a value - integer, percentage etc.  I think that the description here wants it to be a percentage which I think too limiting.

[Bo Wu] Fixed.

<tp>
Well no, it is median only when it is a 50-percentile which is only the default here and if the user chose 90 instead, wanting the three percentiles to be 60, 90, 95, then I think median is misleading.

And RFC3393 says (along with defining ipdv:-) that the 50-percentile is the median which is correct.  Here you are defining low, something else, high and when something else is not 50, then it is not the median.  I am struggling for a word that sits between low and high that does not have connotations of being the middle!  intermediate?

Tom Petch