Subject: [OPSEC] What is new in draft-ietf-opsec-v6-13.txt ?

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Thu, 1 Mar 2018 13:08:17 +0000

There are a lot of changes in the -13 version, many minor and a couple of bigger ones (such the ULA section). A new author, Enno Rey, has joined the team and has provided a tremendous amount of suggestions/changes. We also have acted on the comments from Ole Troan, Ron Bonnica, Bernie Volz, Fernando Gont and Erik Kline.

As usual you can compare the versions with:
https://tools.ietf.org/rfcdiff?url2=draft-ietf-opsec-v6-13.txt

The authors will welcome reviews and comments especially on the new section 2.1.2 (Use of ULAs): this 'ugly' topic needs to be in this document and no author wants to recommend it obviously ;-)

One open point is what to do with 'mostly obsolete' tunneling such as Teredo and 6to4 ? Ole wants to remove those sections completely but the authors feel that we need to keep them to be exhaustive.

Same for the CGN (NAT444) section, not really an IPv6 topic, but an important related-one and the document is in OPSEC WG (which is protocol version agnostic).

Thank you in advance and see you in London

-éric

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 9 Mar 2018 08:30:19 +1300

Eric,
> The authors will welcome reviews and comments especially on the new section 2.1.2 (Use of ULAs): this 'ugly' topic needs to be in this document and no author wants to recommend it obviously ;-)

I don't see anything ugly in the new text of 2.1.2; it is neutral and accurate. (There are specialised use cases for ULAs such as draft-ietf-anima-autonomic-control-plane, but I don't think it's necessary to mention them here.)
 
> One open point is what to do with 'mostly obsolete' tunneling such as Teredo and 6to4 ? Ole wants to remove those sections completely but the authors feel that we need to keep them to be exhaustive.

I agree with the authors. Also, you say:
"Teredo is now mostly never used and it is no more automated in most	
environment, so, it is less of a threat."

I was amazed recently to discover that this statement is untrue. I refer to fully updated Windows 10 Home laptops (two of them) which came up with an active Teredo interface that I had to disable.

Actually, such a statement is more true of 6to4 today, which I think nobody configures by default.

> Same for the CGN (NAT444) section, not really an IPv6 topic, but an important related-one and the document is in OPSEC WG (which is protocol version agnostic).

However, the scope of the draft is "IPv6 Networks" so this really does seem out of scope to me.

   Brian