Subject: [OPSEC] Call For Adoption: draft-camwinget-opsec-ns-impact

From: Ron Bonica <[email-masked]>
Date: Fri, 5 Jun 2020 15:04:57 +0000

Folks,

This email begins a call for adoption on draft-camwinget-opsec-ns-impact<https://datatracker.ietf.org/doc/draft-camwinget-opsec-ns-impact/>. The call for adoption will end on 6/19/2020.

                                        Ron and Jen

Juniper Business Use Only

---

From: tom petch <[email-masked]>
Date: Wed, 10 Jun 2020 10:18:44 +0000

________________________________________
From: OPSEC <[email-masked]> on behalf of Ron Bonica <rbonica=[email-masked]>
Sent: 05 June 2020 16:04
To: OPSEC
Subject: [OPSEC] Call For Adoption: draft-camwinget-opsec-ns-impact

Folks,

Support

I would have liked this to be a TLS document but the fact that it is not makes it even more important that it is adopted.

Tom Petch

                                        Ron and Jen

---

From: Warren Kumari <[email-masked]>
Date: Wed, 10 Jun 2020 08:41:44 -0400

Actually, that raises an important point -- why is it *not* a TLS
document? Are we wading into deep waters here? Did TLS object to this
document, or just show no interest, or say "'tis a fine idea, but too
operational for here, vaya con dios"?

Can this CfA be CCed to the TLS WG so that we get more review?

W

> _______________________________________________
> OPSEC mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsec

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Thu, 11 Jun 2020 02:30:45 +0000

On 6/10/20, 5:42 AM, "OPSEC on behalf of Warren Kumari" <[email-masked] on behalf of [email-masked]> wrote:

    Actually, that raises an important point -- why is it *not* a TLS
    document? Are we wading into deep waters here? Did TLS object to this
    document, or just show no interest, or say "'tis a fine idea, but too
    operational for here, vaya con dios"?
[NCW] It is the latter, that is, it is more about the operational impacts of network security.  When it was presented at the TLS WG,
It was noted that the draft presented TLS use cases but from an operational perspective and didn't fit with their current charter.
There were suggestions that opsec could be a better fit.

    W

---

From: tom petch <[email-masked]>
Date: Thu, 11 Jun 2020 08:14:53 +0000

From: Nancy Cam-Winget (ncamwing) <[email-masked]>
Sent: 11 June 2020 03:30

<tp>
I track the discussions on the TLS list, saw the discussion there inter alia and have a more jaundiced view.
<rant>
The TLS WG has many highly skilled, highly active proponents, more so than any other IETF WG I know.  Its culture I see as perfect security no matter what.  TLS 1.3 thus addresses all known problems no matter what.  If this renders it unusable in places, too bad - perfect security cannot be compromised.  This I-D says TLS 1.3 is not perfect in some settings so the TLS WG would commit suicide before ever adopting it.  Which is a shame since that is where the expertise lies and where any infelicities in the I-D might be detected.  Shame, but that is how it is.
</rant>
Tom Petch

    W

---

From: Warren Kumari <[email-masked]>
Date: Mon, 15 Jun 2020 14:57:12 -0400

[ Top post ]

Thanks Nancy, Tom, et al,

I also checked with the TLS chairs and ADs[0], and Ben replied saying
that he feels it should be fine in OPSEC[1], but that it's probably
worth giving a heads-up to TLS if / when this approaches WGLC.

So, great - as I think I've already mentioned, I happen to think that
this is useful.

Thanks everyone,
W

[0]: It's really not good having WGs stepping on each other's toes,
and I hadn't been following this in TLS...
[1]: Seeing as Roman is an author, I'm gonna count that as implicit
support for it being here :-)

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Mon, 15 Jun 2020 21:53:57 +0000

Thank you Warren for checking in with Ben....and yes, Roman is a co-author but will let him voice his own opinion __

Giving a heads up to the TLS group makes sense as that is where the bulk of the comments to drive this latest version came from.

Warm regards, Nancy

On 6/15/20, 11:58 AM, "Warren Kumari" <[email-masked]> wrote:

    [ Top post ]

    
    
    Thanks everyone,
    W