Subject: RE: [Ospf-wireless-design] Design Team slides for IETF 63

From: "Henderson, Thomas R" <[email-masked]>
Date: Tue, 2 Aug 2005 11:23:44 -0700

> -----Original Message-----
> From: Acee Lindem [mailto:[email-masked]] 
> Sent: Tuesday, August 02, 2005 7:00 AM
> To: Richard Ogier
> Cc: [email-masked]
> Subject: Re: [Ospf-wireless-design] Design Team slides for IETF 63
> 
> 
> The draft revision containing the technical details of your 
> proposal just made the IETF meeting cut-off (July 18th).  
> Hence, it is premature to say that reached consensus. As Tom 
> states in his slides, Boeing will soon make the full report 
> and GTNetS implementation available for evaluation.
> 

I agree that it is premature to say that we have consensus.  We do need
more discussion, though.  Richard has made a lot of points on this list
over the past few months that have largely gone unchallenged.  Does that
mean that people agree with him?

We have to get another approval to release the below to a wider (general
public) distribution, so please do not redistribute the below outside of
the design team at this time.  However, it is now posted for the design
team:

http://hipserver.mct.phantomworks.org/ietf/ospf/

In particular, there is a 100+ page tech report.  I don't expect people
to wade through the whole thing, but please look at the data in chapter
4 and summary in chapter 5, if you only read a portion of it.  

> > Richard wrote:
> > 
> > Regarding the "Smart Peering" draft by Roy et al. Is the 
> plan to allow
> > time for this new idea (which by the way is closely related to my
> > definition of a "routable" neighbor) to be developed into a 
> fine tuned
> > implementation?  If this idea can be demonstrated in a 
> short time, then
> > it might be worth considering.  But we have already delayed 
> the decision
> > by several months, so I think we need to avoid dragging on 
> indefinitely.

We have some results on a basic implementation of the Smart Peering
draft-- see Section 4 of our report.

I agree with Phil-- we need to agree first on an overall framework for
this extension (MDR vs. Overlapping Relays)- then, there are additional
design elements that need to be considered such as hello design, 2-hop
neighbor info dissemination, and flooding backups.

Tom

_______________________________________________
Ospf-wireless-design mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf-wireless-design

---

From: Richard Ogier <[email-masked]>
Date: Thu, 04 Aug 2005 18:39:44 -0700

>4 and summary in chapter 5, if you only read a portion of it.

I read Chapters 4 and 5 the technical report, and think the authors
did an excellent job in comparing the different proposals.

I would like to comment on the smart peering approach,
studied in Section 4.5 of the report.
I agree that "smart peering" has a circular dependency
problem if non-adjacent neighbors are included in LSAs.
(A simple 4-node example can be constructed to show this.)

To avoid this problem, I considered a variation in which
each router lists its adjacent neighbors in a new Hello TLV.
Then the router can avoid forming an adjacency
with a neighbor if there already exists a path of adjacencies
from the router to that neighbor based on the adjacency
information obtained from Hellos.  This can be used in
conjunction with the MDR extension, so that a router
selects adjacent neighbors as before except that it
avoids forming an adjacency with a neighbor if there
already exists a path of adjacencies to that neighbor.
An adjacent neighbor still remains adjacent only as long as
either the router or the neighbor is a (Backup) MDR, so
that adjacencies are still aligned with (Backup) MDRs.
This will reduce the number of adjacencies (at least a little),
but I have not run simulations to determine how this
affects performance.

Here is an example that shows one potential drawback of smart peering.
Consider a network of 100 nodes whose placement is such that the
connectivity graph is a cycle.  Then smart peering may result in the
formation of 99 adjacencies.  (Even though there are 100 edges in
the cycle, only 99 adjacencies are needed to connect all nodes.)
Now suppose that these 100 nodes all travel toward the same
geographical point so that all nodes end up being 1 hop
from each other. With smart peering, no new adjacencies
are formed, so that the adjacency graph still has diameter
99 even though the connectivity graph has diameter 1.
I'm not sure this is really "smart".  With MDRs, one MDR
will be selected, and adjacencies will be formed between
the MDR and all other routers (similar to the DR in an OSPF
broadcast network).

Richard