Subject: Re: Opaque LSA

From: "Manral, Vishwas" <[email-masked]>
Date: Mon, 27 May 2002 08:29:11 -0400

Hi Amit,

As the OSPF spec today stands, there is no means to do that. An operator
needs to be careful while configuring the priorities and order in which the
routers are brought up, so that the DR is opaque capable.

It however could be achieved, that the DR is Opaque capable, by setting the
priority to higher than the existing DR and doing a slight, backward
compatible change, to the DR election to do the following: -

When the Opaque capable router comes up and realizes that the DR is not
opaque capable, it could well claim itself to be the DR. The DR election
would take place and the DR with higher priority would be chosen the DR and
in case the opaque capable router has higher priority it could become the
DR.

This would be backward compatible in the sense that all routers would choose
the same DR. However I do not know of anyone who does this. ;-)

Thanks,
Vishwas

-----Original Message-----
From: Amit Srivastava [mailto:[email-masked]]
Sent: Monday, May 27, 2002 5:07 PM
To: [email-masked]
Subject: Opaque LSA

 Hi All,

             My Doubt is that if a router which is opaque LSA capable cannot
become DR and the DR on the network is not supporting then how will the
information be flooded to the other routers in the network which are opaque
LSA capable.

regards

amit

---

From: Amit Srivastava <[email-masked]>
Date: Mon, 27 May 2002 20:47:57 -0700

Hi All,
           My Doubt is that within the same Autonomous system if both OSPF and RIP are running and a router runs RIP on one interface and OSPF on the other then the routes that are learned by RIP will be flooded in the OSPF domain as intera area , inter area or As external Path???
regards
Amit

---------------------------------
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup

---

From: Amit Srivastava <[email-masked]>
Date: Mon, 27 May 2002 20:50:01 -0700

Hi Vishwas!!
               Even i thought the same thing but RFC 2370 no where specifies that your Opaque LSA specking router should always be DR!!
Thanks for the help!!
regards
Amit
  "Manral, Vishwas" <[email-masked]> wrote: Hi Amit, As the OSPF spec today stands, there is no means to do that. An operator needs to be careful while configuring the priorities and order in which the routers are brought up, so that the DR is opaque capable. It however could be achieved, that the DR is Opaque capable, by setting the priority to higher than the existing DR and doing a slight, backward compatible change, to the DR election to do the following: - When the Opaque capable router comes up and realizes that the DR is not opaque capable, it could well claim itself to be the DR. The DR election would take place and the DR with higher priority would be chosen the DR and in case the opaque capable router has higher priority it could become the DR.  This would be backward compatible in the sense that all routers would choose the same DR. However I do not know of anyone who does this. ;-) Thanks,Vishwas-----Original Message-----
From: Amit Srivastava [mailto:[email-masked]]
Sent: Monday, May 27, 2002 5:07 PM
To: [email-masked]
Subject: Opaque LSA

 Hi All,
             My Doubt is that if a router which is opaque LSA capable cannot become DR and the DR on the network is not supporting then how will the information be flooded to the other routers in the network which are opaque LSA capable.
regards
amit

---

From: Alex Zinin <[email-masked]>
Date: Mon, 27 May 2002 23:14:22 -0700

Vishwas,

  BTW, that's exactly the method that one can use if the DR
  responsibility needs to be reassigned to another router
  without disconnecting the interfaces (remember the thread
  about a month ago about ISIS-ish DR election). I promised
  one person to send a message on this to the list, but got
  disrupted apparently :)

--
Alex

---

From: Acee Lindem <[email-masked]>
Date: Tue, 28 May 2002 11:09:34 -0400

Amit Srivastava wrote:
>  Hi All,
>
>            My Doubt is that within the same Autonomous system if both
> OSPF and RIP are running and a router runs RIP on one interface and OSPF
> on the other then the routes that are learned by RIP will be flooded in
> the OSPF domain as intera area , inter area or As external Path???

All non-OSPF routes redistributed (aka, imported) into the OSPF routing
domain are advertised using type 5 (AS external) LSAs or type 7 (NSSA)
LSAs.

>
> regards
>
> Amit
>
>
> ------------------------------------------------------------------------
> *Do You Yahoo!?*
> Yahoo! <http://rd.yahoo.com/welcome/*http://fifaworldcup.yahoo.com> -
> Official partner of 2002 FIFA World Cup

--
Acee

---

From: Amit Srivastava <[email-masked]>
Date: Tue, 28 May 2002 23:23:39 -0700

Hi All,
         Thanks Acee for the help.I have one more doubt regarding the opaque LSA and TE.The opaque LSA is used to carry some
network related information.How do you configure your opaque LSA to carry the network related information such as Link type,Link ID,Max bandwidth,unreserved Bandwidth,Max reservable bandwidth e.t.c
                                              Are these information configured via CLI(that is what i think)???If yes then what are the commands that are used to configure the opaque LSA for TE.Bcoz i went through the OSPF commands it says little about the configuration of network information related to TE.
regards
Amit

---

From: Acee Lindem <[email-masked]>
Date: Wed, 29 May 2002 09:38:24 -0400

Amit Srivastava wrote:
>   Hi All,
>
>          Thanks Acee for the help.I have one more doubt regarding the
> opaque LSA and TE.The opaque LSA is used to carry some
>
> network related information.How do you configure your opaque LSA to
> carry the network related information such as Link type,Link ID,Max
> bandwidth,unreserved Bandwidth,Max reservable bandwidth e.t.c
>
>                                               Are these information
> configured via CLI(that is what i think)???If yes then what are the
> commands that are used to configure the opaque LSA for TE.Bcoz i went
> through the OSPF commands it says little about the configuration of
> network information related to TE.

Amit,

You should not have to configure link type, link ID, and maximum bandwidth
in OSPF. This information should be available elsewhere in your system. Normally
the reservations are handled dynamically by a separate functional component
(e.g., RSVP) and this component passes the per interface reservations information
to OSPF as reservations are added or dropped.

--
Acee

---

From: Amit Srivastava <[email-masked]>
Date: Wed, 29 May 2002 22:10:36 -0700

Hi Acee,
        Thanks for the help!! Actually you are right the application which wants to use the opaque LSA capability of OSPF should by means of some API or sockets send the aplication specific data to the opaque LSA.The OSPF on receiving the new application data would originate the new opaque LSA.
                                           Actually i got this yesterday only after sending the mail.
Thanks Once again
Regards
Amit

Amit,

--
Acee