Subject: Re: OSPF WG Charter Proposal

From: "Naidu, Venkata" <[email-masked]>
Date: Mon, 28 Oct 2002 18:22:02 -0500

Rohit/Acee,

 Some quick comments w.r.t new charter.

 1. Can you consider "Flooding Optimizations" into charter ?
    If not, can you please explain the reason, why we should not ?
    This is field of its own - we might expect lot of drafts.

 2. One of the Alex's work "OSPF Link-local Signaling" will
    be very imp for future OSPF enhancements. As you know,
    the options are getting over in OSPF headers.

 3. "OSPF TE" and "OSPF Hitless Restart" MIBs must be
    considered as separate drafts. Recent OSPFv2 MIB only
    talks about Opaque LSAs - but content carried in those
    LSAs are not specified in any MIB. I am be willing
    to write those drafts - what is your opinion, Kireeti/Padma ?

 4. "Flooding over Parallel Point-to-Point Links" can be
    considered as an informational RFC.

 Thank You.

--
Venkata.

-> -----Original Message-----
-> From: Rohit Dube [mailto:[email-masked]]
-> Sent: Monday, October 28, 2002 5:55 PM
-> To: [email-masked]
-> Subject: OSPF WG Charter Proposal
->
->
->
-> Folks,
->
-> Here is a strawman of the Charter. Please have a look at and send
-> any comments you may have to me or Acee or to the list.
->
-> The current charter is largely designed to clear up items that have
-> pending for a while. The charter will be re-visited periodically and
-> new items that come up will be added after discussions with the ADs.
->
-> Thanks,
-> Rohit and Acee
-> (OSPF WG Co-chairs)
->
->
->

---

From: Rohit Dube <[email-masked]>
Date: Mon, 28 Oct 2002 18:47:16 -0500

Venkata,

Thanks for your comments. Some of my own are inline.

A meta comment first - our first goal is to clear the decks
by getting done with all the work (drafts + implementation
experience) that has accumulated over time. Once enough
of this done, it would be a natural point for the WG to
expand on the charter.

On Mon, 28 Oct 2002 18:22:02 -0500 "Naidu, Venkata" writes:
=>Rohit/Acee,
=>
=> Some quick comments w.r.t new charter.
=>
=> 1. Can you consider "Flooding Optimizations" into charter ?
=>    If not, can you please explain the reason, why we should not ?
=>    This is field of its own - we might expect lot of drafts.

We considered this but would like to see some operational requirements
before including this in the charter. Is anybody running OSPF networks
hitting this problem with no workarounds in sight?

It would be a candidate for a future version of the charter once some
of the current items clear.

=>
=> 2. One of the Alex's work "OSPF Link-local Signaling" will
=>    be very imp for future OSPF enhancements. As you know,
=>    the options are getting over in OSPF headers.
=>
=> 3. "OSPF TE" and "OSPF Hitless Restart" MIBs must be
=>    considered as separate drafts. Recent OSPFv2 MIB only
=>    talks about Opaque LSAs - but content carried in those
=>    LSAs are not specified in any MIB. I am be willing
=>    to write those drafts - what is your opinion, Kireeti/Padma ?

I was considering reflecting OSPF-TE in a MIB too. And this could
be a potential item for this or a future. But is there an operator
burning for this stuff?

=>
=> 4. "Flooding over Parallel Point-to-Point Links" can be
=>    considered as an informational RFC.

What draft are you referring to?

=>
=> Thank You.
=>
=>--
=>Venkata.

Best,
--rohit.