Subject: Question wrt to default route generated by stub-ABR:

From: Mani Devarajan <[email-masked]>
Date: Wed, 9 Oct 2002 17:37:44 -0700

Hi all,

      ASBR
      -----     ------     -----    -------
     |     |   |      |   |     |  |       |
     | R1  |   | R2   |   |  R3 |  |  R5   |
     |     |   |      |   |     |  |       |
      -----     ------     -----    -------
       |  |I1 I2|  | |I4  I5|  |I6 I9| |
 RIP---    -----   |  ------    -----  |
           AREA1   |  AREA 0    AREA2  |
                   |I3                 |I10
                   |      -----        |
                   |   I7|     |I8     |
                    -----|  R4 |-------
                   AREA0 |     | AREA2
                          -----

          * AREA2 is configured for Stub

  In the above scenario, both ABR's(R4,R3) of Area2
generates a default route. If R5 considers the default
route through R4 to reach the external network and
if I bring down the I7 interface on R4, I observed
that R4 flushes the summary LSA's it generated in
Area2 except for the default-summary-LSA. Is it
correct behaviour.

 My doubt is, as R4 is not an ABR anymore (it is
just an internal router in Area2 after setting I7
down) is it correct to have the default-summary-LSA
genereated by R4 in Area2 database instead of flushing
it.

Thanks in advance,
-Mani

---

From: Acee Lindem <[email-masked]>
Date: Wed, 9 Oct 2002 22:22:23 -0400

Mani,

You are correct, R4 should purge it's default summary
advertisement since it is no longer an ABR.

Thanks,
Acee

--
Acee

---

From: Mani Devarajan <[email-masked]>
Date: Thu, 10 Oct 2002 11:46:21 -0700

Thanks Acee, and also I just want to correct my
question, it is type-7 default LSA that it didnt
get flushed and not default-summary-LSA.

   And also I have one more question wrt same topic,
On setting I7 down, R4 has default route through Area2(I8)
and R5 has a default route through  network on I9
and R3 has a default route through network on I6.

   But R3 also has a network specific type-5 route
to external rip network, so it takes precedence over the
default-route.

   Isnt it routing loop, R3 having a default route
through network on the interface I6 and R5 having a default
route through  network on the interface I9.

---

From: Acee Lindem <[email-masked]>
Date: Thu, 10 Oct 2002 15:09:59 -0400

> get flushed and not default-summary-LSA.

Hello Mani,

Ok - in this case it could be either a problem with
the OSPF implementation or a configuration problem.
If the type 7 is automatically generated by virtue
of the fact that it is an NSSA ABR, then the type 7 should
be withdrawn when R4 ceases to be an ABR. However, if
you have configured R4 to unconditionally originate an
external default, then this is a configuration problem.

> route through  network on the interface I9.

Yup.

--
Acee