Subject: Re: DR / BDR election on different links configured as on same subnet

From: Don Goodspeed <[email-masked]>
Date: Tue, 22 Oct 2002 15:48:53 -0400

Box B should not allow the same subnet to be configured on two
different links.  However, since DR election is on a per-interface
basis, not on a strictly per-subnet basis, DR election would
be done independantly on each link (aka interface).  LSA flooding,
etc. would be done as if the interfaces were on two different
subnets.  SPF calculations are another matter entirely, and
as such, routing will not occur between the two links.

If Box B is really a Layer-2 switch that has an OSPF interface
on it's "VLAN" that both ports are assigned to, well that's
a different scenario that you did not describe in your picture.
Let us know if that's the case.

-don

 --- On Tue 10/22, Delia Kecskemeti  wrote:
From: Delia Kecskemeti [mailto: [email-masked]]
To: [email-masked]
Date: Tue, 22 Oct 2002 14:51:21 -0400
Subject: DR / BDR election on different links configured as on same subnet

> Hi,
>
> I need to find out how is OSPF supposed to act in this particular case:
> Link between routers R1 and R2 and link between R2 and R3 are configured
> to
> be on the same subnet, say:
> a.b.c.x / 24
> In my understanding, the DR / BDR mechanism is applied on one broadcast
> link
> to which several routers attach, to minimize number of adjacencies and
> network burden on that link.
>
> Should DR and BDR mechanism be also applied to this scenario, that is R1,
> R2, R3 would elect a DR and BDR for that subnet a.b.c.0/24. Therefore if
> R1
> and R3 are the DR and BDR, then R2 would duplicate sending of PDUs to
> both
> links, in order to reach both DR and BDR? In my opinion it should not. I
> am
> told that it should, as this would be a particular case of OSPF support
> for
> layer 2 switching. Is there some specification in an RFC about this?
>
> R1-----------R2-----------R3
>
> Thank you very much and have a nice day,
> Delia
>

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!

---

From: Don Goodspeed <[email-masked]>
Date: Tue, 22 Oct 2002 16:11:03 -0400

Box B being the R2 in the diagram.  Doing it by memory,
I labelled them A--B--C.  -don

 --- On Tue 10/22, Don Goodspeed  wrote:
From: Don Goodspeed [mailto: [email-masked]]
To: [email-masked]
Date: Tue, 22 Oct 2002 15:48:53 -0400
Subject: Re: DR / BDR election on different links configured as on same subnet

---

From: Don Goodspeed <[email-masked]>
Date: Thu, 24 Oct 2002 18:09:11 -0400

Kiran,

As for the IP network:
    R1    R2    R3
     |     |     |
     |     |     |
    ---------------
which maps to the physical network:
    R1----R2----R3

Please separate L2 switching (bridging, etc.) of
packets from the L3 or IP/OSPF processing of
the packets when looking at this situation.

L2 switches or bridges will flood to all ports (with
limited expections) ALL multicast, broadcast, and
unknown packets, and will forward all "learned"
packets to their destination ports.  In other
words, if R2 is doing it's job as a switch or bridge
properly, R1, R2, and R3 will see all of each others
packets when they are on the same subnet.

Therefore, R1, R2, and R3 process packets at the
IP/OSPF level as if they were all connected into the
same "hub" or shared media access network, aka a
broadcast network in OSPF.  Therefore, RFC2328
takes care of what to do on a broadcast network in
terms of sending and receiving packets.

Cheers,
Don

 --- On Thu 10/24, Kiran S  wrote:
From: Kiran S [mailto: [email-masked]]
To: [email-masked]
Date: Thu, 24 Oct 2002 15:14:18 +0900
Subject: Re: DR / BDR election on different links configured as on same subnet

> Cheng-yin,
>
>   Yep... It is R1, R2, R3 peering over a same VLAN and subnet.
> The setup will be more clear if we connect all these OSPF routers to a L2
> switch or hub.
> In this case there will be a common DR/BDR election.
> But now the physical connection R1---R2---R3 and all belong to same
> subnet.
>
> This is a typical network connection, and this network looks logical.
> Any RFCs/standard stating how well we can handle this situation ?
> Thanks. !
>
> Cheers
> Kiran
>