Subject: Re: How to set the link costs ?

From: "Manral, Vishwas" <[email-masked]>
Date: Wed, 30 Oct 2002 07:01:08 -0500

Hi Yasu,

A formula used to find cost of a link can be

cost = 10 ^ 8 /(bandwidth in bps), which is used by implementations.

Thanks,
Vishwas

-----Original Message-----
From: Yasuhiro Ohara [mailto:[email-masked]]
Sent: Wednesday, October 30, 2002 5:21 PM
To: [email-masked]
Subject: How to set the link costs ?

Is there any way to calculate/produce the link cost, if topology is
given ? I know that depends on the topology and how the network
administrators want traffic to go through, but I think there should be
some generic guidance, to realize the policy if one is given. (I mean
"how traffic go through" by "policy".)

Is there any related work, tools or papers ?
How do you parameterize the costs on your network ?

I know the type of the link is a way.
I want another if there's.

Waiting for your reply.

regards,
yasu

---

From: "Banerjee, Gargi" <[email-masked]>
Date: Wed, 30 Oct 2002 15:32:36 -0500

Yasu,

Yes, there are a number of papers to compute dynamic link costs based on
traffic matrix, importance of source destination end points, congestion etc.
Some valuable papers are (published in Infocom):
1. A new approach to routing with dynamic metrics
http://citeseer.nj.nec.com/chen98new.html
2. Minimum Interference Routing with Applications to MPLS Traffic
Engineering http://citeseer.nj.nec.com/kodialam00minimum.html
3. Internet Traffic Engineering by optimizing OSPF weights
http://citeseer.nj.nec.com/fortz00internet.html

Hope this helps,
Gargi

-----Original Message-----
From: Yasuhiro Ohara [mailto:[email-masked]]
Sent: Wednesday, October 30, 2002 6:51 AM
To: [email-masked]
Subject: How to set the link costs ?

Waiting for your reply.

regards,
yasu