Subject: Padding for OSPF packets in the OSPF implementations

From: "Singh, Gurpreet" <[email-masked]>
Date: Wed, 9 Oct 2002 12:09:32 -1000

Hi

OSPF spec RFC 2328 does not allow any padding field for extra bytes for the
OSPF pakcets.

Consider the following situation.

 <<...OLE_Obj...>>
The IP packet length in the IP header covers the Junk bytes. But the OSPF
header does not.

If such a OSPF packet is received should the implementations accept this
packet as a valid packet or ignore it ?

I know this is a implementation specific question but what would be the
correct implementation according to the protocol specification.

Thanks

Gurpreet

---

From: "Singh, Gurpreet" <[email-masked]>
Date: Wed, 9 Oct 2002 12:36:58 -1000

Thanks Acee. I think the picture was not very clear in the e-mail. I was
refering to the padding at the end itself.

Gurpreet

-----Original Message-----
From: Acee Lindem [mailto:[email-masked]]
Sent: Wednesday, October 09, 2002 6:27 PM
To: [email-masked]
Subject: Re: Padding for OSPF packets in the OSPF implementations

Gurpreet,

How does one find the start of the OSPF header if there
are junk bytes between the IPv4 header and the OSPF header?
This doesn't seem valid to me.

On a related topic, I feel packets with padding on the end should
be accepted. This is in the spirit of RFC 1958 suggesting
to be tolerant when accepting and conservative when sending (I believe this
comes from an earliar Jon Postal quote). Note that
draft-nguyen-ospf-lls-01.txt
depends on packets with a longer IP length being accepted for backward
compatibility.

Singh, Gurpreet wrote:

> ________________________________________________________________________
> |   IP Header     |        OSPF Header        |    OSPF Payload
> |  Junk bytes |
> |                        |                                      |
> |                   |
> ________________________________________________________________________
>
>
> |-----------------------------------------IP Header
> Length-----------------------------------|
>                         |-----------------------OSPF Packet Length
> ---------------------------------|
>
>
>

--
Acee

---

From: "Naidu, Venkata" <[email-masked]>
Date: Wed, 9 Oct 2002 18:45:20 -0400

-> The IP packet length in the IP header covers the Junk bytes.
-> But the OSPF header does not.

  There are some situation even in RFC2328 (example MD5
  message digest) some data is written past OSPF packet
  but not counted as OSPF packet length.

  RFC2328 page 232 reads:

         (d) The MD5 digest is written over the OSPF key (i.e.,
             appended to the original OSPF packet). The digest is
             not counted in the OSPF packet's length field, but
             is included in the packet's IP length field. Any
             trailing pad or length fields beyond the digest are
             not counted or transmitted.

--
Venkata.