Subject: Re: when to run in NBMA or P2MP mode?

From: Rohit Gupta <[email-masked]>
Date: Tue, 1 Oct 2002 03:09:41 -0700

Hi,
Good explanation but tell me that if p2mp can be
effectively used without the full mesh of ospf routers
then why dont we always use this. Why should we then
use NBMA model at all?

TIA

--Rohit

----- Original Message -----
From: "Manav Bhatia" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, October 01, 2002 12:41 PM
Subject: Re: when to run in NBMA or P2MP mode?

| Dhaval,
| Let me give it a shot!
|
| As i understand, you want to clarify the following
| - Why the restriction of being able to reach all
neighbors directly is
| placed in order to run in NBMA mode when we always
send unicasts to our
| neighbors?
| - When would we like to run as p2mp
| - How can one determine which mode to run in?
|
| The reason why we want all the neighbors to be
reached directly is because
| we want to use mechanisms similar to those used in
the broadcast subnets.
| This helps making the NBMA segments more efficient
in terms of :
| - neighbor maintenance
| - database synchronization
| - database representation
| - reducing the O(n^2) relationships to O(n)
|
| Emulating NBMA as a normal broadcast network helps
the representation of an
| NBMA subnet within OSPF LSDB as indistinguishable
from the representation
| of a broadcast subnet.
| However, NBMA segments can fail when the two
attached neighbors are not
| able to communicate directly with each other.If, for
example, a PVC fails
| or is misconfigured or if an SVC cannot be
established, due to capacity or
| policy reasons, routing over NBMA will fail!
|
| When to use point-to-multipoint mode?
|
| Used if the nonbroadcast subnets cannot support a
large number of routers
| in complete mesh.
|
| To connect 200 routers in a full mesh over a Frame
Relay/ATM subnet, one
| would require (200)(200-1)/2 = 19,900 PVCs! Even
when SVCs are used,
| capacity limitations may prohibit pairwise
connectivity. One cant thus use
| the NBMA model as each router cant now communicate
directly with the every
| other router! The only alternative thus left is
p2mp.
| The problem comes when operating a full mesh FR/ATM
network in p2mp mode
| because now the work involved in neighbor
maintenance, flooding and
| database representation increases as O(n^2), where n
is the nos. of routers
| attached to the subnet, instead of O(n) that can be
achieved with the NBMA
| model.
|
| For the final question i guess the answer is that if
you cant provide full
| mesh support then its better to model the network as
p2mp.
|
| Regards,
| Manav

__________________________________________________
Do you Yahoo!?
New DSL Internet Access from SBC & Yahoo!
http://sbc.yahoo.com

---

From: Acee Lindem <[email-masked]>
Date: Tue, 1 Oct 2002 09:00:57 -0700

> then why dont we always use this. Why should we then

Rohit,

NBMA should not be used if you don't have a full mesh. If you do
have a full mesh using NBMA can significantly reduce your OSPF
neighbor adjacencies and flooding overhead. Let's say that you have a
full mesh attached to an NBMA subnet with N OSPF routers. You'll
require N (N - 1) adjacencies in the case of P2MP and 2 (N - 1)
in the case of NBMA.

Thanks,

--
Acee

---

From: Dave Katz <[email-masked]>
Date: Tue, 1 Oct 2002 09:17:49 -0700

Exactly.