Subject: Re: OSPF Adjacencies

From: Kerpal <[email-masked]>
Date: Fri, 18 Oct 2002 05:11:18 -0700

Almost there....And by "DC" you mean Directly Connected?

How many lack of acks does Cisco's implementation define N as being before the
adj is brought down?

Kerpal

On Thu, 17 Oct 2002 21:38:30 -0700 Padma Pillay-Esnault <[email-masked]>
wrote:

> Kerpal
>
>
>
> > >
> > > In addition, does the "lack of not
> receiving an ack and
> > > retransmitting the
> > > update until adj is destroy by hello"  then
> tell me that the
> > > adjacency is
> > > not actually brought down by the lack off
> acks but by the lack of a
> > > hello.
> > > Is this correct?
> > >
>
> Yes - according to spec.
>
> > > Is it mandatory for ALL updates to be ack?
> > >
> > > Is it that common to see implementations of
> OSPF tear down the adj after
> > > N
> > > number of retransmission for update or DBD
> packet? Do you know which
> > > vendors
> > > actually do this?
> > >
>
> It is not common, AFAIK the only implementation
> that does this is Cisco's
> for over DC. Derek Yeung and I came up with
> this to solve problem of the
> detection of neighbors that died over a DC
> circuit after being FULL.
> This was later documented in a draft.
>
> Padma
>
>
> > > Thank you!
> > >
> > >
> > > Kerpal
> > >
> > >
> > >
> > > -----Original Message-----
> > > From: Mailing List
> [mailto:[email-masked]]On Behalf Of
> Sina
> > > Mirtorabi
> > > Sent: Thursday, October 17, 2002 6:25 PM
> > > To: [email-masked]
> > > Subject: Re: OSPF Adjacencies
> > >
> > >
> > > Kerpal,
> > >
> > > > Hi All,
> > > >
> > > >   I am looking to understand what are the
> reason in which an OSPF
> > > > adjacency
> > > > may be torn down (aside from physical
> layer issues and
> > > > RouterDeadInterval).
> > > >
> > >
> > > those are actually the main one, receiving
> a 1 one way Hello also tear
> > > down
> > > an adj
> > >
> > >
> > > > More specific, would not receiving an
> acknowledgement for a LSU
> > > > result in an
> > > > adjacency to be torn down?
> > >
> > > some implementation tear down the adj after
> N number of retransmission
> > > for
> > > update or DBD packet
> > > RFC actually states that if ack is not
> received, retransmission will
> > > re-occur until adj is destroyed by Hello.
> mostly this condition would be
> > > enough for non-DC link but might not be in
> some very rare cases for
> > > example
> > > if Hello packet make it through and not the
> update ( say because of the
> > > packet size the packet gets corrupted on
> lower layer etc ) ....
> > >
> > >
> > > Sina
> > >
> > >
> > > >
> > > >
> > > > thanks
> > > >
> > > > Kerpal
> > >
> >
> >
> _______________________________________________
> > Join Excite! - http://www.excite.com
> > The most personalized portal on the Web!
> >
>

---

From: Padma Pillay-Esnault <[email-masked]>
Date: Fri, 18 Oct 2002 06:34:26 -0700

> Almost there....And by "DC" you mean Directly Connected?

No. I meant DC - Demand Circuit.
(Sorry for my use of an acronym.)

In regular cases, the lack of hellos would trigger the Dead Timer Interval
and tear the adjacency down. This is sufficient to ensure correct operation
of OSPF.

> How many lack of acks does Cisco's implementation define N as being before the

It was 3 retransmissions but could have changed since.

Padma