Subject: Re: OSPF Adjacencies

From: Kerpal <[email-masked]>
Date: Fri, 18 Oct 2002 09:12:37 -0700

Do you know what the command is on Cisco to adjust this setting?

Kerpal

On Fri, 18 Oct 2002 09:03:56 -0700 Sina Mirtorabi <[email-masked]> wrote:

> Kerpal
>
> > Gotcha.  After I had sent the question, I
> found the section in
> > the RFC that
> > speaks about this (page 88).  However, I was
> unable to find where
> > it states
> > that if ack is not received, retransmission
> will re-occur until adj is
> > destroyed by Hello.  Could you point me to
> this?
>
> see end of section 13.6
>
> >
> > In addition, does the "lack of not receiving
> an ack and retransmitting the
> > update until adj is destroy by hello"  then
> tell me that the adjacency is
> > not actually brought down by the lack off
> acks but by the lack of a hello.
> > Is this correct?
>
> Padma already answered this
>
> >
> > Is it mandatory for ALL updates to be ack?
>
> yes unless it is received less than
> MinLSArrival
>
>
> > Is it that common to see implementations of
> OSPF tear down the adj after N
> > number of retransmission for update or DBD
> packet? Do you know
> > which vendors
> > actually do this?
>
> Cisco does it and we do for both DC and non-DC
> link, further setting N is
> configurable and can also be disabled through
> configuration
>
> Sina
>
>
> >
> > Thank you!
> >
> >
> > Kerpal
> >
> >
> >
> > -----Original Message-----
> > From: Mailing List
> [mailto:[email-masked]]On Behalf Of
> Sina
> > Mirtorabi
> > Sent: Thursday, October 17, 2002 6:25 PM
> > To: [email-masked]
> > Subject: Re: OSPF Adjacencies
> >
> >
> > Kerpal,
> >
> > > Hi All,
> > >
> > >   I am looking to understand what are the
> reason in which an OSPF
> > > adjacency
> > > may be torn down (aside from physical layer
> issues and
> > > RouterDeadInterval).
> > >
> >
> > those are actually the main one, receiving a
> 1 one way Hello also
> > tear down
> > an adj
> >
> >
> > > More specific, would not receiving an
> acknowledgement for a LSU
> > > result in an
> > > adjacency to be torn down?
> >
> > some implementation tear down the adj after N
> number of retransmission for
> > update or DBD packet
> > RFC actually states that if ack is not
> received, retransmission will
> > re-occur until adj is destroyed by Hello.
> mostly this condition would be
> > enough for non-DC link but might not be in
> some very rare cases
> > for example
> > if Hello packet make it through and not the
> update ( say because of the
> > packet size the packet gets corrupted on
> lower layer etc ) ....
> >
> >
> > Sina
> >
> >
> > >
> > >
> > > thanks
> > >
> > > Kerpal
>

---

From: Sina Mirtorabi <[email-masked]>
Date: Fri, 18 Oct 2002 09:17:41 -0700

> Do you know what the command is on Cisco to adjust this setting?

limit retransmissions <[dc <1-255>] [non-dc <1-255>]

default is 24 for dc and 12 for non-dc

Sina