Subject: Link TLV's sub-TLVs

From: Kunihiro Ishiguro <[email-masked]>
Date: Tue, 15 Oct 2002 01:24:16 -0700

Here is a current Link TLV's sub-TLVs list ;-) which is referred in
various drafts.  With this TLVs I think we are pretty much ok
(hopefully...).  I'll submit updated draft.

            Traffic Engineering Link TLV (type 2) sub-TLVs

Traffic Engineering sub-TLVs
============================
1  - Link type (1 octet)
2  - Link ID (4 octets)
3  - Local interface IP address (4N octets)
4  - Remote interface IP address (4N octets)
5  - Traffic engineering metric (4 octets)
6  - Maximum bandwidth (4 octets)
7  - Maximum reservable bandwidth (4 octets)
8  - Unreserved bandwidth (32 octets)
9  - Administrative group (4 octets)

GMPLS sub-TLVs
==============
11 - Link Local/Remote Identifiers (8 octets)
14 - Link Protection Type (4 octets)
15 - Interface Switching Capability Descriptor (variable)
16 - Shared Risk Link Group (variable)

IPv6 sub-TLVs
=============
17 - Neighbor ID (8 octets)
18 - Local Interface IPv6 Address (16N octets)
19 - Remote Interface IPv6 Address (16N octets)

Diffserv aware MPLS sub-TLVs
============================
TBD - Bandwidth Constraint Model Id (1 octet)
      Bandwidth Constraints (4N octets)
TBD - Local Overbooking Multiplier (2N octets)

10,12,13 are not used by historical reason.

Reference
=========
draft-katz-yeung-ospf-traffic-08.txt
draft-ietf-ccamp-ospf-gmpls-extensions-08.txt
draft-ishiguro-ospf-ospfv3-traffic-01.txt
draft-ietf-tewg-diff-te-proto-01.txt
--
Kunihiro Ishiguro

---

From: "Naidu, Venkata" <[email-masked]>
Date: Sat, 19 Oct 2002 10:59:46 -0400

Vishwas,

-> Why do we need the TLV
->
-> 11 - Link Local/Remote Identifiers (8 octets)
->
-> The Neighbor Id identifies the remote Interface ID.
-> The local Interface ID is the Link ID of the LSA.

  sub-TVL 11 is used to represent unnumbered links for
  TE purposes. Those IF_IDs are not in the same *space*
  of IP Addresses in a router, but they can coincide with
  IP addresses. To resolve the issue of this coincidence,
  for unambiguous identification of parallel unnumbered
  links this TLV 11 is introduced in GMPLS drafts.

  Whereas, Link ID and Neighbor ID sub-TLVs identifies mostly
  a *routing instance* not a specific *interface instance*.

--
Venkata.

---

From: "Manral, Vishwas" <[email-masked]>
Date: Sun, 20 Oct 2002 05:36:46 -0400

Hi Venkata,

Then can we state that

"Link State ID of Intra-Area-TE-LSA should be the Interface ID of the
link.". Will all links advertized in TE topology also have an Interface ID?

I thought not and did mail the author about it and got no reply, besides
that I did raise the question on the same statement on the other mail to the
list.

Thanks,
Vishwas

-----Original Message-----
From: Naidu, Venkata [mailto:[email-masked]]
Sent: Saturday, October 19, 2002 8:30 PM
To: [email-masked]
Subject: Re: Link TLV's sub-TLVs

Vishwas,

--
Venkata.