Subject: Query on implementation of SNMP TRAP ospfTxRetransmit

From: Roy Jose <[email-masked]>
Date: Tue, 29 Oct 2002 18:22:59 +0530

Hi,

   The TRAP message ospfTxRetransmit is supposed to contain Lsdb entry
details as given in its defenition. When an OSPF packet contains is
associated with only one Lsdb, there are no problems. But, when the same
OSPF packet like UPDATE, DATABASE DESCRIPTION, etc is associated with more
than one Lsdb entry, what can be done? Can we set Lsdb details to zero and
send? Anybody knows about some implementations?

    ospfTxRetransmit NOTIFICATION-TYPE
        OBJECTS {
                    ospfRouterId, -- The originator of the trap
                    ospfIfIpAddress,
                    ospfAddressLessIf,
                    ospfNbrRtrId, -- Destination
                    ospfPacketType,
                    ospfLsdbType,
                    ospfLsdbLsid,
                    ospfLsdbRouterId
                  }
        STATUS             current
        DESCRIPTION
           "An ospfTxRetransmit  trap  signifies  than  an
           OSPF  packet  has  been retransmitted on a non-
           virtual interface.  All packets that may be re-
           transmitted  are associated with an LSDB entry.
           The LS type, LS ID, and Router ID are  used  to
           identify the LSDB entry."

Thanks,
Roy

---

From: Acee Lindem <[email-masked]>
Date: Tue, 29 Oct 2002 13:59:03 -0500

Roy,

I haven't implemented this trap but I'd just use the first LSA in
packet. Not speaking as WG co-chair and being completely
honest, I can't imagine why anyone would enable this trap in the
first place. One of the main causes of retransmissions is congestion
and sending this trap would only exacerbate matters.

--
Acee