Subject: Re: Link TLV's sub-TLVs

From: "Manral, Vishwas" <[email-masked]>
Date: Sat, 19 Oct 2002 05:03:38 -0400

Hi Kunihiro Ishiguro,

Why do we need the TLV

11 - Link Local/Remote Identifiers (8 octets)

The Neighbor Id identifies the remote Interface ID. The local Interface ID
is the Link ID of the LSA.

Thanks,
Vishwas

-----Original Message-----
From: Kunihiro Ishiguro [mailto:[email-masked]]
Sent: Tuesday, October 15, 2002 1:54 PM
To: [email-masked]
Subject: Link TLV's sub-TLVs

Here is a current Link TLV's sub-TLVs list ;-) which is referred in
various drafts.  With this TLVs I think we are pretty much ok
(hopefully...).  I'll submit updated draft.

            Traffic Engineering Link TLV (type 2) sub-TLVs

Traffic Engineering sub-TLVs
============================
1  - Link type (1 octet)
2  - Link ID (4 octets)
3  - Local interface IP address (4N octets)
4  - Remote interface IP address (4N octets)
5  - Traffic engineering metric (4 octets)
6  - Maximum bandwidth (4 octets)
7  - Maximum reservable bandwidth (4 octets)
8  - Unreserved bandwidth (32 octets)
9  - Administrative group (4 octets)

GMPLS sub-TLVs
==============
11 - Link Local/Remote Identifiers (8 octets)
14 - Link Protection Type (4 octets)
15 - Interface Switching Capability Descriptor (variable)
16 - Shared Risk Link Group (variable)

IPv6 sub-TLVs
=============
17 - Neighbor ID (8 octets)
18 - Local Interface IPv6 Address (16N octets)
19 - Remote Interface IPv6 Address (16N octets)

Diffserv aware MPLS sub-TLVs
============================
TBD - Bandwidth Constraint Model Id (1 octet)
      Bandwidth Constraints (4N octets)
TBD - Local Overbooking Multiplier (2N octets)

10,12,13 are not used by historical reason.

Reference
=========
draft-katz-yeung-ospf-traffic-08.txt
draft-ietf-ccamp-ospf-gmpls-extensions-08.txt
draft-ishiguro-ospf-ospfv3-traffic-01.txt
draft-ietf-tewg-diff-te-proto-01.txt
--
Kunihiro Ishiguro

---

From: Kunihiro Ishiguro <[email-masked]>
Date: Sat, 19 Oct 2002 06:31:57 -0700

>is the Link ID of the LSA.

Please ask to GMPLS draft author.
--
Kunihiro Ishiguro