Subject: OSPFv3 nexthop

From: "Manral, Vishwas" <[email-masked]>
Date: Thu, 28 Nov 2002 06:45:37 -0500

Hi folks,

I was going thru the OSPFv3 RFC which in section it states that

"In IPv6, the calculation of the next hop's IPv6 address (which will be a
link-local address) proceeds along the same lines as the IPv4 next hop
calculation (see Section 16.1.1 of [Ref1])."
I think this is not correct. After carefully reading the RFC I figured out
that Link-LSA's can have global scope IPv6 addresses too. I see no reason
why we cannot have global addresses as next hop. Besides for some conditions
of redistribution we may require global scope addresses for nexthop.
Any opinions?
Thanks,
Vishwas

---

From: Acee Lindem <[email-masked]>
Date: Thu, 28 Nov 2002 23:53:49 -0500

Hello Vishwas,

Manral, Vishwas wrote:
> why we cannot have global addresses as next hop.

You are guarenteed to have a link local address on all OSPFv3
interfaces while there is no guarentee that you have a global
address. I believe this is the rationale for using the
link local.

> Besides for some conditions

Are you trying determine whether a third party next hop can be
advertised by matching global subnets?

--
Acee