Subject: OSPF reference bandwidth

From: "Field, Brian" <[email-masked]>
Date: Tue, 5 Nov 2002 10:04:21 -0700

Is the 100Mb/s reference bandwidth that's used to cost out
links defined in an RFC somewhere or is this it a value
informally agreed to by the vendors?  I didn't see reference
to this value in 2328 and didn't see any other RFCs which looked
like they would specify this value.

Thanks
Brian

---

From: "Joyal, Daniel R (Daniel)" <[email-masked]>
Date: Tue, 5 Nov 2002 12:15:31 -0500

Brian,

 It's in the OSPFv2 MIB, RFC 1850. See
OSPF Interface Metric Table on pages 39-40.
Unfortunately, with this fixed reference bandwidth,
anything over 100mbps results in a cost of 1.
The update to this MIB should probably add
a read-write reference bandwidth object.

-Dan

-----Original Message-----
From: Field, Brian [mailto:[email-masked]]
Sent: Tuesday, November 05, 2002 12:04 PM
To: [email-masked]
Subject: OSPF reference bandwidth

Thanks
Brian

---

From: "Field, Brian" <[email-masked]>
Date: Tue, 5 Nov 2002 13:20:23 -0700

Hi Dan,

Thanks for the pointer to 1850.  If I'm parsing the MIB correctly,
the reference value (100Mb/s) is not in the MIB, but rather the
interface cost value, based on the 10^8/ifSpeed, is stored.

I'm wondering if it would make sense if the MIB contained an object that
holds the reference bandwidth value used to compute link costs?  Further,
it might be useful if the OspfIfMetricEntry where to be augmented to
include an indication if ospfIfMetricValue was computed using the default
value (10^8 or other default) or if the OSPF link cost value was assigned
to the interface directly.

Obviously, the 10^8 default value has limitations for us today.
I would be convienent if we were able to reset the default reference
bandwidth value (which is possible), but then to perform sanity checks
via NM tools that all routers are using the same reference value.  Further,
we might want to verify that all interfaces costs' are derived from
this references value, and those which are not, can be detected by NM
tools.

Thoughts?

Thanks
Brian

    ospfIfMetricValue OBJECT-TYPE
        SYNTAX   Metric
        MAX-ACCESS   read-create
        STATUS   current
        DESCRIPTION
           "The metric of using this type  of  service  on
           this interface.  The default value of the TOS 0
           Metric is 10^8 / ifSpeed."
       ::= { ospfIfMetricEntry 4 }

-----Original Message-----
From: Joyal, Daniel R (Daniel) [mailto:[email-masked]]
Sent: Tuesday, November 05, 2002 10:16 AM
To: [email-masked]
Subject: Re: OSPF reference bandwidth

Brian,

-Dan

-----Original Message-----
From: Field, Brian [mailto:[email-masked]]
Sent: Tuesday, November 05, 2002 12:04 PM
To: [email-masked]
Subject: OSPF reference bandwidth

Thanks
Brian

---

From: "Joyal, Daniel R (Daniel)" <[email-masked]>
Date: Tue, 5 Nov 2002 16:47:17 -0500

Responses inline.

-Dan

-----Original Message-----
From: Field, Brian [mailto:[email-masked]]
Sent: Tuesday, November 05, 2002 3:20 PM
To: [email-masked]
Subject: Re: OSPF reference bandwidth

Hi Dan,

>> That's correct. The reference bandwidth is not a configurable
>> parameter. I don't know how many OSPF implementations actually
>> compute the default interface metric based on the above formula,
>> though.

>> I think it could be useful. I know of at least one implementation that
>> supports configurable reference bandwidth.

Thoughts?

Thanks
Brian

-----Original Message-----
From: Joyal, Daniel R (Daniel) [mailto:[email-masked]]
Sent: Tuesday, November 05, 2002 10:16 AM
To: [email-masked]
Subject: Re: OSPF reference bandwidth

Brian,

-Dan

-----Original Message-----
From: Field, Brian [mailto:[email-masked]]
Sent: Tuesday, November 05, 2002 12:04 PM
To: [email-masked]
Subject: OSPF reference bandwidth

Thanks
Brian