Subject: Nssa (P-bit Policy Paradox)

From: Krishna Rao <[email-masked]>
Date: Wed, 13 Nov 2002 08:53:11 -0000

Hi,
Is there any proposed solution to overcome this
paradox.

thanks,
krishna
__________________________________________________________
Give your Company an email address like
ravi @ ravi-exports.com.  Sign up for Rediffmail Pro today!
Know more. http://www.rediffmailpro.com/signup/

---

From: Sina Mirtorabi <[email-masked]>
Date: Wed, 13 Nov 2002 03:35:41 -0800

krishna

> -----Original Message-----
> From: Mailing List [mailto:[email-masked]]On Behalf Of
> Krishna Rao
> Sent: Wednesday, November 13, 2002 12:53 AM
> To: [email-masked]
> Subject: Nssa (P-bit Policy Paradox)
>
>
> Hi,

one solution could be to use type-7 to type-5 translation in order to import
some prefix into NSSA area therefore there will not be a need to advertise
same prefix in both NSSA and external to NSSA area

if there is a need to annouce a prefix in both NSSA and outside of NSSA you
could advertise say a metric type-1 for prefix outside of NSSA in that case
the traffic from outside of NSSA will not be hijacked into NSSA ( since
type-1 metric will be prefered over type-2 metric advertised in NSSA ).

however the reverse still can occur if the path through NSSA router goes
over the ABR, the traffic will go outside  of NSSA area which may be
acceptable if we consider that NSSA has limited resources ...

Sina