Subject: Forwarding Address

From: Krishna Rao <[email-masked]>
Date: Fri, 22 Nov 2002 09:02:35 -0000

Hi,
I have a doubt as to, in what sequence a NSSA ASBR decides a
forwarding address for the Type-7 lsa:

Reference : NSSA draft 11
Section 3.3
------------
1)If the network between the NSSA AS boundary router
and the adjacent AS is advertised into OSPF as an internal OSPF
route, the forwarding address should be the next hop address as is
currently done with
Type-5 LSAs.

2)If the intervening network is not advertised into OSPF as an
internal OSPF route and the Type-7 LSA's P-bit is set, a
forwarding address should be selected from one of the router's
active OSPF interface addresses which belong to the NSSA.

3)When a router is forced to pick a forwarding address for a
Type-7 LSA, precedence should be given first to
the router's loopback addresses (provided internal addressing is
supporte).

4)If a loopback address is not used and the selected forwarding
address's interface transitions to a Down state (see OSPF Section
9.3), one must select a
new forwarding address for any Type-7 LSAs which reference the
previously selected forwarding address and then re-originate these
Type-7 LSAs.

5)If internal addresses are not available, preference
should be given to the router's active OSPF stub network addresses
to avoid the possible extra hop of a transit network's address.

Q1) Does steps 1,2 apply at NSSA ASBR which
     will originally originate the lsa?

Q2) Are steps 3,4,5 meant for NSSA ABR which does the
     translation of Type-7 lsa to Type-5 lsa?
     What does term "forced" means here.
     My understanding is that these steps only apply
     for ASBR, since ABR will just ignore the Type-7
     lsa with 0.0.0.0 forwarding address.

Q3) If my above understandig is wrong, what is the
     correct sequence.

Thanks in advance,

krishna

__________________________________________________________
Give your Company an email address like
ravi @ ravi-exports.com.  Sign up for Rediffmail Pro today!
Know more. http://www.rediffmailpro.com/signup/

---

From: Sina Mirtorabi <[email-masked]>
Date: Fri, 22 Nov 2002 05:24:57 -0800

Krishna,

> -----Original Message-----
> From: Mailing List [mailto:[email-masked]] On
> Behalf Of Krishna Rao
> Sent: Friday, November 22, 2002 1:03 AM
> To: [email-masked]
> Subject: Forwarding Address
>
>
> Hi,
> and the adjacent AS is advertised into OSPF as an internal
> OSPF route, the forwarding address should be the next hop
> address as is currently done with Type-5 LSAs.
>
> 2)If the intervening network is not advertised into OSPF as
> an internal OSPF route and the Type-7 LSA's P-bit is set, a
> forwarding address should be selected from one of the
> router's active OSPF interface addresses which belong to the NSSA.
>
> Type-7 LSA, precedence should be given first to the router's
> loopback addresses (provided internal addressing is supporte).
>
> 4)If a loopback address is not used and the selected
> forwarding address's interface transitions to a Down state
> (see OSPF Section 9.3), one must select a new forwarding
> address for any Type-7 LSAs which reference the previously
> selected forwarding address and then re-originate these Type-7 LSAs.
>
> should be given to the router's active OSPF stub network
> addresses to avoid the possible extra hop of a transit
> network's address.
>

Yes

>      translation of Type-7 lsa to Type-5 lsa?

No to the ASBR, when an ABR translate a type 7 to 5 , FA is kept intact.
The only time ABR will change the FA is when there is an agregation and
the FA ( for the summary ) will be set to zero

>      What does term "forced" means here.

When the P bit is set, an ASBR should ( is forced to) pick up a FA for
that type 7 ( otherwise no translation will occur )

If P bit is not set the setting of FA is optional and it is actually
better to set the FA to zero ( in case a loopback address cannot be
chosen as FA )

>      lsa with 0.0.0.0 forwarding address.

Yes it applies to ASBR

Sina