Subject: Type-7 to Type-5 translation

From: Krishna Rao <[email-masked]>
Date: Thu, 5 Dec 2002 05:11:35 -0000

Hi,
I have few doubts with regards to below translation:

Reference : NSSA draft 11
Section   : 4.2
Step 2
-------
If the Type-7 LSA is not contained in any explicitly
configured Type-7 address range and the calculating router has
the highest router ID amongst NSSA translators which have
originated a functionally equivalent Type-5 LSA (i.e. same
destination, cost and non-zero forwarding address) and which
are reachable over area 0 and the NSSA, then a Type-5 LSA
should be generated if there currently is no Type-5 LSA
originating from this router corresponding to the Type-7 LSA's
network or there is an existing Type-5 LSA and either it
corresponds to a local OSPF external source whose path type
and metric is less preferred (see Section 3.5 step (6), parts
(b) and (d)) or it doesn't and the Type-5 LSA's path type or
cost(s) have changed (See Section 3.5 step (5)) or the
forwarding address no longer maps to a translatable Type-7
LSA.

Q1) Case when there is existing Type-5 Lsa:
     "corresponds to a local OSPF external source "
     what does this exactly mean ?
     Does it mean, the Type-5 external route learned by NSSA ABR
     (Translator), which is not result of Type-7 to Type-5
translation,
     but it is describing the same network, which will be
described by
     resulting translated Type-5.

Q2)"or it doesn't and the Type-5 LSA's path type or
     cost(s) have changed".

     Does this imply comparison between path type and cost of:
     1)Type-5 (result of Type-7 translation)
     2)Type-5 (result of Type-7 translation, but now path/cost
has
       changed)
     For e.g
     Previously translated Type-7 Lsa has Type-2 external path.
     New Type-7 Lsa (new instance of previous) has Type-1 external
path.
     So resulting Type-5 needs to reflect the path change.

Thanks in advance,
krishna

---

From: Sina Mirtorabi <[email-masked]>
Date: Thu, 5 Dec 2002 04:54:07 -0800

Krishna ,

> configured Type-7 address range and the calculating router
> has the highest router ID amongst NSSA translators which have
> originating from this router corresponding to the Type-7
> LSA's network or there is an existing Type-5 LSA and either
> it corresponds to a local OSPF external source whose path
> type and metric is less preferred (see Section 3.5 step (6), parts
> forwarding address no longer maps to a translatable Type-7 LSA.

Ok let me rephrase the above a bit in a simplify form, the translator
will translate a type 7 LSA if either of the below is satisfied

- there is not currently a type 5 generated by this router( as a result
of translation)
- there is a type 5 generated by this router ( but not as a result of
translation, that is locally sourced ) which has less proffered metric
(type) compared to the type 7
-  there is a type 5 generated by this router ( as a result of
translation ) but metric or FA changed therefore a new type 5 is needed
to be generated

>      what does this exactly mean ?

An ABR attached to a NSSA area while redistributing, it can originate
type 5 directly into attached non-NSSA-area this is called local sourced
type 5 LSA ( not as a result of translation )

>      but it is describing the same network, which will be described by

No, local OSPF external source means that the ABR is directly generating
type 5 into non-NSSA-area ( see above )

>      2)Type-5 (result of Type-7 translation, but now path/cost has
>        changed)
>      For e.g
>      New Type-7 Lsa (new instance of previous) has Type-1
> external path.

Correct

Sina