Subject: OSPFv3 Applications Support

From: Acee Lindem <[email-masked]>
Date: Wed, 18 Dec 2002 10:57:46 -0500

At the 55th IETF WG meeting, there were two proposals for
supporting additional OSPF applications. There was quite
a lively discussion of the relative merits of each and
we decided that it would be best to discuss it further on
the OSPF WG list. Heretofore, there hasn't been any further
discussion so I figure it is time to get the ball rolling (or
in this case, the E-mails flying).

   - OSPFv2 Opaque LSAs in OSPFv3
     http://www.ietf.org/internet-drafts/draft-kompella-ospf-opaquev2-00.txt

   - Traffic Engineering Extensions to OSPF version 3
     http://www.ietf.org/internet-drafts/draft-ishiguro-ospf-ospfv3-traffic-01.txt

The first defines the transformations necessary to map OSPFv2
opaque LSAs to OSPFv3. The second defines how to map the most
widely implemented and deployed OSPFv2 opaque to OSPFv3 using
new LSA types.

I'll defer any opinions of my own to separate E-mail speaking
as a WG member. In any case, we need to reach a rough concensus
on this as it will impact future work.

--
Acee

---

From: Kunihiro Ishiguro <[email-masked]>
Date: Fri, 20 Dec 2002 20:51:53 -0800

>widely implemented and deployed OSPFv2 opaque to OSPFv3 using

Well, besides I wrote a draft for OSPFv3 TE, I support defining a new
LS type for new application.  OSPFv3 already has clean design and very
flexible architecture for new application.
--
Kunihiro Ishiguro