Subject: Re: Question about nexthop calculation

From: Igor Miroshnik <[email-masked]>
Date: Sat, 21 Dec 2002 23:26:23 -0500

Jasmine,

The information used immediately is the outgoing interface. Besides, at this stage the nexthop
address can be retrieved from the link data of the directly connected router vertex. This nexthop
address is used later, when a remote vertex inherits nexthops to the directly connected router
vertices.

Thanks,
Igor

 --- j j <[email-masked]> wrote:
>Igor,
>
>Why is it necessary to record nexthops for routers
>connected via network to the root?  Where is this
>information used?
>is it used to process stub links or inter-area
>route calcuations?
>
>thanks
>
>jasmine
>
>--- Igor Miroshnik <[email-masked]> wrote:
>> On Sat, 21 Dec 2002 10:46:51 -0800, j j
>> <[email-masked]> wrote:
>>
>> >hello folks,
>> >
>> >I am going through Zebra and Moy's source code for
>> >OSPFv2.  The question I have is when calculating
>> >next hops for a router vertex that is directly
>> >connected to the root (i.e. calculating router) via
>> >a network vertex, why can't we simply inherit the
>> >nexthops of the network vertex ? Moy and Zebra both
>> >do something special for this case which I cannot
>> >understand.
>> >
>> >It seems like the root should be able to reach the
>> >router through all the nexthops that were
>> calculated
>> >for the network vertex.
>> >
>> >I hope I was able to clearly explain my doubts.
>> >
>> >thanks
>> >
>> >jasmine
>>
>> Jasmine,
>>
>> The nexthop address for a router vertex via a
>> network one is the IP address of the destination
>> router on the network mentioned, whereas the nexthop
>> address for a network vertex directly connected
>> to the root is not. Actually, the latter does not
>> have any nexthop. That is why we can't simply
>> inherit the nexthops of that network vertex. In our
>> implementation, that nexthop's address is zero.
>>
>> Thanks,
>> Igor

---

From: j j <[email-masked]>
Date: Wed, 25 Dec 2002 13:54:20 -0800

Hello,

I had posted a question to the list before but I
am not sure if made it or not. So this is a repost.

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com

---

From: j j <[email-masked]>
Date: Wed, 25 Dec 2002 13:57:43 -0800

Hello,

Case 1: Router A and B have 4 point to point links
connecting them.  Should we create 16 nexthops or 4?

Case 2: Lets say Router A (root) has 4 connections to
a network.  And Router B has 4 connections to the same
network. When calculating nexthops for RouterB should
we create 16 or 4 nexthops?

thanks

---

From: Acee Lindem <[email-masked]>
Date: Tue, 31 Dec 2002 15:13:39 -0500

> Hello,

Hello jj,

> connecting them.  Should we create 16 nexthops or 4?

4. How do you get 16? You must be envisioning an
implementation that mantains every possible permutation
of the four next hops (including the empty one ;^).

> we create 16 or 4 nexthops?

I'd say the correct answer is that you aggregate the
networks at layer 2 and have a single next hop. However, if
must correct multiple IP interfaces to the same network you'd
have 4.

--
Acee