Subject: Re: Question about nexthop calculation

From: Igor Miroshnik <[email-masked]>
Date: Sat, 21 Dec 2002 14:27:21 -0500

On Sat, 21 Dec 2002 10:46:51 -0800, j j <[email-masked]> wrote:

>hello folks,
>
>I am going through Zebra and Moy's source code for
>OSPFv2.  The question I have is when calculating
>next hops for a router vertex that is directly
>connected to the root (i.e. calculating router) via
>a network vertex, why can't we simply inherit the
>nexthops of the network vertex ? Moy and Zebra both
>do something special for this case which I cannot
>understand.
>
>It seems like the root should be able to reach the
>router through all the nexthops that were calculated
>for the network vertex.
>
>I hope I was able to clearly explain my doubts.
>
>thanks
>
>jasmine

Jasmine,

The nexthop address for a router vertex via a network one is the IP address of the destination
router on the network mentioned, whereas the nexthop address for a network vertex directly connected
to the root is not. Actually, the latter does not have any nexthop. That is why we can't simply
inherit the nexthops of that network vertex. In our implementation, that nexthop's address is zero.

Thanks,
Igor

---

From: j j <[email-masked]>
Date: Sat, 21 Dec 2002 16:08:05 -0800

Igor,

Why is it necessary to record nexthops for routers
connected via network to the root?  Where is this
information used?
is it used to process stub links or inter-area
route calcuations?

thanks

jasmine

--- Igor Miroshnik <[email-masked]> wrote:
> The nexthop address for a router vertex via a
> network one is the IP address of the destination
> router on the network mentioned, whereas the nexthop
> address for a network vertex directly connected
> to the root is not. Actually, the latter does not
> have any nexthop. That is why we can't simply
> inherit the nexthops of that network vertex. In our
> implementation, that nexthop's address is zero.
>
> Thanks,
> Igor

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com