Subject: Receiving AS-external-LSAs with same LS ID - different net masks

From: Abhijit Kumbhare <[email-masked]>
Date: Wed, 11 Dec 2002 16:08:28 -0800

If I receive 2 AS-external-LSAs with the same LS ID
(which for some reason happens to be in a broadcast IP
address format) - same advertising router but
different masks - how do I handle it?

For me a buggy neighbor router is advertising all the
AS-external-LSAs with LS ID in the broadcast address
format (this format in itself is not totally against
the RFC - RFC 2328 appendix section E - algorithm for
assigning LS IDs - does allow you to advertise in that
format). The bug part is that is that it is sending 2
different LSAs with same LS ID.
e.g. 208.144.0.0/17 and 208.144.96.0/19 routes have
the same broadcast address 208.144.127.255. So this
buggy router sends me the 2 LSAs with this LS ID.

Should I install 2 different LSAs or only one? Which
mask (smaller or longer)? I checked the same with a
Cisco router - and it installed only one of them
(smaller mask).

I know it should not be advertised in this fashion
(because the RFC says that LSAs are identified by LS
ID, advertising router & LS type - then seq number,
checksum, age in that order).

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com

---

From: Acee Lindem <[email-masked]>
Date: Wed, 11 Dec 2002 19:39:01 -0500

Abhijit,
I wouldn't bother try to handle a bug in someone else's
implementation. You certainly shouldn't try to install
multiple LSA since they are identified soly by the
(type, lsid, advertising router) tuple. Hence I'd say
that as long as you don't crash you are ok.

--
Acee