Subject: RFC1850 - compilation error

From: "Divya Mukundan (dmukunda)" <[email-masked]>
Date: Fri, 12 Sep 2003 11:58:52 +0530

Hi,

I'm getting the following compilation error in "compliance statements"
of RFC1850 (OSPF-TRAP-MIB). I'm using smicng and Fred Baker
said that the MIB compiled with it and that smicng could have changed
subsequently. Is anyone aware of an option in smicng that can suppress
this error? Any other suggestions?

-----------------------------------RFC1850--------------------------------------------
-- compliance statements

       ospfTrapCompliance MODULE-COMPLIANCE
           STATUS  current
           DESCRIPTION
              "The compliance statement "
          MODULE  -- this module
          MANDATORY-GROUPS { ospfTrapControlGroup }  <<<====

           GROUP       ospfTrapControlGroup <<<====
           DESCRIPTION
              "This group is optional but recommended for all
              OSPF systems"

-----------------------------------ERROR----------------------------------------------
E: f(OSPF-TRAP-MIB.my), (470,21) Group "ospfTrapControlGroup" is both a
MANDATORY and conditional group for module "OSPF-TRAP-MIB"

Thanks,
-Divya

---

From: Don Goodspeed <[email-masked]>
Date: Mon, 15 Sep 2003 14:58:28 -0400

Divya,

I think so, so at this point, it's probably best to contact
Dave Perkins at snmpinfo.com.  An alternate source within
Cisco might be Simon Chow who I used to work for and also
knows Dave and knows smic and smicng.

-don

===================================
Don,

Thanks for your tip. That did not work though :(
I'm passing the following options to smicng. In addition to these,
I tried compiling with -CT but that did not suppress the error.

SMICOPTS = "-CF -C0N -CN -C0T -C03"

Am I doing the right thing by adding CT to these options or does
it conflict with any of the above?

Thanks,
-Divya

At 02:11 PM 9/12/2003 -0400, Don Goodspeed wrote:
>Divya,
>
>You can try using -CT. For more on smicng, contact Dave Perkins
>at www.snmpinfo.com as he is the author of smicng. These option
>are also described in his book "Understanding SNMP MIBs" which
>is where I looked.
>
>-don
>

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!