Subject: Re: router LSA with unknown link type

From: Vishwas Manral <[email-masked]>
Date: Wed, 24 Nov 2004 20:09:35 -0800

Hi Acee,

I think we cannot leave this to an implementation, as it can cause
routing loops if different routers have different assumptions and hence
different Router LSA's on which to build the routing table.

Thanks,
Vishwas

-----Original Message-----
From: Mailing List [mailto:[email-masked]] On Behalf Of Acee
Lindem
Sent: Wednesday, November 24, 2004 9:37 PM
To: [email-masked]
Subject: Re: router LSA with unknown link type

Field, Brian wrote:

>If a router receives a router LSA that contains several links and
>for one of the links, the link type field is not known, should the
>router ignore the entire router LSA or just skip this one link?
>
>
Hi Brian,
Unfortunately, the handling of unknown link types is not specifically
defined in RFC 2328.
Since links types 1-4 are the only ones defined an implementation should
probably log
the invalid link type (with rate limiting). Whether it ignores the LSA
or just the unknown link is
implementation specific. If we were to move forward with link type
extension it would not be
backward compatible (at least not without knobs or other mechanisms).

Thanks,
Acee

>Thanks
>Brian

---

From: Sina Mirtorabi <[email-masked]>
Date: Thu, 25 Nov 2004 01:33:56 -0500

Vishwas,

->
->Hi Acee,
->
->I think we cannot leave this to an implementation, as it can 
->cause routing loops if different routers have different 
->assumptions and hence different Router LSA's on which to 
->build the routing table.

If we are talking about an action in the future, that is an extension which
add or use a new link type, then the specification should handle backward
compatibility problem.

If we are talking about present and say a bug which introduces an unknown
link in Router LSA, then since there is nothing specified in 2328, different
implementation could handle unknown link differently and yes this could
cause problem. We don't have much choice to leave to implementation in this
case because there are implementation already out there ;-)

Sina

->
->Thanks,
->Vishwas
->
->-----Original Message-----
->From: Mailing List [mailto:[email-masked]] On 
->Behalf Of Acee Lindem
->Sent: Wednesday, November 24, 2004 9:37 PM
->To: [email-masked]
->Subject: Re: router LSA with unknown link type
->
->Field, Brian wrote:
->
->>If a router receives a router LSA that contains several 
->links and for 
->>one of the links, the link type field is not known, should 
->the router 
->>ignore the entire router LSA or just skip this one link?
->>
->>
->Hi Brian,
->Unfortunately, the handling of unknown link types is not 
->specifically defined in RFC 2328. Since links types 1-4 are 
->the only ones defined an implementation should probably log 
->the invalid link type (with rate limiting). Whether it 
->ignores the LSA or just the unknown link is implementation 
->specific. If we were to move forward with link type extension 
->it would not be backward compatible (at least not without 
->knobs or other mechanisms).
->
->Thanks,
->Acee
->
->>Thanks
->>Brian
->>
->>
->>
->