Subject: Re: What will happen in this kind of topology with 100 nbrs and 2000 ASEs ??

From: Jing Shen <[email-masked]>
Date: Tue, 2 Nov 2004 19:24:34 +0800

Do you means this could be dealt by increasing CPU
ability of router ?

If it is, I come to see why Alcaltel use MIPS CPU with
2GB memory in it router.

Jing

--- "Mollin, Arvind - LiqwidKrystal"
<[email-masked]> 的正文：
> Thanks for one n all.
> Well this case is something related to congestion as
> Vishwas have
> pointed out. Suppose R1 sends a update, ( that is
> each neighbor will
> send an update 100 updates altogether) then R2 would
> send back 99*100
> updates to R1, thus R1 is busy in processing them
> and doesn't send
> hello's or doesn't process hellos, also sometimes
> the buffer overflows.
> These are the reason why ospf flaps. So in this kind
> of topology the
> processing will hog the CPU.
>   Well, I have read that some implementations can
> handle upto 750
> neighbors. !! provided congestions are avoided.
>
> --Arvind
>
> -----Original Message-----
> From: Mailing List
> [mailto:[email-masked]] On Behalf Of Dave
> Katz
> Sent: Monday, October 25, 2004 11:52 AM
> To: [email-masked]
> Subject: Re: What will happen in this kind of
> topology with 100 nbrs and
> 2000 ASEs ??
>
> This kind of behavior is related to the quality of
> the implementation.
> Some implementations can handle 100 neighbors with
> aplomb.  There's no
> reason this shouldn't be stable, particularly with
> the large default
> timer values.
>
> But my rants on this subject are well known...
>
>
> On Oct 24, 2004, at 11:40 PM, Vishwas Manral wrote:
>
> > Hi Arvind,
> >
> > Instead of increasing the "Router Dead Interval",
> you could instead
> use
> > techniques as given in
> >
>
http://www.ietf.org/internet-drafts/draft-ietf-ospf-scalability-08.txt
> >
> > Thanks,
> > Vishwas
> >
> > -----Original Message-----
> > From: Mailing List
> [mailto:[email-masked]] On Behalf Of
> > Nitin
> > Kakkar
> > Sent: Monday, October 25, 2004 10:33 AM
> > To: [email-masked]
> > Subject: Re: What will happen in this kind of
> topology with 100 nbrs
> > and
> > 2000 ASEs ??
> >
> > Most probable reason seems to be that Hello's
> doesn't come on time and
> > adjacencies are dropped. Some time later hellos
> come and adjacencies
> > are
> > reestablished. May be you can increase your
> adjacency dead timer and
> > try
> > again.
> > HTH
> > Nitin
> >   -----Original Message-----
> > From: Mailing List
> [mailto:[email-masked]]On Behalf Of
> > Mollin,
> > Arvind - LiqwidKrystal
> > Sent: 2004Ae10OA25EO 10:12
> > To: [email-masked]
> > Subject: What will happen in this kind of topology
> with 100 nbrs and
> > 2000
> > ASEs ??
> >
> >
> >
> > Hi,
> >
> >   I have two routers connected back to back
> through a gig link. I have
> > configured 100 VLANs in that single gig link, now
> each vlan act as
> > virtual
> > interface. I have configured 100 neighbors on each
> router using these
> > 100
> > virtual interfaces. All the neighbors are in
> backbone. See the figure
> > below,
> >
> >
> >
> > ( 100 nbrs )R1 -------------100 vlans
> ------------------ R2 ( 100 nbrs
> > )
> >
> >
> >
> > After sometime I could see all nbrs flapping
> often. What could be the
> > reason
> > for this ??
> >
> > Is this topology right?, Has anybody tested with
> this kind of setup ??
> >
> >
> >
> > Thanks
> >
> > Arvind
> >
> >
>

=====
Jing Shen

Data Communication Center
HangZhou TeleCom
HangZhou ZJ 310027
P.R.China

' spamcontrol '

_________________________________________________________
Do You Yahoo!?
150万曲MP3疯狂搜，带您闯入音乐殿堂
http://cn.rd.yahoo.com/mail_cn/tag/yisou/music/*http://music.yisou.com/
美女明星应有尽有，搜遍美图、艳图和酷图
http://cn.rd.yahoo.com/mail_cn/tag/yisou/image/*http://image.yisou.com
1G就是1000兆，雅虎电邮自助扩容！
http://cn.rd.yahoo.com/mail_cn/tag/1g/*http://cn.mail.yahoo.com/event/mail_1g/

---

From: Erblichs <[email-masked]>
Date: Wed, 3 Nov 2004 11:34:17 -0800

Jing,

        The CPU exeuted instructions per second can
        be a factor IFF :

            - the SPF like calc delays the processing of
            OSPF control packets, (I am assumning that
            the forwarding layer is independent)

            - the freq of changed LSAs in Updates is
             freq that SPFs are continually being
             recieved which in turn continually triggers
             SPFs calcs.

            - etc....,

        However, the CPU can have minimal effect if
        all the OSPF control pkts are merged into
        input queues and pkts are dropped/delayed
        due to context switching latencies..

        So, a bad hard/software design can not be
        corrected by a very fast CPU.

        Mitchell Erblich
        ------------------------

Jing Shen wrote:
> <[email-masked]> µÄÕýÎÄ£º
> > Thanks for one n all.
> 150ÍòÇúMP3·è¿ñËÑ£¬´øÄú´³ÈëÒôÀÖµîÌÃ
> ÃÀÅ®Ã÷ÐÇÓ¦ÓÐ¾¡ÓÐ£¬ËÑ±éÃÀÍ¼¡¢ÑÞÍ¼ºÍ¿áÍ¼
> 1G¾ÍÊÇ1000Õ×£¬ÑÅ»¢µçÓÊ×ÔÖúÀ©ÈÝ£¡

---

From: Erblichs <[email-masked]>
Date: Wed, 3 Nov 2004 13:48:48 -0800

Sorry,

        I sometimes type to fast..

        Mitchell Erblich

>              freq that SPFs are continually being

              freq enough that LSAs are continually being

---

From: Jing Shen <[email-masked]>
Date: Thu, 4 Nov 2004 18:09:09 +0800

Well, I see. But, how could we determine the optimal
size for ingree queue ?

Another question, someone suggests: a OSPF area should
not consist of more than 50 routers. Is that also a
restriction for current high speed networks?

regards

Jing Shen

 --- Erblichs <[email-masked]> 的正文：
> Dave
> > Data Communication Center
=== message truncated ===