Subject: Re: Redistribute Static routes

From: Ilan Bercovich <[email-masked]>
Date: Tue, 2 Nov 2004 08:56:20 +0200

Thanks for your reply, Acee
But I still don't get it:
1) Can a router redistribute static routes without being ASBR?
Or is once a router redistributes static routes it had already actualy
became an ASBR?
2) How can one select if a static route would be considered as type-1 or as
type-2?
Thanks,
Ilan

                      Acee Lindem
                      <[email-masked]         To:      [email-masked]
                      M>                       cc:
                      Sent by: Mailing         Subject: Re: Redistribute Static routes
                      List
                      <[email-masked]
                      .LSOFT.COM>

                      01/11/2004 20:25
                      Please respond
                      to Mailing List

Hi Ilan,

----- Original Message -----
From: "Ilan Bercovich" <[email-masked]>
To: <[email-masked]>
Sent: Monday, November 01, 2004 9:53 AM
Subject: Redistribute Static routes

> Hello
>
> Is "Redistribute Static routes" equivalent to configuring the router as
> ASBR?

It depends on the implementation. One could use any redistribution
to determine whether the router advertises itself as ASBR (as per the E-bit
in the  router LSA)  or one could only advertise oneself as an ASBR if
there
are actually active redistributed routes to advertise.

>
> Is there a way to configure type-1 metric and type-2 metric by standard
> MIBs?
>
> Is there a way to select if type-2 or type-2 is used by standard MIBs?

No. However, for stub areas one can configure the type of the ABR
generated default route via the OSPF MIB (ospfStubMetric).

> Thanks,
> Ilan

---

From: Acee Lindem <[email-masked]>
Date: Tue, 2 Nov 2004 07:20:20 -0500

----- Original Message -----
From: "Ilan Bercovich" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, November 02, 2004 1:56 AM
Subject: Re: Redistribute Static routes

> 1) Can a router redistribute static routes without being ASBR?

No - if an OSPF router advertises AS externals or type 7s it is an
ASBR.

> Or is once a router redistributes static routes it had already actualy

Yes.

> 2) How can one select if a static route would be considered as type-1 or as

Implementation dependent configuration.

Hope this helps,
Acee