Subject: ospfv3 - Route Entry

From: Vivek Dubey <[email-masked]>
Date: Thu, 23 Jun 2005 05:28:07 -0000

Hi,

RFC 2328: Section 11
--------------------
Destination Type: Router entries are kept for area border routers and AS boundary routers

draft-ietf-ospf-ospfv3-update-04
--------------------------------
Section 3.3  The Routing table Structure:
An entry for each router in the area is kept

<vivek> Calculation of reachability to stub networks and prefixes described in intra-area-prefix LSA is similar. What's the need to maintain an entry for each router in the area ?

Thanks
Vivek

---

From: Acee Lindem <[email-masked]>
Date: Fri, 24 Jun 2005 12:41:58 -0400

>Hi,
Hi Vivek,

><vivek> Calculation of reachability to stub networks and prefixes described in intra-area-prefix LSA is I guess similar. What's the need to maintain an entry for each router in the area ?
>  
>
Other implementations are possible. As you know, the OSPFv3 intra-area SPF
calculation is done in 2 phases. First a Shortest Path Tree (SPT) is 
built from the
router and network LSAs. In the second phase, the intra-area-prefix-LSAs 
are
examined and routes are added to the routing table for reachable 
prefixes based
on whether the reference LSA is reachable (among other checks). So, one 
either
needs to lookup the route to the corresponding node in the SPT or the 
reference
LSA. RFC 2740 chose the former and I think it is more straight forward.

Thanks,
Acee