Subject: Re: type-5 las extarnal-tag field

From: Vishwas Manral <[email-masked]>
Date: Thu, 14 Jul 2005 20:53:10 -0700

Hi,

Nice summary given by Dave. Here is something I think it can be used
for: -

http://www.ietf.org/internet-drafts/draft-ietf-isis-admin-tags-03.txt

Thanks,
Vishwas
-----Original Message-----
From: Mailing List [mailto:[email-masked]] On Behalf Of Dave
Katz
Sent: Friday, July 15, 2005 8:02 AM
To: [email-masked]
Subject: Re: type-5 las extarnal-tag field

Back in prehistory (end of the Reagan years), this was known as the  
"Milo Word" (since Milo Medin was the guy who wanted it put in  
there.)  It was originally intended to be a pre-BGP way of  
controlling external route distribution, by carrying an AS number  
(for example.)  The choice of which externals to distribute back out  
of the domain was made in part by tags added at the point where the  
routes came in.  Yes, in those days people did inject full Internet  
routing into their IGP, but it was a smaller, slower world back then.

Now it's sort of a Rorschach test for routing interactions.

On Jul 14, 2005, at 7:54 PM, Paresh Khatri wrote:

> HI Ajay,
>
> The external route tag is not used by OSPF itself.  It is  
> transparently conveyed with type-5/type-7 LSAs so that applications  
> can make any desired use of it.  One particular application is when  
> you are doing two-way redistribution at multiple points.  In such a  
> case, you could associate a certain tag when redistributing routes  
> into OSPF.  That way, when you are redistributing *from* OSPF into  
> another protocol at some other redistribution point, you can dis- 
> regard the routes that have that tag associated with it.
>
> HTH,
> Paresh.
>
>
>
> -----Original Message-----
> From: Mailing List [mailto:[email-masked]]On Behalf Of  
> tajay
> Sent: Thursday, 14 July 2005 12:07 AM
> To: [email-masked]
> Subject: type-5 las extarnal-tag field
>
>
> hi guys,
> I am not clear about extarnal-route-tag field in the type-5 lsa.  Can
> anyone  just give me some information about that. Also what should be
> the default value of the tag field? where it is useful ..?
>
> thanks
> ajay
>
>
> This communication, including any attachments, is confidential. If
>  you are not the intended recipient, you should not read it - please
>  contact me immediately, destroy it, and do not copy or use any  
> part of
>  this communication or disclose anything about it.
>
>
>

---

From: Paresh Khatri <[email-masked]>
Date: Fri, 15 Jul 2005 15:36:36 +1000

Hi Ajay,

You sure can.  It does not really matter where/how the tag was set - you can match on it when redistributing into BGP (depending, of course, on the platform/software you are using)

HTH,
Paresh.

-----Original Message-----
From: Mailing List [mailto:[email-masked]]On Behalf Of tajay
Sent: Friday, 15 July 2005 03:29 PM
To: [email-masked]
Subject: Re: type-5 las extarnal-tag field

hi pareash,
thanks for explaination, i have some  doubts,
Paresh Khatri wrote:

>HI Ajay,
>
>The external route tag is not used by OSPF itself.  It is transparently conveyed with type-5/type-7 LSAs so that applications can make any desired use of it.  One particular application is when you are doing two-way redistribution at multiple points.  In such a case, you could associate a certain tag when redistributing routes into OSPF.  That way, when you are redistributing *from* OSPF into another protocol at some other redistribution point, you can dis-regard the routes that have that tag associated with it.
>
Do you mean controlling redistribution based on tag field..???

I am just giving one example...

R1------------------------R2---------------------------R3--------------------------R4

R1 and R2 runs RIP.  
R2 and R3 runs OSPF.
R3 and R4 runs BGP.

Now suppose at R2  I am redistributing routes into ospf domain  with tag 
field   100 .
Also suppose  there are some static routes at R2 which i am 
redistributing into OSPF domain with tag 200.

Now my question is how R3 can use these tag field while redistributing 
into BGP domain. In normal impementation do we have that type of 
configuration command which allows filtering based on tag fields.

thanks
ajay

>From: Mailing List [mailto:[email-masked]]On Behalf Of tajay
> contact me immediately, destroy it, and do not copy or use any part of 

This communication, including any attachments, is confidential. If 
 you are not the intended recipient, you should not read it - please 
 contact me immediately, destroy it, and do not copy or use any part of 
 this communication or disclose anything about it.