Subject: redistributing default route ?

From: Ramanan N <[email-masked]>
Date: Sun, 5 Mar 2006 13:19:39 -0500

Hi

For the following config in a OSPF router,
...
ip route 0.0.0.0 0.0.0.0 null0
...

router ospf 1
redistribute static
network x.x.x.x ...
...

1. should OSPF redistribute the static default route (0/0) in its ASE ?
2. or OSPF should redistribute this default route only if the command
"default-info originate" is present ?

TIA,
Ramanan

---

From: Acee Lindem <[email-masked]>
Date: Sun, 5 Mar 2006 14:10:39 -0500

Hi Ramanan,

OSPF redistribution (or import/export) policy is a local matter and not
covered by RFC 2328. 

Thanks,
Acee

---

From: Ramanan N <[email-masked]>
Date: Sun, 5 Mar 2006 19:23:25 -0500

Thanks Acee.
I was wondering if there was atleast one implementation
doing the redistribution of static default route.
Please let me know if there is any such implementation.

General idea is to avoid the static default route redistribution
to safeguard the network.

Ramanan

---

From: Tony Li <[email-masked]>
Date: Sun, 5 Mar 2006 16:31:32 -0800

This list is intended for OSPF protocol standardization discussions, not
for customer support or market research.

Respectfully,
Tony