Subject: Re: Question regarding the P bit in type-7 LSA

From: Sunil Patro <[email-masked]>
Date: Wed, 8 Mar 2006 13:50:11 -0800

Does generating multiple type-5 LSAs for the same destination create
problem in any way? The same could happen if multiple ASBRs generate
type-5 LSA for the same network.

Coming back to the context again, consider the following network.

        Area 0                      Area 1 (nssa)
area 2 (nssa)

A------------------------------B----------------------------------C-----
---------------------------------D

Area 2's border router D can be either directly connected back to Area 0
again or through a virtual link.

In this case, if C generates two type-7 LSAs for a network as an ASBR,
the type-7 will be translated to type-5 through B and D at the same
time.

So, two type-5 LSA for the same network will end up in area 0. How is
this case handled then?

Thanks

Sunil

________________________________

From: Mailing List [mailto:[email-masked]] On Behalf Of
Vishwas Manral
Sent: Wednesday, March 08, 2006 12:50 PM
To: [email-masked]
Subject: Re: Question regarding the P bit in type-7 LSA

Hi Sunil,

Acee may not be able to reply till the evening, so let me give it a try
in the mean while.

"If this is the case, the P-bit must be reset in the  type-7 NSSA so the
type-7 LSA isn't again translated into a type-5 LSA by another NSSA area
border router."

Isnt the reason embedded in the question you ask?

I guess we do not want to originate multiple Type-5 LSA's for the same
destination and that is the reason for the P-bit setting.

Thanks,
Vishwas

On 3/8/06, Sunil Patro <[email-masked]> wrote:

	From section 3.4 of rfc 1587(The OSPF NSSA Option),
	
	  "If a router is attached to another AS and is also an NSSA
area border
	   router, it may originate a both a type-5 and a type-7 LSA for
the
	   same network.  The type-5 LSA will be flooded to the backbone
(and 
	   all attached type-5 capable areas) and the type-7 will be
flooded
	   into the NSSA.  If this is the case, the P-bit must be reset
in the
	   type-7 NSSA so the type-7 LSA isn't again translated into a
type-5
	   LSA by another NSSA area border router."

	Can someone throw some light on why the P bit must be clear in
the case
	when an ASBR originates both a type 7 and type 5 LSA for the
same
	network?
	
	Thanks in advance. 
	Sunil

---

From: Vishwas Manral <[email-masked]>
Date: Wed, 8 Mar 2006 14:12:20 -0800

Hi Sunil,

Having multiple LSA's for the same destination are not very useful, though
they do not create a problem.

The topology you refer to looks very interesting but may not ever be that
way in the real world.

Thanks,
Vishwas

On 3/8/06, Sunil Patro <[email-masked]> wrote:
> problem in any way? The same could happen if multiple ASBRs generate type-5
> LSA for the same network.
>
>
>
> A------------------------------B----------------------------------C--------------------------------------D
>
>
>
> In this case, if C generates two type-7 LSAs for a network as an ASBR, the
> type-7 will be translated to type-5 through B and D at the same time.
>
> So, two type-5 LSA for the same network will end up in area 0. How is this
> case handled then?
>
>
>
> Thanks
>
> Sunil
>
>
>   ------------------------------
>
> *From:* Mailing List [mailto:[email-masked]] *On Behalf Of *Vishwas
> Manral
> *Sent:* Wednesday, March 08, 2006 12:50 PM
> *To:* [email-masked]
> *Subject:* Re: Question regarding the P bit in type-7 LSA
>
>
>
> Hi Sunil,
>
> Acee may not be able to reply till the evening, so let me give it a try in
> the mean while.
>
> On 3/8/06, *Sunil Patro* <[email-masked]> wrote:
>
>   "If a router is attached to another AS and is also an NSSA area border
>    router, it may originate a both a type-5 and a type-7 LSA for the
>    same network.  The type-5 LSA will be flooded to the backbone (and
>    all attached type-5 capable areas) and the type-7 will be flooded
>    into the NSSA.  If this is the case, the P-bit must be reset in the
>    type-7 NSSA so the type-7 LSA isn't again translated into a type-5
> Can someone throw some light on why the P bit must be clear in the case
> when an ASBR originates both a type 7 and type 5 LSA for the same
> network?
>
> Thanks in advance.
> Sunil
>
>
>

---

From: Acee Lindem <[email-masked]>
Date: Wed, 8 Mar 2006 21:03:49 -0500

>The topology you refer to looks very interesting but may not ever be that
Hi Sunil,
I agree with Vishwas. Additionally, since the non-translator ABR/ASBR
is the original source of the route, it makes no sense for the 
translating ABR to re-advertise it
and will only delay convergence should connectivity to the destination 
be lost.

Thanks,
Acee