Subject: Re: OAPFv3: what is the use of prefixes in Link LSA

From: "Goyal, Manoj" <[email-masked]>
Date: Thu, 9 Mar 2006 09:30:37 -0800

I think I asked the first question in a wrong way, sure that
the link LSAs are used by the DR to construct the IAP-LSA for the
broadcast network.
But what is the use of the link LSAs having prefixes for
P2P links as all the prefixes are present in the router's
IAP LSAs already?? Practically most links are P2P.

Manoj

-----Original Message-----
From: Mailing List [mailto:[email-masked]] On Behalf Of Paul
Wells
Sent: Wednesday, March 08, 2006 6:01 PM
To: [email-masked]
Subject: Re: OAPFv3: what is the use of prefixes in Link LSA

Hi Manoj,

Goyal, Manoj wrote:
> HI,
> 
> In ospfv3 the intra-area-prefix LSAs have all the prefixes and routing
table
> 
> should be calculated using them. Then what is really the use of having
> 
> the prefixes of the link in its link-LSA.

For broadcast and nbma links, the prefixes in the link lsas are used by 
the DR to construct the intra-area prefix lsa associated with the 
network lsa.

> 
> Is there a case where the router will not include some prefixes in 
> intra-area-prefix LSA
> 
> but advertise in the link-LSA? I don't see any such case.

Prefixes for broadcast/nbma transit links are advertised by the DR on 
behalf of the attached routers, and not by the non-DR routers 
themselves.  But if you are asking if some of the prefixes won't appear 
in _any_ intra-area prefix lsa, then no, I don't think so.

Regards,
Paul

> Thanks,
> Manoj
============================================================
The information contained in this message may be privileged
and confidential and protected from disclosure. If the reader
of this message is not the intended recipient, or an employee
or agent responsible for delivering this message to the
intended recipient, you are hereby notified that any reproduction,
dissemination or distribution of this communication is strictly
prohibited. If you have received this communication in error,
please notify us immediately by replying to the message and
deleting it from your computer. Thank you. Tellabs
============================================================

---

From: Acee Lindem <[email-masked]>
Date: Thu, 9 Mar 2006 19:44:10 -0500

Hi Manoj,

In the RFC 2370 update draft, I added text explicitly stating that link 
LSAs are not
needed for virtual links. I considered saying they MAY be omitted
on p2p links as well but was worried that conceivably an implementation 
could
use link LSAs exclusively for next-hop computation (they are needed for 
next-hop
computation on NBMA links). Are there other opinions on this?

Thanks,
Acee