Subject: [OSPF] draft-ietf-ospf-ospfv3-graceful-restart-03

From: "Vivek Dubey" <[email-masked]>
Date: 2 May 2006 13:41:39 -0000

Section 3.2:
If this were not the case, the pre-restart and post-restart LSAs wouldn't be the same and the restart would be disruptive.

<vivek> If "post-restart" here means "after router undergoing restart has exited/exiting graceful-restart", it is supposed to reoriginate LSAs as per Section 2.3 RFC 3623. Description in Section 2.3 RFC 3623 does not mandate the contents to be same. Than why do pre-restart and post-restart LSAs need to be same?

Preservation of Interface IDs have more to do with figuring out whether restarting router has re-established all its adjacencies.

-Vivek

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Tue, 02 May 2006 20:06:59 -0400

Vivek,

>Preservation of Interface IDs have more to do with figuring out whether restarting router has re-established all its adjacencies.
Since the interface ID is in the link data for OSPFv3 router LSAs, a 
change in interface ID
could result in a mismatch between neighbor adjacency state for the 
restarting router and
the pre-restart router LSA. Synchronizing the change across the 
restarting router and
the helping routers would be very difficult (if not next to impossible) 
and would probably
result in unreachability or premature graceful restart termination. It 
is much better for the
restarting router to preserve this state across restarts.

Hope this helps,
Acee

>-Vivek
>
>
>  
>
>  
>
>------------------------------------------------------------------------
>