Subject: [OSPF] Re : IPV6 Adress Prefixes

From: "badvel vishnu reddy" <[email-masked]>
Date: 13 May 2006 23:37:41 -0000

Hi All,
Rfc 2740 section A.4.1 says Address Prefix is an
   encoding of the prefix itself as an even multiple of 32-bit words,
   padding with zero bits as necessary; this encoding consumes
   (PrefixLength + 31) / 32) 32-bit words.
So if i use this approach for example my prefixLength is 64 i need to fill 3 32 bit words? is this correct i feel i can fill 2 32 bit words for this prefix length. Can someone give pointers on how many 32 bit words do i need to fill
Regards
Vishnu  

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Dave Katz <[email-masked]>
Date: Sat, 13 May 2006 21:54:55 -0600

(64+31)/32 = 95/32 = 2

On May 13, 2006, at 5:37 PM, badvel vishnu reddy wrote:

> So if i use this approach for example my prefixLength is 64 i need  
> to fill 3 32 bit words? is this correct i feel i can fill 2 32 bit  
> words for this prefix length. Can someone give pointers on how many  
> 32 bit words do i need to fill
> Regards
> Vishnu
>
>
>
>