Subject: Re: [OSPF] draft-venkata-ospf-dynamic-hostname-02.txt

From: Carlos Pignataro <[email-masked]>
Date: Sat, 01 Mar 2008 22:43:57 -0500

Please find two additional small comment inline.

On 2/29/2008 7:15 PM, Subbaiah Venkata said the following:
> Hi Anton,
> 
> Great questions. Some of them we already thought but deferred for WG 
> consensus.
> Answers inline.
> 
> On Fri, Feb 29, 2008 at 4:21 AM, Anton Smirnov <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>        Hi all,
>        have a comment on this draft (OK, it's not WG document yet but hope
>     that's not a problem).
>        The document doesn't stipulate that Dynamic Hostname TLV can be
>     present at most once. 
> 

In addition to the scope clarifications from below, we can also 
explicitly mention one TLV per RI LSA.

> 
> Yes. I think it is better to keep it simple by mandating one Dynamic 
> hostname TLV per originator.
> This saves unnecessary flooding and network bandwidth.
>  
> 
>     Also, if implementation chooses to announce both
>     AS and area scope RI LSA then it is not clear if it is allowed to
>     announce different names.
> 
> 
> Again, one TLV per originator. If a router is originating at least one 
> AS scope LSA
> (for example, an ASBR originating AS external LSAs) then it should 
> generate AS scope
> Dynamic hostname TLV. Otherwise it should originate area scope TLV.
>  
> 
> 
> 
>        I personally would prefer 1:1 mapping between ID and router's name
>     to be required but some people might disagree with me. Either way
>     document should specify if multiple names are allowed or not.
> 
> 
> We will include some wording on these in the next revision of the draft.
>  
> 
> 
>        If we are to send text string then document should specify what
>     exactly is understood by 'text'. Is it ASCII or UTF-8 encoding? Are
>     symbols like 0x1 or 0xAF allowed?
> 
> 
> We discussed and deferred this for WG consensus.
> I prefer ASCII text unless there is a strong reason for UTF-8 or UNICODE.

We'd like to get thoughts and opinions on this, as likely arguments for 
both encoding in US-ASCII and UTF-8 charsets can be made. E.g., a 
hostname as a globally/widely visible name would use US-ASCII [RFC2277], 
etc.

Thanks,

--Carlos.

> 
> Thanks for the review.
> 
> Venkata.
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf

-- 
--Carlos Pignataro.
Escalation RTP - cisco Systems
_______________________________________________
OSPF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ospf

---

From: "Spagnolo, Phillip A" <[email-masked]>
Date: Mon, 3 Mar 2008 10:15:47 -0800

All,
We are pleased to announce the release of Boeing's OSPFv3 Address
Families and MANET MDR Quagga source code.  The code has been upgraded
to Quagga 0.99.9.

OSPFv3 Address Families
<http://tools.ietf.org/html/draft-ietf-ospf-af-alt>
OSPFv3 MANET MDR <http://tools.ietf.org/html/draft-ietf-ospf-manet-mdr>

The code can be found at
<http://hipserver.mct.phantomworks.org/ietf/ospf/>.

At the website, you will find 
* Documentation
* Quagga Address Family patch
* Quagga MANET MDR patch
* Quagga MANET MDR GTNetS patch
* GTNetS MANET MDR simulator

Sincerely,
Phillip A. Spagnolo
Networked Systems Technology
Boeing Phantom Works
425-373-2810
[email-masked]
_______________________________________________
OSPF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ospf