Subject: [OSPF] Few Queries related to RFC 4577

From: "Lokesh Jain" <[email-masked]>
Date: Tue, 11 Mar 2008 23:57:50 +0530

Hi All,

I am new to this routing protocol and VPN stuff. Although I have understood
BGP/MPLS IP VPN to a large extent. But I am not able to related few concepts
in RFC 4577 to BGP/MPLS IP VPN.

1. OSPF domain is said to be a "set of sites in which routes should be
distributed as intra-network routes". These sites are under a single VPN or
they can be under multiple VPNs.
2. Can one VRF be associated be multiple OSPF instances on a single PE
router? If yes, please give an example deployment scenario.
3. OSPF domain identifier is same as Route Distinguisher ?

Any pointers towards some tutorials related to RFC 4577 would be of great
help :)

-- 
~~~~~~~~~~~~~
Thanks & Regards,
~~~~~~~~~~~~~
Lokesh Jain
Senior Software Engineer,
Samsung India Software Operations Pvt. Ltd.,
Bagmane Tech Park, C V Raman Nagar,
Bangalore.
Mob: 9880611348
-----------------------------------------------------
You always miss 100% of the chances u don't take
_______________________________________________
OSPF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ospf

---

From: Peter Psenak <[email-masked]>
Date: Thu, 13 Mar 2008 15:11:57 +0100

Lokesh

Lokesh Jain wrote:

> Hi All,
> 
> I am new to this routing protocol and VPN stuff. Although I have 
> understood BGP/MPLS IP VPN to a large extent. But I am not able to 
> related few concepts in RFC 4577 to BGP/MPLS IP VPN.
> 
> distributed as intra-network routes". These sites are under a single VPN 
> or they can be under multiple VPNs.

typically part of a single VPN, but they can be part of multiple as well.

> router? If yes, please give an example deployment scenario.

nothing prevent you to do that. People use multiple OSPF processes in 
the same VRF for various things, even though it's not always the best 
design choice.

> 3. OSPF domain identifier is same as Route Distinguisher ?

no, OSPF domain-id is a OSPF specific variable.

thanks,
Peter
> 
> Any pointers towards some tutorials related to RFC 4577 would be of 
> great help :)
> 
> -- 
> ~~~~~~~~~~~~~
> Thanks & Regards,
> ~~~~~~~~~~~~~
> Lokesh Jain
> ------------------------------------------------------------------------
>