Subject: [OSPF] Describing a point-to-point link in Router LSA

From: suketu soni <[email-masked]>
Date: Wed, 2 Sep 2009 07:59:41 +0000

Hi,

A point-to-point link type is included twice in a Router-LSA.

1) As Link Type = 1 (p2p), with neighboring router's RID as Link ID. This happens when the adjacency status is FULL.

2) As Link Type = 3 (stub), with IP subnet address as Link ID. This happens when the interface state is point-to-point, regardless of the status of adjacency.

I found out that if a point-to-point link is used as passive-interface, then adjacency will not be formed. Hence, link type = 1 advertizement will be absent. However, a link type = 3 advertizement of such a link makes it reachable.

Please share more examples where it helps to advertize a p2p link type in two ways. My intention is to understand the need for having two types of advertizements for the same p2p link.

Thank you.

Best wishes
Suketu Soni
_________________________________________________________________
Log on to MSN India for a lowdown on what’s hot in the world today
http://in.msn.com

---

From: Acee Lindem <[email-masked]>
Date: Wed, 2 Sep 2009 19:32:08 -0400

Hi Suketu,
See inline.
On Sep 2, 2009, at 3:59 AM, suketu soni wrote:

> 1) As Link Type = 1 (p2p), with neighboring router's RID as Link  
> ID. This happens when the adjacency status is FULL.
>
> 2) As Link Type = 3 (stub), with IP subnet address as Link ID. This  
> happens when the interface state is point-to-point, regardless of  
> the status of adjacency.
>
> I found out that if a point-to-point link is used as passive- 
> interface, then adjacency will not be formed. Hence, link type = 1  
> advertizement will be absent. However, a link type = 3  
> advertizement of such a link makes it reachable.
>
> Please share more examples where it helps to advertize a p2p link  
> type in two ways. My intention is to understand the need for having  
> two types of advertizements for the same p2p link.

The two links serve completely different purposes. The type 1 link is  
to advertise connectivity to the other router, i.e., an edge in the  
SPF graph, while the type 3 link is to advertise the IP subnet.

Thanks,
Acee

>
> Thank you.
>
> Best wishes
> Suketu Soni
> One blink is all it takes for the world to change. One click and  
> MSN India helps you catch up Try it!
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf