Subject: Re: [OSPF] OSPF Hybrid Broadcast and P2MP Interface Type

From: Anton Smirnov <[email-masked]>
Date: Thu, 09 Dec 2010 22:58:21 +0100

Hi Jeffrey,

> We developed the solution for a real network situation

It's a bit hard to see value of the proposal without knowing more about
possible network scenarios where this solution may be applicable.
Situations when cost to each neighbor is different usually mean that L2
paths to them are different. Bunch of separate L2 connections are
grouped together and presented to OSPF on L3 as single multiaccess
interface - but underneath it is L2 point-to-multipoint network. So
saying that Hello packet propagation is more optimal is not true -
replication is just moved from OSPF to lower level.

Thinking of network solutions which could benefit from assigning
different cost to each neighbor I come up with things like VPLS, Metro
Ethernet. May be fixed radio networks. But these all are L2 p2mp
networks. Multiaccess is just emulated and benefits of using it are
ephemeral.

Anton

On 11/22/2010 05:36 PM, Jeffrey (Zhaohui) Zhang wrote:
> Hi,
> 
> I presented the draft http://www.ietf.org/draft-nsheth-ospf-hybrid-bcast-and-p2mp-01.txt in Beijing (slides http://www.ietf.org/proceedings/79/slides/ospf-9.ppt) and it was deferred to the mailing list on whether the problem is worth the working group effort (some who reviewed the draft agreed that the proposed solution is reasonable for the problem).
> 
> I'd like to request folks to review the draft/slides and voice your opinion. We developed the solution for a real network situation and would like to see that it gets consensus and standardized so that more operators/vendors can benefit from this.
> 
> Thanks.
> Jeffrey
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Fri, 10 Dec 2010 13:35:26 -0500

Aton,

> -----Original Message-----
> From: Anton Smirnov [mailto:[email-masked]] 
> Sent: Thursday, December 09, 2010 4:58 PM
> To: Jeffrey (Zhaohui) Zhang
> Cc: [email-masked]
> Subject: Re: [OSPF] OSPF Hybrid Broadcast and P2MP Interface Type
> 
>    Hi Jeffrey,
> 

It is difficult to go into too much details, but there are real examples of true-broadcast radio networks where the bw/delay is different between different pairs of radios.

> replication is just moved from OSPF to lower level.

Even so you still have the benefit of reduced number of adjacencies.

> networks. Multiaccess is just emulated and benefits of using it are

Multiacess could be emulated in such a way that minimum replication happens - in that case the benefit is real.

The key is that the lower layer is presented to L3 as multi-access and we could/should take advantage of it.

Thanks.

Jeffrey

> > I presented the draft 
> http://www.ietf.org/draft-nsheth-ospf-hybrid-bcast-and-p2mp-01
.txt in Beijing (slides > http://www.ietf.org/proceedings/79/slides/ospf-9.ppt) and it 
> was deferred to the mailing list on whether the problem is 
> worth the working group effort (some who reviewed the draft 
> agreed that the proposed solution is reasonable for the problem).
> > 
> > I'd like to request folks to review the draft/slides and 
> voice your opinion. We developed the solution for a real 
> network situation and would like to see that it gets 
> consensus and standardized so that more operators/vendors can 
> benefit from this.
> > 
> > Thanks.
> > Jeffrey

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Mon, 13 Dec 2010 14:46:44 -0600

> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Jeffrey (Zhaohui) Zhang

Jeffrey:

Hi!

...
> It is difficult to go into too much details, but there are real
> examples of true-broadcast radio networks where the bw/delay is
> different between different pairs of radios.

It is very tempting to use the model that you describe, but radio
networks can be "flimsy" because of interference, signal fading,
movement, etc..  The broadcast model for neighbor discovery/maintenance
can quickly become unusable for nodes that loose connectivity to the DR.
It is very easy to see how the same L2 media may provide nodes that
don't have the same view of the other nodes (not everyone is within
radio range of everyone else, for example).

This brings me to wanting to establish p2p adjacencies while using the
broadcast capabilities of the media to reach whoever is within
transmission range (to propagate Hellos and to flood LSAs).  The
recognition that the characteristics between nodes can be different
should also result in the recognition that the adjacencies between pairs
of nodes may not all have the same state at the same time.

My 1c.

Alvaro.

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 20 Dec 2010 15:17:46 -0500

Alvaro,

Sorry for the late response.

Please see below. 

> From: Alvaro Retana (aretana) [mailto:[email-masked]] 
> Sent: Monday, December 13, 2010 3:47 PM
> Subject: RE: [OSPF] OSPF Hybrid Broadcast and P2MP Interface Type
> 

There are real-life examples where a radio network is built to guarantee that if a node can reach a central node then it can reach others who can also reach the central node (e.g., a satellite network). A node's transimission/receiving capability can be impacted by its placement, but the broadcast property of the network is still maintained (if a station is so out of place then it is considered off the network, just like a cable is cut in the wired ethernet case).

The premise is that we have a broadcast network but one can reach some stations with a metric that is different from when reaching others.

If that premise is not satisfied, then it's a different topic (and out of the scope).

Thanks.
Jeffrey

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Mon, 20 Dec 2010 14:44:36 -0600

> From: Jeffrey (Zhaohui) Zhang [mailto:[email-masked]]
> Sent: Monday, December 20, 2010 3:18 PM

Jeffrey:

...
> > movement, etc..  The broadcast model for neighbor
> > discovery/maintenance can quickly become unusable for nodes that
> > loose connectivity to the DR.
> >
> There are real-life examples where a radio network is built to
> guarantee that if a node can reach a central node then it can reach
> others who can also reach the central node (e.g., a satellite
network).

That's transitive connectivity (nodes can reach each other through the
satellite), not direct connectivity (a node sends a broadcast and others
receive it w/out any other node in the middle).

...but that could be a completely separate discussion. ;-)

...
> The premise is that we have a broadcast network but one can reach some
> stations with a metric that is different from when reaching others.
> 

You should specifically mention the limitations of the solution in the
draft to avoid generalizations...like the one I made when you suggested
"radio networks".

Happy Holidays!!

Alvaro.

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 20 Dec 2010 15:48:14 -0500

Alvaro,

The transitive connectivity is at l2 level though :-)

I will emphasize that fact that the premise is a broadcast network.

Thanks.
Jeffrey

> Sent: Monday, December 20, 2010 3:45 PM
> > If that premise is not satisfied, then it's a different 
> topic (and out
> > of the scope).
>