Subject: [OSPF] FW: New Version Notification for draft-xu-ospf-encapsulation-cap-00.txt

From: Xuxiaohu <[email-masked]>
Date: Tue, 3 Mar 2015 02:13:57 +0000

Hi all,

Any comments are welcome.

Best regards,
Xiaohu

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Saturday, February 28, 2015 4:21 PM
> To: Uma Chunduri; Luis M. Contreras; Robert Raszuk; Xuxiaohu; Luis M.
> Contreras; Xuxiaohu; Uma Chunduri; Robert Raszuk
> Subject: New Version Notification for draft-xu-ospf-encapsulation-cap-00.txt
> 
> 
> A new version of I-D, draft-xu-ospf-encapsulation-cap-00.txt
> has been successfully submitted by Xiaohu Xu and posted to the IETF repository.
> 
> Name:		draft-xu-ospf-encapsulation-cap
> Revision:	00
> Title:		Advertising Encapsulation Capability Using OSPF
> Document date:	2015-02-28
> Group:		Individual Submission
> Pages:		5
> URL:
> http://www.ietf.org/internet-drafts/draft-xu-ospf-encapsulation-cap-00.txt
> Status:
> https://datatracker.ietf.org/doc/draft-xu-ospf-encapsulation-cap/
> Htmlized:       http://tools.ietf.org/html/draft-xu-ospf-encapsulation-cap-00
> 
> 
> Abstract:
>    In a particular network environment where MPLS-SPRING-enabled routers
>    are partially deployed, it needs to transport MPLS traffic through an
>    IP-based tunnel between two MPLS-SPRING-enabled routers so as to
>    traverse non-MPLS routers.  The ingress of the IP-based tunnel must
>    know which encapsulation type is supported by the egress of that IP-
>    based tunnel.This document describes how to advertise the
>    encapsulation capability of MPLS-SPRING-enabled routers using OSPF.
>    Note that this encapsulation capablity advertisment may be applicalbe
>    to other use cases as well.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: Karsten Thomann <[email-masked]>
Date: Tue, 03 Mar 2015 07:57:35 +0100

Hi,

some comments:
last sentence of section 1:
capablity -> capability
applicalbe -> applicable
Section 3:
The Encapsulation Capability TLV could not appear more than once wihin a 
given OSPF Router Information (RI) Opaque LSA .
Would like to change it to SHOULD NOT or better MUST NOT instead of 
could not and at the end of the sentence is a space which should be removed.

Encapsualtion -> Encapsulation
Cability -> Capability
vairalbe-> variable

Section 4:
.. -> . at the end of the sentence

Regards
Karsten

Am 03.03.2015 um 03:13 schrieb Xuxiaohu:
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf

---

From: Xuxiaohu <[email-masked]>
Date: Tue, 3 Mar 2015 08:08:09 +0000

Hi Karsten,

Thanks a lot for your comments. I will update them in the next version.

Best regards,
Xiaohu

> From: Karsten Thomann [mailto:[email-masked]]
> Sent: Tuesday, March 03, 2015 2:58 PM
> To: Xuxiaohu; [email-masked]
> Subject: Re: [OSPF] FW: New Version Notification for
> draft-xu-ospf-encapsulation-cap-00.txt
> 
> Hi,
> 
> some comments:
> The Encapsulation Capability TLV could not appear more than once wihin a given
> OSPF Router Information (RI) Opaque LSA .
> Would like to change it to SHOULD NOT or better MUST NOT instead of could not
> and at the end of the sentence is a space which should be removed.
> 
> >> Htmlized:
> http://tools.ietf.org/html/draft-xu-ospf-encapsulation-cap-00
> >>
> >>
> >> Abstract:
> >> Please note that it may take a couple of minutes from the time of
> >> submission until the htmlized version and diff are available at tools.ietf.org.
> >>
> >> The IETF Secretariat