Subject: [OSPF] draft-ietf-ospf-two-part-metric : Max metric handling

From: Shraddha Hegde <[email-masked]>
Date: Tue, 6 Oct 2015 09:58:09 +0000

Authors,

As per my understanding of the draft, SPF calculation uses sum of metric from the interface cost and the network to router cost advertised by the neighbor.
Handling of MAX metric is not described in the draft.  Since the metric will be sum of 2 16 bit numbers it can exceed the normal 0xffff metric value and the draft should talk about how to handle these cases.

Rgds
Shraddha

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 8 Oct 2015 09:33:03 +0000

Hi Shraddha,
Since RFC 2328 and RFC 5340 don’t explicitly call out the case of 0xffff, I don’t see why this should be handled. Perhaps, we should state both metric SHOULD be set to 0xffff in the stub router case.
Thanks,
Acee

From: Shraddha Hegde <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, October 6, 2015 at 5:58 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: draft-ietf-ospf-two-part-metric : Max metric handling

Authors,

Rgds
Shraddha

---

From: Shraddha Hegde <[email-masked]>
Date: Tue, 13 Oct 2015 04:30:52 +0000

Acee,

Yes, the metric change for the stub router scenario needs to be updated.

This draft is changing the maximum possible metric for a path between two adjacent nodes from 0xffff to oxffffffff.
This breaks the existing assumption that 0xffff is the max_metric i.e last resort metric. From operational
Perspective it’s better to mention this point explicitly  in the draft.

Rgds
Shraddha

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: Thursday, October 08, 2015 3:03 PM
To: Shraddha Hegde <[email-masked]>; [email-masked]
Cc: OSPF WG List <[email-masked]>
Subject: Re: draft-ietf-ospf-two-part-metric : Max metric handling

Hi Shraddha,

Authors,

Rgds
Shraddha

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 17 Oct 2015 00:06:22 +0000

Hi Shraddha,

Even if we set both metrics to 0xffff, the link metric is 0x1FFE. This is far from 0xffffff. Hence, I don’t really understand your concern of this changing the behavior.

Thanks,
Acee

From: Shraddha Hegde <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, October 13, 2015 at 12:30 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: RE: draft-ietf-ospf-two-part-metric : Max metric handling

Acee,

Rgds
Shraddha

To: Shraddha Hegde <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

Hi Shraddha,

Authors,

Rgds
Shraddha

---

From: Shraddha Hegde <[email-masked]>
Date: Mon, 19 Oct 2015 05:53:34 +0000

Hi Acee,

It was a mistake to think 0xffff added to 0xffff will make it 0xffffffff .
The metric will be 0x1fffe which is still much greater than 0xffff.

If an operator has assigned  metric of 0xffff for a link  thinking that this will be the last resort  link
Since there is no metric beyond 0xffff.
This assumption will be broken when two part metric is introduced. As there can be node-node paths with metric
Larger than oxffff, so 0xffff is no longer a safe last resort metric.

Introducing two-part metric for broadcast links into the network has operational impact and I think it should be stated explicitly in the draft.

Rgds
Shraddha

Sent: Saturday, October 17, 2015 5:36 AM

Hi Shraddha,

Thanks,
Acee

Acee,

Rgds
Shraddha

Hi Shraddha,

Authors,

Rgds
Shraddha

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 19 Oct 2015 10:36:58 +0000

Hi Shraddha,

Date: Monday, October 19, 2015 at 1:53 AM

Hi Acee,

Explain to me how it is not longer a safe last resort metric if it is greater than 0xffff? Show me a viable topology?

We will cover stub router operation in the next revision.

Thanks,
Acee

Rgds
Shraddha

Hi Shraddha,

Thanks,
Acee

Acee,

Rgds
Shraddha

Hi Shraddha,

Authors,

Rgds
Shraddha

---

From: Shraddha Hegde <[email-masked]>
Date: Tue, 20 Oct 2015 04:35:45 +0000

Acee,

>Explain to me how it is not longer a safe last resort metric if it is greater than 0xffff? Show me a viable topology?

              8fff        10
           ---------E ---------
     8fff|                        \
D--------    8fff       10   \
|           |_____F-------G
| 10                                   \ 10
A-----------B-----------------C
       10             10

In the above topology D’s interface cost is set to 8fff. F’s network-to-router cost is also set to 8fff.

The path from A to C in normal operation is A->B->C.
Let’s say B-> C link should be replaced . Setting B->C interface cost 0xffff will not move the traffic away from that link
Since the cost  to reach C via other path is

A->D->F->G->C
 Is
10 + 8fff + 8fff + 10 + 10 + 10=  1202E

0x1202E is greater than 0xffff.

In the absence of two-part metric the cost would be 10 + 8fff +10+10+10 = 0x902f
And the traffic would be diverted.

Did I miss something? Or misunderstood the two-part metric?

Rgds
Shraddha

Sent: Monday, October 19, 2015 4:07 PM

Hi Shraddha,

Hi Acee,

Thanks,
Acee

Rgds
Shraddha

Hi Shraddha,

Thanks,
Acee

Acee,

Rgds
Shraddha

Hi Shraddha,

Authors,

Rgds
Shraddha

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 20 Oct 2015 22:08:34 +0000

Hi Shraddha,

Ok - so you are concerned about the case where another routers is the stub router - not the case where the router with the 2-part metric is the stub router. Note that the situation below is no different than anytime you have a path with one than one link and you give them strange costs. In general, setting the link to 0xffff is less effective as the normal operational costs of the links approach 0xffff. The introduction of 2-part metric doesn’t introduce any problems.

Thanks,
Acee

Date: Tuesday, October 20, 2015 at 12:35 AM

Acee,

              8fff        10
           ---------E ---------
     8fff|                        \
D--------    8fff       10   \
|           |_____F-------G
| 10                                   \ 10

A->D->F->G->C
 Is

Rgds
Shraddha

Hi Shraddha,

Hi Acee,

Thanks,
Acee

Rgds
Shraddha

Hi Shraddha,

Thanks,
Acee

Acee,

Rgds
Shraddha

Hi Shraddha,

Authors,

Rgds
Shraddha