Subject: Re: [OSPF] Regarding draft-ppsenak-ospf-te-link-attr-reuse-00

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 21 Oct 2015 11:47:48 +0000

Hi Shraddha,

From: OSPF <[email-masked]<mailto:[email-masked]>> on behalf of Shraddha Hegde <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, October 21, 2015 at 1:20 AM
To: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: [OSPF] Regarding draft-ppsenak-ospf-te-link-attr-reuse-00

Hi All,

draft-ppsenak-ospf-te-link-attr-reuse-00 proposes moving and/or copying TLVs from the TE Opaque LSA to the Extended Link Opaque LSA. The draft lists the problems that the draft is trying to solve.  I have reproduced that list of problems below, with each problem followed by what I believe to be a better and simpler solution.

   1.  Whenever the link is advertised in a TE Opaque LSA, the link
       becomes a part of the TE topology, which may not match IP routed
       topology.  By making the link part of the TE topology, remote
       nodes may mistakenly believe that the link is available for MPLS
       TE or GMPLS, when, in fact, MPLS is not enabled on the link.

To address this issue, we simply need to define a new sub-TLV in the TE Link LSAto say whether MPLS/GMPLS/RSVP is enabled on the link instead of moving the TLVs around into different LSAs.

   2.  The TE Opaque LSA carries link attributes that are not used or
       required by MPLS TE or GMPLS.  There is no mechanism in TE Opaque
       LSA to indicate which of the link attributes should be passed to
       MPLS TE application and which should be used by OSPFv2 and other
       applications.

OSPF database is a container and OSPF can use any of the LSAS for its own use including the TE LSAs.  As far as the TE database goes, it contains data from TE LSAs as well as non-TE LSAs (Network LSA) today so the reasoning described here doesn’t make sense.

   3.  Link attributes used for non-TE purposes is partitioned across
       multiple LSAs - the TE Opaque LSA and the Extended Link Opaque
       LSA.  This partitioning will require implementations to lookup
       multiple LSAs to extract link attributes for a single link,
       bringing needless complexity to the OSPFv2 implementations.

There will be nodes in the network which will run older software which send these attributes via TE LSAs so the problem of looking into the TE LSAs for TE relatedinformation doesn’t get solved with this draft.  Rather it makes it more complicated. With this draft, the multiple LSA lookup will only increase.  An implementation will first have to find if Extended link LSA contains the required info, if not it will need to look up the info in TE.LSA.

The applications using the TE parameters for non-TE use-cases will use the OSPF Prefix/Link attributes for these use cases. Hence, there is no requirement to lookup the LSAs in multiple places. Backward compatibility will be covered in the specifications of these applications.

Thanks,
Acee

Looking up multiple LSAs for information is an implementation issue and I am sure there will be implementations that will handle this  gracefully so that it doesn’t cause
delays in critical paths. It doesn’t seem reasonable to come up with protocol extensions to solve implementation issues.

Rgds
Shraddha

---

From: Chris Bowers <[email-masked]>
Date: Wed, 21 Oct 2015 17:20:23 +0000

In my opinion the backwards compatibility problems introduced by this proposal outweigh potential gains.

As a concrete example, there is at least one existing implementation of remote LFA where policy is used to select a backup tunnel that does not share an SRLG with the failed link.  This SRLG information is carried in the TE Opaque LSA.

As it currently reads, I think the proposal in  draft-ppsenak-ospf-te-link-attr-reuse has the potential to break existing standards-compliant implementations.

I might be OK with having the proposal only apply to sub-TLVs  that get defined in the future.  However, I think that taking TLVs that were  standardized over ten years ago, and selectively moving them or copying them to a different LSA based on a set of rules that is subject to interpretation is going to create confusion and interoperability headaches.

Chris

From: OSPF [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Wednesday, October 21, 2015 6:48 AM
To: Shraddha Hegde <[email-masked]>; OSPF WG List <[email-masked]>
Subject: Re: [OSPF] Regarding draft-ppsenak-ospf-te-link-attr-reuse-00

Hi Shraddha,

Hi All,

Thanks,
Acee

Rgds
Shraddha

---

From: Peter Psenak <[email-masked]>
Date: Wed, 21 Oct 2015 19:40:06 +0200

Hi Chris,

> proposal outweigh potential gains.

there is no backwards compatibility problem with the draft.

>
> As a concrete example, there is at least one existing implementation of
> remote LFA where policy is used to select a backup tunnel that does not
> share an SRLG with the failed link.  This SRLG information is carried in
> the TE Opaque LSA.

that is fine, you are free to do that if the link is TE enabled, there 
is no problem. If the link is not TE enabled and you use TE Opaque LSA 
to flood the SRLG data for such link, you are going against the current 
specification. There is no way to do that today, because any router that 
would receive such TE Opaque LSA must assume such link is TE enabled.

>
> As it currently reads, I think the proposal in
>   draft-ppsenak-ospf-te-link-attr-reuse has the potential to break
> existing standards-compliant implementations.

I don't believe so.

>
> I might be OK with having the proposal only apply to sub-TLVs  that get
> defined in the future.  However, I think that taking TLVs that were
>   standardized over ten years ago, and selectively moving them or
> copying them to a different LSA based on a set of rules that is subject
> to interpretation is going to create confusion and interoperability
> headaches.

What we propose is the way to advertise link attributes without making 
the link part of TE topology. We simply do not have a way to do that 
today. I do not see any problem in doing so, because we do not change 
anything on the TE Opaque LSA side, we are defining something new.

thanks,
Peter

>
> Chris
>
> *From:*OSPF [mailto:[email-masked]] *On Behalf Of *Acee Lindem (acee)
> *Sent:* Wednesday, October 21, 2015 6:48 AM
> *To:* Shraddha Hegde <[email-masked]>; OSPF WG List <[email-masked]>
> *Subject:* Re: [OSPF] Regarding draft-ppsenak-ospf-te-link-attr-reuse-00
>
> Hi Shraddha,
>
> *From: *OSPF <[email-masked] <mailto:[email-masked]>> on
> behalf of Shraddha Hegde <[email-masked]
> <mailto:[email-masked]>>
> *Date: *Wednesday, October 21, 2015 at 1:20 AM
> *To: *OSPF WG List <[email-masked] <mailto:[email-masked]>>
> *Subject: *[OSPF] Regarding draft-ppsenak-ospf-te-link-attr-reuse-00
>
>     Hi All,
>
>     draft-ppsenak-ospf-te-link-attr-reuse-00 proposes moving and/or
>     copying TLVs from the TE Opaque LSA to the Extended Link Opaque LSA.
>     The draft lists the problems that the draft is trying to solve.  I
>     have reproduced that list of problems below, with each problem
>     followed by what I believe to be a better and simpler solution.
>
>     To address this issue, we simply need to define a new sub-TLV in the
>     TE Link LSAto say whether MPLS/GMPLS/RSVP is enabled on the link
>     instead of moving the TLVs around into different LSAs.
>
>     OSPF database is a container and OSPF can use any of the LSAS for
>     its own use including the TE LSAs.As far as the TE database goes, it
>     contains data from TE LSAs as well as non-TE LSAs (Network LSA)
>     today so thereasoning described here doesn’t make sense.
>
>     There will be nodes in the network which will run older software
>     which send these attributes via TE LSAs so the problem of looking
>     into the TE LSAs for TE relatedinformation doesn’t get solved with
>     this draft.  Rather it makes it more complicated. With this draft,
>     the multiple LSA lookup will only increase.An implementation will
>     first have to find if Extended link LSA contains the required info,
>     if not it will need to lookup the info in TE.LSA.
>
> The applications using the TE parameters for non-TE use-cases will use
> the OSPF Prefix/Link attributes for these use cases. Hence, there is no
> requirement to lookup the LSAs in multiple places. Backward
> compatibility will be covered in the specifications of these applications.
>
> Thanks,
>
> Acee
>
>     Looking up multiple LSAs for information is an implementation issue
>     and I am sure there will be implementations that will handle this
>     gracefully so that it doesn’t cause
>
>     delays in critical paths. It doesn’t seem reasonable to come up with
>     protocol extensions to solve implementation issues.
>
>     Rgds
>
>     Shraddha
>
>
>
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf
>

---

From: Chris Bowers <[email-masked]>
Date: Wed, 21 Oct 2015 19:44:50 +0000

Peter,

RFC3630 does not appear to restrict the use of the attributes it defines.   The term "TE extensions" may seem to imply some restriction, but the Applicability section of RFC3630 explicitly addresses this potential interpretation by saying that a more accurate designation is "extended link attributes".

1.1.  Applicability

   Many of the extensions specified in this document are in response to
   the requirements stated in [5], and thus are referred to as "traffic
   engineering extensions", and are also commonly associated with MPLS
   Traffic Engineering.  A more accurate (albeit bland) designation is
   "extended link attributes", as the proposal is to simply add more
   attributes to links in OSPF advertisements.

-------
Also, the response below uses the term "TE-enabled" which along with "TE-application" does not appear to have a precise definition in draft-ppsenak-ospf-te-link-attr-reuse-00.   Based on RFC 3630, it seems reasonable to say that a link is "TE-enabled" if the link is advertised in the TE Opaque LSA.  I don't think this is the meaning you intend, so to avoid confusion, I will use the term "RFC-3630-TE-enabled" to mean that the link is advertised in the TE Opaque LSA defined in RFC 3630. 

So can you clarify what "TE-enabled" or a "TE-application" means in your document?  I assume that it should mean that MPLS is enabled, but it is actually not clear to me if just having LDP-enabled on a link would qualify as being "TE-enabled" or not. 

Thanks,
Chris

-----Original Message-----
From: Peter Psenak [mailto:[email-masked]] 
Sent: Wednesday, October 21, 2015 12:40 PM
To: Chris Bowers <[email-masked]>; Acee Lindem (acee) <[email-masked]>; Shraddha Hegde <[email-masked]>; OSPF WG List <[email-masked]>
Subject: Re: [OSPF] Regarding draft-ppsenak-ospf-te-link-attr-reuse-00

Hi Chris,

>
> As a concrete example, there is at least one existing implementation 
> of remote LFA where policy is used to select a backup tunnel that does 
> not share an SRLG with the failed link.  This SRLG information is 
> carried in the TE Opaque LSA.

that is fine, you are free to do that if the link is TE enabled, there is no problem. If the link is not TE enabled and you use TE Opaque LSA to flood the SRLG data for such link, you are going against the current specification. There is no way to do that today, because any router that would receive such TE Opaque LSA must assume such link is TE enabled.

I don't believe so.

>
> I might be OK with having the proposal only apply to sub-TLVs  that 
> get defined in the future.  However, I think that taking TLVs that were
> copying them to a different LSA based on a set of rules that is 
> subject to interpretation is going to create confusion and 
> interoperability headaches.

What we propose is the way to advertise link attributes without making the link part of TE topology. We simply do not have a way to do that today. I do not see any problem in doing so, because we do not change anything on the TE Opaque LSA side, we are defining something new.

thanks,
Peter

>     today so thereasoning described here doesn't make sense.
>
>     into the TE LSAs for TE relatedinformation doesn't get solved with
> the OSPF Prefix/Link attributes for these use cases. Hence, there is 
> no requirement to lookup the LSAs in multiple places. Backward 
>     gracefully so that it doesn't cause
>
>     delays in critical paths. It doesn't seem reasonable to come up with

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 21 Oct 2015 20:13:20 +0000

Speaking strictly with my WG Chair hat off:

Chris, 

I hope we are not going to have to call in the lawyers ;^) It is clear
that RFC 3630 was published by the OSPF WG to satisfy traffic engineering
requirements (simply read the abstract, introduction, and the note the
name of the opaque LSA type). Despite this loophole in the applicability,
there is no IETF specification documenting the usage of these link
attributes beyond traffic engineering and hence no backward compatibility
issue. The argument of whether non-TE applications require the gratuitous
origination of the TE link LSAs or can use the OSPF Prefix/Link attributes
is purely technical.

Thanks,
Acee 

On 10/21/15, 3:44 PM, "Chris Bowers" <[email-masked]> wrote:

>Peter,
>
>RFC3630 does not appear to restrict the use of the attributes it defines.
>  The term "TE extensions" may seem to imply some restriction, but the
>Applicability section of RFC3630 explicitly addresses this potential
>interpretation by saying that a more accurate designation is "extended
>link attributes".
>
>1.1.  Applicability
>
>Also, the response below uses the term "TE-enabled" which along with
>"TE-application" does not appear to have a precise definition in
>draft-ppsenak-ospf-te-link-attr-reuse-00.   Based on RFC 3630, it seems
>reasonable to say that a link is "TE-enabled" if the link is advertised
>in the TE Opaque LSA.  I don't think this is the meaning you intend, so
>to avoid confusion, I will use the term "RFC-3630-TE-enabled" to mean
>that the link is advertised in the TE Opaque LSA defined in RFC 3630.
>
>So can you clarify what "TE-enabled" or a "TE-application" means in your
>document?  I assume that it should mean that MPLS is enabled, but it is
>actually not clear to me if just having LDP-enabled on a link would
>qualify as being "TE-enabled" or not.
>
>Thanks,
>Chris
>
>
>To: Chris Bowers <[email-masked]>; Acee Lindem (acee)
><[email-masked]>; Shraddha Hegde <[email-masked]>; OSPF WG List
><[email-masked]>
>that is fine, you are free to do that if the link is TE enabled, there is
>no problem. If the link is not TE enabled and you use TE Opaque LSA to
>flood the SRLG data for such link, you are going against the current

---

From: Peter Psenak <[email-masked]>
Date: Wed, 21 Oct 2015 22:23:51 +0200

Hi Chris,

>     attributes to links in OSPF advertisements.

RFC3630 says:

    The extensions provide a way of describing the traffic engineering
    topology (including bandwidth and administrative constraints) and
    distributing this information within a given OSPF area.  This
    topology does not necessarily match the regular routed topology,

above clearly indicates that if the link is advertised in TE Opaque LSA, 
it is part of the TE topology, otherwise it is not. That restricts the 
usage of the TE Opaque LSA to the links that are part of the TE topology.

> So can you clarify what "TE-enabled" or a "TE-application" means in your document?  I assume that it should mean that MPLS is enabled, but it is actually not clear to me if just having LDP-enabled…

TE-enabled means the link is part of the traffic engineering topology as 
described by RFC3630.

thanks,
Peter

> .

---

From: Chris Bowers <[email-masked]>
Date: Thu, 22 Oct 2015 15:00:50 +0000

Peter,

I would suggest making the text of the draft more explicit about the conditions under which a given link and set of attributes should be included in the TE Opaque LSA or the Extended Link Opaque LSA.  RFC3630 is subject to interpretation on its own, and since it was written before the existence of the Extended Link Opaque LSA, it is not self-evident how to interpret it with respect to using this new LSA.   Clarifying the proposed rules for use of the TE Opaque LSA or the Extended Link Opaque LSA without relying on interpretations of 3630 will be helpful.  It will help the WG evaluate the proposal overall and determine what, if any, backwards compatibility issues this proposal may cause with existing implementations.  It may also help future implementers avoid interoperability and backwards compatibility issues.

As a concrete example, I think it would be useful to explicitly address the case of how to advertise a link that only supports LDP in the text of the draft.   Below is an example of a format that would clarify this.    From the response to my question below regarding LDP, I assume that a link that only supports LDP signaling and not RSVP-signaling would not be advertised in the TE Opaque LSA.  However, I am honestly not positive that this is what is intended.

Format of proposed clarifying text:
------------------

A link MUST NOT be advertised in the TE Opaque LSA under the following conditions:

1) The link does not support RSVP-TE signaling.

2) Another condition...

A link MAY be advertised in the TE Opaque LSA under the following conditions:

1) Another condition ...

A link MUST NOT be advertised in the Extended Link Opaque LSA under the following conditions:

1) Some other condition ....

Thanks,
Chris

-----Original Message-----
From: Peter Psenak [mailto:[email-masked]] 
Sent: Wednesday, October 21, 2015 3:24 PM
To: Chris Bowers <[email-masked]>; Acee Lindem (acee) <[email-masked]>; Shraddha Hegde <[email-masked]>; OSPF WG List <[email-masked]>
Subject: Re: [OSPF] Regarding draft-ppsenak-ospf-te-link-attr-reuse-00

Hi Chris,

RFC3630 says:

above clearly indicates that if the link is advertised in TE Opaque LSA, it is part of the TE topology, otherwise it is not. That restricts the usage of the TE Opaque LSA to the links that are part of the TE topology.

thanks,
Peter

---

From: Alia Atlas <[email-masked]>
Date: Thu, 22 Oct 2015 13:00:31 -0400

<no-hat>

The LFA and RLFA work both have the ability to use SRLG information, which
has only been available in the TE Opaque LSA.  That's not been considered a
problem.

The TE Opaque LSA would be, presumably, required if SPRING is supported
which has no implications on whether RSVP-TE is enabled.

My question is what does an assumption about being "TE-enabled" mean?
What are the benefits of trying to change interpretations that have existed
for
at least 5+ years?

Regards,
Alia
</no-hat>

On Thu, Oct 22, 2015 at 11:00 AM, Chris Bowers <[email-masked]> wrote:

> Peter,
>
> I would suggest making the text of the draft more explicit about the
> conditions under which a given link and set of attributes should be
> included in the TE Opaque LSA or the Extended Link Opaque LSA.  RFC3630 is
> subject to interpretation on its own, and since it was written before the
> existence of the Extended Link Opaque LSA, it is not self-evident how to
> interpret it with respect to using this new LSA.   Clarifying the proposed
> rules for use of the TE Opaque LSA or the Extended Link Opaque LSA without
> relying on interpretations of 3630 will be helpful.  It will help the WG
> evaluate the proposal overall and determine what, if any, backwards
> compatibility issues this proposal may cause with existing
> implementations.  It may also help future implementers avoid
> interoperability and backwards compatibility issues.
>
> As a concrete example, I think it would be useful to explicitly address
> the case of how to advertise a link that only supports LDP in the text of
> the draft.   Below is an example of a format that would clarify this.
> From the response to my question below regarding LDP, I assume that a link
> that only supports LDP signaling and not RSVP-signaling would not be
> advertised in the TE Opaque LSA.  However, I am honestly not positive that
> this is what is intended.
>
> To: Chris Bowers <[email-masked]>; Acee Lindem (acee) <[email-masked]>;
> Shraddha Hegde <[email-masked]>; OSPF WG List <[email-masked]>
> > RFC3630 does not appear to restrict the use of the attributes it
> defines.   The term "TE extensions" may seem to imply some restriction, but
> the Applicability section of RFC3630 explicitly addresses this potential
> interpretation by saying that a more accurate designation is "extended link
> attributes".
> >
> > 1.1.  Applicability
> >
> reasonable to say that a link is "TE-enabled" if the link is advertised in
> the TE Opaque LSA.  I don't think this is the meaning you intend, so to
> avoid confusion, I will use the term "RFC-3630-TE-enabled" to mean that the
> link is advertised in the TE Opaque LSA defined in RFC 3630.
> >
> actually not clear to me if just having LDP-enabled on a link would qualify
> as being "TE-enabled" or not.
>
> > To: Chris Bowers <[email-masked]>; Acee Lindem (acee) <
> [email-masked]>; Shraddha Hegde <[email-masked]>; OSPF WG List <
> [email-masked]>
> is no problem. If the link is not TE enabled and you use TE Opaque LSA to
> the link part of TE topology. We simply do not have a way to do that today.
> I do not see any problem in doing so, because we do not change anything on
> the TE Opaque LSA side, we are defining something new.
> >
> > thanks,
> > Peter
> >
> >>
> >> Chris
> >>

---

From: Peter Psenak <[email-masked]>
Date: Thu, 22 Oct 2015 19:08:14 +0200

Hi Alia,

please see inline:

> has only been available in the TE Opaque LSA.  That's not been considered a

it is a problem if the user does not want to use the link for MPLS 
traffic engineering. The reason is that any router receiving such TE 
Opaque LSA would automatically make the link part of the traffic 
engineering topology. RFC3630 clearly says that traffic engineering 
topology is described by TE Opaque LSAs and that such topology does not 
necessarily match the regular routed topology.

> which has no implications on whether RSVP-TE is enabled.

SPRING does not use TE Opaque LSA.

> My question is what does an assumption about being "TE-enabled" mean?

means that the link is part of the traffic engineering topology.

> What are the benefits of trying to change interpretations that have
> existed for
> at least 5+ years?

not sure what interpretation are you referring to, but RFC3630 is clear 
on what the TE Opaque LSAs are used for.

thanks,
Peter

>
> Regards,
> Alia
> </no-hat>
>
> On Thu, Oct 22, 2015 at 11:00 AM, Chris Bowers <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Peter,
>
>     included in the TE Opaque LSA or the Extended Link Opaque LSA.
>     RFC3630 is subject to interpretation on its own, and since it was
>     written before the existence of the Extended Link Opaque LSA, it is
>     not self-evident how to interpret it with respect to using this new
>     LSA.   Clarifying the proposed rules for use of the TE Opaque LSA or
>     the Extended Link Opaque LSA without relying on interpretations of
>     3630 will be helpful.  It will help the WG evaluate the proposal
>     overall and determine what, if any, backwards compatibility issues
>     this proposal may cause with existing implementations.  It may also
>     help future implementers avoid interoperability and backwards
>     compatibility issues.
>
>     As a concrete example, I think it would be useful to explicitly
>     address the case of how to advertise a link that only supports LDP
>     in the text of the draft.   Below is an example of a format that
>     would clarify this.    From the response to my question below
>     regarding LDP, I assume that a link that only supports LDP signaling
>     and not RSVP-signaling would not be advertised in the TE Opaque
>     LSA.  However, I am honestly not positive that this is what is intended.
>
>     From: Peter Psenak [mailto:[email-masked] <mailto:[email-masked]>]
>     To: Chris Bowers <[email-masked] <mailto:[email-masked]>>;
>     Acee Lindem (acee) <[email-masked] <mailto:[email-masked]>>;
>     Shraddha Hegde <[email-masked] <mailto:[email-masked]>>;
>     OSPF WG List <[email-masked] <mailto:[email-masked]>>
>     defines.   The term "TE extensions" may seem to imply some
>     restriction, but the Applicability section of RFC3630 explicitly
>     addresses this potential interpretation by saying that a more
>     accurate designation is "extended link attributes".
>      >
>      > 1.1.  Applicability
>      >
>     above clearly indicates that if the link is advertised in TE Opaque
>     LSA, it is part of the TE topology, otherwise it is not. That
>     restricts the usage of the TE Opaque LSA to the links that are part
>     of the TE topology.
>
>      >
>      > -------
>      > Also, the response below uses the term "TE-enabled" which along
>     with "TE-application" does not appear to have a precise definition
>     in draft-ppsenak-ospf-te-link-attr-reuse-00.   Based on RFC 3630, it
>     seems reasonable to say that a link is "TE-enabled" if the link is
>     advertised in the TE Opaque LSA.  I don't think this is the meaning
>     you intend, so to avoid confusion, I will use the term
>     "RFC-3630-TE-enabled" to mean that the link is advertised in the TE
>     Opaque LSA defined in RFC 3630.
>      >
>      > So can you clarify what "TE-enabled" or a "TE-application" means
>     in your document?  I assume that it should mean that MPLS is
>     enabled, but it is actually not clear to me if just having
>     LDP-enabled on a link would qualify as being "TE-enabled" or not.
>
>      > From: Peter Psenak [mailto:[email-masked]
>     <mailto:[email-masked]>]
>      > To: Chris Bowers <[email-masked]
>     <mailto:[email-masked]>>; Acee Lindem (acee) <[email-masked]
>     <mailto:[email-masked]>>; Shraddha Hegde <[email-masked]
>     <mailto:[email-masked]>>; OSPF WG List <[email-masked]
>     <mailto:[email-masked]>>
>      >> In my opinion the backwards compatibility problems introduced by
>     this
>      >> proposal outweigh potential gains.
>      >
>      > that is fine, you are free to do that if the link is TE enabled,
>     there is no problem. If the link is not TE enabled and you use TE
>     Opaque LSA to flood the SRLG data for such link, you are going
>     against the current specification. There is no way to do that today,
>     because any router that would receive such TE Opaque LSA must assume
>     such link is TE enabled.
>      >
>      >>
>      > What we propose is the way to advertise link attributes without
>     making the link part of TE topology. We simply do not have a way to
>     do that today. I do not see any problem in doing so, because we do
>     not change anything on the TE Opaque LSA side, we are defining
>     something new.
>      >
>      > thanks,
>      > Peter
>      >
>      >>
>      >> Chris
>      >>
>      >> *From:*OSPF [mailto:[email-masked]
>     <mailto:[email-masked]>] *On Behalf Of *Acee Lindem
>      >> (acee)
>      >> *To:* Shraddha Hegde <[email-masked]
>     <mailto:[email-masked]>>; OSPF WG List
>      >> <[email-masked] <mailto:[email-masked]>>
>      >> *From: *OSPF <[email-masked]
>     <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>> on
>     <mailto:[email-masked]>
>      >> <mailto:[email-masked] <mailto:[email-masked]>>>
>      >> *To: *OSPF WG List <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>
>      >>              becomes a part of the TE topology, which may not
>     match IP
>      >> routed
>      >>
>      >>              required by MPLS TE or GMPLS.  There is no
>     mechanism in TE
>      >>      Opaque
>      >>
>      >>              MPLS TE application and which should be used by
>     OSPFv2 and
>      >> other
>      >>
>      >>              applications.
>      >>
>      >> [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: Peter Psenak <[email-masked]>
Date: Fri, 23 Oct 2015 10:09:02 +0200

Hi Chris,

please see inline:

> I would suggest making the text of the draft more explicit about the conditions under which a given link and set of attributes should be included in the TE Opaque LSA or the Extended Link Opaque LS…

Sure, we can add more text in the draft.

What I have a problem with is that you are questioning RFC3630 and claim 
that it subject to interpretation. I don't think that is the case. 
RFC3630 defines TE Opaque LSAs as a mechanism to describe TE topology. 
There is nothing left that is subject to interpretation. If we do not 
have an agreement on this part, there is no text in the draft that is 
going to make things clear.

> As a concrete example, I think it would be useful to explicitly address the case of how to advertise a link that only supports LDP in the text of the draft.   Below is an example of a format that w…

LDP being enabled on link is orthogonal to link being part of the TE 
topology. Implementation can choose what makes link part of TE topology, 
some may have explicit command on a per interface basis, some may do it 
based on some other feature being enabled on the link. No matter what 
mechanism they use it is a local decision on the box that makes the link 
part of TE topology and triggers the advertisement of the TE Opaque LSA 
for such link. What is important is that as soon as the TE Opaque LSA is 
flooded all other nodes in the area will assume they can use such link 
for traffic engineering and use it during the TE cSPF.

> Format of proposed clarifying text:

one can do traffic engineering without RSVP. RFC3630 does not mandate 
the usage of RSVP.

> A link MAY be advertised in the TE Opaque LSA under the following conditions:

the only condition is that user decided to make the link part of the 
traffic engineering topology, regardless of what is the local mechanism 
on the box to make that happen.

> A link MUST NOT be advertised in the Extended Link Opaque LSA under the following conditions:

I do not see any reason to specify why a link MUST NOT be advertised in 
Extended Link Opaque LSA.

TE Opaque LSA and Extended Link Opaque LSA are orthogonal to each other. 
TE Opaque LSA is dedicated for traffic engineering and must not be used 
for anything else.

thanks,
Peter

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sun, 25 Oct 2015 21:28:04 +0000

Speaking with no hats on…

I just want to add that we have a separate OSPF metric and OSPF TE Metric
so the mere fact that there is a similar object in GMPLS doesn’t imply
that it automatically is applicable to IP applications as well.

Thanks,
Acee 

On 10/22/15, 1:08 PM, "Peter Psenak (ppsenak)" <[email-masked]> wrote:

>>      >>          1.  Whenever the link is advertised in a TE Opaque
>>LSA, the
>>      >> link
>>      >>
>>      >>              topology.  By making the link part of the TE
>>topology,
>>      >> remote
>>      >>
>>      >>              nodes may mistakenly believe that the link is
>>available
>>      >> for MPLS
>>      >>
>>      >>          2.  The TE Opaque LSA carries link attributes that are
>>not
>>      >> used or
>>      >>
>>      >>              LSA to indicate which of the link attributes
>>should be
>>      >> passed to
>>      >>
>>      >>          3.  Link attributes used for non-TE purposes is
>>partitioned
>>      >> across
>>      >>
>>      >>              multiple LSAs - the TE Opaque LSA and the Extended
>>Link
>>      >> Opaque
>>      >>
>>      >>              LSA.  This partitioning will require
>>implementations to
>>      >> lookup
>>      >>
>>      >>              multiple LSAs to extract link attributes for a
>>single
>>      >> link,
>>      >>

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 26 Oct 2015 01:01:54 +0000

Hi,
No hats

I'm familiar with at least 2 implementations which have this issue, this draft solves real problem.

Regards,
Jeff

> On Oct 25, 2015, at 2:28 PM, Acee Lindem (acee) <[email-masked]> wrote:
>