Subject: [OSPF] proposed text for draft-ppsenak-ospf-te-link-attr-reuse

From: Chris Bowers <[email-masked]>
Date: Fri, 4 Dec 2015 17:32:34 +0000

Draft authors,

I would like to suggest the following text for the Backwards Compatibility section of this document.

-------
Some deployments of LFA and remote LFA currently rely on link attributes (such as SRLG and admin groups) being carried in the TE Opaque LSA.  These applications are described in RFC 5286, RFC 7490,  draft-ietf-rtgwg-lfa-manageability, and draft-psarkar-rtgwg-rlfa-node-protection.  When a network is using an application that relies on link attributes being carried in the TE Opaque LSA , care should be taken to continue to advertise the appropriate link attributes in the TE Opaque LSA.

Note that a node that does not directly participate in remote LFA by originating repair tunnels itself may still need to continue originating link attributes in the TE Opaque LSA for use by other nodes in the network.   Therefore, when evaluating software upgrades or configuration changes which may result in changes to which link attributes are being advertised in the TE Opaque LSA, even for a subset of routers in the network,  care should be taken to evaluate the impact of that change across the entire network.
-------

Thanks,
Chris

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 4 Dec 2015 21:31:24 +0000

Hi Chris,

Thanks for your comments - sounds reasonable to me.
With inclusion of your comments - would you be satisfied with the solution proposed?

Thanks and have a great weekend!

Regards,
Jeff

On Dec 4, 2015, at 9:33 AM, Chris Bowers <[email-masked]<mailto:[email-masked]>> wrote:

Draft authors,

-------

Thanks,
Chris

_______________________________________________
OSPF mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ospf

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 4 Dec 2015 21:50:17 +0000

Jeff, Chris,

These additions look reasonable to me as well.
Thanks,
Acee

From: OSPF <[email-masked]<mailto:[email-masked]>> on behalf of Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Date: Friday, December 4, 2015 at 4:31 PM
To: Chris Bowers <[email-masked]<mailto:[email-masked]>>
Cc: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [OSPF] proposed text for draft-ppsenak-ospf-te-link-attr-reuse

Hi Chris,

Regards,
Jeff

Draft authors,

-------

Thanks,
Chris

---

From: Peter Psenak <[email-masked]>
Date: Sat, 05 Dec 2015 14:39:20 +0100

Hi Chris,

On 12/4/15 18:32 , Chris Bowers wrote:
> Some deployments of LFA and remote LFA currently rely on link attributes
> (such as SRLG and admin groups) being carried in the TE Opaque LSA.
> These applications are described in RFC 5286, RFC 7490,
> draft-ietf-rtgwg-lfa-manageability, and
> draft-psarkar-rtgwg-rlfa-node-protection. When a network is using an
> application that relies on link attributes being carried in the TE
> Opaque LSA , care should be taken to continue to advertise the
> appropriate link attributes in the TE Opaque LSA.

Here I would add:

"Doing so would make the link part of the traffic engineering topology 
as defined in RCF 3630."

"Advertising the particular link attribute in TE Opaque LSA does not 
prevent the same attribute to be advertised in Extended Prefix LSA for 
the same link."

thanks,
Peter

> Note that a node that does not directly participate in remote LFA by
> originating repair tunnels itself may still need to continue originating
> link attributes in the TE Opaque LSA for use by other nodes in the
> network.   Therefore, when evaluating software upgrades or configuration
> changes which may result in changes to which link attributes are being
> advertised in the TE Opaque LSA, even for a subset of routers in the
> network,  care should be taken to evaluate the impact of that change
> across the entire network.
> -------
> Thanks,
> Chris
>
>
> [email-masked]