Subject: [P2Prg] Re: P2prg digest, Vol 1 #73 - 2 msgs

From: Abrar Bin Yousuf <[email-masked]>
Date: Fri, 14 Nov 2003 21:15:12 -0800 (PST)

Hi,
I have been following the p2p scenario for about one
year now. However, the issue of security is one of the
most unregulated part. Everybody has come up with
their own implementation (though general consensus on
certain technologies does exist).

As Rita has posted, a lot of technologies can be
directly deployed to p2p - e.g. SSL, PKI, etc. Groove
has used PKI based approach. JXTA bases systems can
easily integrate SSL. Most of system sceem contented
to use of hash techniques. However with millions of
users, Hashing alone is not enough. 

However, the issue of security in a scenario of purely
anonymous p2p is one of interest as how can you deploy
security without breaking the anonymity. 

Security even in centralized or hybrid systems is
still of concern. I strongly beleive that as p2p grows
in usage and importance, the security aspect will get
more and more critical. 

As such to set up a security research group would be
great AFAIT.

Regards,
Abrar Bin Yousuf

--- [email-masked] wrote:
> Send P2prg mailing list submissions to
> 	[email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web,
> visit
> 	https://www.ietf.org/mailman/listinfo/p2prg
> or, via email, send a message with subject or body
> 'help' to
> 	[email-masked]
> 
> You can reach the person managing the list at
> 	[email-masked]
> 
> When replying, please edit your Subject line so it
> is more specific
> than "Re: Contents of P2prg digest..."
> 
> 
> Today's Topics:
> 
>    1. Re: Proposed research tracks ... (Rita Chen)
>    2. Re: Proposed research tracks ...
> ([email-masked])
> 
> --__--__--
> 
> Message: 1
> From: "Rita Chen" <[email-masked]>
> To: [email-masked]
> Subject: Re: [P2Prg] Proposed research tracks ...
> Date: Fri, 14 Nov 2003 04:52:21 +0000
> 
> Hi,
> I think we should cover P2P security in some way.
> Sure, many off-shelf 
> security tools can be directly adopted into P2P.
> However, P2P has its 
> uniqueness. For example, when a peer discover an
> endpoint from a P2P 
> network, how does it make sure this endpoint is
> exactly wanted? This depends 
> on the right public key distribution. Then the
> question becomes: can we use 
> WOT/PKI directly into P2P world? Do we need 100%
> secure P2P world all the 
> time?
> 
> -Rita
> 
> 
> --__--__--
> 
> Message: 2
> From: [email-masked]
> Date: Fri, 14 Nov 2003 02:25:21 -0500
> To: Rita Chen <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [P2Prg] Proposed research tracks ...
> 
> Rita:
> 
> Was this message in response to my posting regarding
> the IRTF 
> Group Security Research Group?
> 
> If so, I am not proposing that we rely on off the
> shelf 
> solutions.  The GSEC RG is a group filled with
> members who for 
> the last eight years have been studying group key
> distribution 
> algorithms; identity based PK crypto; etc.  They are
> an already 
> formed group of experts who are looking for a new
> challenge.  
> Let's engage them to help with our problem set.  
> 
> Jeffrey Altman
> 
> 
> Quoting Rita Chen <[email-masked]>:
> 
> > Hi,
> > I think we should cover P2P security in some way.
> Sure, many
> > off-shelf 
> > security tools can be directly adopted into P2P.
> However, P2P 
> has
> > its 
> > uniqueness. For example, when a peer discover an
> endpoint from 
> a
> > P2P 
> > network, how does it make sure this endpoint is
> exactly wanted?
> > This depends 
> > on the right public key distribution. Then the
> question 
> becomes:
> > can we use 
> > WOT/PKI directly into P2P world? Do we need 100%
> secure P2P 
> world
> > all the 
> > time?
> > 
> > -Rita
> End of P2prg Digest

__________________________________
Do you Yahoo!?
Protect your identity with Yahoo! Mail AddressGuard
http://antispam.yahoo.com/whatsnewfree

_______________________________________________
P2prg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2prg

---

From: Bill Yeager <[email-masked]>
Date: Thu, 20 Nov 2003 21:21:49 -0800

Are you volunteering for our RG Security research track?

Bill