Subject: [P2Prg] Security Research Track

From: [email-masked]
Date: Fri, 28 Nov 2003 13:42:35 -0000

Hi,

I'm technical leader of a collaborative research project in the P2P area.  

Description and more info at www.mmapps.org

We've been working on an area of P2P that doesn't seem to fit too neatly within the proposed research tracks. The nearest seems to be the security one.  I'd be interested in peoples' opinions on whether and how we fit in. I don't want to derail the track you've already described, but we probably should be in there somehow.  I'm certainly willing to contribute.

Our focus is on fixing problems where the peers are not malicious but are selfish.  Sometimes our solutions help with problems of malice too (by making malicious behaviour expensive) but that's not our real focus.  So we're looking at things like reputation, micro-payment and groups policing themselves.

Any comments?
 
Ben Strulo 
BT Research, UK

> o Security issues
> 
>     	Security in a P2P system is extremely difficult because of the 
> possible
> 	pure ad-hoc nature and behavior that can exhibit 
> itself. One may and
> 	and often will not be able to depend on a centralized 
> certificate 
> authority
> 	based PKI to bootstrap secure networks. The 
> requirements are the same:
> 	Privacy, Authentication, Integrity, and 
> non-repudiation. The possible 
> solutions
> 	are quite interesting and often point towards PGP-like 
> Webs-of-Trust
> 	and reputation models.
> 	.
> 	On the other hand, in an enterprise, a very 
> centralized, CA PKI will be
> 	necessary for P2P to fly there. On top of this we have 
> the usual DoS
> 	attacks, the requirement to support anonymous, and autonomous
> 	peer nodes, etc.
> 
> 	It is appropriate to begin here with a survey of the 
> current P2P 
> research
> 	on security to establish a foundation for discussion, 
> and synergy with
> 	the IETF security efforts.
> 
> 	This is a difficult and truly interesting area for research.
> 
> 	Subgroup leader: To be determined.

_______________________________________________
P2prg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2prg

---

From: Samrat Bhattacharjee <[email-masked]>
Date: Fri, 28 Nov 2003 08:51:45 -0500 (EST)

|Our focus is on fixing problems where the peers are not malicious but are selfish.  Sometimes our solutions help wi

Certainly of paramount interest to us!  I was also wondering if this should be covered under security, and
assuming that it would.  Shall I assume that you would like to be part of this subgroup?

bobby