Subject: AW: AW: [P2Prg] P2P vs traditional client-server model

From: "Kellerer, Wolfgang" <[email-masked]>
Date: Mon, 23 Oct 2006 11:32:20 +0200

Hi,

Searching for Google's systems I found:

http://labs.google.com/papers/bigtable.html

stating some distributed storage system for structured data used by google. I have not checked it in detail, but is is different from DHTs (no key-value pairs, etc.), I agree . However, also their requirements are different as they 'own' the infrastructure (no churn, etc.), but look for a easy and self organizing way to maintain the indexes etc. Similar conditions apply, e.g., for P2P global service discovery.

I do not think the Client-Server vs. P2P comparison should limit us to explore the benefits of P2P. On the other hand P2P is not the the best solution for any data management application, that is also true.

Regards,

Wolfgang

------------------------------------------
Dr.-Ing. Wolfgang Kellerer
Senior Manager
Future Networking Lab
Ubiquitous Services Platform
 
DoCoMo Communications Laboratories Europe GmbH Landsberger Str. 312
80687 Munich, Germany
 
Tel. +49-89-56824-222
Fax. +49-89-56824-300
E-mail: [email-masked]
http://www.docomolab-euro.com
------------------------------------------

SPMS 2007 - The 3rd Intl. Workshop on Next Generation Service Platforms for Future Mobile Systems, in conjunction with SAINT 2007, Hiroshima, Japan, January 15-19, 2007 http://www.docomoeurolabs.de/callforpaper_SAINT_SPMS2007.html 

> -----Ursprüngliche Nachricht-----
> Von: Tien Tuan Anh Dinh [mailto:[email-masked]] 
> Gesendet: Montag, 23. Oktober 2006 11:18
> An: Kellerer, Wolfgang
> Betreff: Re: AW: [P2Prg] P2P vs traditional client-server model
> 
> Hi,
> According to the paper "The google cluster architecture", in
> labs.*google*.com/papers/*google**cluster*-ieee.pdf
> 
> Google divided its network to many clusters, each cluster has some web
> servers which forward queries to an index (sub)cluster and an document
> (sub)cluster. This architecture is fairly distributed, but i 
> don't think
> it's P2P, and definitely not DHT
> 
> 
> Kellerer, Wolfgang wrote:
> > Hi,
> >
> > Coming back to your (pessimistic) view of Client-Server vs. 
> Peer-to-Peer along the Google case.
> >
> > What, if it turns out that Google uses a Peer-to-Peer 
> system, e.g., DHT-like system, behind their servers? I don't 
> know details just trying to turn your view around.
> >
> > Regards,
> >
> > Wolfgang
> >
> > ------------------------------------------
> > Dr.-Ing. Wolfgang Kellerer
> > Senior Manager
> > Future Networking Lab
> > Ubiquitous Services Platform
> >  
> > DoCoMo Communications Laboratories Europe GmbH Landsberger Str. 312
> > 80687 Munich, Germany
> >  
> > Tel. +49-89-56824-222
> > Fax. +49-89-56824-300
> > E-mail: [email-masked]
> > http://www.docomolab-euro.com
> > ------------------------------------------
> >
> > SPMS 2007 - The 3rd Intl. Workshop on Next Generation 
> Service Platforms for Future Mobile Systems, in conjunction 
> with SAINT 2007, Hiroshima, Japan, January 15-19, 2007 
> http://www.docomoeurolabs.de/callforpaper_SAINT_SPMS2007.html 
> >   
> 
> 

_______________________________________________
P2prg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2prg

---

From: "Kurt Tutschku" <[email-masked]>
Date: Mon, 23 Oct 2006 12:03:17 +0200

Hi,

I agree with Wolfgang. Personally, I think the research area of distributed
systems and P2P in particular has evolved over the last years. 

Nowadays, it's quite important to investigate which algorithm can be used in
what context/application. 

For example, what about the dependability of distributed systems? Can P2P
mechanisms improve the fault tolerance while meeting certain performance
requirements? Does a C/S approach fulfil the same requirements? 

We investigated parts of this issue for supporting vertical handovers in a
mobile network using a P2P mechanism. You can find these results in [1]

Best Regards
Kurt

[1] T. Hoßfeld, S. Oechsner, K. Tutschku, F.-U. Andersen, L. Caviglione.
Supporting Vertical Handover by Using a Pastry Peer-to-Peer Overlay Network.
Mobile Peer-to-Peer Computing MP2P'06, in conjunction with the 4th IEEE
International Conference on Pervasive Computing and Communications
(PerCom'06), Pisa, Italy, March 2006.

> -----Original Message-----
> From: Kellerer, Wolfgang [mailto:[email-masked]]
> Sent: Monday, October 23, 2006 11:32 AM
> To: Tien Tuan Anh Dinh; [email-masked]
> Subject: AW: AW: [P2Prg] P2P vs traditional client-server model
> 
> 
> Hi,
> 
> stating some distributed storage system for structured data used by
> google. I have not checked it in detail, but is is different from DHTs (no
> key-value pairs, etc.), I agree . However, also their requirements are
> different as they 'own' the infrastructure (no churn, etc.), but look for
> a easy and self organizing way to maintain the indexes etc. Similar
> conditions apply, e.g., for P2P global service discovery.
> 
> I do not think the Client-Server vs. P2P comparison should limit us to
> explore the benefits of P2P. On the other hand P2P is not the the best
> solution for any data management application, that is also true.
> 
> Regards,
> 
> Wolfgang
> 
> 
> SPMS 2007 - The 3rd Intl. Workshop on Next Generation Service Platforms
> for Future Mobile Systems, in conjunction with SAINT 2007, Hiroshima,
> Japan, January 15-19, 2007