Subject: RE: [P2Prg] RG participation.

From: "John Buford" <[email-masked]>
Date: Mon, 2 Oct 2006 13:45:11 -0400

Active RGs seem to have one or more 
of the following characteristics:
1. the RG is coupled to a specific WG (e.g. HIP)
2. the work is closely related to the historical
   activity of the IETF so that there is a critical
   mass of interested researchers already in the IETF
   to participate
3. the research topic hasn't reached a scale where
   it has its own conference forums outside IETF
4. the chair(s) own/drive/energize the RG activities
   to a large extent
5. there is a sizeable commercial motivation for
   research & subsequent standardization of a network
   protocol problem space

Regarding P2P as an RG:
1. there is no coupling yet, possibly P2P-SIP
   might be in the future, and P2P-SIP parties made
   requests at Dallas P2PRG meeting for support
2. P2P is an area which has no standardization
   history in IETF to draw from
3. P2P has many conferences, and most researchers
   seem to prefer the peer-review process, recognition and
   collaboration in those venues
4. this might succeed, but doesn't seem to be a preferred
   model.  the extended efforts of Bill & Bobby should 
   be noted and are certainly appreciated by many.
5. most p2p systems have been closed protocols
   which have succeeeded without standardization and
   related research.

In the long run it seems that something like P2PRG
will be needed and important for the IETF.

In the near term, the most likely scenario to re-activate 
it would be to couple it directly to P2P-SIP, which is having
its second BOF soon.  The best time to work that
out would be if and after its charter is approved.

The general idea would be 1) to scope the RG
charter so that it addresses specific open issues
that are outside of the WG charter, (e.g, decentralized
security)
2) survey the P2P-SIP WG and P2P RG to see how many people
would actively work on IDs for these open issues.
3) have some type of active cross-over coordination between
RG and WG, as in HIP RG/WG, and one or more "owner"
individuals who want to drive the RG work.

Regarding the P2PRG service discovery subgroup I hope 
to continue that work if the RG continues.

John

-----Original Message-----
From: Samrat Bhattacharjee [mailto:[email-masked]]
Sent: Tuesday, September 26, 2006 1:18 PM
To: [email-masked]
Cc: [email-masked]
Subject: [P2Prg] RG participation.

Hello...

Our research group has been dormant for some time now, and the IRTF
chair (cc'ed) has enquired if it makes sense to continue the P2P-RG.  
It is clear that all who are members here are working on their own P2P
research; however, the RG has not (yet) been quite the forum for
exchanging ideas that we had initially hoped.  This is not to take
away from the work that the RG has already produced, however, lately,
there does not seem to be much activity, and this is of concern.

  Bottom line: Should we still keep this RG open?  If you have a
  strong opinion one way or another, please drop us a line.

Note that silence implies that we recommend to the IRTF that the RG be
shut down, so if you are in favor of continuing this group, please
include some ideas on how to generate more research activity.

Thanks.

Bill and Bobby

_______________________________________________
P2prg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2prg

_______________________________________________
P2prg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2prg

---

From: "Henry Sinnreich" <[email-masked]>
Date: Mon, 2 Oct 2006 14:31:01 -0700

John Buford writes:

>the most likely scenario to re-activate it would be to couple it 
>directly to P2P-SIP, which is having its second BOF soon (San Diego
IETF).

I believe this is a very constructive proposal. Since new P2P protocols
are still emerging and their research is out of scope for the proposed
P2P SIP WG, the P2P RG could provide a very effective support by taking
on the research topics that can support P2P SIP. 

Examples of topics of interest include such as:

- Neighbor node discovery based on latency,
- Overlays for range queries, for example searching by last name,
- Overlays for searching by attribute (location, business, etc.),
- Addressing the security vulnerabilities on overlays for P2P SIP,
- Hierarchical overlays,
- etc.,

We can almost promise there will be no shortage of challenges :-)

Thanks, Henry

-----Original Message-----
From: John Buford [mailto:[email-masked]] 
Sent: Monday, October 02, 2006 12:45 PM
To: Samrat Bhattacharjee; [email-masked]; [email-masked]
Subject: RE: [P2Prg] RG participation.

Regarding P2P as an RG:

John

-----Original Message-----
From: Samrat Bhattacharjee [mailto:[email-masked]]
Sent: Tuesday, September 26, 2006 1:18 PM
To: [email-masked]
Cc: [email-masked]
Subject: [P2Prg] RG participation.

Hello...

Thanks.

Bill and Bobby

---

From: Aaron Falk <[email-masked]>
Date: Sun, 8 Oct 2006 14:28:58 -0700

OFFPATH/EMMERG folks-

See the proposal below to re-scope the P2PRG to be tied to a  
(proposed) IETF P2P-SIP working group.  Are there any issues of  
overlap or conflict the (proposed) IRTF EMMERG RG?  It's OK for RGs  
to have overlapping scope but it's not good to unnecessarily fracture  
the community.

P2PRG-  The current draft EMMERG charter can be found here: http:// 
www.irtf.org/chairfiles/emmerg-charter-v5a.txt.

--aaron

Begin forwarded message:

> From: "Henry Sinnreich" <[email-masked]>
> Date: October 2, 2006 2:31:01 PM PDT
> To: "John Buford" <[email-masked]>, "Samrat  
> Bhattacharjee" <[email-masked]>, <[email-masked]>,  
> <[email-masked]>

---

From: Bill Yeager <[email-masked]>
Date: Sun, 8 Oct 2006 16:24:00 -0700

Hi aaron,

I personally think that P2P SIP is too narrow a scope for the P2P RG.  
I would think that yes, the P2P RG can do research on P2P SIP, but  
strongly discourage limiting its scope too narrowly.

Bill

co-chair P2P RG

On Oct 8, 2006, at 2:28 PM, Aaron Falk wrote:

> IRSG mailing list
> [email-masked]
> http://mailman.isi.edu/mailman/listinfo/irsg

---

From: Aaron Falk <[email-masked]>
Date: Sun, 8 Oct 2006 16:32:11 -0700

Bill-

Understood.  However, I submit that the RG agenda should follow the  
interests and energy of the participants.  Another thing to keep in  
mind is that the charter of the RG can be broader than the near-term  
work plan.  An RG may choose to work on a broad array of topics in a  
serial fashion, focusing on a narrower set at any one time.

--aaron

On Oct 8, 2006, at 4:24 PM, Bill Yeager wrote:

> Hi aaron,
>
> I personally think that P2P SIP is too narrow a scope for the P2P  
> RG. I would think that yes, the P2P RG can do research on P2P SIP,  
> but strongly discourage limiting its scope too narrowly.
>
> Bill
>
> co-chair P2P RG
>

---

From: "Roy, Radhika R." <[email-masked]>
Date: Sun, 8 Oct 2006 19:51:06 -0400

Aaron and Bill:
 
Definitely, RG will follow its own agenda as it is supposed to be - much broader than that of P2P-SIP.
 
In fact, P2P-SIP WG is a pointer how useful researches of RG have fueled to form a WG like this to extend SIP in P2P environment. Going forward RG may help P2P-SIP as needed.
 
In the same token, off-path WG will help P2P-SIP to solve the NAT crossing problems. I also opine that P2P-SIP WG needs to depend on other WGs like off-path in solving the NAT-crossing problems instead of dealing with it directly as P2P-SIP have many more immediately problems to solve.
 
We are happy to see that RG will continue with new spirit.
 
Radhika

________________________________

From: [email-masked] on behalf of Aaron Falk
Sent: Sun 10/8/2006 7:32 PM
To: Bill Yeager
Cc: [email-masked]; Internet Steering Group; [email-masked]
Subject: Re: [IRSG] Fwd: [P2Prg] RG participation.

Bill-

--aaron

On Oct 8, 2006, at 4:24 PM, Bill Yeager wrote:

>> P2PRG-  The current draft EMMERG charter can be found here: http:// <http:///>

---

From: Bill Yeager <[email-masked]>
Date: Sun, 8 Oct 2006 17:09:33 -0700

Hi aaron,

I agree that those participants in the P2P RG who wish to do research  
on P2P SIP should be encouraged to do so. On the other hand, my  
objection is to the "re-scoping" of the P2P RG to be aligned with the  
IETF P2P-SIP WG. Anyone in the P2P-SIP WG that wishes to do research  
on that topic in the P2P RG is more than welcome to take the lead,  
begin to create conversations, and, and go for it. Our charter is  
intentionally general so that such efforts do not conflict.

Bill

On Oct 8, 2006, at 4:32 PM, Aaron Falk wrote:

> mind is that the charter of the RG can be broader than the near- 
> term work plan.  An RG may choose to work on a broad array of  
> topics in a serial fashion, focusing on a narrower set at any one  
> time.
>
> --aaron
>

---

From: "Roy, Radhika R." <[email-masked]>
Date: Sun, 8 Oct 2006 20:45:44 -0400

Bill and Aaron:
 
To me is OK as Bill has said, 
 
"Anyone in the P2P-SIP WG that wishes to do research on that topic in the P2P RG is more than welcome to take the lead, begin to create conversations, and, and go for it."
 
In fact, this is the purpose of the whole discussion. I believe that no one saying that P2P RG will work for development P2P-SIP standards or re-define its charter to align with P2P-SIP WG. 
 
For example, many members of P2P-RW are directly contributing to P2P-SIP WG. Without the efforts or experiences in P2P-RG, it would have very difficult to take lead in forming the P2P-SIP WG.
 
What Bill explained above is in fact the norm of all IETF WGs.
 
Radhika

From: [email-masked] on behalf of Bill Yeager
Sent: Sun 10/8/2006 8:09 PM
To: Aaron Falk
Cc: [email-masked]; Internet Steering Group; [email-masked]
Subject: Re: [IRSG] Fwd: [P2Prg] RG participation.

Hi aaron,

Bill

---

From: Bill Yeager <[email-masked]>
Date: Sun, 8 Oct 2006 18:57:09 -0700

Hi Radhika,

Thanks for you thoughtful agreement. I'm looking forward to this  
research beginning and hopefully I can contribute some insights myself.

Best regards,

Bill

On Oct 8, 2006, at 5:45 PM, Roy, Radhika R. wrote:

> "Anyone in the P2P-SIP WG that wishes to do research on that topic  
> in the P2P RG is more than welcome to take the lead, begin to  
> create conversations, and, and go for it."
>
> In fact, this is the purpose of the whole discussion. I believe  
> that no one saying that P2P RG will work for development P2P-SIP  
> standards or re-define its charter to align with P2P-SIP WG.
>
> For example, many members of P2P-RW are directly contributing to  
> P2P-SIP WG. Without the efforts or experiences in P2P-RG, it would  
> have very difficult to take lead in forming the P2P-SIP WG.
>