Subject: AW: [P2Prg] P2P vs traditional client-server model

From: "Kellerer, Wolfgang" <[email-masked]>
Date: Mon, 23 Oct 2006 10:05:37 +0200

Hi,

Coming back to your (pessimistic) view of Client-Server vs. Peer-to-Peer along the Google case.

What, if it turns out that Google uses a Peer-to-Peer system, e.g., DHT-like system, behind their servers? I don't know details just trying to turn your view around.

Regards,

Wolfgang

------------------------------------------
Dr.-Ing. Wolfgang Kellerer
Senior Manager
Future Networking Lab
Ubiquitous Services Platform
 
DoCoMo Communications Laboratories Europe GmbH Landsberger Str. 312
80687 Munich, Germany
 
Tel. +49-89-56824-222
Fax. +49-89-56824-300
E-mail: [email-masked]
http://www.docomolab-euro.com
------------------------------------------

SPMS 2007 - The 3rd Intl. Workshop on Next Generation Service Platforms for Future Mobile Systems, in conjunction with SAINT 2007, Hiroshima, Japan, January 15-19, 2007 http://www.docomoeurolabs.de/callforpaper_SAINT_SPMS2007.html 

> -----Ursprüngliche Nachricht-----
> Von: Tien Tuan Anh Dinh [mailto:[email-masked]] 
> Gesendet: Dienstag, 17. Oktober 2006 12:53
> An: [email-masked]
> Betreff: [P2Prg] P2P vs traditional client-server model
> 
>   Hi,
> 
> Let's look at the "traditional client-server model" in 
> another way, with 
> Google as an example. Apparantly, Google employs a very 
> well-engineered 
> distributed systems with thousands of machines all over the 
> world, but i 
> think in the essence, it still follows a client-server model. All 
> searchs from a Web browser (client) goes directly to a Google server.
> 
>   We go on and on about how P2P systems allow 
> decentralization of their 
> services, hence difficult to take down and can be immuned from DoS 
> attacks on their availability. Now look at google, i dont 
> know how many 
> times it suffered from such attacks. None ??
> 
>   What P2P services that google doesn't have ? Global 
> searching ? You're 
> taking about the master here. Global storage system ? Google has no 
> problem in giving you 2-3Gb freely(emails, pictures and other 
> spaces). 
> Sharing ? Google video, Picassa and even Google music.
> 
>   So i come to think what the future of P2P would be like, especially 
> when the day that all file-sharing networks got shut down by RIAA. In 
> the user point of view, what advantage that P2P systems have 
> over Google 
> (or other client-server modeled system with load of money). 
> Technically, 
> is there any P2P service that cant be provided with equal 
> quality by a 
> very rich company ?
> 
>   Then, i stopped being depressed for one second, when looking at the 
> security issues. Many ways to define privacy, but for me, it 
> consists of 
> anonymity and unlinkability (no correlation). You won't get anonymity 
> when using Google (search, GMail ...). Is there any truly 
> anonymous P2P 
> systems out there ? At least there are undergoing development 
> for such 
> systems. Correlation is really a pain in the *ss, Google 
> correlates all 
> your search and your mail and store that on the database, it 
> knows you 
> better than you know yourself. Once that database leaks, or 
> got seized 
> by the police, your privacy is seriously violated, and worse thing is 
> that nothing you can do about it. P2P behaves much better in this 
> situation, as your activity (search) were distributed among all other 
> peers, and they won't be interested in keeping your (log) 
> information at 
> all. It's also hard for the police to track down your activity on the 
> net; they'd have to look at other peers' computers as well, and those 
> peers will definitely not give in easily.
> 
>   In summary, my big question is, will there really be a 
> bright future 
> for P2P ?
> 
> _______________________________________________
> P2prg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/p2prg
> 
> 

_______________________________________________
P2prg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2prg

---

From: Tien Tuan Anh Dinh <[email-masked]>
Date: Mon, 23 Oct 2006 10:24:03 +0100

Hi,
According to the paper "The google cluster architecture", in
labs.*google*.com/papers/*google**cluster*-ieee.pdf

Google divided its network to many clusters, each cluster has some web
servers which forward queries to an index (sub)cluster and an document
(sub)cluster. This architecture is fairly distributed, but i don't think
it's P2P, and definitely not DHT

Kellerer, Wolfgang wrote:
> What, if it turns out that Google uses a Peer-to-Peer system, e.g.,
DHT-like system, behind their servers? I don't know details just trying
to turn your view around.
> SPMS 2007 - The 3rd Intl. Workshop on Next Generation Service Platforms
for Future Mobile Systems, in conjunction with SAINT 2007, Hiroshima,
Japan, January 15-19, 2007
http://www.docomoeurolabs.de/callforpaper_SAINT_SPMS2007.html

---

From: Rob Sherwood <[email-masked]>
Date: Mon, 23 Oct 2006 10:56:52 -0400

On Mon, Oct 23, 2006 at 10:24:03AM +0100, Tien Tuan Anh Dinh wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Hi,

As a data point:

If you read the Google File system paper, they claim that clusters of
sufficient size experience continuous churn from machine failures and
thus are effectively P2P systems.  If you have a component that fails
with probability 0.00001 but you have 100000 such components, you will
have a consistant and steady failures, similar to P2P.

http://labs.google.com/papers/gfs.html

- Rob
.