Subject: [p2p-sip] about DHT in p2p sip

From: threelions0916 at yahoo.com.cn (threelions)
Date: Tue Oct 18 04:35:56 2005

Hello£¬every one, I am a new guy to the p2p sip mailing list, very glad to meet you all .

I have read the Internet draft" A P2P Approach to SIP Registration draft-bryan-sipping-p2p-01 ¡±£¬this draft use the chord like DHT as the p2p algorithm,  DHT must maintain a structured p2p overlay on the IP network, so the join and leave of node will put a processing burden on the other nodes. and we know computers go online and offline frequently, it's said the average online time of pc on Internet is 1 hour, if the p2p network is big enough that several thousands of node are in the chord ring, then the change of chord topology is very frequent, this will greatly reduce the efficiency of chord. 

so my question is if the p2p sip using DHT mainly focus on the enterprise network, not Internet ? or is there any other methods that can be used to solve the efficiency problem? 

regards

===============================
Michael Liu
new technology department
china netcom shanghai branch
UPT:(86-21)61125030
Email: [email-masked]
msn:[email-masked]
CCIE#13438

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20051018/c54b98f8/attachment.html

---

From: bryan at ethernot.org (David A. Bryan)
Date: Tue Oct 18 10:18:30 2005

There has definitely been some discussion about different mechanisms
on this list and among the participants. I choose Chord in the draft
you mentioned because it is one of the most common, as well as best
understood DHT algorithms, so it made the draft a bit clearer I think,
since lots of people understand Chord already. I also think it is very
well suited to the enterprise space.

Chord does place some burden on the nodes for leaves and joins,
although the developers of Chord also worked to make it as efficient
as possible under those circumstances. It also has some issues with
partitioning. I think there are certainly other DHT systems that will
make sense as well -- personally I like the idea that different
systems could be used, but also think we need to do it in a way that
is standardized to make sure different nodes can interoperate -- if
every manufacturer uses a different DHT, it would be unlikely any
devices would be able to interoperate.

I guess the answer is that there certainly different methods one could
use, and different methods likely have tradeoffs in terms of
simplicity, efficiency, scalability and lookup speed. Chord is just
one possibility.

David

On 10/18/05, threelions <[email-masked]> wrote:
>
>
> Hello?every one, I am a new guy to the p2p sip mailing list, very glad to
> meet you all .
>
> I have read the Internet draft" A P2P Approach to SIP Registration
> draft-bryan-sipping-p2p-01 "?this draft use the chord like DHT as the p2p
> algorithm,  DHT must maintain a structured p2p overlay on the IP network, so
> the join and leave of node will put a processing burden on the other nodes.
> and we know computers go online and offline frequently, it's said the
> average online time of pc on Internet is 1 hour, if the p2p network is big
> enough that several thousands of node are in the chord ring, then the change
> of chord topology is very frequent, this will greatly reduce the efficiency
> of chord.
>
> so my question is if the p2p sip using DHT mainly focus on the enterprise
> network, not Internet ? or is there any other methods that can be used to
> solve the efficiency problem?
>
> regards
>
>
> _______________________________________________
> p2p-sip mailing list
> [email-masked]
> http://lists.cs.columbia.edu/mailman/listinfo/p2p-sip
>
>
>

---

From: threelions0916 at yahoo.com.cn (threelions)
Date: Wed Oct 19 05:55:09 2005

thank david for the quick response,  it seems a little funny that DHT were introduced to solve the problem of unstructured p2p algorithm, such as  the limited scalability because of too much broadcast and blind search . but we learn from practice that the pure unstructured or hybrid unstructured p2p such as glutenna$B!"(Bkazza$B!"(Bskype can support millions of people simulteneously online , however no DHT based p2p application can do this until now.

I want to learn from david and other experts if I want to build a large p2p network for service provider , is the unstructured or hybrid unstructured p2p algorithm the practical choice? or some dht algorithm can do this in the near future?

regards.

Michael

----- Original Message ----- 
From: "David A. Bryan" <[email-masked]>
To: "threelions" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, October 18, 2005 10:18 PM
Subject: Re: [p2p-sip] about DHT in p2p sip

> > Hello$B!$(Bevery one, I am a new guy to the p2p sip mailing list, very glad to
> > meet you all .
> >
> > draft-bryan-sipping-p2p-01 "$B!$(Bthis draft use the chord like DHT as the p2p
���������������������������������������b��j(�������������������������������������m���r�j)�ɨh��(���