Subject: [p2p-sip] Issue #6 NAT Traversal milestone

From: dromasca at avaya.com (Romascanu, Dan (Dan))
Date: Tue, 31 Jan 2006 16:58:13 +0200

Personally I prefer to list the deliverables and mention in brackets (if
needed), so that we have a clear idea what and when to do this if the
situation asks. Regards, Dan

> -----Original Message-----
> From: Eunsoo Shim [mailto:eunsoo at research.panasonic.com] 
> Sent: Tuesday, January 31, 2006 4:53 PM
> To: Romascanu, Dan (Dan)
> Cc: Philip Matthews; Dean Willis; Juergen Quittek; Michael 
> Slavitch; Roy, Radhika R.; P2P-SIP
> Subject: Re: [p2p-sip] Issue #6 NAT Traversal milestone
> 
> A deliverable for that was not listed because we are not sure 
> yet about the need.
> The same logic was applied to requirements for SIP extensions.
> If we need to define such requirements, I think writing a 
> draft would be a good way as you said.
> But wouldn't it be OK to leave the deliverables open in the 
> current situation?
> What do you think?
> Thanks.
> 
> Eunsoo
> 
> Romascanu, Dan (Dan) wrote:
> 
> >So, if there will be a need to 'define requirements for 
> enhancements of 
> >existing techniques to be acted on by other working groups', 
> how will 
> >this be convened? Probably by an Internet-Draft. It may be good to 
> >mention this explicitly as a deliverable.
> >
> >Regards,
> >
> >Dan
> >
> >
> > 
> > 
> >
> >  
> >
> >>-----Original Message-----
> >>From: p2p-sip-bounces at cs.columbia.edu 
> >>[mailto:p2p-sip-bounces at cs.columbia.edu] On Behalf Of 
> Philip Matthews
> >>Sent: Tuesday, January 31, 2006 1:32 PM
> >>To: Eunsoo Shim; Dean Willis; Juergen Quittek; Michael 
> Slavitch; Roy, 
> >>Radhika R.
> >>Cc: P2P-SIP
> >>Subject: Re: [p2p-sip] Issue #6 NAT Traversal milestone
> >>
> >>
> >>I am OK with this wording.
> >>
> >>
> >>Why don't we wait a day to see if anyone has any 
> objections, and, if 
> >>not, declare consensus on this resolution to the issue?
> >>
> >>
> >>- Philip
> >>
> >>
> >>
> >>On 30-Jan-06, at 16:37 , Eunsoo Shim wrote:
> >>
> >>    
> >>
> >>>The wording by Juergen is OK with me, too.
> >>>So far, no one objected to adding such a statement into 
> the charter 
> >>>draft.
> >>>Philip expressed a concern about it (saying it does not add
> >>>      
> >>>
> >>anything
> >>    
> >>
> >>>new) but I see from his email that he is willing to accept
> >>>      
> >>>
> >>the change. 
> >>    
> >>
> >>>Philip, please correct me if I am wrong here.
> >>>I believe we agree on what the statement should say and
> >>>      
> >>>
> >>there are only
> >>    
> >>
> >>>subtle differences in wording.
> >>>These subtle differences of wording should not prevent us
> >>>      
> >>>
> >>from moving
> >>    
> >>
> >>>forward.
> >>>
> >>>Dean and David, if appropriate, would you mind integrating the 
> >>>proposed statement into the charter draft and posting the
> >>>      
> >>>
> >>new revised
> >>    
> >>
> >>>draft?
> >>>Thanks.
> >>>
> >>>Eunsoo
> >>>
> >>>Dean Willis wrote:
> >>>
> >>>      
> >>>
> >>>>On Jan 30, 2006, at 7:47 AM, Juergen Quittek wrote:
> >>>>
> >>>>
> >>>>        
> >>>>
> >>>>>5.  Select firewall/NAT traversal technique(s) for P2P SIP and   
> >>>>>integrate them
> >>>>>    into the P2P SIP architecture or framework.  If necessary,   
> >>>>>define requirements
> >>>>>    for enhancements of existing techniques to be acted
> >>>>>          
> >>>>>
> >>on by other
> >>    
> >>
> >>>>>working groups.
> >>>>>          
> >>>>>
> >>>>This is also acceptable to me, and I think it might draw
> >>>>        
> >>>>
> >>less fire
> >>    
> >>
> >>>>from the IAB than the previous formulation.
> >>>>
> >>>>--
> >>>>Dean
> >>>>
> >>>>        
> >>>>
> >>_______________________________________________
> >>p2p-sip mailing list
> >>p2p-sip at cs.columbia.edu
> >>https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip
> >>
> >>    
> >>
> 
>

---

From: dean.willis at softarmor.com (Dean Willis)
Date: Tue, 31 Jan 2006 12:10:32 -0600

> situation asks. Regards, Dan

Of course, the problem is that we don't yet know exactly what  
extensions we will need to propose or request. Therefore, it's hard  
to build specific deliverables and milestones into the charter.

We could explicitly describe the work process around this, something  
like:

It is expected that the work of the P2P-SIP group may require  
extensions to other IETF protocols, including SIP and its supporting  
mechanisms for NAT traversal. When these requirements are identified  
by the P2P-SIP group they will be communicated to the responsible  
working group via the change process appropriate to that working  
group or protocol. In most cases this communication will take the  
form of an internet-draft outlining the problem, use cases, and  
requirements to be met.

How's that?

--
Dean

---

From: philip_matthews at magma.ca (Philip Matthews)
Date: Tue, 31 Jan 2006 13:40:59 -0500

Dean:

Where would you put this paragraph?

How do you feel about the following?

OLD:

	The working group will operate in close cooperation with the SIP,
	SIPPING, SIMPLE, MMUSIC and BEHAVE working groups, as well as the
	IRTF. Respecting the IETF specification change policy, the working
	group will refer any possible changes or extensions as suggestions to
	the appropriate WGs as needed. A guiding principal of the WG will be
	to avoid extensions or change wherever possible.

NEW:

	The working group will operate in close cooperation with the SIP,
	SIPPING, SIMPLE, MMUSIC and BEHAVE working groups, as well as the
	IRTF. It is expected that the work of the P2P-SIP group may require
	extensions to other IETF protocols, including SIP and its supporting
	mechanisms for NAT traversal. When these requirements are identified
	by the P2P-SIP group they will be communicated to the responsible
	working group via the change process appropriate to that working group
	or protocol. In most cases this communication will take the form of an
	internet-draft outlining the problem, use cases, and requirements to b
	met. A guiding principal of the WG will be to avoid extensions or  
change
	wherever possible.

Does this work?

- Philip

On 31-Jan-06, at 13:10 , Dean Willis wrote:

> We could explicitly describe the work process around this,  
> something like:
>
> extensions to other IETF protocols, including SIP and its  
> supporting mechanisms for NAT traversal. When these requirements  
> are identified by the P2P-SIP group they will be communicated to  
> the responsible working group via the change process appropriate to  
> that working group or protocol. In most cases this communication  
> will take the form of an internet-draft outlining the problem, use  
> cases, and requirements to be met.
>
> How's that?
>
> --
> Dean

---

From: slavitch at gmail.com (Michael Slavitch)
Date: Tue, 31 Jan 2006 15:16:05 -0500

It does indeed. Thank you.

On 31/01/06, Philip Matthews <philip_matthews at magma.ca> wrote:
> supporting
> group

--
Michael Slavitch
Ottawa, Ontario Canada
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060131/c0fe25c5/attachment.html

---

From: eunsoo at research.panasonic.com (Eunsoo Shim)
Date: Tue, 31 Jan 2006 16:36:19 -0500

It looks good to me, as well.

Eunsoo

Michael Slavitch wrote:

> On 31/01/06, *Philip Matthews* <philip_matthews at magma.ca
> <mailto:philip_matthews at magma.ca>> wrote:
>
>     Dean:
>