Subject: [p2p-sip] OpenWengo

From: jack at fauche.org (Aymeric Moizard)
Date: Tue, 10 Jan 2006 13:46:38 +0100 (CET)

On Mon, 9 Jan 2006, Enrico Marocco wrote:

> Henning Schulzrinne wrote:
>> Another SIP client, but open source: http://www.openwengo.com/
> 
> It looks very skypish :-)

and based on deprecated source of eXosip...

>> Does not appear to run in p2p mode, but might be a basis for experiments
>> in that space, given the GPL license.
> 
> I completely agree that an open source approach would be great for both
> supporting the specification and facilitating its adoption. However, I
> think it would be most useful (and maybe easyer) to implement the p2p
> support on an existing open source stack; in this way, test applications
> will be simple and won't have to care about complex gui stuff, while the
> (as minimal as possible) effort to add p2p features to existing programs
> using that stack, can be made by official developers.
> 
> Is anyone interested in such a kind of project?

I maintain the eXosip stack. (http://www.antisip.com/download/)
It's wriiten in C, portable, simple to use, simple to extend and it's GPL code.

I would (and will anyway) personally help much for adding p2p support in it.

Aymeric

> Among available stacks, my preference would go to nokia's sofia-sip
> (http://sofia-sip.sourceforge.net/), which is pretty modular and well
> documented.
> 
> Cheers
> Enrico
> 
> 
> Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.
> 
> ====================================================================
> CONFIDENTIALITY NOTICE
> This message and its attachments are addressed solely to the persons
> above and may contain confidential information. If you have received
> the message in error, be informed that any use of the content hereof
> is prohibited. Please return it immediately to the sender and delete
> the message. Should you have any questions, please send an e_mail to
> MailAdmin at tilab.com. Thank you
> ====================================================================
> 
> _______________________________________________
> p2p-sip mailing list
> p2p-sip at cs.columbia.edu
> https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip
>

---

From: Kasthuriram_V at infosys.com (Kasthuri Ram V.)
Date: Tue, 10 Jan 2006 17:39:36 +0530

> I would (and will anyway) personally help much for adding p2p support in it.

Sure. That would be great!

I was exploring eXosip a few days back. Only thing that put me off with
eXosip was that I couldn't find enough documentation on it. Would be
glad if a good documentation is available. (If one is not available,
atleast a wiki on antisip site would have helped things).

Cheers,
Ram
--

> > Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the use of the addressee(s). If you are not the intended recipient, please notify the sender by e-mail and delete the original message. Further, you are not to copy, disclose, or distribute this e-mail or its contents to any other person and any such actions are unlawful. This e-mail may contain viruses. Infosys has taken every reasonable precaution to minimize this risk, but is not liable for any damage you may sustain as a result of any virus in this e-mail. You should carry out your own virus checks before opening the e-mail or attachment. Infosys reserves the right to monitor and review the content of all messages sent to or from this e-mail address. Messages sent to or from this e-mail address may be stored on the Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***

---

From: eunsoo at research.panasonic.com (Eunsoo Shim)
Date: Tue, 10 Jan 2006 09:33:09 -0500

This is great.
It is a fantastic idea to have an open source stack supporting the 
(future) P2P SIP spec the IETF will come up.

BTW, I am interested in Java-based implementation. Would anyone 
recommend any particular Java-based SIP stack implementation?
Thanks.

Eunsoo

---

From: lists at bulukucing.org (Benny Prijono)
Date: Tue, 10 Jan 2006 14:59:23 +0000

> (future) P2P SIP spec the IETF will come up.

Now if only the spec is available so that us mere programmers can 
begin to code.. ;)

> recommend any particular Java-based SIP stack implementation?

I personally like JAIN SIP. The design is good, with clear separation 
from stateless message, transaction layer, and dialog layer. At least 
from what I read from the documentation, which is excellent btw. An 
open source JAIN SIP stack is also available:

http://snad.ncsl.nist.gov/proj/iptel/

regards,
Benny

---

From: ssal at intracom.gr (Sotiris Salloum)
Date: Tue, 10 Jan 2006 17:03:49 +0100

Hi, 

Jain SIP from NIST, 

http://java.sun.com/products/jain/certprod_table.html 

https://jain-sip.dev.java.net/ 

Regards

Sotiris Salloum MSc.
Staff Engineer 
R&D INTRACOM SA - Content Delivery System 
Athens, Greece 
19002, www.intracom.com

-----Original Message-----
From: p2p-sip-bounces at cs.columbia.edu
[mailto:p2p-sip-bounces at cs.columbia.edu] On Behalf Of Eunsoo Shim
Sent: Tuesday, January 10, 2006 3:33 PM
To: Aymeric Moizard
Cc: p2p-sip at cs.columbia.edu
Subject: Re: [p2p-sip] OpenWengo

This is great.

Eunsoo

---

From: eunsoo at research.panasonic.com (Eunsoo Shim)
Date: Tue, 10 Jan 2006 10:18:59 -0500

> Now if only the spec is available so that us mere programmers can 
May the WG be formed soo..n!

> http://snad.ncsl.nist.gov/proj/iptel/
Thanks for the information about JAIN SIP stack.
Regards,

Eunsoo

---

From: jack at fauche.org (Aymeric Moizard)
Date: Tue, 10 Jan 2006 17:26:42 +0100 (CET)

>> I maintain the eXosip stack. (http://www.antisip.com/download/) It's 
>> wriiten in C, portable, simple to use, simple to extend and it's GPL 
>> code.
>>

http://www.antisip.com/documentation/eXosip2

Then, for howto:

http://www.antisip.com/documentation/eXosip2/modules.html

The doc is doxygen generated and thus included in the code.
Aymeric

---

From: enrico.marocco at TILAB.COM (Enrico Marocco)
Date: Wed, 11 Jan 2006 10:37:22 +0100

> Now if only the spec is available so that us mere programmers can 

But code is also needed by writers for refining their specs: we're
trapped :-)

I think it would be useful to start coding the draft spec (some work has
been done at Columbia and at William And Mary, but it's not open source)
for contributing feedback and suggestions. In this way, keeping alingned
coding and writing, we should end with good code and complete specs.

Enrico