Subject: [p2p-sip] NATs and P2P

From: effis at dsp.co.il (Effi Shiri)
Date: Tue, 21 Mar 2006 14:22:50 +0200

One more thing, what is the most common type of NAT? 
(Symmetric, Full Coned, Address Restricted or Port Restricted)

Thanks

-----Original Message-----
From: Zhou Ya Jin [mailto:l4hurd at 163.com] 
Sent: Tuesday, March 21, 2006 2:16 PM
To: Effi Shiri
Cc: p2p-sip at cs.columbia.edu
Subject: Re: [p2p-sip] NATs and P2P

As far as I know, in China, we use  NAT_traversal to connect two parts
of P2P software.  You can find more information at information at
http://en.wikipedia.org/wiki/NAT_traversal. 
Technically, you can say this is not P2P anymore because it needs
another server who has public IP.  :)

----- Original Message ----- 
From: "Effi Shiri" <effis at dsp.co.il>
To: "Zhou Ya Jin" <l4hurd at 163.com>; <p2p-sip at cs.columbia.edu>
Sent: Tuesday, March 21, 2006 7:59 PM
Subject: RE: [p2p-sip] NATs and P2P

Thanks Zhou!

So if most people do not have Public addresses, I guess the whole p2p is
not p2p anymore? 

-----Original Message-----
From: Zhou Ya Jin [mailto:l4hurd at 163.com] 
Sent: Tuesday, March 21, 2006 1:44 PM
To: Effi Shiri; p2p-sip at cs.columbia.edu
Subject: Re: [p2p-sip] NATs and P2P

Actually in China, many internet user does not have public IP. As far as
I am concerned, people in my office share a public IP. We use a router
for NAT.
----- Original Message ----- 
From: "Effi Shiri" <effis at dsp.co.il>
To: <p2p-sip at cs.columbia.edu>
Sent: Tuesday, March 21, 2006 4:22 PM
Subject: Re: [p2p-sip] NATs and P2P

> 
> 
> This is very interesting
> Do you have statistics on how many Home users actually have Public IP?
> 
> 
> -----Original Message-----
> From: p2p-sip-bounces at cs.columbia.edu
> [mailto:p2p-sip-bounces at cs.columbia.edu] On Behalf Of Philip Matthews
> Sent: Tuesday, March 21, 2006 2:36 AM
> To: P2P-SIP
> Subject: [p2p-sip] NATs and P2P
> 
> [I guess all this traffic on the mailing list will teach me not to go

> on vacation
> just before an IETF meeting!]
> 
> As I catch up on all the messages about NATs over the past two weeks,
> it seems to me that many people are thinking only of the "Public P2P  
> Service Provider"
> use-case as described in the use-cases document. In other words, a
Skype
> competitor.
> 
> However, the use-cases document that David Bryan and his co-authors  
> wrote
> identified a number of other use-cases and it seems to me that these  
> have somewhat
> different NAT traversal requirements.
> 
> In particular, in some of these other use-cases, it seems to me that  
> we CANNOT assume
> there are peers with public IP addresses.
> 
> For example, consider the "Presence using Multimedia Consumer  
> Electronics Devices"
> use-case (section 3.1.3) -- essentially a P2P network of multimedia  
> consumer electronics devices
> that need presence information. Who is going to pay the extra money  
> to give their digital camera (or those
> neat 770 tablets that Nokia is demoing here in Dallas?) a public IPv4

> address?? On the contrary,
> devices like this are almost certainly going to have private IP  
> addresses -- it is very common today for
> wireless internet providers to place a big NAT in front of their  
> entire network and give private addresses
> to all their customers.
> 
> Or consider the "IP PBX" use-case -- a IP PBX system for a company  
> with a number of small branches
> scattered throughout the world. Each branch is going to have a NAT in

> front of its network, and all
> the phones in that branch are going to have private IP addresses.  
> None of the phones are going to
> have public IP addresses.
> 
> It is handling the NAT traversal issues for use-cases like these that

> Eric Cooper and I wrote our
> internet-draft on NAT Traversal for P2P:
>       http://www.ietf.org/internet-drafts/draft-matthews-p2psip-nats- 
> and-overlays-00.txt
> 
> - Philip
> 
> _______________________________________________
> p2p-sip mailing list
> p2p-sip at cs.columbia.edu
> https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip
> 
> ______________________________________________________________________
> DSP Group LTD. automatically scans all emails and attachments using
> MessageLabs Email Security System.
> ______________________________________________________________________
> 
> _______________________________________________
> p2p-sip mailing list
> p2p-sip at cs.columbia.edu
> https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip
> 
> 
> __________ NOD32 1.1452 (20060320) Information __________
> 
> This message was checked by NOD32 antivirus system.
> http://www.eset.com
> 
>

______________________________________________________________________
DSP Group LTD. automatically scans all emails and attachments using
MessageLabs Email Security System.
______________________________________________________________________

__________ NOD32 1.1452 (20060320) Information __________

This message was checked by NOD32 antivirus system.
http://www.eset.com

______________________________________________________________________
DSP Group LTD. automatically scans all emails and attachments using
MessageLabs Email Security System.
______________________________________________________________________

---

From: l4hurd at 163.com (Zhou Ya Jin)
Date: Tue, 21 Mar 2006 20:43:07 +0800

Most of NAT in china is Full Coned.  That is based on my knowledeg, maybe not correct.
----- Original Message ----- 
From: "Effi Shiri" <effis at dsp.co.il>
To: "Zhou Ya Jin" <l4hurd at 163.com>
Cc: <p2p-sip at cs.columbia.edu>
Sent: Tuesday, March 21, 2006 8:22 PM
Subject: RE: [p2p-sip] NATs and P2P

Thanks

----- Original Message ----- 
From: "Effi Shiri" <effis at dsp.co.il>
To: "Zhou Ya Jin" <l4hurd at 163.com>; <p2p-sip at cs.columbia.edu>
Sent: Tuesday, March 21, 2006 7:59 PM
Subject: RE: [p2p-sip] NATs and P2P

Thanks Zhou!

----- Original Message ----- 
From: "Effi Shiri" <effis at dsp.co.il>
To: <p2p-sip at cs.columbia.edu>
Sent: Tuesday, March 21, 2006 4:22 PM
Subject: Re: [p2p-sip] NATs and P2P

Skype