Subject: [p2p-sip] SIP, ICE, and an Overlay Network

From: effis at dsp.co.il (Effi Shiri)
Date: Thu, 16 Mar 2006 12:59:26 +0200

Hi all,

Does anyone have statistic on how many home users are not behind NAT?

-----------------------------

On 3/16/06, Karst Bjorgson <karstbj at yahoo.com> wrote:

--- Jonathan Rosenberg <jdrosen at cisco.com> wrote:

> Now, in terms of p2p nat traversal for SIP itself,
> the sip-outbound
> mechanism works just fine for p2p sip as well. The 
> difference is that
> the proxy is just another host in the mesh. Of
> course, it better be one
> on the public network so everyone can reach it, else
> you will not be
> able to get incoming calls from everyone. 

I am sorry, but I don't get it. If the "P2P" in P2PSIP
has any meaning, we are speaking of a network where
there are no proxies. 

In case where a UA is behind a NAT (and can't take part in the P2P
overlay), an ordinary node / super node architecture could be set up. A
super node would act as a proxy (with outbound support) for a set of
ordinary nodes in order to traverse NAT for SIP signaling. 

Marc

______________________________________________________________________
DSP Group LTD. automatically scans all emails and attachments using
MessageLabs Email Security System.
______________________________________________________________________

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060316/3923a397/attachment.html

---

From: marc.bailly at gmail.com (Marc Bailly)
Date: Thu, 16 Mar 2006 12:22:38 +0100

Effi,

As it was mentionned by Salman a few days ago :
- 50% of broadband US/UK MSN users behind NAT,
http://research.microsoft.com/~pablo/papers/CCR.pdf<http://research.microsoft.com/%7Epablo/papers/CCR.pdf>(CCR
Jan 2006)
- According to Nielsen ratings 2 out of 5 Americans have broadband access at
home. http://www.nielsen-netratings.com/pr/pr_050928.pdf

In France for example, I don't know the number but all ISPs now offer ADSL
boxes with a NAT function so the proportion of natted users increases every
day.

Marc

On 3/16/06, Effi Shiri <effis at dsp.co.il> wrote:
> On 3/16/06, *Karst Bjorgson* < karstbj at yahoo.com> wrote:
>
>
>
> _______________________________________________
> p2p-sip mailing list
> p2p-sip at cs.columbia.edu
> https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip
>
>
>

--
-------------------
Marc Bailly
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060316/c990c691/attachment-0001.html