Subject: [p2p-sip] SIP, ICE, and an Overlay Network

From: BeckW at t-systems.com (Beck01, Wolfgang)
Date: Thu, 16 Mar 2006 14:58:58 +0100

>  > Heh, yes. Or vice versa, finally defining that DO method 
> to SIP for  > carrying XMLRPC. :)
> 
> i don't know about do.  what i meant is that you map INVITE 
> to XML-RPC function called sip.INVITE, etc.  then SIP Proxy 
> would become an XML-RPC server, which listens at port 80 and/or 443.
> 
> -- juha
Why not REST?

GET http://example.com/INVITE/bob/

Wolfgang

---

From: ggb at tid.es (Gustavo García Bernardo)
Date: Thu, 16 Mar 2006 15:35:43 +0100

In my opinion, we first should define if P2P SIP should work through HTTP
proxies, only HTTPS proxies or none of them.   Not only for SIP messages,
but also for DHT and RTP messages....

As someone has said before, these are "politically incorrect" things...

In any case, I think this feature is a minor detail and doesn't change the
P2P SIP architecture which should be defined before discussing this kind of
details.

G.

> -----Mensaje original-----
> De: p2p-sip-bounces at cs.columbia.edu [mailto:p2p-sip-
> bounces at cs.columbia.edu] En nombre de Beck01, Wolfgang
> Enviado el: jueves, 16 de marzo de 2006 14:59
> Para: jh at tutpro.com; aki.niemi at nokia.com
> CC: p2p-sip at cs.columbia.edu
> Asunto: Re: [p2p-sip] SIP, ICE, and an Overlay Network
> 
> 
> 
> _______________________________________________
> p2p-sip mailing list
> p2p-sip at cs.columbia.edu
> https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip