Subject: [p2p-sip] Questions on #5 "A P2P SIP Arch - 2 layer approach".

From: ksankar at cisco.com (Krishna Sankar (ksankar))
Date: Wed, 29 Mar 2006 19:32:25 -0800

Folks,

	Have some quick questions on slide #5 "A P2P SIP Arch - 2 layer
approach". I assume:

	a)	This is could be a network topology, definitely not a
logical topology.
	b)	ONs & SNs are all SIP end-points and will be hashed as
per Chord algorithm.
	c)	So even though there could be a visibility and
reachability association between specific SNs and ONs, the P2P substrate
will not reflect this, as the hash could place them in different areas
in the ring. In fact, if the hash didn't, it will degenerate to a
routing table (not that that is bad, but that is not what we want to
achieve at a macro level)
	d)	Hopefully this diagram is not overloaded with NAT
traversal as well. In that case, the SN will represent the ONs which
hang off of it. In this case the hashing will happen on the ON name but
the IP address will be that of the associated SN. The SN knows how to
get to the Ones it represents.
	e)	Extending a) further, the Chord ring representation of
this diagram will be very different.

Cheers
<k/>

---

From: eunsoo at research.panasonic.com (Eunsoo Shim)
Date: Thu, 30 Mar 2006 16:38:40 -0500

>	b)	ONs & SNs are all SIP end-points and will be hashed as
ON and SN are NOT SIP entities.
ONs do not participate in DHT.

>achieve at a macro level)
ONs are not in the (Chord) ring.

>get to the Ones it represents.
The diagram is not overloaded with NAT traversal.

>this diagram will be very different.
Please see the answers in the above.

Thanks.

Eunsoo