Subject: [p2p-sip] Problem statement for P2P SIP NAT traversal

From: RBrown at talkswitch.com (Rob Brown)
Date: Mon, 6 Mar 2006 21:39:57 -0500

Agreed.  IPv4 must be supported.

Regards,
Robert Brown
TalkSwitch

> -----Original Message-----
> From: p2p-sip-bounces at cs.columbia.edu 
> [mailto:p2p-sip-bounces at cs.columbia.edu] On Behalf Of Eunsoo Shim
> Sent: March 6, 2006 9:33 PM
> To: Michael Slavitch
> Cc: P2P-SIP
> Subject: Re: [p2p-sip] Problem statement for P2P SIP NAT traversal
> 
> I strongly believe support for IPv4 is a must.
> Thanks.
> 
> Eunsoo
> 
> Michael Slavitch wrote:
> 
> > Are you serious? How many ISP's offer IPV6?  How many organizations 
> > outside academe and a few large enterprises?
> > Do you realize how many people in the real world still use Windows 
> > 2000 and Windows 98, including some very large organizations?
> > Given past history Vista will  run on the majority of 
> Windows desktop 
> > systems starting around  2010-2011, and that is optimistic.
> >
> > In the meantime, Skype works now.
> >
> > If P2PSIP is limited to IPV6 we might as well call it a day 
> right now 
> > and start licensing runtime modules from Skype.
> >
> >
> > On 3/6/06, * Frederick Lefebvre* <fred at perspectiveip.ca 
> > <mailto:fred at perspectiveip.ca>> wrote:
> >
> >     What about mandating the use IPv6 and leave the NAT 
> traversal issue to
> >     the IPv6 transition mechanism used?  Wouldn't it make the
> >     implementation of p2p-sip easier if the protocol did 
> not have to work
> >     around NATs?
> >     Of course, feel free to wonder if this is a realistic 
> proposal or not.
> >     But with the upcoming Windows Vista, all of a sudden a 
> fairly large
> >     percentage of users will have V6 connectivity and it 
> might not sound
> >     so crazy anymore.
> >
> >     -- Fred
> >
> >     On 3/6/06, Karst Bjorgson <karstbj at yahoo.com
> >     <mailto:karstbj at yahoo.com>> wrote:
> >     > > >Do you know if there is any intent for Teredo to
> >     > > support symmetric NATs?
> >     > > >I'd suggest this be a base requirement for P2P-SIP.
> >     >
> >     > I am pretty sure that a Teredo implementation could be
> >     > tuned to work through a lot of symmetric NAT, or at
> >     > least in the symmetric to non-symmetric cases. But, as
> >     > Jonathan said, IPv6 should be supported as an option.
> >     > The combination of IPv4 and IPv6 will work more often
> >     > than IPv4 alone.
> >     >
> >     > -- Karst
> >     >
> >     > __________________________________________________
> >     > Do You Yahoo!?
> >     > Tired of spam?  Yahoo! Mail has the best spam 
> protection around
> >     > http://mail.yahoo.com
> >     > _______________________________________________
> >     > p2p-sip mailing list
> >     > p2p-sip at cs.columbia.edu <mailto:p2p-sip at cs.columbia.edu>
> >     > https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip
> >     <https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip>
> >     >
> >
> >     _______________________________________________
> >     p2p-sip mailing list
> >     p2p-sip at cs.columbia.edu <mailto:p2p-sip at cs.columbia.edu>
> >     https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip
> >
> >
> >
> >
> > --
> > Michael Slavitch
> > Ottawa, Ontario Canada
> >
> >-------------------------------------------------------------
> ----------
> >-
> >
> >_______________________________________________
> >p2p-sip mailing list
> >p2p-sip at cs.columbia.edu
> >https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip
> >  
> >
> 
> _______________________________________________
> p2p-sip mailing list
> p2p-sip at cs.columbia.edu
> https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip
>

---

From: tme at multicasttech.com (Marshall Eubanks)
Date: Mon, 6 Mar 2006 21:49:01 -0500

I agree too. Anyone who does not should audit the current discussion  
on NANOG.

Regards
Marshall Eubanks