Subject: [p2p-sip] SIP, ICE, and an Overlay Network

From: RADHIKA.R.ROY at saic.com (Roy, Radhika R.)
Date: Thu, 16 Mar 2006 12:00:01 -0500

G:
 
I think that it is an interesting discussion for working of P2P-SIP with
HTTP proxies.
 
SIP has hired all the things that HTTP does, only in different context: SIP
is almost like P2P keeping primarily human users in mind, while HTTP is a
client-server model.
 
Semantically, many things of SIP will find appropriate place in HTTP
although the syntaxes might be different, and in this way, at least, P2P-SIP
will also be able to work with HTTP proxies, I believe.
 
Best regards,
Radhika

  _____  

From: p2p-sip-bounces at cs.columbia.edu on behalf of Gustavo Garc?a Bernardo
Sent: Thu 3/16/2006 9:35 AM
To: Beck01, Wolfgang
Cc: p2p-sip at cs.columbia.edu
Subject: Re: [p2p-sip] SIP, ICE, and an Overlay Network

In my opinion, we first should define if P2P SIP should work through HTTP 
proxies, only HTTPS proxies or none of them.   Not only for SIP messages, 
but also for DHT and RTP messages.... 

As someone has said before, these are "politically incorrect" things... 

In any case, I think this feature is a minor detail and doesn't change the 
P2P SIP architecture which should be defined before discussing this kind of 
details. 

G.

---

From: slavitch at gmail.com (Michael Slavitch)
Date: Thu, 16 Mar 2006 11:06:16 -0800

Excellent observation.  If we have hired it, hire it well.

Michael

On 3/16/06, Roy, Radhika R. <RADHIKA.R.ROY at saic.com> wrote:
> _______________________________________________
> p2p-sip mailing list
> p2p-sip at cs.columbia.edu
> https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip
>

--
Michael Slavitch
Ottawa, Ontario Canada