Subject: [p2p-sip] __A_New_Internet-draft_is_available

From: jwshi at bupt.edu.cn (Juwei Shi)
Date: Thu, 24 Aug 2006 10:33:6 +0800

Yes, I agree with Seaward, hierarchically inter-connecting heterogeneous overlays is more practical than the mesh based approach. ¡¡¡¡

Interworking among heterogeneous hierarchical is more efficient than do it meshy, you can not expect a flat huge mesh over whole world can work reliably, the reason why mesh is used is the absence of a acceptable standard.

Thanks.

Seaward 

From: p2p-sip-bounces at cs.columbia.edu [mailto:p2p-sip-bounces at cs.columbia.edu] On Behalf Of K.Yamamoto
Sent: Thursday, August 24, 2006 2:16 AM
To: Juwei Shi; p2p-sip at cs.columbia.edu
Subject: Re: ?-?¡è: [p2p-sip] A New Internet-draft is available

WHEN NUMEROUS MULTI-OVERLAID NODES ARE INTERCONNECTED, "the interworking among heterogenous overlays" IS GENERALLY MESSY NOT HIERACHICAL. 

THANK YOU. --KYPLEASE QUALITY CONTROL LIKE BUILDING A LEXUS.
Juwei Shi <jwshi at bupt.edu.cn> wrote: 
The NAT issues will be discussed in our future drafts. 
This draft focuses on the interworking among heterogenous overlays and the SIP-over-P2P architecture in one single overlay is proposed by E. Shim etc. 
http://www.p2psip.org/drafts/draft-shim-sipping-p2p-arch-00.txt
Thanks
Juwei

??¡®????oo: K.Yamamoto [mailto:kyara543 at yahoo.com] 
??¡®¨¦€??¡ª?¨¦¡ª¡ä: 2006?1¡ä8???23?¡ª£¤ 12:21
?¡±?????oo: Juwei Shi; p2p-sip at cs.columbia.edu
???¨¦¡é?: Re: [p2p-sip] A New Internet-draft is available
THE DOCUMENT IS GORGEOUS BUT NEED RENAME AS "A MESHY ARCHITECTURE AMONG MULTIPLE P2P-SIP NETWORKS".
FOMULA "Node-ID=Hash(Node-IP)" HAS PROBLEM WITH MULTIPLE NODES BEHIND A NAT.  THERE IS LITTLE ABOUT P2P OR SIP, FOR ONE SINGLE OVERLAY.  THANK YOU.  --KY PLEASE QUALITY CONTROL LIKE BUILDING A LEXUS.

Juwei Shi <jwshi at bupt.edu.cn> wrote:
Hello, all
We have
 submitted a new Internet-draft entitled a€?A Hierarchical P2P-SIP Architecturea€?. This draft focuses on the SIP-over-P2P architecture and interworking of heterogeneous overlay networks. 
 
This document is available in the Internet-drafts archive now:
http://www3.ietf.org/internet-drafts/draft-shi-p2psip-hier-arch-00..txt
Comments are welcomed!
Thanks
Juwei
Juwei Shi 
Wireless Technology Innovation Institute (WTI)
Beijing Univ. of Posts and Telecommunications (BUPT)
Tel: +86-10-62283600 ext. 312
Email: jwshi at bupt.edu.cn
_______________________________________________
p2p-sip mailing list
p2p-sip at cs.columbia.edu
https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip

Yahoo! Messenger with Voice. Make PC-to-Phone Calls to the US (and 30+ countries) for 2?¡é/min or less.

Yahoo! Messenger with Voice. Make PC-to-Phone Calls to the US (and 30+ countries) for 2¡é/min or less. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060823/08964055/attachment-0001.html

---

From: kyara543 at yahoo.com (K.Yamamoto)
Date: Wed, 23 Aug 2006 21:02:16 -0700 (PDT)

I AGREE HIERARCHICAL MORE EASY AND DISLIKES MESS TOO.

BUT UNLESS YOU DELIBERATELY MANIPULATE EVERY MULTI-OVERLAY NODES SO THAT A NODE CAN SAY "HEY, MY CHORD STACK DOES NOT CONNECT WITH ANOTHER CHORD NODE ALSO IN PASTRY OVERLAY BUT CONNECT WITH THE OTHER CHORD NODE ALSO IN BT OVERLAY", OTHERWISE AUTONOMOUS INTERCONNECTION OF MULTI-OVERLAY NODES VERY POSSIBLY WILL FORM A CYCLIC MESH.

EXAMPLE: LETS DENOTE A NODE OF MULTI-OVERLAYS X AND Y AS XY. INTERCONNECT NODES ABC, AC AND BC FORMS A MESH.

WHEN YOU CAN MANIPULATE NODES OF MULTIPLE OVERLAYS, WHY NOT MANIPULATE THEM TO USE ONLY ONE OVERLAY? 

THANK YOU.

--KY
PLEASE QUALITY CONTROL LIKE BUILDING A LEXUS.

Juwei Shi <jwshi at bupt.edu.cn> wrote:      
 Yes, I agree with Seaward, hierarchically inter-connecting heterogeneous overlays is more practical than the mesh based approach.   

         
Thanks.

Seaward 

---------------------------------
           From: p2p-sip-bounces at cs.columbia.edu           [mailto:p2p-sip-bounces at cs.columbia.edu] On Behalf Of           K.Yamamoto
Sent: Thursday, August 24, 2006 2:16           AM
To: Juwei Shi; p2p-sip at cs.columbia.edu
Subject:           Re: ??0
2???: [p2p-sip] A New Internet-draft is           available

THANK YOU.
 
--KY
PLEASE QUALITY CONTROL LIKE BUILDING A LEXUS.
Juwei           Shi <jwshi at bupt.edu.cn> wrote:                                     v\:* {  BEHAVIOR: url(#default#VML) } o\:* {  BEHAVIOR: url(#default#VML) } w\:* {  BEHAVIOR: url(#default#VML) } .shape {  BEHAVIOR: url(#default#VML) }               st1\:* {  BEHAVIOR: url(#default#ieooui) }               @font-face {  font-family: ; } @font-face {  font-family: ???????; } @font-face {  font-family: @???????; } @page Section1 {size: 595.3pt 841.9pt; margin: 72.0pt 90.0pt 72.0pt 90.0pt; } P.MsoNormal {  TEXT-JUSTIFY: inter-ideograph; FONT-SIZE: 10.5pt; MARGIN: 0cm 0cm 0pt; FONT-FAMILY: "Times New Roman"; TEXT-ALIGN: justify } LI.MsoNormal {  TEXT-JUSTIFY: inter-ideograph; FONT-SIZE: 10.5pt; MARGIN: 0cm 0cm 0pt; FONT-FAMILY: "Times New Roman"; TEXT-ALIGN: justify } DIV.MsoNormal {  TEXT-JUSTIFY: inter-ideograph; FONT-SIZE: 10.5pt; MARGIN: 0cm 0cm 0pt; FONT-FAMILY: "Times New Roman"; TEXT-ALIGN: justify } A:link {  COLOR: blue; TEXT-DECORATION: underline } SPAN.MsoHyperlink {
  COLOR: blue; TEXT-DECORATION: underline } A:visited {  COLOR: purple; TEXT-DECORATION: underline } SPAN.MsoHyperlinkFollowed {  COLOR: purple; TEXT-DECORATION: underline } P {  FONT-SIZE: 12pt; MARGIN-LEFT: 0cm; MARGIN-RIGHT: 0cm; FONT-FAMILY: "Times New Roman"; mso-margin-top-alt: auto; mso-margin-bottom-alt: auto } PRE {  FONT-SIZE: 10pt; MARGIN: 0cm 0cm 0pt; FONT-FAMILY: "Courier New" } SPAN.EmailStyle19 {  COLOR: navy; FONT-FAMILY: Arial; mso-style-type: personal-reply } DIV.Section1 {  page: Section1 }                                      

             Thanks
             Juwei

---------------------------------
             
             ????????oo: K.Yamamoto             [mailto:kyara543 at yahoo.com] 
???????????????????:             2006?1??8???23?????             12:21
????????oo: Juwei Shi;             p2p-sip at cs.columbia.edu
????????: Re:             [p2p-sip] A New Internet-draft is available

FOMULA "Node-ID=Hash(Node-IP)" HAS PROBLEM WITH MULTIPLE NODES BEHIND A NAT.
 
 THERE IS LITTLE ABOUT P2P OR SIP, FOR ONE SINGLE OVERLAY.
 
 THANK YOU.
 
 --KY
 PLEASE QUALITY CONTROL LIKE BUILDING A LEXUS.

We have
 submitted a new Internet-draft entitled a???A Hierarchical P2P-SIP Architecturea???. This draft focuses on the SIP-over-P2P architecture and interworking of heterogeneous overlay networks. 

             Comments are             welcomed!
             
             Thanks
             Juwei
             
             Juwei Shi             

                          
---------------------------------
             
             Yahoo! Messenger with Voice. Make             PC-to-Phone Calls to the US             (and 30+ countries) for 2???/min or             less.

---------------------------------
           Yahoo! Messenger with Voice. Make           PC-to-Phone Calls to the US (and 30+ countries) for 2??/min or           less. 

---------------------------------
Get your own web address for just $1.99/1st yr. We'll help. Yahoo! Small Business.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060824/514919c9/attachment.html

---

From: br at brianrosen.net (Brian Rosen)
Date: Thu, 24 Aug 2006 09:44:31 -0400

While I think this work is interesting, I believe it?s beyond what we would
consider within our first charter.  Are there people who think otherwise?

________________________________________
From: p2p-sip-bounces at cs.columbia.edu
[mailto:p2p-sip-bounces at cs.columbia.edu] On Behalf Of K.Yamamoto
Sent: Thursday, August 24, 2006 12:02 AM
To: Juwei Shi; Seaward Hu; p2p-sip at cs.columbia.edu
Subject: Re: [p2p-sip] __A_New_Internet-draft_is_available

BUT UNLESS YOU DELIBERATELY MANIPULATE EVERY MULTI-OVERLAY NODES SO THAT A
NODE CAN SAY "HEY, MY CHORD STACK DOES NOT CONNECT WITH ANOTHER CHORD NODE
ALSO IN PASTRY OVERLAY BUT CONNECT WITH THE OTHER CHORD NODE ALSO IN BT
OVERLAY", OTHERWISE AUTONOMOUS INTERCONNECTION OF MULTI-OVERLAY NODES VERY
POSSIBLY WILL FORM A CYCLIC MESH.

EXAMPLE: LETS DENOTE A NODE OF MULTI-OVERLAYS X AND Y AS XY. INTERCONNECT
NODES ABC, AC AND BC FORMS A MESH.

WHEN YOU CAN MANIPULATE NODES OF MULTIPLE OVERLAYS, WHY NOT MANIPULATE THEM
TO USE ONLY ONE OVERLAY? 

THANK YOU.
--KY
PLEASE QUALITY CONTROL LIKE BUILDING A LEXUS.
Juwei Shi <jwshi at bupt.edu.cn> wrote:
?
Yes, I agree with Seaward, hierarchically inter-connecting heterogeneous
overlays is more practical than the mesh based approach.? 
?
?
?
Interworking among heterogeneous hierarchical is more efficient than do it
meshy, you can not expect a flat huge mesh over whole world can work
reliably, the reason why mesh is used is the absence of a acceptable
standard.

Thanks.

Seaward 
?

________________________________________
From: p2p-sip-bounces at cs.columbia.edu
[mailto:p2p-sip-bounces at cs.columbia.edu] On Behalf Of K.Yamamoto
Sent: Thursday, August 24, 2006 2:16 AM
To: Juwei Shi; p2p-sip at cs.columbia.edu
Subject: Re: ??0
2???: [p2p-sip] A New Internet-draft is available
WHEN NUMEROUS MULTI-OVERLAID NODES ARE INTERCONNECTED, "the interworking
among heterogenous overlays" IS GENERALLY MESSY NOT HIERACHICAL. 
THANK YOU.
 
--KY
PLEASE QUALITY
 CONTROL LIKE BUILDING A LEXUS.
Juwei Shi <jwshi at bupt.edu.cn> wrote: 
The NAT issues will be discussed in our future drafts. 
This draft focuses on the interworking among heterogenous overlays and the
SIP-over-P2P architecture in one single overlay is proposed by E. Shim etc. 
http://www.p2psip.org/drafts/draft-shim-sipping-p2p-arch-00.txt
Thanks
Juwei
________________________________________
????????oo: K.Yamamoto [mailto:kyara543 at yahoo.com] 
???????????????????: 2006?1??8???23????? 12:21
????????oo: Juwei Shi; p2p-sip at cs.columbia.edu
????????: Re: [p2p-sip] A New Internet-draft is available
THE DOCUMENT IS GORGEOUS BUT NEED RENAME AS "A MESHY ARCHITECTURE AMONG
MULTIPLE P2P-SIP NETWORKS".
FOMULA "Node-ID=Hash(Node-IP)" HAS PROBLEM WITH MULTIPLE NODES BEHIND A NAT.

 THANK YOU.
 
 --KY

Juwei Shi <jwshi at bupt.edu.cn> wrote:
Hello, all
We have
 submitted a new Internet-draft entitled a???A Hierarchical P2P-SIP
Architecturea???. This draft focuses
 on the SIP-over-P2P architecture and interworking of heterogeneous overlay
networks. 
?
This document is available in the Internet-drafts archive now:
http://www3.ietf.org/internet-drafts/draft-shi-p2psip-hier-arch-00..txt
Comments are welcomed!
Thanks
Juwei
Juwei Shi 
Wireless Technology Innovation Institute (WTI)
Beijing Univ. of Posts and Telecommunications (BUPT)
Tel: +86-10-62283600 ext. 312
Email: jwshi at bupt.edu.cn
_______________________________________________
p2p-sip mailing list
p2p-sip at cs.columbia.edu
https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip
? 
________________________________________
Yahoo! Messenger with Voice. Make PC-to-Phone Calls to the US (and 30+
countries) for 2???/min or less.

________________________________________
Yahoo! Messenger with Voice. Make PC-to-Phone Calls to the US (and 30+
countries) for 2??/min or less. 

________________________________________
Get your own web address for just $1.99/1st yr. We'll help. Yahoo! Small
Business.

---

From: slavitch at gmail.com (Michael Slavitch)
Date: Thu, 24 Aug 2006 09:53:30 -0400

Different overlays will correspond to different groups and regimes, with
different rules and behaviors. The base overlay connects them together using
rules of its own.  Overlays that recurse with independent behavior allow for
rich collaboration based on organized groups with implicit security and
choice.  Hierarchical, selective or authoritative organization is but a
subset of self-organization, it is just far more automated.

It is this aspect of overlays, the ability to nest overlays upon each other,
that makes P2PSIP truly powerful, more powerful than most most could even
imagine, as the application space changes completely.  Self-organizing
automated systems could replace much of the cruft and kludge of the
Internet.  I assert that P2PSIP becomes truly useful if such overlays are
not only permitted but clearly defined for easy implementation.  It looks
like P2PSIP will go that way as long as we remain vigilant, supportive and
smart.

Regards,

On 8/24/06, K.Yamamoto <kyara543 at yahoo.com> wrote:
> *Juwei Shi <jwshi at bupt.edu.cn>* wrote:
>
>
> overlays is more practical than the mesh based approach.
>
>
>
>
>  ------------------------------
> *From:* p2p-sip-bounces at cs.columbia.edu [mailto:
> p2p-sip-bounces at cs.columbia.edu] *On Behalf Of *K.Yamamoto
> *Sent:* Thursday, August 24, 2006 2:16 AM
> *To:* Juwei Shi; p2p-sip at cs.columbia.edu
> *Subject:* Re: ?????: [p2p-sip] A New Internet-draft is available
>
>
> *Juwei Shi <jwshi at bupt.edu.cn>* wrote:
>
> SIP-over-P2P architecture in one single overlay is proposed by E. Shimetc.
>  ------------------------------
>  *??'????oo:* K.Yamamoto [mailto:kyara543 at yahoo.com]
> *??'?????????:* 2006?1?8???23??? 12:21
> *?"?????oo:* Juwei Shi; p2p-sip at cs.columbia.edu
> *??????:* Re: [p2p-sip] A New Internet-draft is available
> *Juwei Shi <jwshi at bupt.edu.cn>* wrote:
>  Hello, all
>
> We have
>  submitted a new Internet-draft entitled a??A Hierarchical P2P-SIP Architecturea??. This draft focuses
>  on the SIP-over-P2P architecture and interworking of heterogeneous overlay networks.
>
>
>
> http://www3.ietf.org/internet-drafts/draft-shi-p2psip-hier-arch-00..txt<http://www3.ietf.org/internet-drafts/draft-shi-p2psip-hier-arch-00.txt>
>  Comments are welcomed!
>  Thanks
> Juwei
>  Juwei Shi
>  ------------------------------
>  Yahoo! Messenger with Voice. Make PC-to-Phone Calls<http://us.rd.yahoo.com/mail_us/taglines/postman1/*http:/usrd.yahoo.com/evt=39663/*http:/voice.yahoo.com>to the US (and 30+ countries) for 2??/min or less.
>
>
>  ------------------------------
> Yahoo! Messenger with Voice. Make PC-to-Phone Calls<http://us.rd.yahoo.com/mail_us/taglines/postman1/*http://us.rd.yahoo.com/evt=39663/*http://voice.yahoo.com>to the US (and 30+ countries) for 2?/min or less.
>
>
>  ------------------------------
> Business<http://us.rd.yahoo.com/evt=41244/*http://smallbusiness.yahoo.com/>.
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060824/34c50192/attachment-0001.html

---

From: slavitch at gmail.com (Michael Slavitch)
Date: Thu, 24 Aug 2006 09:57:39 -0400

Oh, and one more point.  "

Vigilant and smart to me means the following:

1. Create a WG charter that is in scope with achievable goals.
2. Get the WG approved.
3. Deliver a standard that can be broadly supported.
4. Iterate.

The first part of P2PSIP that should be reliable, self-organizing and
iterative is >us<.

On 8/24/06, Michael Slavitch <slavitch at gmail.com> wrote:
> It is this aspect of overlays, the ability to nest overlays upon each
> other, that makes P2PSIP truly powerful, more powerful than most most could
> even imagine, as the application space changes completely.  Self-organizing
> > BUT UNLESS YOU DELIBERATELY MANIPULATE EVERY MULTI-OVERLAY NODES SO THAT
> > A NODE CAN SAY "HEY, MY CHORD STACK DOES NOT CONNECT WITH ANOTHER CHORD NODE
> > EXAMPLE: LETS DENOTE A NODE OF MULTI-OVERLAYS X AND Y AS XY.
> > INTERCONNECT NODES ABC, AC AND BC FORMS A MESH.
> >
> > Interworking among heterogeneous hierarchical is more efficient than do
> > it meshy, you can not expect a flat huge mesh over whole world can work
> > *From:* p2p-sip-bounces at cs.columbia.edu [mailto:p2p-sip-bounces at cs.columbia.edu]
> > *On Behalf Of *K.Yamamoto
> > WHEN NUMEROUS MULTI-OVERLAID NODES ARE INTERCONNECTED, " the
> > interworking among heterogenous overlays" IS GENERALLY MESSY NOT
> > HIERACHICAL.
> >
> > THANK YOU.
> >
> > --KY
> > PLEASE QUALITY
> > This draft focuses on the interworking among heterogenous overlays and
> > the SIP-over-P2P architecture in one single overlay is proposed by E.
> > Shim etc.
> > *??'?????????:* 2006?1?8 ???23??? 12:21
> > *?"?????oo: *Juwei Shi; p2p-sip at cs.columbia.edu
> > *Juwei Shi < jwshi at bupt.edu.cn>* wrote:
> >  Hello, all
> >
> >
> > We have
> > Yahoo! Messenger with Voice. Make PC-to-Phone Calls
> > <http://us.rd.yahoo.com/mail_us/taglines/postman1/*http://us.rd.yahoo.com/evt=39663/*http://voice.yahoo.com>to
> > the US (and 30+ countries) for 2?/min or less.
> >
> >
> > Business
> > <http://us.rd.yahoo.com/evt=41244/*http://smallbusiness.yahoo.com/>.
> >
> >
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060824/ef18bf97/attachment-0001.html

---

From: hsinnrei at adobe.com (Henry Sinnreich)
Date: Thu, 24 Aug 2006 07:20:10 -0700

>the ability to nest overlays upon each other, that makes P2PSIP truly >powerful, more powerful than most most could even imagine, as the >application space changes completely.  Self-organizing automated >systems could replace much of the cruft and kludge of the Internet. 

> The base overlay connects them together using rules of its own. 

Hold this thought for after P2P SIP gets chartered. I believe Michael Slavitch has articulated here (patent chasers: 1st time we saw this) a fundamental new potential for using optimized overlays for various application spaces and to support various business models.

Thanks, Henry

________________________________

From: p2p-sip-bounces at cs.columbia.edu [mailto:p2p-sip-bounces at cs.columbia.edu] On Behalf Of Michael Slavitch
Sent: Thursday, August 24, 2006 8:54 AM
To: K.Yamamoto
Cc: p2p-sip at cs.columbia.edu
Subject: Re: [p2p-sip] __A_New_Internet-draft_is_available

 

Different overlays will correspond to different groups and regimes, with different rules and behaviors. The base overlay connects them together using rules of its own.  Overlays that recurse with independent behavior allow for rich collaboration based on organized groups with implicit security and choice.  Hierarchical, selective or authoritative organization is but a subset of self-organization, it is just far more automated.  

It is this aspect of overlays, the ability to nest overlays upon each other, that makes P2PSIP truly powerful, more powerful than most most could even imagine, as the application space changes completely.  Self-organizing automated systems could replace much of the cruft and kludge of the Internet.  I assert that P2PSIP becomes truly useful if such overlays are not only permitted but clearly defined for easy implementation.  It looks like P2PSIP will go that way as long as we remain vigilant, supportive and smart. 

Regards,

 

THANK YOU.

--KY

 

	Thanks.
	
	Seaward 

________________________________

		From: p2p-sip-bounces at cs.columbia.edu [mailto: p2p-sip-bounces at cs.columbia.edu <mailto:p2p-sip-bounces at cs.columbia.edu> ] On Behalf Of K.Yamamoto
		Sent: Thursday, August 24, 2006 2:16 AM
		To: Juwei Shi; p2p-sip at cs.columbia.edu
		Subject: Re: ?????: [p2p-sip] A New Internet-draft is available

		WHEN NUMEROUS MULTI-OVERLAID NODES ARE INTERCONNECTED, " the interworking among heterogenous overlays" IS GENERALLY MESSY NOT HIERACHICAL. 

		THANK YOU.

		 

		  
		--KY

		  
		PLEASE QUALITY

		Thanks

		Juwei

________________________________

		K.Yamamoto [mailto:kyara543 at yahoo.com] 
		2006?1?8 ???23??? 12:21
		: ??????: Make PC-to-Phone Calls to the US (and 30+ countries) for 2??/min or less.

________________________________

		Yahoo! Messenger with Voice. Make PC-to-Phone Calls <http://us.rd.yahoo.com/mail_us/taglines/postman1/*http:/us.rd.yahoo.com/evt=39663/*http:/voice.yahoo.com> to the US (and 30+ countries) for 2?/min or less. 

________________________________

Get your own web address for just $1.99/1st yr. We'll help. Yahoo! Small Business <http://us.rd.yahoo.com/evt=41244/*http:/smallbusiness.yahoo.com/> . 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060824/c972cf8a/attachment-0001.html

---

From: spencer at mcsr-labs.org (Spencer Dawkins)
Date: Thu, 24 Aug 2006 10:16:23 -0500

Hi, Michael,

Very wise words!

Spencer
  ----- Original Message ----- 
  From: Michael Slavitch 
  To: K. Yamamoto 
  Cc: p2p-sip at cs.columbia.edu 
  Sent: Thursday, August 24, 2006 8:57 AM
  Subject: Re: [p2p-sip] __A_New_Internet-draft_is_available

  The first part of P2PSIP that should be reliable, self-organizing and iterative is >us<.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060824/b8bafdc6/attachment.html

---

From: slavitch at gmail.com (Michael Slavitch)
Date: Thu, 24 Aug 2006 12:09:00 -0400

I fully agree that it must wait until well after the charter.  Get the basic
physics working first.

On 8/24/06, Henry Sinnreich <hsinnrei at adobe.com> wrote:
>
>   patent chasers: 1st time we saw this)
>
On this, I must quote Dr. Strangelove: *"*Yes, but the... whole point of the
doomsday machine... is lost... if you keep it a secret! Why didn't you tell
the world, eh?"  The sole reason IP is useful is because it was told to the
world and it is simple.  Technically, old dead IPX is better, but that
didn't matter because it was too much of a trade secret.  The biggest
problem with global PKI, for example, is that too many organizations want to
control identity acces and policy and use it as barrier, not as an
opportunity for communication.
When I scripted a stark and simple SIP TCP UA  after one reading of RFC3261
I knew SIP would win.  The same lazy ease must be possible with hierarchical
overlays, their policies, and their provisioning.  Feature richness, done
well, will follow, like with HTTP.  Tim Berners-Lee may have anticipated
WebDAV replacing proprietary file servers (see his first post regarding the
web:
http://groups.google.co.uk/group/alt.hypertext/msg/06dad279804cb3ba?dmode=source&hl=en)
but did anyone expect the explosion that happened?

Could anyone have anticipated iTunes or eBay or YouTube or MySpace? That the
web 'revenue model' turned out to be advertising and e-commerce for travel
and cars?

The patent chasers and complexity hounds will have plenty of opportunity to
patent applications and create artificial nuances for this new
environment.  That lesson was sadly learned from core SIP.  It is my opinion
that P2PSIP automation and policy must be so ubiquitous and easy as to
create a functional ecosystem that does not depend on the whims of one
dominant vendor.

Likewise it can't rot in patent isolation by a technology company that
cannot or will not exploit it.  The "how" should be common.
The "what" offers much that can be left to the imagination.

Regards To All

M

> p2p-sip-bounces at cs.columbia.edu] *On Behalf Of *Michael Slavitch
> *Sent:* Thursday, August 24, 2006 8:54 AM
> *To:* K.Yamamoto
> *Cc:* p2p-sip at cs.columbia.edu
>
> *Subject:* Re: [p2p-sip] __A_New_Internet-draft_is_available
>
>
>
> On 8/24/06, *K.Yamamoto* <kyara543 at yahoo.com> wrote:
>
> WHEN NUMEROUS MULTI-OVERLAID NODES ARE INTERCONNECTED, " the interworking
> *
> 2006?1?8 ???23??**?** 12:21**
> **: *
>
> *????**?**?**:** Make PC-to-Phone Calls to the US (and 30+ countries) for
> 2?**?/min or less.*
>
> * *
> *
> *
> *Yahoo! Messenger with Voice. Make PC-to-Phone Calls
> <http://us.rd.yahoo.com/mail_us/taglines/postman1/*http:/us.rd.yahoo.com/evt=39663/*http:/voice.yahoo.com>to
> the US (and 30+ countries) for 2**?/min or less. *
>
>
> <http://us.rd.yahoo.com/evt=41244/*http:/smallbusiness.yahoo.com/>.
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060824/83d370dd/attachment-0001.html

---

From: huang-ming.pan at comcast.net (Peter Pan)
Date: Thu, 24 Aug 2006 09:21:59 -0700

"It is this aspect of overlays, the ability to nest overlays upon each other, that makes P2PSIP truly powerful, more powerful than most most could even imagine, as the application space changes completely."

Which existing successful P2P networks nest upon each other heterogenously?

Which academic or technical reports support the theory of "a truly powerful P2PSIP" with nesting overlays?

When it is "more powerful than most most could even imagine", could it be just another (useless) mirage?

Peter
  ----- Original Message ----- 
  From: Michael Slavitch 
  To: K.Yamamoto 
  Cc: p2p-sip at cs.columbia.edu 
  Sent: Thursday, August 24, 2006 6:53 AM
  Subject: Re: [p2p-sip] __A_New_Internet-draft_is_available

  Regards,

    THANK YOU.

--KYPLEASE QUALITY CONTROL LIKE BUILDING A LEXUS.

              Thanks.

              Seaward 

----------------------------------------------------------------
                From: p2p-sip-bounces at cs.columbia.edu [mailto: p2p-sip-bounces at cs.columbia.edu] On Behalf Of K.Yamamoto
                Sent: Thursday, August 24, 2006 2:16 AM
                To: Juwei Shi; p2p-sip at cs.columbia.edu
                Subject: Re: ?????: [p2p-sip] A New Internet-draft is available

THANK YOU.
 --KYPLEASE QUALITY

--------------------------------------------------------------

                  ??'????oo: K.Yamamoto [mailto:kyara543 at yahoo.com] 
                  ??'?????????: 2006?1?8 ???23??? 12:21
                  ?"?????oo: Juwei Shi; p2p-sip at cs.columbia.edu 
                  ??????: Re: [p2p-sip] A New Internet-draft is available
                  THE DOCUMENT IS GORGEOUS BUT NEED RENAME AS "A MESHY ARCHITECTURE AMONG MULTIPLE P2P-SIP NETWORKS". 
FOMULA "Node-ID=Hash(Node-IP)" HAS PROBLEM WITH MULTIPLE NODES BEHIND A NAT. 
 THERE IS LITTLE ABOUT P2P OR SIP, FOR ONE SINGLE OVERLAY.  THANK YOU.  --KY PLEASE QUALITY CONTROL LIKE BUILDING A LEXUS.

                  Juwei Shi < jwshi at bupt.edu.cn> wrote:
                  Hello, all

We have submitted a new Internet-draft entitled a??A Hierarchical P2P-SIP Architecturea??. This draft focuses
 on the SIP-over-P2P architecture and interworking of heterogeneous overlay networks. 

--------------------------------------------------------------

----------------------------------------------------------------
                Yahoo! Messenger with Voice. Make PC-to-Phone Calls to the US (and 30+ countries) for 2?/min or less.  

----------------------------------------------------------------------------
    Get your own web address for just $1.99/1st yr. We'll help. Yahoo! Small Business . 

------------------------------------------------------------------------------

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060824/6c4594dc/attachment-0001.html

---

From: hsinnrei at adobe.com (Henry Sinnreich)
Date: Thu, 24 Aug 2006 09:25:42 -0700

> When it is "more powerful than most most could even imagine", 

> could it be just another (useless) mirage?

The Internet was such a mirage at the time of SNA, DECnet, ISDN etc. and is now the nightmare of walled garden networks.

Thanks, Henry

From: p2p-sip-bounces at cs.columbia.edu [mailto:p2p-sip-bounces at cs.columbia.edu] On Behalf Of Peter Pan
Sent: Thursday, August 24, 2006 11:22 AM
To: Michael Slavitch; K.Yamamoto
Cc: p2p-sip at cs.columbia.edu
Subject: Re: [p2p-sip] __A_New_Internet-draft_is_available

Peter

	----- Original Message ----- 

	From: Michael Slavitch <mailto:slavitch at gmail.com>  

	To: K.Yamamoto <mailto:kyara543 at yahoo.com>  

	 

	Regards,

	 

	

	
	THANK YOU.

	--KY

	

	 

	Thanks.
	
	Seaward 

		THANK YOU.

		 

		  
		--KY

		  
		PLEASE QUALITY

		Thanks

		Juwei

		

		

		

		  
		 THANK YOU.

		

		 --KY

		  

		
		Juwei Shi < jwshi at bupt.edu.cn <mailto:jwshi at bupt.edu.cn> > wrote:

		Hello, all

		We have

		  

		http://www3.ietf.org/internet-drafts/draft-shi-p2psip-hier-arch-00..txt <http://www3.ietf.org/internet-drafts/draft-shi-p2psip-hier-arch-00.txt> 

		Comments are welcomed!

		Thanks

		Juwei

		Juwei Shi 

		

		Yahoo! Messenger with Voice. Make PC-to-Phone Calls <http://us.rd.yahoo.com/mail_us/taglines/postman1/*http:/usrd.yahoo.com/evt=39663/*http:/voice.yahoo.com>  to the US (and 30+ countries) for 2??/min or less.

	

	

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060824/9f592c98/attachment-0001.html

---

From: huang-ming.pan at comcast.net (Peter Pan)
Date: Thu, 24 Aug 2006 09:56:38 -0700

Agreed.

But must learn to walk and run before to fly.

Peter
----- Original Message -----
From: Henry Sinnreich
To: Peter Pan ; Michael Slavitch ; K.Yamamoto
Cc: p2p-sip at cs.columbia.edu
Sent: Thursday, August 24, 2006 9:25 AM
Subject: RE: [p2p-sip] __A_New_Internet-draft_is_available

> could it be just another (useless) mirage?

The Internet was such a mirage at the time of SNA, DECnet, ISDN etc. and is
now the nightmare of walled garden networks.

Thanks, Henry

[mailto:p2p-sip-bounces at cs.columbia.edu] On Behalf Of Peter Pan

"It is this aspect of overlays, the ability to nest overlays upon each
other, that makes P2PSIP truly powerful, more powerful than most most could
even imagine, as the application space changes completely."

Which academic or technical reports support the theory of "a truly powerful
P2PSIP" with nesting overlays?

When it is "more powerful than most most could even imagine", could it be
just another (useless) mirage?

Peter
----- Original Message -----
From: Michael Slavitch
To: K.Yamamoto
Cc: p2p-sip at cs.columbia.edu
Sent: Thursday, August 24, 2006 6:53 AM
Subject: Re: [p2p-sip] __A_New_Internet-draft_is_available

Regards,

THANK YOU.
--KY

Thanks.

Seaward

From: p2p-sip-bounces at cs.columbia.edu [mailto:
p2p-sip-bounces at cs.columbia.edu] On Behalf Of K.Yamamoto
Sent: Thursday, August 24, 2006 2:16 AM
To: Juwei Shi; p2p-sip at cs.columbia.edu
Subject: Re: ?????: [p2p-sip] A New Internet-draft is available

--KY

PLEASE QUALITY

 THANK YOU.

 --KY

We have

 submitted a new Internet-draft entitled a??A Hierarchical P2P-SIP
Architecturea??. This draft focuses
 on the SIP-over-P2P architecture and interworking of heterogeneous overlay
networks.

Yahoo! Messenger with Voice. Make PC-to-Phone Calls to the US (and 30+
countries) for 2?/min or less.

Business .

---

From: matthew at matthew.at (Matthew Kaufman)
Date: Thu, 24 Aug 2006 10:09:50 -0700

> But must learn to walk and run before to fly.

When building an airplane, one usually doesn't ensure that it has the
capability of either walking or running. To do so would unnecessarily
complicate the design for no tangible benefit.

Working on solving one problem well would be a good start for the p2p-sip
effort. If only we knew exactly which one problem that was... 

Matthew Kaufman
matthew at matthew.at
http://www.amicima.com

---

From: slavitch at gmail.com (Michael Slavitch)
Date: Thu, 24 Aug 2006 13:13:12 -0400

The best evidence of value is seen through intuition, interest,
implementation and follow-on adoption, not papers or reports.
SIP had to be invented first before it could be reported upon.  The
inventors realized what the potential implications were even back then.
That is the essence of invention.

In a competitive world actual evidence is expensive and holds competitive
value, while opinions are free beer.

On 8/24/06, Peter Pan <huang-ming.pan at comcast.net> wrote:
>  *Which existing successful P2P networks nest upon each other
> heterogenously?*
>
> *Which academic or technical reports support the theory of "a truly
> powerful P2PSIP" with nesting overlays?*
> **
> *When it is "more powerful than most most could even imagine", could it be
> just another (useless) mirage?*
>  **
> Peter
>
> *From:* Michael Slavitch <slavitch at gmail.com>
> *To:* K.Yamamoto <kyara543 at yahoo.com>
> *Sent:* Thursday, August 24, 2006 6:53 AM
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060824/2efe9712/attachment-0001.html

---

From: hsinnrei at adobe.com (Henry Sinnreich)
Date: Thu, 24 Aug 2006 10:23:29 -0700

Matthew Kaufman writes:

> solving one problem well would be a good start for the p2p-sip

There are several problems. Here are some that come to my mind:

- The cost and complexity of routing SIP calls through an ever
increasing maze of servers and other VoIP infrastructure. 
Just follow the other SIP related WG lists where SIP call routing is an
endless topic. This routing has to be engineered and maintained by hand,
versus the self organization of P2P.

- Building the IT systems for these server labyrinths and getting up to
date customer data into servers along with business policies, etc. Not
even mentioning mobility.

- Could anyone give a security audit for a labyrinth of VoIP servers?

Thanks, Henry

-----Original Message-----
From: Matthew Kaufman [mailto:matthew at matthew.at] 
Sent: Thursday, August 24, 2006 12:10 PM
To: 'Peter Pan'; Henry Sinnreich; 'Michael Slavitch'; 'K.Yamamoto'
Cc: p2p-sip at cs.columbia.edu
Subject: RE: [p2p-sip] __A_New_Internet-draft_is_available

Working on solving one problem well would be a good start for the
p2p-sip
effort. If only we knew exactly which one problem that was... 

Matthew Kaufman
matthew at matthew.at
http://www.amicima.com

---

From: huang-ming.pan at comcast.net (Peter Pan)
Date: Thu, 24 Aug 2006 10:30:34 -0700

From: "Matthew Kaufman" <matthew at matthew.at>
To: "'Peter Pan'" <huang-ming.pan at comcast.net>; "'Henry Sinnreich'"
<hsinnrei at adobe.com>; "'Michael Slavitch'" <slavitch at gmail.com>;
"'K.Yamamoto'" <kyara543 at yahoo.com>
Cc: <p2p-sip at cs.columbia.edu>
Sent: Thursday, August 24, 2006 10:09 AM
Subject: RE: [p2p-sip] __A_New_Internet-draft_is_available

> complicate the design for no tangible benefit.

Hard to agree with the upstairs.

By no mean I will take an airplane without wheels.

The comparison of airplane with heterogenerous p2psip interconnection seems
to me like that of burrito and drumstick ;-) It is not apple to apple.

Peter

---

From: dean.willis at softarmor.com (Dean Willis)
Date: Thu, 24 Aug 2006 15:14:22 -0500

> By no mean I will take an airplane without wheels.

Then by all means avoid Alaskan floatplanes and the Vancouver Island  
seaplane taxi service. They lack wheels for very good reasons.

Environment dictates design, form follows function.

> to me like that of burrito and drumstick ;-) It is not apple to apple.

But it's fast-food to fast-food.

The question is -- what are we hungry for?

Unfortunately, the charter process does not let us say "All you can  
eat buffet". At the very best, we can pick which toy to get with with  
our "Happy Meal".

--
dean

---

From: huang-ming.pan at comcast.net (Peter Pan)
Date: Thu, 24 Aug 2006 13:32:13 -0700

----- Original Message -----
From: "Dean Willis" <dean.willis at softarmor.com>
To: "Peter Pan" <huang-ming.pan at comcast.net>
Cc: "Matthew Kaufman" <matthew at matthew.at>; "'Henry Sinnreich'"
<hsinnrei at adobe.com>; "'Michael Slavitch'" <slavitch at gmail.com>;
"'K.Yamamoto'" <kyara543 at yahoo.com>; <p2p-sip at cs.columbia.edu>
Sent: Thursday, August 24, 2006 1:14 PM
Subject: Re: [p2p-sip] __A_New_Internet-draft_is_available

> eat buffet". At the very best, we can pick which toy to get with with

When some Asian spell burrito (slang) and drumstick, they are not fast food
but ... :)

Life of a dreamer is easy.

Life with a dreamer is not.

Kick something off solid ground first.

Peter

---

From: jwshi at bupt.edu.cn (Juwei Shi)
Date: Fri, 25 Aug 2006 16:52:17 +0800

I?ll explain the motivation of the hierarchical P2P-SIP architecture. 

The precondition of applying the hierarchical approach is that the SIP-over-P2P structure is adopted. We have presented the benefits of that two layer approach in our draft. 

Various P2P overlays have already existed such as Chord, Pastry and etc. We can?t roughly tie up a specific P2P overlay as the peer locating service for SIP but exclude other overlays. Only one overlay is inflexible and can?t satisfy requirements of all the peers. For example, the requirement of a mobile peer in MANET differs from that of a powerful host in Internet. Thus we believe that heterogeneous P2P overlays will exist, and when we use them as the underlying peer locating service for SIP we can only inter-connect them to retain the connectivity feature of SIP. 

Comments are welcomed!

Thanks 

Juwei 

 

THANK YOU.

--KY

 

Thanks.

Seaward 

  _____  

From: p2p-sip-bounces at cs.columbia.edu [mailto:p2p-sip-bounces at cs.columbia.edu] On Behalf Of K.Yamamoto
Sent: Thursday, August 24, 2006 2:16 AM
To: Juwei Shi; p2p-sip at cs.columbia.edu
Subject: Re: ??0?2???: [p2p-sip] A New Internet-draft is available

THANK YOU.

--KY

PLEASE QUALITY

Thanks

Juwei

  _____  

 

 

 THANK YOU.

 --KY

Hello, all

We have

 submitted a new Internet-draft entitled a???A Hierarchical P2P-SIP Architecturea???. This draft focuses
 on the SIP-over-P2P architecture and interworking of heterogeneous overlay networks. 

Comments are welcomed!

Thanks

Juwei

Juwei Shi 

  _____  

Yahoo! Messenger with Voice. Make <http://us.rd.yahoo.com/mail_us/taglines/postman1/*http:/usrd.yahoo.com/evt=39663/*http:/voice.yahoo.com>  PC-to-Phone Calls to the US (and 30+ countries) for 2???/min or less.

  _____  

Yahoo! Messenger with Voice. Make <http://us.rd.yahoo.com/mail_us/taglines/postman1/*http:/us.rd.yahoo.com/evt=39663/*http:/voice.yahoo.com>  PC-to-Phone Calls to the US (and 30+ countries) for 2??/min or less. 

  _____  

Get your own web address for just $1.99/1st yr. We'll help. Yahoo! <http://us.rd.yahoo.com/evt=41244/*http:/smallbusiness.yahoo.com/>  Small Business. 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060825/91d7eda7/attachment-0001.html

---

From: bessler at FTW.at (Sandford Bessler)
Date: Fri, 25 Aug 2006 14:33:49 +0200

Juwei Shi schrieb:
> The precondition of applying the hierarchical approach is that the 
> SIP-over-P2P structure is adopted. We have presented the benefits of 
> that two layer approach in our draft.
>
>  
>
> Various P2P overlays have already existed such as Chord, Pastry and 
> etc. We can?t roughly tie up a specific P2P overlay as the peer 
> locating service for SIP but exclude other overlays. Only one overlay 
> is inflexible and can?t satisfy requirements of all the peers. For 
> example, the requirement of a mobile peer in MANET differs from that 
> of a powerful host in Internet.
>

> Thus we believe that heterogeneous P2P overlays will exist, and when 
> we use them as the underlying peer locating service for SIP we can 
> only inter-connect them to retain the connectivity feature of SIP.
>
I completely agree with the view of heterogeneous P2P overlays and 
decentral domain administration for security or  resource management  
(e.g. storage). We have even tried to further work out the elegant idea 
of federated DHTs according to the paper of H.Balakrishnan, S.Shenker 
and M.Walfish, Peering Peer to Peer Providers, however the routing 
amounts to that of a mesh network and needs advertising mechanisms 
similar to the BGP protocol. The hierarchical solution really seem to 
reduce the complexity.

Best Regards,
Sandford
> */Juwei Shi <jwshi at bupt.edu.cn>/* wrote:
>
>  
>
> Yes, I agree with Seaward, hierarchically inter-connecting 
> heterogeneous overlays is more practical than the mesh based approach. 
>
>  
>
>  
>
>  
>
>     Interworking among heterogeneous hierarchical is more efficient
>     than do it meshy, you can not expect a flat huge mesh over whole
>     world can work reliably, the reason why mesh is used is the
>     absence of a acceptable standard.
>
>
>     Thanks.
>
>     Seaward
>
>      
>
>          
>
>         ------------------------------------------------------------------------
>
>         *From:* p2p-sip-bounces at cs.columbia.edu
>         [mailto:p2p-sip-bounces at cs.columbia.edu] *On Behalf Of *K.Yamamoto
>         *Subject:* Re: ??0?2???: [p2p-sip] A New Internet-draft is
>         available
>
>         WHEN NUMEROUS MULTI-OVERLAID NODES ARE INTERCONNECTED, "the
>         interworking among heterogenous overlays" IS GENERALLY MESSY
>         NOT HIERACHICAL.
>
>         THANK YOU.
>
>          
>
>         --KY
>
>         PLEASE QUALITY
>
>         */Juwei Shi <jwshi at bupt.edu.cn>/* wrote:
>
>         This draft focuses on the interworking among heterogenous
>         overlays and the SIP-over-P2P architecture in one single
>         overlay is proposed by E. Shim etc.
>
>         ------------------------------------------------------------------------
>
>         *????????oo:* K.Yamamoto [mailto:kyara543 at yahoo.com]
>         *???????????????????:* 2006?1??8???23????? 12:21
>         *????????oo:* Juwei Shi; p2p-sip at cs.columbia.edu
>         *????????:* Re: [p2p-sip] A New Internet-draft is available
>
>         THE DOCUMENT IS GORGEOUS BUT NEED RENAME AS "A MESHY
>         ARCHITECTURE AMONG MULTIPLE P2P-SIP NETWORKS".
>
>         */Juwei Shi <jwshi at bupt.edu.cn>/* wrote:
>
>         Hello, all
>
>         We have
>
>         <http://www3.ietf.org/internet-drafts/draft-shi-p2psip-hier-arch-00.txt>
>
>         Comments are welcomed!
>
>         Thanks
>
>         Juwei
>
>         Juwei Shi
>
>         ------------------------------------------------------------------------
>
>         <http://us.rd.yahoo.com/mail_us/taglines/postman1/*http:/usrd.yahoo.com/evt=39663/*http:/voice.yahoo.com>
>         to the US (and 30+ countries) for 2???/min or less.
>
>          
>
>         ------------------------------------------------------------------------
>
>         <http://us.rd.yahoo.com/mail_us/taglines/postman1/*http:/us.rd.yahoo.com/evt=39663/*http:/voice.yahoo.com>
>         to the US (and 30+ countries) for 2??/min or less.
>
>  
>
>  
>
> ------------------------------------------------------------------------
>
> Get your own web address for just $1.99/1st yr 
> <%20http://us.rd.yahoo.com/evt=43290/*http:/smallbusiness.yahoo.com/domains>. 
> We'll help. Yahoo! Small Business 
> ------------------------------------------------------------------------
>

-- 
Dr. Sandford Bessler
Key Researcher,
ftw. - Telecommunications Research Centre Vienna - www.ftw.at
bessler at ftw.at, Tel: +431 5052830-43

---

From: slavitch at gmail.com (Michael Slavitch)
Date: Fri, 25 Aug 2006 10:31:02 -0400

Brief comments inline.

On 8/25/06, Sandford Bessler <bessler at ftw.at> wrote:
> > etc. We can't roughly tie up a specific P2P overlay as the peer
> > is inflexible and can't satisfy requirements of all the peers. For

Same issue with RSVP, etc. and other low-level reservation protocols.
Deployment is impossible outside of walled-garden silos, automation is
impossible outside of a specific provisioning environment and availability
is fragmented. Heirarchical overlays eliminate that silo effect and give the
opportunity to repair existing silo effects through automated provisioning
of underlying overlays.

> only inter-connect them to retain the connectivity feature of SIP.

"I completely agree with the view of heterogeneous P2P overlays and
reduce the complexity."

BGP is of course one-layer only, by design,and works as intended in its
scope.  The advantage of heirarchical overlays is that they recurse and can
inherit traits and learn requirements from one another as they will speak
the same language.  In other words 'routing' (in a P2P sense) becomes a
virtualized application-space activity provisioned automatically depending
on overlay requirements.  Such automation could then be extended to existing
systems if the underlying network supports it, which means that ad-hoc
reservation of bandwidth might finally work because the provisioning
framework will finally exist.

M
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060825/04037fc0/attachment.html