Subject: Re: [P2PSIP] How to discover which peers provide which type of services

From: "Victor Pascual Ávila" <[email-masked]>
Date: Wed, 6 Feb 2008 12:59:17 +0100

Hi,

On Feb 5, 2008 10:35 AM, JiangXingFeng <[email-masked]> wrote:
> So I think, we could classify the service discovery method into two
> categories:
> The first one is based on the common PUT/GET operations; the other one is
> trying to relying on the most of peer's knowledge to find the suited peer.
>
> The first three methods in P2PP and the method in RELOAD-2 belong to the
> first category; The random work in P2PP and method proposed in SEP belong to
> the second one.
>
> For the second category, since it relies on each peer the request will
> traverse to find the service peer, we could make the intermediate peer not
> only check the routing states of each peer, but also tries to find them in
> the following data source:
> 1. The Peer's client service capability;
> 2. Using Standard Service Name to lookup <resource ID, value> pair.
> 3. Other data source which emerges in the future.
>
> By doing this extension, it will improve the success rate of the lookup
> operation.
>
> How about your opinions? Comments are appreciated.

A service agnostic technique would use a SOA-like approach for
discovering and providing services using the P2PSIP overlay network.
Our concept uses Service Consumer, Service Broker and Service
Providers entities where each one is a peer or even a group of peers
in the P2PSIP overlay network. Abstract Service is requested by
Service Consumer and Service Broker returns implementation of a
service as a reference to Service Provider. Mapping between abstract
service name and implementation is kept within P2PSIP overlay.

<Peer,Service> discovery could be a issue to discuss during the
upcoming meeting in Philadelphia.

Thank you,
-- 
Victor Pascual Ávila
Research Engineer
Tel.  +34 93 542 2906
Fax. +34 93 542 2517

Research Group on Network Technologies and Strategies (NeTS)
Universitat Pompeu Fabra (UPF)
Pg. de Circumval·lació, 8
Office 358
08003 Barcelona (Spain)
http://nets.upf.edu/
_______________________________________________
P2PSIP mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/p2psip

---

From: "Roy, Radhika R Dr CTR USA USAMC" <[email-masked]>
Date: Wed, 06 Feb 2008 09:05:20 -0500

Inline [RRR]

----- Original Message -----
From: Victor Pascual Ávila 
Date: Wednesday, February 6, 2008 7:06
Subject: Re: [P2PSIP] How to discover which peers provide which type of services
To: JiangXingFeng 
Cc: P2PSIP Mailing List 

> Hi,
> 
> On Feb 5, 2008 10:35 AM, JiangXingFeng wrote:
> > 2. Using Standard Service Name to lookup pair.
> > By doing this extension, it will improve the success rate of the 
> lookup> operation.
> >
[RRR] I would not say P2PSIP is completely service agostic per se. The use of the term - SIP, does it not make it almost servcie-specific (i.e. it has a limited view of service as opposed to 'generic')?

[RRR] Are you indicating something like UDDI of web services for discovery? If so, how far do we like to go in developing the P2PSIP protocol as we are NOT chartered for development of the generic P2P protocol?

> discovery could be a issue to discuss during the

[RRR] In any event, we would like to have the experiences of this meeting and let us apply those findings as a part of the P2PSIP protocol development that has more limited objectives. So, your comments in this WG will really be valuable.