Subject: [P2PSIP] Group management on top of P2PSIP?

From: Otso Kassinen <[email-masked]>
Date: Wed, 27 Feb 2008 17:31:59 +0200 (EET)

Hi,
I (and my colleagues) have some tentative ideas about creating a
system that manages user groups on top of P2PSIP.

Here, "groups" mean communities of users/nodes that share some particular 
interest and need to communicate with each other as a group.
A group would be a subset of the nodes of one (or multiple?) overlays.
Groups can overlap and they can be long-lived or short-lived, depending on 
their purpose. Users would join or leave a group at will, and share 
resources or otherwise collaborate within the group. The motivation is
that several different group-based applications could use the
unified group-management as a base for their more specific group 
activities.

Most probably, group management would be an application-level solution that
would just use P2PSIP just as an underlying communication enabler.
Group management as such is probably not in the scope of the P2PSIP WG
(although it could be seen as part of "locating users and resources
within a P2PSIP overlay").

In any case, we want to share the idea with the P2PSIP WG and get
tentative comments. Maybe someone has already thought of a mechanism for
the unified management of such groups. So, the question is:

Has anyone already come up with some ideas or even an implementation
of a decentralized group-management system on top of P2PSIP?
(I searched through the P2PSIP mailing list archives
and found no mention of group management.)

Best regards,
- Otso Kassinen
_______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip

---

From: "Victor Pascual Ávila" <[email-masked]>
Date: Wed, 27 Feb 2008 19:10:00 +0100

Otso,

>  and found no mention of group management.)

Some time ago, we (Pompeu Fabra University) considered including
'Community' concept in the P2PSIP terminology.
We can think about 'Community' as a group of nodes (Overlay layer) or
as a group of users (upper application layer, e.g. SIP).

What do you have in mind?

On the one hand, we considered community/group/whatever as a group of
nodes and our main discussion was about if using a single overlay for
both communities or just using one overlay (routing, storage) for each
community. On the other hand, if we consider community as a group of
users on the top of a single (or many) overlays, is there any
significant difference between (SIP) (sub)domains concept and
communities? I'm not trying to group users into domains, just
suggesting a similar concept.

We are preparing a paper on a related topic. It's basically a P2PSIP
live streaming tv platform where users are grouped into
stations/channels. Definitely, it is not in the scope of the P2PSIP
WG.

Cheers,
-- 
Victor Pascual Ávila
Research Engineer
Tel.  +34 93 542 2906
Fax. +34 93 542 2517

Research Group on Network Technologies and Strategies (NeTS)
Universitat Pompeu Fabra (UPF)
Pg. de Circumval·lació, 8
Office 358
08003 Barcelona (Spain)
http://nets.upf.edu/
_______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip

---

From: "Roy, Radhika R Dr CTR USA USAMC" <[email-masked]>
Date: Wed, 27 Feb 2008 13:47:07 -0500

Hi, Victor:

It is an interesting concept: Community.

We like to see this paper.

Best regards,
Radhika

PS: We used to think like server farms. A server farm many have many servers for providing reliability and load sharing purposes. However, the logical view of the server has been a single server using standardized protocol(s) to the outside world. The communication within the servers was proprietary. 

In the case of "community" concept, I assume, that we can use the similar concept like that of the server farm. However, there is a difference. Now, the communications protocols used within a community will be standardized, as I guess you will be proposing in your draft.

It will extend the P2PSIP concept for making a peer more robust - as I see it - a "logical" P2PSIP peer will probably NEVER fail because it is a part of a larger community.

Definitely, it is welcomed to see the concept. If it is needed, we can form another WG to standadize this "community" P2PSIP protocol.

----- Original Message -----
From: Victor Pascual Ávila 
Date: Wednesday, February 27, 2008 13:10
Subject: Re: [P2PSIP] Group management on top of P2PSIP?
To: Otso Kassinen 
Cc: [email-masked]

> Otso,
> 
> On Wed, Feb 27, 2008 at 4:31 PM, Otso Kassinen 
> wrote:
> > Has anyone already come up with some ideas or even an 
> implementation> of a decentralized group-management system on top 
> of P2PSIP?

---

From: Otso Kassinen <[email-masked]>
Date: Thu, 28 Feb 2008 15:53:27 +0200 (EET)

Hi Victor and Radhika.

> What do you have in mind?

We should first determine, which is the better approach:
"a group is an overlay" or "many groups per overlay",
just as you pointed out. It must be studied, what can be done
with the communities in these approaches; is there something that
(for example) restricts group functionality if plain overlays are used.

Group management is often an integral part of P2P environments,
especially in person-to-person communication systems.
This kind of protocols can be studied to get ideas for our solution.

> is there any significant difference between (SIP) (sub)domains
> concept and communities?

I think, groups are more dynamic than a node just belonging to a specific 
domain, and overlapping of groups is easier (but the concepts are similar).

The "server farm style" concept for reliability and load sharing
(mentioned by Radhika) seems to emphasize the redundancy of nodes.
That is clearly related to P2PSIP. However, we are primarily thinking of
group management where non-redundant nodes - a node per user - are taking
part in some activity or interest, person to person (e.g. games, IM).

Gallup / questionnaire for those interested in the Community topic:
* Does anyone have an idea, what existing WG could be suitable for taking
   the Community idea further?
* Alternately, if there's no suitable WG, we could consider forming
   a new WG. This would be quite a big step; if a new WG is started,
   there should be some broader agenda than just P2PSIP group management.
   For example, Radhika's idea about peer robustness could be included?

Best regards,
- Otso

---

From: Li Li <[email-masked]>
Date: Thu, 28 Feb 2008 10:22:07 -0500

--- Our apology if you have received multiple copies of this CFP ----

IEEE MILCOM 2008 (IEEE Conference on Military Communications) will have 
a dedicated session on P2P overlay networks. Your recent work in the P2P 
overlay area are cordially invited for submission to this session.

MILCOM'08 will be held from Nov. 17-19 at the San Diego Convention 
Center in California, US.

The deadline for paper submission has been extended as follows:

Abstracts Due: March 17, 2008
Draft Papers Due: April 25, 2008
Author Notification: June 9, 2008
Final Papers Due: July 18, 2008

The detailed CFP information can be found at 
http://www.milcom.org/call_papers.html.

Li Li (Communications Research Centre of Canada) &
John Buford (Avaya Labs)

Co-chair, P2P overlay networks for military comms.
MILCOM'08