Subject: [P2PSIP] Merge of P2PP and RELOAD

From: Cullen Jennings <[email-masked]>
Date: Sun, 24 Feb 2008 13:15:46 -0800

I just submitted a new draft which is a merge of the P2PP work and the  
RELOAD work.

>
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-bryan-p2psip-reload-03.txt

_______________________________________________
P2PSIP mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/p2psip

---

From: Michael Chen <[email-masked]>
Date: Thu, 28 Feb 2008 06:38:05 -0800

Hi,

It's great to see progress!

Could the authors of P2PP highlight what parts of p2pp were adopted in 
RELOAD-03?

Thanks

--Michael

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip

---

From: "Henry Sinnreich" <[email-masked]>
Date: Thu, 28 Feb 2008 07:03:44 -0800

> Could the authors of P2PP highlight what parts of p2pp were adopted
> in RELOAD-03?

Excellent question! I fully concur.

Thanks, Henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Michael Chen
Sent: Thursday, February 28, 2008 8:38 AM
To: P2PSIP WG
Subject: Re: [P2PSIP] Merge of P2PP and RELOAD

Hi,

Thanks

--Michael

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 28 Feb 2008 11:39:53 -0800

> Could the authors of P2PP highlight what parts of p2pp were adopted in 

I'm not a P2PP author, but I hope you won't mind if I respond.

As you know, architecturally P2PP and RELOAD were actually very
similar, with quite similar feature sets. Even so, it's pretty hard to
merge all the words piecewise so we ended up starting with the RELOAD
text and trying to make sure that all the functionality in P2PP that
wasn't in RELOAD (unstructured DHTs, hop-by-hop reliability,
diagnostics, etc.)  got merged in. So, I think the more important
question here is whether we lost important P2PP functionality in the
merge. I think the answer to that is "no".

Best,
-Ekr

---

From: "Henry Sinnreich" <[email-masked]>
Date: Thu, 28 Feb 2008 14:53:10 -0800

The question by Michael Chen has not been answered by the authors of

Eric Rescorla has provided the answer:
>whether we lost important P2PP functionality in the merge. 
>I think the answer to that is "no".

The P2PP has some very distinct features and I could not find them in
Reload-03. P2PP is not listed in the References.

If and how the features of P2PP have been merged, a list would be most
helpful. 
Also a discussion if/when some P2P features could not be merged. 
This is important to a number of people who have implemented P2PP or may
be planning or contemplating to do so.

Thanks, Henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Eric Rescorla
Sent: Thursday, February 28, 2008 1:40 PM
To: Michael Chen
Cc: P2PSIP WG
Subject: Re: [P2PSIP] Merge of P2PP and RELOAD

Best,
-Ekr