Subject: Re: [P2PSIP] [MMUSIC] HIP NAT Traversal using NICE

From: "Henry Sinnreich" <[email-masked]>
Date: Wed, 2 Apr 2008 11:58:37 -0700

Gonzalo,

I would be interested in an updated evaluation from you on the practical
(near term) potential of using HIP NAT traversal for P2PSIP.  
There was even talk of running code.

Can you (and anyone else) share a few key thoughts, references and links
to running code?

Henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Gonzalo Camarillo
Sent: Wednesday, April 02, 2008 5:47 AM
To: mmusic
Cc: [email-masked]; [email-masked];
[email-masked]; David Ward
Subject: [MMUSIC] HIP NAT Traversal using NICE

Folks involved in the MMUSIC WG,

the HIP WG is developing a NAT traversal solution that is based on NICE:

http://www.ietf.org/internet-drafts/draft-ietf-hip-nat-traversal-03.txt

http://www.ietf.org/internet-drafts/draft-rosenberg-mmusic-ice-nonsip-00
.txt

This means that we depend on the NICE draft to have a working NAT 
traversal solution for HIP. However, from the presentation of this draft

in the last IETF, it is not clear to us whether or not the MMUSIC WG is 
going to work on this draft.

The HIP WG would like to encourage the MMUSIC WG to work on this 
specification, since we need it. If the MMUSIC WG decides not to do so, 
the HIP WG will most likely copy/paste the contents of the NICE draft in

our NAT traversal spec. However, we believe that having a stand-alone 
NICE specification can be useful for protocols other than HIP that will 
decide to use ICE for NAT traversal in the future.

A clarification of the status of this work in the MMUSIC WG would be 
appreciated.

Thanks,

Gonzalo
HIP WG co-chair
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic
_______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip

---

From: Miika Komu <[email-masked]>
Date: Mon, 7 Apr 2008 00:02:31 +0300 (EEST)

On Wed, 2 Apr 2008, Henry Sinnreich wrote:

Hi Henry,

NAT traversal implementations are work in progress at least for the 
following projects:

http://www.hip4inter.net/
http://www.openhip.org/
http://www.infrahip.net/

-- 
Miika Komu                                       http://www.iki.fi/miika/
_______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 07 Apr 2008 10:08:28 +0300

Hi,

yes, as Miika points out, there are several groups working on it. We 
should be doing the first interop tests between different 
implementations shortly.

Cheers,

Gonzalo

---

From: "Henry Sinnreich" <[email-masked]>
Date: Mon, 7 Apr 2008 06:13:27 -0700

Thanks Miika and Gonzalo!

Can you keep us advised of the interoperability work?
This will have IMO very beneficial effects for the whole industry.

Henry 

-----Original Message-----
From: Gonzalo Camarillo [mailto:[email-masked]] 
Sent: Monday, April 07, 2008 2:08 AM
To: Miika Komu
Cc: Henry Sinnreich; mmusic; P2PSIP Mailing List;
[email-masked]; [email-masked];
[email-masked]; David Ward
Subject: Re: [P2PSIP] [MMUSIC] HIP NAT Traversal using NICE

Hi,

Cheers,

Gonzalo