Subject: [P2PSIP] diagnostic information by ALTO?

From: Song Haibin <[email-masked]>
Date: Wed, 11 Mar 2009 15:11:03 +0800

Dear all,

This email is aimed to start a discussion of whether ALTO can be used to
provide the diagnostic information for p2psip diagnostics. But at present,
I'm not sure how it works, maybe it can be used to measure the path between
two peers or something else.

Best Regards,
Haibin
Skype: alexsonghw

---

From: "Das, Saumitra" <[email-masked]>
Date: Wed, 11 Mar 2009 00:39:48 -0700

I would think that this should still be done by p2psip diagnostics. This is node specific information that is being pulled from the overlay nodes. Such information gathering is not currently in the scope of ALTO afaik.

ALTO information provides peer selection guidance and the information about that guidance may not be available to end applications (e.g. how an ISP ranks peers may be based on internal data that is not for public consumption). So I do not think that having ALTO information about peers would suffice for diagnostics. There are definitely diagnostics required in the overlay itself to debug problems, make dynamic adjustments to algorithms etc.

Best,
Saumitra

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Song Haibin
Sent: Wednesday, March 11, 2009 12:11 AM
To: 'P2PSIP WG'
Subject: [P2PSIP] diagnostic information by ALTO?

Dear all,

Best Regards,
Haibin
Skype: alexsonghw

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip

---

From: Song Haibin <[email-masked]>
Date: Wed, 11 Mar 2009 16:57:51 +0800

>From: Das, Saumitra [mailto:[email-masked]]
>Sent: Wednesday, March 11, 2009 3:40 PM
>To: Song Haibin; 'P2PSIP WG'
>Subject: RE: [P2PSIP] diagnostic information by ALTO?
>
>I would think that this should still be done by p2psip diagnostics. This is
node
>specific information that is being pulled from the overlay nodes. Such
>information gathering is not currently in the scope of ALTO afaik.

I agree. If ALTO can provide some kind of node information that can be used
for p2psip diagnostics, I think it is meaningful to take it into account and
such kind of diagnostic information can be retrieved by peers using p2psip
diagnostics method. But IMO most of the node information is dynamic and ALTO
has not considered that by this time (or in the near future).

>ALTO information provides peer selection guidance and the information about
that
>guidance may not be available to end applications (e.g. how an ISP ranks
peers
>may be based on internal data that is not for public consumption). So I do
not
>think that having ALTO information about peers would suffice for
diagnostics.

Agree.

>There are definitely diagnostics required in the overlay itself to debug
>problems, make dynamic adjustments to algorithms etc.
>
>Best,
>Saumitra
>