Subject: [P2PSIP] 答复: Re: 答复: Re: New Version Notification for draft-wang-p2psip-event-notification-extension-00

From: [email-masked]
Date: Wed, 4 Mar 2009 12:41:13 +0800

lichun li <[email-masked]> 写于 2009-03-04 10:49:41:

> So the other node will automatically become notifier before the
> subscriber refreshes subscription?
Yes

> Another question. What will a notifier do if it detects that a
> subscriber fails?
Current version of the draft doesn't take account of this situation. Since 
the notifier may not adjacent to the subscriber, it's difficult to perform 
such a failure detection. To ease the situation, notifier should configure 
a appropriate expirition timer and prohibit permanent subscription.

> 
> 2009/3/4 <[email-masked]>
> >
> > Thanks for the comments, see 3.3.4
> > 3.3.4. Storage and replication
> >
> >    The Notifier MUST store the subscription state as part of resource
> >    data object and enforce the same replication strategy. In case a 
node
> >    fails, the other node where the replica stored can process any
> >    request towards the replicated resource.
> >
> > Thanks
> >
> >
> >
> >
> >
> > lichun li <[email-masked]>
> >
> > 2009-03-03 20:38
> >
> > 收件人
> > [email-masked]
> > 抄送
> > "[email-masked]" <[email-masked]>
> > 主题
> > Re: [P2PSIP] New Version Notification for draft-wang-p2psip-event-
> notification-extension-00
> >
> >
> >
> >
> > I think subscribe/notify mechnism is very neccesary and can also be 
used
> > to inform other events other than data modification.
> >
> > Have consider notifier migration? At a glance, I don't find notifier
> > migration in the draft.
> > If the orignal notifier leaves or fails, another peer should become
> > new notifier immediately.
> > Otherwise, the subscriber may not get the latest data for a while.
> >
> > On Tue, Mar 3, 2009 at 4:05 PM,  <[email-masked]> wrote:
> > >
> > > Hi,folks
> > >     I have wrote a draft regarding p2psip event notification 
extension. I
> > > think it can meet the requirements of real time data access 
scenario.
> > >
> > >     Hope for your comments.
> > >
> > > IETF I-D Submission Tool <[email-masked]>
> > >
> > > 2009-03-02 19:40
> > >
> > > 收件人
> > > [email-masked]
> > > 抄送
> > > [email-masked]
> > > 主题
> > > New Version Notification for
> > >  draft-wang-p2psip-event-notification-extension-00
> > >
> > >
> > >
> > >
> > >
> > > A new version of I-D, draft-wang-p2psip-event-notification-
> extension-00.txt
> > > has been successfuly submitted by Jun Wang and posted to the IETF
> > > repository.
> > >
> > > Filename: draft-wang-p2psip-event-notification-extension
> > > Revision:                  00
> > > Title:                                   P2PSIP Event 
> Notification Extension
> > > Creation_date:                  2009-03-02
> > > WG ID:                                   Independent Submission
> > > Number_of_pages: 20
> > >
> > > Abstract:
> > > The p2p technology is data centric, where the data objects are
> > > distributed in the p2p overlay according to the routing algorithm.
> > > Applications access the data objects via peer/client protocol or
> > > gateways, and some of them require data replicas to be synchronized
> > > in real time, such as a data object stored in overlay and its cache
> > > copy in client memory. This can be achieved by introducing an event
> > > notification extension to p2p protocol. This document describes the
> > > subscribe/notify mechanism for p2psip and define several new methods
> > > to implement such extension.
> > >
> > >
> > >
> > >
> > > The IETF Secretariat.
> > >
> > >
> > >
> > > --------------------------------------------------------
> > > ZTE Information Security Notice: The information contained in 
> this mail is solely property of the sender's organization. This mail
> communication is confidential. Recipients named above are obligated 
> to maintain secrecy and are not permitted to disclose the contents 
> of this communication to others.
> > > This email and any files transmitted with it are confidential 
> and intended solely for the use of the individual or entity to whom 
> they are addressed. If you have received this email in error please 
> notify the originator of the message. Any views expressed in this 
> message are those of the individual sender.
> > > This message has been scanned for viruses and Spam by ZTE Anti-
> Spam system.
> > >
> > > _______________________________________________
> > > P2PSIP mailing list
> > > [email-masked]
> > > https://www.ietf.org/mailman/listinfo/p2psip
> > >
> > >
> >
> >
> >
> > --
> > Sincerely yours,
> >
> > Lichun Li
> > Mobile Life New Media Lab, BUPT
> >
> >
> > --------------------------------------------------------
> > ZTE Information Security Notice: The information contained in this
> mail is solely property of the sender's organization. This mail 
> communication is confidential. Recipients named above are obligated 
> to maintain secrecy and are not permitted to disclose the contents 
> of this communication to others.
> > This email and any files transmitted with it are confidential and 
> intended solely for the use of the individual or entity to whom they
> are addressed. If you have received this email in error please 
> notify the originator of the message. Any views expressed in this 
> message are those of the individual sender.
> > This message has been scanned for viruses and Spam by ZTE Anti-Spam 
system.
> 
> 
> 
> --
> Sincerely yours,
> 
> Lichun Li
> Mobile Life New Media Lab, BUPT

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: lichun li <[email-masked]>
Date: Wed, 4 Mar 2009 15:20:21 +0800

2009/3/4  <[email-masked]>:
> such a failure detection. To ease the situation, notifier should configure a
> appropriate expirition timer and prohibit permanent subscription.

I think notifier can detect subscriber's failing if the subscriber
doesn't respond to notify messages.

>> >    data object and enforce the same replication strategy. In case a node
>> > I think subscribe/notify mechnism is very neccesary and can also be used
>> > > think it can meet the requirements of real time data access scenario.
>> > >
>> > >     Hope for your comments.
>> > >
>> > > Filename:
>> > >  draft-wang-p2psip-event-notification-extension
>> > > Revision:                  00
>> > > Title:                                   P2PSIP Event
>> Notification Extension

-- 
Sincerely yours,

Lichun Li