Subject: [P2PSIP] targeted requests

From: "Das, Saumitra" <[email-masked]>
Date: Tue, 24 Mar 2009 14:02:04 -0700

One point I would like to confirm from the current draft is the separation of the routing key from the storage and retrieval key. By routing key I mean the resource id/node id in the destination list and storage/retrieval key I mean the resource id in the storereq or fetchreq. There are several important reasons why we may want to store/fetch a data value with resource id X on a node with node id Y where Y is not the owner of X. This can be considered as a targeted STORE than a routed STORE.

This is important for the following immediate reasons:
1. Successor replication which is important to have for data availability. Some of the extensions such as the self tuning draft require successor replication (a targeted STORE of resource id X on node id Y where Y is not the owner of X)
2. Caching is likely to be an important part of a successful p2p system and this enables targeted STOREs to be performed to nodes that will cache information.

Just wanted to confirm that this is intended as part of the draft.

Thanks
Saumitra

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Tue, 24 Mar 2009 18:21:09 -0700

Based on section 9.4, successor replication is already supported in RELOAD.  However, the following sentence makes it unsuitable for a generic targeted STORE request, such as would be needed for caching: 

"The peers receiving these check they came from an
   appropriate predecessor in their neighbor table and that they are in
   a range that this predecessor is responsible for, and then they store
   the data."

I am not sure that the above check really buys much anyway.  So, perhaps we can do without it.  Any node may reject a STORE request that it is unable to honor anyway.  

Also, I notice that section 9 is a little light on normative text.  It probably needs a further scrub to ensure it is implementable in an interoperable fashion. 

Thanks,
Vidya

From: [email-masked] [mailto:[email-masked]] On Behalf Of Das, Saumitra
Sent: Tuesday, March 24, 2009 2:02 PM
To: [email-masked]
Subject: [P2PSIP] targeted requests

Thanks
Saumitra