Subject: [P2PSIP] Should remove joining_peer_id and leaving_peer_id

From: "Michael Chen" <[email-masked]>
Date: Sat, 05 Dec 2009 08:30:39 -0700

Hi,

What is the purpose of the NodeId in JoinReq and LeaveReq? 

         struct {
            NodeId                joining_peer_id;
            opaque                overlay_specific_data<0..2^16-1>;
         } JoinReq;

         public struct {
            NodeId                leaving_peer_id;
            opaque                overlay_specific_data<0..2^16-1>;
         } LeaveReq;

The NodeId of the originating peer can be obtained from the signature.
Unless the draft allows a peer to request a Join or Leave on behave of
another peer, these two fields should be removed.

Thanks

--Michael

---

From: jc <[email-masked]>
Date: Sat, 5 Dec 2009 13:47:20 -0500

Because you MUST be directly connected to send these messages the field is of no use. These shouldn't routed via third party.

Julian

On Dec 5, 2009, at 10:30 AM, Michael Chen wrote:

> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip