Subject: [P2PSIP] Remove StoreReq.resource, FetchReq.resource, etc.

From: "Michael Chen" <[email-masked]>
Date: Sat, 26 Dec 2009 18:15:44 -0700

Hi,

The resource IDs in these request structures should be removed and be provided only from the Destination list in the forwarding header.

StoreReq.resource

FetchReq.resource

StatReq.resource

FindReq.resource

This can avoid the possible inconsistency between the header and the message. It may make the request structure seemingly incomplete, but less is more.

Thanks

--Michael

---

From: Eric Rescorla <[email-masked]>
Date: Sat, 26 Dec 2009 17:20:35 -0800

On Sat, Dec 26, 2009 at 5:15 PM, Michael Chen <[email-masked]> wrote:
> Hi,
> The resource IDs in these request structures should be removed and be
> provided only from the Destination list in the forwarding header.
>     StoreReq.resource
>     FetchReq.resource
>     StatReq.resource
>     FindReq.resource
> This can avoid the possible inconsistency between the header and the
> message. It may make the request structure seemingly incomplete, but less is
> more.

These aren't actually redundant. There are times when you want to do a
Store or a Fetch to the non-responsible node (e.g., replica stores).

-Ekr