Subject: [P2PSIP] Using Cassandra for SIP?

From: Andy Savage <[email-masked]>
Date: Thu, 10 Jun 2010 15:18:57 +0800

Hi there,

I was thinking about using Cassandra for SIP location lookups.

Does anybody have any ideas on whether this would be a good/bad idea? It
seems to be good for storing Key/Value pairs (and other data too like
presence) but I wasn't sure as it doesn't seem to be talked about much on
this list.

Any thoughts from the experts?

http://cassandra.apache.org/

Cheers,
Andy
<http://cassandra.apache.org/>
-- 
"The greatest challenge to any thinker is stating the problem in a way that
will allow a solution"
- Bertrand Russell

Andy Savage
Cell Phone: +852 936 34341
Skype ID: andy_savage
Linked In: http://www.linkedin.com/in/andysavage

---

From: Andy Savage <[email-masked]>
Date: Thu, 10 Jun 2010 15:59:48 +0800

Yes, I can see that with a dedicated server with an external IP this
wouldn't be a problem but obviously when the nodes are behind NAT it becomes
a problem.

So what are the possible solutions to this issue?

Obviously I could imagine there is the idea of having supernodes in the same
way that Skype does (nodes not behind nat) and using them as registrars.

Andy Savage

On Thu, Jun 10, 2010 at 3:31 PM, Adrian Georgescu <[email-masked]>wrote:

> Yes, you can use it to replace a dedicated registrar server, yet the real
> problem is not storing the location information, is traversing the NAT for
> SIP signaling and media. The distributed location server is just part of the
> solution. #goodidea
>
> Adrian
>
> On Jun 10, 2010, at 9:18 AM, Andy Savage wrote:
>
> Hi there,
>
>  _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip
>
>
>

---

From: Andy Savage <[email-masked]>
Date: Thu, 10 Jun 2010 16:20:30 +0800

So I guess my question is how do other methods proposed, for example SIPDHT2
work in this regard? How do they propose to solve the holy-grail nat
traversal problem?

Andy Savage

On Thu, Jun 10, 2010 at 4:08 PM, Adrian Georgescu <[email-masked]>wrote:

>
> On Jun 10, 2010, at 9:59 AM, Andy Savage wrote:
>
> Obviously I could imagine there is the idea of having supernodes in the
> same way that Skype does (nodes not behind nat) and using them as
> registrars.
>
>
> Yes this supernodes idea works well in practice. Your cassandra nodes must
> also have SIP registrar and Proxy functions and properly perform NAT
> traversal for their clients.
>
> Adrian
>
> --
>> "The greatest challenge to any thinker is stating the problem in a way
>> that will allow a solution"
>> - Bertrand Russell
>>
>> Andy Savage

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 10 Jun 2010 10:36:19 -0400

We're working on a prototype.

Henning

On Jun 10, 2010, at 3:18 AM, Andy Savage wrote:

> Does anybody have any ideas on whether this would be a good/bad idea? It seems to be good for storing Key/Value pairs (and other data too like presence) but I wasn't sure as it doesn't seem to be talked about much on this list.
> 
> "The greatest challenge to any thinker is stating the problem in a way that will allow a solution"
> - Bertrand Russell
> 
> Andy Savage

---

From: Adrian Georgescu <[email-masked]>
Date: Thu, 10 Jun 2010 09:31:24 +0200

Yes, you can use it to replace a dedicated registrar server, yet the  
real problem is not storing the location information, is traversing  
the NAT for SIP signaling and media. The distributed location server  
is just part of the solution. #goodidea

Adrian

On Jun 10, 2010, at 9:18 AM, Andy Savage wrote:

> Does anybody have any ideas on whether this would be a good/bad  
> idea? It seems to be good for storing Key/Value pairs (and other  
> data too like presence) but I wasn't sure as it doesn't seem to be  
> talked about much on this list.
>

---

From: Adrian Georgescu <[email-masked]>
Date: Thu, 10 Jun 2010 10:08:21 +0200

On Jun 10, 2010, at 9:59 AM, Andy Savage wrote:

> wouldn't be a problem but obviously when the nodes are behind NAT it  
> becomes a problem.
>
> Obviously I could imagine there is the idea of having supernodes in  
> the same way that Skype does (nodes not behind nat) and using them  
> as registrars.
>

Yes this supernodes idea works well in practice. Your cassandra nodes  
must also have SIP registrar and Proxy functions and properly perform  
NAT traversal for their clients.

Adrian

> On Thu, Jun 10, 2010 at 3:31 PM, Adrian Georgescu <ag@ag- 
> projects.com> wrote:

---

From: Adrian Georgescu <[email-masked]>
Date: Thu, 10 Jun 2010 10:23:37 +0200

Is pure implementation specific. It works if you get it right.

Take the wooden cup.

Adrian

On Jun 10, 2010, at 10:20 AM, Andy Savage wrote:

> So I guess my question is how do other methods proposed, for example  
> SIPDHT2 work in this regard? How do they propose to solve the holy- 
> grail nat traversal problem?
>
> -- 
> On Thu, Jun 10, 2010 at 4:08 PM, Adrian Georgescu <ag@ag- 
> projects.com> wrote:
>
>> Yes, I can see that with a dedicated server with an external IP  
>> this wouldn't be a problem but obviously when the nodes are behind  
>> NAT it becomes a problem.
>>
> Yes this supernodes idea works well in practice. Your cassandra  
> nodes must also have SIP registrar and Proxy functions and properly  
> perform NAT traversal for their clients.
>
> Adrian
>
>> -- 
>> Yes, you can use it to replace a dedicated registrar server, yet  
>> the real problem is not storing the location information, is  
>> traversing the NAT for SIP signaling and media. The distributed  
>> location server is just part of the solution. #goodidea
>>
>> Adrian
>>

---

From: jc <[email-masked]>
Date: Fri, 11 Jun 2010 01:22:09 -0400

You'd need to modify the code for nat traversal to work because of the  
need to route any message to any node.

Sent from my iPhone