Subject: [P2PSIP] A question about "state database" in RELOAD

From: xuan tai <[email-masked]>
Date: Tue, 20 Jul 2010 17:36:58 +0800

Dear Everyone:
I have a question when I was reading the draft about RELOAD named “*
draft-ietf-p2psip-base-08*", and welcome everybody to join me to discuss the
question.
In 5.1.2, it mentions that
"

 Any intermediate peer which forwards a RELOAD message MUST arrange that if
it receives a response to that message the response can be routed back
through the set of nodes through which the request passed.  This may be
arranged in one of two ways:

   o  The peer MAY add an entry to the via list in the forwarding header

      that will enable it to determine the correct node.

   o  The peer MAY keep per-transaction state which will allow it to

      determine the correct node.

......

"

The first question is:

What scenario the second method is used for? What the "per-transaction"
exactly means?

The second question is:

As for the example explaining the second method, it mentions an equipment
named "state database" which can store the transaction ID and Node ID used
for the forwarding of response message. But the draft has not defined such
equipment before, so I can't understand it very much, for example, is it a
centralized equipment in network? Or a functional entity which can be
distributed deployed and ensuring every node can share the same information
timely?

Thanks a lot.

-- 
Regards,

北京邮电大学 / Beijing University of Posts and Telecommunications (BUPT)
台璇 / Tai Xuan
e-mail: [email-masked]
mobile:+86135-8176-2082

---

From: jc <[email-masked]>
Date: Wed, 21 Jul 2010 00:23:42 -0400

On Jul 20, 2010, at 5:36 AM, xuan tai wrote:

> Dear Everyone:
> I have a question when I was reading the draft about RELOAD named “draft-ietf-p2psip-base-08", and welcome everybody to join me to discuss the question.
>  Any intermediate peer which forwards a RELOAD message MUST arrange that if it receives a response to that message the response can be routed back through the set of nodes through which the request passed.  This may be arranged in one of two ways:
> What scenario the second method is used for? What the "per-transaction" exactly means?

This means that an intermediate node will "hold state" information on the message until no longer necessary.

> The second question is:
> As for the example explaining the second method, it mentions an equipment named "state database" which can store the transaction ID and Node ID used for the forwarding of response message. But the draft has not defined such equipment before, so I can't understand it very much, for example, is it a centralized equipment in network? Or a functional entity which can be distributed deployed and ensuring every node can share the same information timely?

The "state database can be anything. It could be as simple as an std::vector<node_state> where node_state is some class that holds state information.

> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip