Subject: Re: [P2PSIP] draft-ietf-p2psip-base-12

From: Eric Rescorla <[email-masked]>
Date: Tue, 18 Jan 2011 05:32:26 -0800

On Nov 17, 2010, at 11:28 AM, Marc Petit-Huguenin wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Few more nits:
> 
> - - Section 5.5.4.1 "typedef uint16  KindId;"
> 
> This contradicts section 13.6 that states that KindId are 32-bit integers.
> 
> (Reported by Stéphane Bryant)
> 

I'm tempted to change the bits on the wire here--bigger seems better. Obviously
this is a breaking change. Comments?

> - - Section 5.5.4.2 "} ConfigUpdateRsp"
> 
> Should be ConfigUpdateAns to match the other answer definitions.
> 

Fixed.

> - - Section 9.1 last paragraph
> 
> s/peer id/Node-ID/
> 
> - - Section 11 2nd paragraph
> 
> This paragraph is a duplicate of the first sentence of the previous paragraph.

Fixed.

> - -- 
> Marc Petit-Huguenin
> Personal email: [email-masked]
> Professional email: [email-masked]
> Blog: http://blog.marc.petit-huguenin.org
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.10 (GNU/Linux)
> 
> iEYEARECAAYFAkzkLN0ACgkQ9RoMZyVa61cKdgCeI0GK4nzV/JdzCf5Or7jre9fL
> 3OgAnA+j+zp6wOQ2N1Ryxl45cDH+jZUg
> =vIN0
> -----END PGP SIGNATURE-----
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Tue, 18 Jan 2011 10:29:56 -0800

On 01/18/2011 05:32 AM, Eric Rescorla wrote:
> - Section 5.5.4.1 "typedef uint16  KindId;"
> 

I am personally all for breaking compatibility between different versions of an
I-D.  You can make it easy for implementers by incrementing the minor version in
the Forwarding header (i.e. 0x01-->0x02, and it will still be changed to 0x0a
when published as an RFC).

- -- 
Marc Petit-Huguenin