Subject: [P2PSIP] Some literature pointers to work on DHT Anonymity ...

From: Jan Seedorf <[email-masked]>
Date: Wed, 7 Nov 2012 16:06:15 +0000

Hi Marc and all,

As discussed yesterday in the P2PSIP session, here are some papers that have proposed mechanisms for DHT routing anonymity (most of them are based on Onion routing). I guess this is very related to your document draft-petithuguenin-p2psip-reload-anonymous-01. In particular, the first paper below focusses on P2PSIP.

-- A. Fessi, N. Evans, H. Niedermayer, and R. Holz, \Pr2-P2PSIP: Privacy Preserving P2P Signaling for VoIP and IM," in Principles, Systems and Applications of IP Telecommunications (IPTComm). iptcomm.org, 2010, last
visited on June 4th, 2012. [Online]. Available: http://iptcomm.org/iptcomm2010/ IPTComm2010-Proceedings.pdf

-- J. McLachlan, A. Tran, N. Hopper, and Y. Kim, \Scalable Onion Routing with Torsk," in Proceedings of the 16th ACM Conference on Computer and Communications Security (CCS). ACM. New York, NY, USA, 2009.

-- A. Panchenko, S. Richter, and A. Rache, \NISAN: Network Information Service for Anonymization Networks," in Proceedings of the 16th ACM Conference on Computer and Communications Security (CCS). ACM, New York, NY, USA, 2009.

-- Q. Wang and N. Borisov, \Octopus: A Secure and Anonymous DHT Lookup," in 32nd International Conference on Distributed Computing Systems (ICDCS). IEEE Computer Society, Washington DC, USA, 2012.

 - Jan

---

From: Diego Suarez <[email-masked]>
Date: Thu, 8 Nov 2012 12:54:48 +0100

Hi all,

Related to this topic, and in case it is of interest to the group, in the following paper we have studied different mechanism for routing anonymity ( like using external anonymous systems, routing variations or headers obfuscation ) among other security aspects of P2PSIP.

D. Touceda, J.M. Sierra, A. Izquierdo and H. Schulzrinne, "Survey of Attacks and Defenses on P2PSIP Communications", IEEE Communications Surveys and Tutorials, Volume 14, Issue 3, pp. 750-783, Third Quarter 2012. 

cheers

On Nov 7, 2012, at 5:06 PM, Jan Seedorf wrote:

> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip