Subject: [P2PSIP] RELOAD Base: Question on certificate renewal

From: Dean Willis <[email-masked]>
Date: Fri, 9 Nov 2012 10:37:27 -0600

AD asks:

How is node key rollover done? Do I loose all stored data? I think you need to make all those clear.

So, what I think we're talking about is what happens to my data when my certificate expires. 

Does my NodeID change?

Is there a way to re-cert my stored data?

What exactly is the process for refreshing the data I have stored?

--
Dean

---

From: Dean Willis <[email-masked]>
Date: Wed, 14 Nov 2012 16:44:24 -0600

> What exactly is the process for refreshing the data I have stored?

I met with Cullen and EKR today, and here's what I think we have:

If the NodeID cert expires, you lose all data stored with that NodeID. If we want to invent a "recertification" technique (Marc suggested that the CA can issue a new cert with the same NodeID) we can do that in a separate document.

We will need to add a clarifying sentence to the draft.

--
Dean