Subject: [P2PSIP] I-D Action: draft-ietf-p2psip-access-control-00.txt

From: [email-masked]
Date: Sat, 16 Feb 2013 08:20:11 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Peer-to-Peer Session Initiation Protocol Working Group of the IETF.

	Title           : Configuration of Access Control Policy in REsource LOcation And Discovery (RELOAD) Base Protocol
	Author(s)       : Marc Petit-Huguenin
	Filename        : draft-ietf-p2psip-access-control-00.txt
	Pages           : 13
	Date            : 2013-02-16

Abstract:
   This document describes an extension to the REsource LOcation And
   Discovery (RELOAD) base protocol to distribute the code of new Access
   Control Policies without having to upgrade the RELOAD implementations
   in an overlay.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-p2psip-access-control

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-p2psip-access-control-00

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Sat, 16 Feb 2013 08:33:17 -0800

Here's the changelog:

- - Removed inconsistency in the terminology section.
- - Updated the IANA section and added reference to RFC 3688.
- - Removed "This is probably not legal..." in the security section.
- - Renamed "access-control-code" to simply "code" as it has to be
  prefixed by the namespace anyway, so there is no risk of conflict.

I still have to finish the implementation of the access control policy for
ShaRe - I will submit a new version before the deadline if I find the time to
finish that and update the reference implementation.

Comments, questions and suggestions welcome.

On 02/16/2013 08:20 AM, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories. This draft is a work item of the Peer-to-Peer Session 
> Initiation Protocol Working Group of the IETF.
> 
> Title           : Configuration of Access Control Policy in REsource 
> LOcation And Discovery (RELOAD) Base Protocol Author(s)       : Marc 
> Petit-Huguenin Filename        : draft-ietf-p2psip-access-control-00.txt 
> Pages           : 13 Date            : 2013-02-16
> 
> Abstract: This document describes an extension to the REsource LOcation And
> Control Policies without having to upgrade the RELOAD implementations in
> an overlay.
> 
> 

- -- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org
Profile: http://www.linkedin.com/in/petithug