Subject: [P2PSIP] FW: I-D Action: draft-ietf-p2psip-diagnostics-10.txt

From: "Songhaibin (A)" <[email-masked]>
Date: Mon, 4 Feb 2013 09:00:10 +0000

Hi guys,

We have made quite a few changes to the p2psip diagnostics draft, now we believe it has solved the comments from the WGLC with solutions from last IETF meeting consensus. Maybe a second WGLC is needed for more sufficient review. 

BR,
-Haibin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Monday, February 04, 2013 4:51 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [P2PSIP] I-D Action: draft-ietf-p2psip-diagnostics-10.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>  This draft is a work item of the Peer-to-Peer Session Initiation Protocol Working
> Group of the IETF.
> 
> 	Title           : P2P Overlay Diagnostics
> 	Author(s)       : Haibin Song
>                           Jiang Xingfeng
>                           Roni Even
>                           David A. Bryan
> 	Filename        : draft-ietf-p2psip-diagnostics-10.txt
> 	Pages           : 31
> 	Date            : 2013-02-04
> 
> Abstract:
>    This document describes mechanisms for P2P overlay diagnostics.  It
>    defines extensions to the RELOAD P2PSIP base protocol RELOAD
>    [I-D.ietf-p2psip-base] to collect diagnostic information, and details
>    the protocol specifications for these extensions.  Useful diagnostic
>    information for connection and node status monitoring is also
>    defined.  The document also describes the usage scenarios and
>    provides examples of how these methods are used to perform
>    diagnostics in a P2PSIP overlay networks.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-p2psip-diagnostics
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ietf-p2psip-diagnostics-10
> 
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-ietf-p2psip-diagnostics-10
> 
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Tue, 05 Feb 2013 00:42:05 +0100

Hi Haibin,

Let us check it. We'll probably go for a second WGLC.

Thanks,

Carlos & Brian

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Thu, 14 Feb 2013 22:30:21 +0100

Hi folks,

Please review the doc, as several changes have been made.  If you
believe it's ready to go, please affirmatively say so. If you believe we
need to do more review, please say that.

If you find problems, of course we want to hear them.

Thanks,

Brian & Carlos

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Thu, 14 Feb 2013 18:06:02 -0800

Section 8 answers my concern about security, although the section will need a
formal schema.  AFAIC this draft is ready to be submitted to the IESG.

I also reviewed the other changes and noticed that most of the nits I
suggested were not applied.  In addition I noticed that some references need
an update:

I-D.zheng-p2psip-diagnose
I-D.ietf-behave-rfc3489bis
I-D.ietf-mmusic-ice

and perhaps more.

Globally the whole document still feel like it needs some editing.

On 02/14/2013 01:30 PM, Carlos Jesús Bernardos Cano wrote:
> Hi folks,
> 
> Please review the doc, as several changes have been made.  If you believe
> it's ready to go, please affirmatively say so. If you believe we need to do
> more review, please say that.
> 
>> We have made quite a few changes to the p2psip diagnostics draft, now we
>> believe it has solved the comments from the WGLC with solutions from last
>> IETF meeting consensus. Maybe a second WGLC is needed for more sufficient
>> review.
>> 
>> BR, -Haibin
>> 
>>> -----Original Message----- From: [email-masked]
>>> [mailto:[email-masked]] On Behalf Of [email-masked] 
>>> Sent: Monday, February 04, 2013 4:51 PM To: [email-masked] Cc:
>>> [email-masked] Subject: [P2PSIP] I-D Action:
>>> draft-ietf-p2psip-diagnostics-10.txt
>>> 
>>> 
>>> A New Internet-Draft is available from the on-line Internet-Drafts
>>> directories. This draft is a work item of the Peer-to-Peer Session
>>> Initiation Protocol Working Group of the IETF.
>>> 
>>> Title           : P2P Overlay Diagnostics Author(s)       : Haibin
>>> Song Jiang Xingfeng Roni Even David A. Bryan Filename        :
>>> draft-ietf-p2psip-diagnostics-10.txt Pages           : 31 Date
>>> : 2013-02-04
>>> 
>>> Abstract: This document describes mechanisms for P2P overlay
>>> diagnostics.  It defines extensions to the RELOAD P2PSIP base protocol
>>> RELOAD [I-D.ietf-p2psip-base] to collect diagnostic information, and
>>> details the protocol specifications for these extensions.  Useful
>>> diagnostic information for connection and node status monitoring is
>>> also defined.  The document also describes the usage scenarios and 
>>> provides examples of how these methods are used to perform diagnostics
>>> in a P2PSIP overlay networks.
>>> 
>>> 
>>> _______________________________________________ P2PSIP mailing list 
>>> [email-masked] https://www.ietf.org/mailman/listinfo/p2psip
> 
> 
> _______________________________________________ P2PSIP mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/p2psip
> 

- -- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org
Profile: http://www.linkedin.com/in/petithug

---

From: "Songhaibin (A)" <[email-masked]>
Date: Sun, 17 Feb 2013 08:37:24 +0000

Thank you very much, Marc! I'm sorry that the nits your raised were not addressed. When we update the document, we focused on the main concerns but forgot these tiny nits. Now I'm editing the document offline and wait for the instructions from the chairs.

BR,
-Haibin

> Sent: Friday, February 15, 2013 10:06 AM
> To: P2PSIP WG
> Subject: Re: [P2PSIP] FW: I-D Action: draft-ietf-p2psip-diagnostics-10.txt
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.12 (GNU/Linux)
> 
> iQIcBAEBCAAGBQJRHZgIAAoJECnERZXWan7Eg3UP/3TbamxxlmzLI9ZN9MQijJpL
> 7LqsDSTFpK20hlZTj5zXVgI/wBOJVLC3fRmWDXB94NalUiENLQUFxBenXvLvBK+k
> 592fp12gR3oZaTblBFcLz/+Dh4v3dj4lXRbAXODBDYN0FbErmDiSGexScKBWpgCc
> C3e1WVsk6YCsEWAyAvWn+oBfvV8WQVEyBZUNnLgWzF+gv0FZ6dmVQGoalpWV
> BrZE
> fjWnL+RTFaXROimHFKSt6XpRVfW5wNDLiDJdlCSWehWz21FOrFthMFejaULsG3Y6
> yNqUkayjhJO39hJDZjP0KGKaQrX4dD8Q2Jezrld0QyudYgcZQmlMjmlb+aYENoDP
> Lu5zeXAPXik62/D5dw64eh9htMfd9lOI9bZ8p7FJxPSw2H79hVGCJ9GChGmVE5p1
> kC6tK50K614foVRWpgg9QeuVRhQW4iDJJz+4ItOv7KjpdkR5XbNZyP9TZ28O/J3B
> cl00SLUxbl8t8lCj/VpKJ8IEuQmr24HEWZPtOEcYTxIqM6OdBVRRZUgrbcBujKfY
> vEQmOQ5x1CRTsz+xUD04+WLItm5z/MF+iMJdBi1HwKf3eJIoiIQauE+W0lGsXrF5
> hrOfgrkSKbWeAxfJB4JYQqOpMH219eaz4K0+1/pb6eUpMRdAj13gWqXshb7ED/1Q
> /S+Tg8mEG5dtu1veJ6P6
> =iRZw
> -----END PGP SIGNATURE-----