Subject: Re: [P2PSIP] Review of DRR and RPR documents

From: Zongning <[email-masked]>
Date: Sun, 17 Feb 2013 01:30:13 +0000

Hi, Carlos and all.

We have submitted new revision of DRR draft and RPR draft. The main change is that we did some wording in RPR draft to avoid referring to DRR as normative reference.
As said, we still have some duplication in the two drafts because we want to keep them independent to each other.
Further comments and suggestions are welcome.
Thanks.

-Ning

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Carlos Jesús Bernardos Cano
> Sent: Wednesday, January 23, 2013 12:44 AM
> To: Roni Even
> Cc: [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: [P2PSIP] Review of DRR and RPR documents
> 
> Hi Roni,
> 
> Thanks for the prompt reaction.
> 
> If the split/merging discussion has already taken place, I don't want to
> bring it again, but I just found a bit artificial the separation in two
> documents (and now I see why). I see the point of implementation
> compliance with one RFC and not the other, but current text in RPR
> refers to protocol extensions defined in DRR, so we are not there
> either.
> 
> As I see it (personal opinion) if we want to keep two separate
> documents, we still need some additional work on the wording of them,
> and we might end up duplicating some content. The merging approach would
> make the text cleaner, but would have the problem you pointed out.
> 
> Thanks,
> 
> Carlos
> 
> On Tue, 2013-01-22 at 15:09 +0200, Roni Even wrote:
> > Hi Carlos,
> > Thanks for the review, we will look at the comments as for merging the
> documents. Originally it was one document and it was a WG decision to split it
> to allow implementation to be compliant with an RFC if they want only to
> support DRR or RPR
> > Roni Even
> >
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Carlos Jes?s Bernardos Cano
> > Sent: 22 January, 2013 1:51 PM
> > To: [email-masked]
> > Cc: [email-masked]; [email-masked]
> > Subject: [P2PSIP] Review of DRR and RPR documents
> >
> > Hi,
> >
> > As agreed during the last meeting, I've performed a review of
> draft-ietf-p2psip-drr and draft-ietf-p2psip-rpr documents, prior to shipping
> them to the IESG for publication. My reviews are attached to this e-mail (I
> added comments to the PDF version of each draft, hope this is fine).
> >
> > I'd like authors to go through the comments before sending the documents to
> the IESG. There might be some issues that need to be brought to the WG for
> discussion.
> >
> > I'd also like to ask the WG for opinion on one particular aspect. I'm wondering
> if it would be better to merge both documents into a single one. Currently, both
> documents make quite a lot of cross-references, but still there is duplicate text
> in both of them, so I'd be more in favor of merging (personal opinion). Please,
> comment on this on the mailing list.
> >
> > Thanks,
> >
> > Carlos
> >
> 
> 
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Mon, 18 Feb 2013 10:16:45 +0100

Dear Ning,

OK, thanks for the updates. Let me take a look and post my revision.

Carlos